hjslfs-1.3.49.3 ist offline

  • Quote

    Original von hjs
    In Kürze werd ich meine verdächtigte 12er mal mit nem Build beauftragen - wenn se ( wie ich nu erwarte ) durchrennt , stell ich die wieder online ...


    Nee - da is definitiv n Kinken drin - der Build rannte zwar durch - leider "unbeaufsichtigt" und leider fängt das Logging keine SegFaults ein - aber ich schätze da kam einer , denn nach kurzem hantieren im Sys gabs n SegFault in mc ... :(


    - Strippen der Packages hatte noch n Kinken - irgendwie gibts sowohl find als auch strip halt erst später im Sys , also auf den Host umgebogen


    - da der check der libc ohne externe Tools auskommt , hab ich die Abfrage , ob das triplet erforderlich ist entsprechend angepasst


    Da die libc einer der beiden kritischsten Punkte im Buildgeschehen ist - sollte man den aktivieren ( im Sys )


    HJS

  • Hallo HJS,


    mein System läuft stabil mit der 1.2, da ist es natürlich schwierig sich zu überwinden, weiter zu bauen...
    Habe leider die nächsten 4 Monate auch überhaupt keine Zeit dafür. Im Sommer könnte ich mir aber durchaus vorstellen, nochmal ne 1.3 anzuwerfen.


    Viele Grüße
    Marc

    Full-Budget: Athlon XP 2600+ auf Asrock K7VT4A+, XFX Nvidia Geforce 6200, Hauppauge Nova-S Plus.
    HjsLfs 1.2.8 mit VDR 1.6.0-2 und xineliboutput.

  • Quote

    Original von kanotixer
    Hallo HJS,


    mein System läuft stabil mit der 1.2, da ist es natürlich schwierig sich zu überwinden, weiter zu bauen...


    Wenn ich nich eigens dafür ne Maschine hier rumstehen hätte , würd ich mir das wohl auch überlegen :)


    Quote


    Habe leider die nächsten 4 Monate auch überhaupt keine Zeit dafür. Im Sommer könnte ich mir aber durchaus vorstellen, nochmal ne 1.3 anzuwerfen.


    Hm - in 4 Monaten wirste keine 1.3er mehr finden ... hoff ich doch :gap


    HJS


  • Nu kann man auch wieder in der Übersicht Einstellungen ändern .
    Habs auf nem anderen Weg realisiert :)


    HJS

  • Nu werden auch bei den addons packages gebuildet - mit aufs/timestamp


    Da die per cvs verfügbare aufs2 Version unter 2.6.29er Kernel nicht compiliert , hab ich mir mal die git Version geholt - da liefs dann .


    Da so ohne weiteren Aufwand squashfs und aufs im Kernel sind hab ich mal curl und git mit in die addons genommen .


    HJS

  • Sodele


    Nu werden in der Base die Dependencies mit ins Binary Package gepackt .


    Als Extension hab ich mir "hl0" einfallen lassen :)


    Für die Addons muß ich den Prozeß noch etwas erweitern .


    Wenn dann die Bin-Install Routine fertig ist ....


    HJS

  • Irgendwie ist mir durch das Check-handling doch noch der tarball der Kernelheader durch die Lappen gegangen ... :gap


    Das aus den Binaries erstellte Sys rennt dann zwar , aber beim Compilieren weiterer Packages könnte es dann etwas unangenehm werden :rolleyes: - fixed


    Nu werd ich die eigentlichen Buildscripte wieder auslagern , um sie aktualisiert nachzuladen , die Routine zum Install aktualisieren , das Packaging noch in den Addons implementieren ...


    ... und dann ist mal wieder ne Stable fällig :]


    HJS

  • Sodele - von

    Quote

    Nu werd ich die eigentlichen Buildscripte wieder auslagern , um sie aktualisiert nachzuladen , die Routine zum Install aktualisieren , das Packaging noch in den Addons implementieren ...


    bleibt :


    die Routine zum Install aktualisieren , das Packaging noch in den Addons implementieren ...


    HJS

  • Da es ja einen gewissen Sinn ergibt , wenn man die Listen der verfügbaren Buidscripts auch dynamisch hält , statt sie statisch im Basescript zu halten ... :rolleyes:


    gibbet ne kleine Korrektur :gap


    HJS

  • Streng genommen sollte der Binary Install bereits funktionieren - wenn ich denn die Bins schon online hätte ... :gap


    Deps werden noch nicht berücksichtigt - schließlich gibbet derzeit nur eine Liste , die passt sicher untereinander .


    Der Host für 290309 ist übrigens online ...


    HJS

  • Sodele - noch n paar kleinere Kinken gefunden und entfernt
    Das Builden der DEPs klappt nu auch mit aufs .


    Da ich mit ner offensichtlich beschädigten git-Kernelversion mit aufs einige unfeine SegFaults kassiert habe , ist als Option nun die definitive Abwahl von aufs zum Packaging möglich .


    HJS

  • Mal wieder n bißchen getan :gap


    Mittlerweile sollte das Strippen vor dem Packaging auch ohne SegFaults funzen ...


    Durch die Erfahrungen der letzten Testläufe hab ich vermutlich auch die Schuldigen für die Haken und Kinken mit der CD012a gefunden ... werds bald wissen ...


    HJS

  • Quote

    Original von hjs
    Mittlerweile sollte das Strippen vor dem Packaging auch ohne SegFaults funzen ...


    Ähömpf - manchmal sieht man einfach keinen einzelnen Baum im Wald ... abba nu :gap


    Quote


    Durch die Erfahrungen der letzten Testläufe hab ich vermutlich auch die Schuldigen für die Haken und Kinken mit der CD012a gefunden ... werds bald wissen ...


    Der erste Schuldige ist definitiv : strippen in aufs ist gefährlich - warum auch immer ...


    HJS

  • Dann hab ichs halt mal gemacht, das mit der 1.3.39.4...


    Als einzige Änderung zum Default den Kernel dingens.30 statt 29.1.
    Durchlaufen und Kompilieren lassen, gleichzeitig Binaries erstellt, alles gut.


    Leider mochte Grub mein Bios und die Festplatte nicht (Grub geom error...),
    also nochmal von Binaries installieren. Alles super, tolle Sache das mit den Binaries!


    Aber dann:
    Er findet nach dem Reboot keine exe_doit, und springt nach dem Login wieder zum Login zurück. Man kann also innerhalb der Installation nichts fixen, nur über die CD.
    Hattest Du sowas auch schon? Schon ein komischer Fehler, gell. Und warum gibts da keine exe_doit?


    EDIT:
    Er versucht nach dem Auspacken der Binaries mkbin1 aufzurufen, es gibt allerdings nur mkbin.
    Ein manuelles Kopieren von hjslfs auf die lfs-Partition bringt leider auch nichts.



    Grüße
    Marc

    Full-Budget: Athlon XP 2600+ auf Asrock K7VT4A+, XFX Nvidia Geforce 6200, Hauppauge Nova-S Plus.
    HjsLfs 1.2.8 mit VDR 1.6.0-2 und xineliboutput.

    The post was edited 2 times, last by kanotixer ().


  • Jo :)


    Quote


    Aber dann:
    Er findet nach dem Reboot keine exe_doit, und springt nach dem Login wieder zum Login zurück. Man kann also innerhalb der Installation nichts fixen, nur über die CD.
    Hattest Du sowas auch schon? Schon ein komischer Fehler, gell. Und warum gibts da keine exe_doit?


    War ja klar , der Haken kommt immer erst später :gap


    Er findet keine exe_doit weil der Teil des Scripts , in dem /hjslfs komplett auf die Zielpartition kopiert wird beim Binaryinstall leider nicht abgearbeitet wird ... fixed



    Quote

    EDIT:
    Er versucht nach dem Auspacken der Binaries mkbin1 aufzurufen, es gibt allerdings nur mkbin.
    Ein manuelles Kopieren von hjslfs auf die lfs-Partition bringt leider auch nichts.



    Jo - mkbin1 wird zwar erstellt , aber ebent nicht auf die Zielpartition kopiert .
    Daher findet kein grpconv und pwconv statt .
    Daher is auch nix mit einloggen ...


    Wenn du die Inst noch nich geplättet hast :


    - von CD booten
    - LFS Partition mounten
    - chroot darein
    - pwconv
    - grpconv
    - root PW ggf anpassen


    Ansonsten die .5 nehmen :)


    HJS

  • Hab mich für die 1.3.39.5 entschieden, allerdings mit den Binaries, die ich schon hatte. So ganz mag er aber noch net.


    Schonmal komisch. Dann geht er zwar ans builden der Addons, und fährt danach herunter, wenn ich hochfahre, gehts aber wieder von vorne los.

    Full-Budget: Athlon XP 2600+ auf Asrock K7VT4A+, XFX Nvidia Geforce 6200, Hauppauge Nova-S Plus.
    HjsLfs 1.2.8 mit VDR 1.6.0-2 und xineliboutput.

  • Quote

    Original von kanotixer
    Hab mich für die 1.3.39.5 entschieden, allerdings mit den Binaries, die ich schon hatte. So ganz mag er aber noch net.


    Schonmal komisch. Dann geht er zwar ans builden der Addons, und fährt danach herunter, wenn ich hochfahre, gehts aber wieder von vorne los.


    Wenn ich nur wüßte , an welcher Stelle ist die "-m" fürs ln versteckt hab - der verfolgt mich schon länger :gap


    EOF ist n Überbleibsel :whatever - fixed


    Der Dauer-Addon-Build liegt an der nicht korrigierten ~/.bash_profile - da erfolgt der Aufruf - fixed


    HJS