mp3oss -> schlechter sound über plugin, guter sound von der Konsole

  • Hallo VDR'ler,


    da ich ein PVR350 user bin (anloger VDR) würde ich meine mp3s gerne über die soundkarte in zusammenhang mit mit alsa oder oss ausgeben.


    Leider bin ich bei diesem Vorhaben bis jetzt gescheitert.
    Grund: Der Ton vom Plugin (mp3oss) ist sehr schlecht. (andere Plugins gehen garnicht da sie nur DVB als sounddevice anbieten, leider - musik gefällt mir besser als mp3oss :-( ).


    Er ist verzerrert, hört sich an als wär ein billiger gitarrenverzerrer vorgeschaltet, ausserdem ist ein leises Knacken zu hören.


    Besonders interessant ist hier, dass der Ton bei der WIedergabe von filmen via mplayer, der ebenfalls die soundkarte nutz, einwandfrei ist.
    Auch mp3 mit mplayer unter der konsole werden in guter qualität wiedergeben.


    Code
    1. mplayer -ao alsa /pub/mp3/Der_Song.mp3
    2. oder
    3. mplayer -ao oss /pub/mp3/Der_Song.mp3


    Geht beides super.


    Das Problem scheint also beim mp3oss plugin zu liegen.
    Hier in diesem Thread wird das auch besprochen, leider ohne echte lösung.


    Ich verwende das snd_hda_intel modul für meine Soundkarte (HDA Via VT82xx mit Realtek ALC660 Chipsatz).


    Ich gehe allerding von einem SW Fehler aus weil der sound ja über mplayer und konsole geht.


    Allerding werwendet mplayer alsa, das plugin aber oss.


    Werde mal versuchen den mplayer mit oss zu testen.


    Wär super wenn einer eine Idee hat.


    lg mcdikki

    Linux - Life is too short for reboot.
    VDR: Linvdr0.7 | Mahlzeitiso 4b2 | VDR 1.4.7 Extp. 40| Dr.Seltsam Kernel 2.6.29
    Hauppauge PVR350 als Ausgabedevice und PVR 500 MCE als Eingabe
    Asus A8V-VM SE | 1024MB RAM | Athlon64 4000+ | 500GB HDD | Antec Fusion MCE Gehäuse mit 430W Netzteil und trotzdem leise :-)

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von mcdikki ()

  • Hab mir mal für mich eine Übergangslösung gebastelt.


    Ich rufe einfach den mplayer über die commands.conf und ein script auf.
    Der spielt dann eine playliste (Kann man mit dem mp3oss plugin erstellen) über alsa ab.
    Da ich nur mplayer über die Soundkarte laifen lasse und den vdr direkt, kann ich gleichzeitig TV schauen (ohne ton) und mp3s hören. Um das ganze wieder zu stoppen habe ich ein zweites script welches den mplayerprozess beendet.


    die scripts:
    playMP3list.sh -> spielt entweder eine standardplaylist oder nimmt eine als parameter entgegen


    stopMP3list.sh -> beendet die wiedergabe der Playlist.


    Hab die dateien angehängt, das .txt müsst ihr natürlich entfernen.

    Dateien

    Linux - Life is too short for reboot.
    VDR: Linvdr0.7 | Mahlzeitiso 4b2 | VDR 1.4.7 Extp. 40| Dr.Seltsam Kernel 2.6.29
    Hauppauge PVR350 als Ausgabedevice und PVR 500 MCE als Eingabe
    Asus A8V-VM SE | 1024MB RAM | Athlon64 4000+ | 500GB HDD | Antec Fusion MCE Gehäuse mit 430W Netzteil und trotzdem leise :-)

  • wow!


    Es muss aber doch trotzdem möglich sein, die gleiche Klangqualität auch mit dem mp3(oos)-plugin zu erzielen. Vielleicht findet sich ja mal jemand, der es von OSS auf alsa umbaut.


    Hast Du mal mit diesen Werten experimentiert:



    Zitat

    Normalisierer Pegel = 25
    48 Einstellungen Setzt den Lautstärkepegel für den Normalisierer. Es sind Werte zwischen 0 und 50 erlaubt. Bei 0 wird der Normalisierer ausgeschaltet. Der Normalisierer wird gebraucht, wenn die Musikstücke einer Abspielliste mit verschiedenen Lautstärkepegeln aufgenommen wurden.


    Begrenzer Pegel = 70
    Setzt den Lautstärkepegel für den Lautstärkebegrenzer. Es sind Werte zwischen 25 und 100 erlaubt. Bei 100 wird der Begrenzer ausgeschaltet.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Zitat

    andere Plugins gehen garnicht da sie nur DVB als sounddevice anbieten, leider - musik gefällt mir besser als mp3oss


    Das music-Plugin kann doch oss es muss nur mit OSS-Support kompiliert werden.

    Gruß Tom


    99% der ComputerFehler sitzen zwischen Tastatur und Rückenlehne :schiel


    VDR -> JBC230C63P-330WD/1.7.17/xineliboutput-cvs/vdpau/Nova-DVBT/Sundtek-Stick
    TV -> Samsung LE37B679

  • Ja, klar, ich habe so ziemlich alle Stellschrauben die das Plugin bietet (im OSD) ausprobiert.


    WIll mich jetzt mal erkundigen ob es nicht im allgemeinen möglich ist ein mp3plugin zu bauen das auf mplayer aufbaut.


    Aber erstmal muss ich mich einarbeiten wie das pluginprogrmmieren für vdr funktioniert.


    Leider beherrsche ich weder C noch perl, daher weiß ich nicht ob ich es hin bekomme.

    Linux - Life is too short for reboot.
    VDR: Linvdr0.7 | Mahlzeitiso 4b2 | VDR 1.4.7 Extp. 40| Dr.Seltsam Kernel 2.6.29
    Hauppauge PVR350 als Ausgabedevice und PVR 500 MCE als Eingabe
    Asus A8V-VM SE | 1024MB RAM | Athlon64 4000+ | 500GB HDD | Antec Fusion MCE Gehäuse mit 430W Netzteil und trotzdem leise :-)

  • @ tom: vielen Dank für den hinweis.


    @ Dr. Seltsamm: könntest du das nicht mal für den Kernel Kompilieren oder muss ich mich da an Toxic wenden?


    Im allgemeinen wäre es schön wenn man statt oss auch alsa nehmen könnte.

    Linux - Life is too short for reboot.
    VDR: Linvdr0.7 | Mahlzeitiso 4b2 | VDR 1.4.7 Extp. 40| Dr.Seltsam Kernel 2.6.29
    Hauppauge PVR350 als Ausgabedevice und PVR 500 MCE als Eingabe
    Asus A8V-VM SE | 1024MB RAM | Athlon64 4000+ | 500GB HDD | Antec Fusion MCE Gehäuse mit 430W Netzteil und trotzdem leise :-)

  • Zitat

    Original von mcdikki
    @ Dr. Seltsamm: könntest du das nicht mal für den Kernel Kompilieren oder muss ich mich da an Toxic wenden?


    was meinst Du? das music-Plugin? wäre einen Versuch wert, auch wenn es ebenfalls oss statt alsa nutzt. Hat mit dem kernel nichts zu tun, das wäre eher die Baustelle von Toxic-Tonic. Ich habe aber auch ein Woody-Entwicklungssystem und kann es ja mal probieren. Wenn es bislang bei Toxic nicht dabei ist (?), wird es wohl an gcc-2.95-Inkompatibilitäten liegen.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Das plugin gibt es (musik-0.2.0), aber es kann in der Version von Toxic nur DVB und nicht oss/alsa.

    Linux - Life is too short for reboot.
    VDR: Linvdr0.7 | Mahlzeitiso 4b2 | VDR 1.4.7 Extp. 40| Dr.Seltsam Kernel 2.6.29
    Hauppauge PVR350 als Ausgabedevice und PVR 500 MCE als Eingabe
    Asus A8V-VM SE | 1024MB RAM | Athlon64 4000+ | 500GB HDD | Antec Fusion MCE Gehäuse mit 430W Netzteil und trotzdem leise :-)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von mcdikki ()

  • Zitat

    Original von mcdikki
    Das plugin gibt es (musik-0.2.0), aber es kann in der Version von Toxic nur DVB und nicht oss/alsa.


    laut Beschreibung basiert es auf dem mp3-Plugin.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • http://drseltsam.device.name/v…0-tt-music-oss-osdmod.tgz


    music-Plugin mit OSS (muss im Plugin-setup noch von DVB auf oss umgestellt werden!) sowie dem OSD-Mod, d.h. das Potenzial der PVR350 wird voll ausgeschöpft. Optisch ist es mit der Anzeige der Cover genial. Klanglich habe ich zum mp3oss keinen Unterschied bemerkt. Auf einem anderen Board mit Via Soundchip klang es schlimmer. Den Gegentest mit mplayer werde ich die Tage mal machen. Jetzt glotze ich erstmal was :)


    Das Plugin heisst music (nicht musicoss) und überschreibt daher das vorhandene Plugin aus Toxics Paket!

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Hallo Doc.


    Also bei dem Plugin ist es genau das gleiche wie bei mp3oss, schlechter, übersteuerter Ton.


    Trotzdem Danke für den Versuch, vielleicht hift es ja anderen :-)


    Ich hab jetzt erstmal andere Probleme mit meinem VDR (siehe Hier).


    lg mcdikki


    [edit 16.1.07 - 02:31]
    Da ich das andere Problem gelöst habe, bin ich jetzt wieder an diesem.


    Dabei fiel mir noch auf, dass die beiden plugins die lautstärkereglung ignorieren.


    Daraus könnte folgen, dass der Pegel einfach zu hoch ist und so der schlechte ton entsteht.


    Aber warum lässt sich der Ton nicht einstellen?


    Ich habe sowohl über alsamixer als auch über smixer versucht die Lautstärke zu regulieren - ohne Erfolg.


    Auch die einstellung fürs Normaliseren und Limiteren in den Plugineinstellungen scheinen keinen Effekt zu haben.


    Hat einer eine Idee woran das liegen könnte?


    lg mcdikki

    Linux - Life is too short for reboot.
    VDR: Linvdr0.7 | Mahlzeitiso 4b2 | VDR 1.4.7 Extp. 40| Dr.Seltsam Kernel 2.6.29
    Hauppauge PVR350 als Ausgabedevice und PVR 500 MCE als Eingabe
    Asus A8V-VM SE | 1024MB RAM | Athlon64 4000+ | 500GB HDD | Antec Fusion MCE Gehäuse mit 430W Netzteil und trotzdem leise :-)

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von mcdikki ()

  • Keiner eine Idee?


    Gibt es eigentlich unter linvdr auch einen OSSMixer?


    Habe je bis jetzt nur versucht über alsamixer zu steueren.


    lg mcdikki

    Linux - Life is too short for reboot.
    VDR: Linvdr0.7 | Mahlzeitiso 4b2 | VDR 1.4.7 Extp. 40| Dr.Seltsam Kernel 2.6.29
    Hauppauge PVR350 als Ausgabedevice und PVR 500 MCE als Eingabe
    Asus A8V-VM SE | 1024MB RAM | Athlon64 4000+ | 500GB HDD | Antec Fusion MCE Gehäuse mit 430W Netzteil und trotzdem leise :-)

  • tut mir leid, aber alle Soundkarten, mit denen ich bisher gearbeitet habe, ließen sich über den alsamixer regeln.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Hallo,


    nach dem ich mich ein bischen blöd angestellt habe, läuft nun auch das music-plugin über oss.


    seit dem ich aber die dafür notwendige "sounddurchschleifung" über die soundkarte realisiert habe fällt mir auf, das bei tv-sendungen nur noch ton aus der rechten box kommt!


    wenn ich aber mit dem scart-adapter für die pvr an den tv gehe geht es wunderbar. -> also kein pvr-problem


    mache ich in der konsole "aplay test.wav" mit der durchschleif-methode kommt auch ton auf beiden kanälen. -> also kein soundkartenproblem
    hab gerade gemerkt das auch beim music-plugin und beim mplayer der ton aus beiden boxen kommt.


    dvd und tv geht aber nur ein kanal?


    woran könnte das denn liegen??? :schiel



    martin

    ---------------------------------------------------------------------------
    Mahlzeit-ISO 3.2 mit Dr.Seltsam-Kernel 2.6.23.9 mit Toxic-Tonic 1.4.7 ext40 Paketen
    AMD Geode 1700+ auf AsRock K7VT4A+ / 768MB-RAM / 500GB-WD-SATA-HDD / PVR350
    Aureon 5.1 PCI Soundkarte / Alphacool 256x128

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von kaloy_le ()

  • die Ursache liegt also nicht in der Kabelverbindung vom Soundkartenausgang zum TV. Es muss die Verbindung von der weissen und roten Chinchkupplung (die vom Adapter ausgeht) zum Line-In der Soundkarte sein. Hast Du da einen 3,5mm Stereo-Klinkenstecker? Sitzt er richtig in der Buchse?

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • hi doc,


    ja genau. 2 chinch-stecker auf 3,5 mm klinke.
    meiner meinung nach könnte es aber auch der adapter von der pvr selbst sein.
    ich werde heut abend mal versuchen die beiden chinch-klinken-adapter (den auf dem output-weg nutzt man ja baugleiche) zu tauschen und schauen wie sich das problem verhält.


    zudem wirkt der sound sehr leise. (nicht das oben beschriebene problem!) gestern, plötzlich wurde er !spontan! aber laut. (also normal laut) als ich den vdr neustartete war er wieder leise und blieb es auch. am kabel wackeln entlarvte keinen wackelkontakt.
    ordnen wir das problem trotzdem einen möglichen wackelkontakt der kabel zu oder gab es in der vergangenheit schon mal ähnliche probleme?


    da die chinch-klinke-adapter aber immer gut funktionierten, vermute ich das es vielleicht der pvr-adapter selbst sein könnte. kann man soetwas einzeln nachbestellen? auf der hauppauge-hp find ich nix. muß man also auf den marktplatz hier im :portal4 hoffen?


    gruß



    martin

    ---------------------------------------------------------------------------
    Mahlzeit-ISO 3.2 mit Dr.Seltsam-Kernel 2.6.23.9 mit Toxic-Tonic 1.4.7 ext40 Paketen
    AMD Geode 1700+ auf AsRock K7VT4A+ / 768MB-RAM / 500GB-WD-SATA-HDD / PVR350
    Aureon 5.1 PCI Soundkarte / Alphacool 256x128

  • Moin,


    hab mich gestern mal etwas eingehender mit dem Problem beschäftigt und folgendes herausgefunden:


    Die Kabel sind alle in Ordnung!
    Ursache des Problems ist, das man im Alsamixer erkennen kann das im Line-in ein Kanal auf Mute gestellt ist. Wenn man dieses Mute manuell deaktiviert funktioniert alles wunderbar. Zunächst zumindest. Denn sobald man an der Fernbedienung die Lautstärke ändert, wird das Mute für diesen Kanal sofort wieder gesetzt!
    Teilweise Abhilfe schafft wenn ich in den Einstellungen des Line-in Kanals vom advchctl-plugin von 'VDR' auf 'einstellbar' wechsle. Dann wird das Muteing beim ändern der Lautstärke nicht aktiviert. Auch beim VDR neustarten ist alles ok. Nur wenn ich reboote wird das Mute wieder gesetzt.
    Ich vermute das dies nur eine Einstellungssache ist. Nur leider hab ich keine Ahnung wo man dies einstellen kann.


    martin

    ---------------------------------------------------------------------------
    Mahlzeit-ISO 3.2 mit Dr.Seltsam-Kernel 2.6.23.9 mit Toxic-Tonic 1.4.7 ext40 Paketen
    AMD Geode 1700+ auf AsRock K7VT4A+ / 768MB-RAM / 500GB-WD-SATA-HDD / PVR350
    Aureon 5.1 PCI Soundkarte / Alphacool 256x128

  • bist Du experimentiefreudig? Dann teste doch mal den
    http://drseltsam.device.name/v…rnel-2.6.25.11-090908.tgz
    Da sind die alsa-Treiber neuer, vielleicht macht das einen Unterschied.


    Probier auch mal das avolctl-Plugin.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • ups, ich nutze doch schon das avolctl-plugin. da hab ich mich wohl verschrieben.


    ich werd mal ne sicherung machen und es probieren.
    sorry wenn ich dumm frag aber einfach runterladen und dann:


    tar xvfz linvdr-kernel-2.6.25.11-090908.tgz -C /
    ldconfig


    anschließend reboot


    und fertig oder?


    gibt es eine möglichkeit abgesehen vom wiederherstellen der sicherung diesen vorgang wieder rückgängig zu machen?

    ---------------------------------------------------------------------------
    Mahlzeit-ISO 3.2 mit Dr.Seltsam-Kernel 2.6.23.9 mit Toxic-Tonic 1.4.7 ext40 Paketen
    AMD Geode 1700+ auf AsRock K7VT4A+ / 768MB-RAM / 500GB-WD-SATA-HDD / PVR350
    Aureon 5.1 PCI Soundkarte / Alphacool 256x128

  • Servus,


    aber klar gibt's die Möglichkeit!


    in /boot gibt's einige symbolische Links, die auf die neuen Files verweisen. Einfach auf die bisherige Version ändern und der alte Kernel wird wieder benutzt. Es sind die symbolischen Links 'config', 'vmlinuz' und 'system'.
    Damit's einfacher wird, vor einspielen des neuen Kernels erstmal nachschauen, auf was die Links verweisen.


    Du solltest nach der Änderung im alsamixer auch die Änderungen speichern mit: alsactl save
    Eventuell in der /etc/init.d/rcStart noch vor dem Start von /etc/init.d/runvdr start einen AUfruf von '/usr/bin/alsactl restore'einfügen.


    Gruß OS/2

    Hardware: Asus Pundit, Celeron 2,4GHz, 1 x TT 1.5, 1 x Skystar2 2.6c, B&O Beolink 5000 an LIRC
    Software: verpanschtes LinVDR 0.7 mit mt20050414 Edition