Wer kümmert sich um die Ebuilds?

  • hiho


    Was haste denn schoenes .. mittlerweile pflege ich mein eigenes overlay weil alles andere sehr oft zu alt ist :-)


    evtl ist das ja fuer einige auch so interessant und du haengst es einfach an den post an .. *g*


    mfg mentox

  • Naja, die ebuilds zu updaten ist eigentlich eine Kleinigkeit, wenn jemand Zugriff hat ist das Repository hat ist das eine Arbeit von wenigen Minuten.


    Meistens sind es so Kleinigkeiten, die mir auffallen. Aktuell nervt mich z.B., dass ich den Patch für das Serial-Plugin bei einer Installation immer von Hand einbasteln muss. Leider hat Ralf keine Lust mehr, sich weiter um das Plugin zu kümmern.


    Weiterhin wollte ich evl. ein ebuild fuer das x11-out-plugin schreiben, da man damit ja prinzipiell auch recht nette dinge machen kann.

  • Zitat

    wer kümmert sich eigentlich um die Ebuilds? Und vor allem wo? Der gentoo-de-overlay wird ja anscheinend kaum noch weiter gepflegt, ...


    Hallo,
    habe ich bei mir inzwischen abbestellt, laut Newsletter sind die Ansprechpartner dort zu finden?

    Mit freundlichen Grüßen
    WOLfgang Schricker


    Linux 3.0.35, Gentoo VDR 1.7.23 (liemikuutio), burn, radio, streamdev-server, text2skin, timeline, vdrmanager, xineliboutput, xvdr
    SILENTMAXX HTPC, ASUS P7P55D-E, INTEL i5-660, 4G RAM, 2 x SAMSUNG HM100UO (RAID1), GeForce EN210, 2 x Hauppauge NOVA-HD-S2


    Linux 2.6.27, Gentoo VDR 1.6.0 (liemikuutio), analogtv, burn, cdda, dvd, dvdswitch, epgsearch, femon, graphtft, image, mp3ng, mplayer, radio, streamdev-server, text2skin, timeline, tvonscreen
    SILVERSTONE LC03V, DFI AD76RAID, AMD AthlonXP1800, 256M RAM, 2 xSEAGATE ST3160815A (RAID1), SAMSUNG HA200JC, FF TT 1.6, BUDGET PCTV-S, LG GSA4163B

  • Zitat

    .... Der gentoo-de-overlay wird ja anscheinend kaum noch weiter gepflegt...


    und das kurz vor meinem Umstieg von linvdr auf gen2vdr ?! :motz2


    Im Ernst ein paar Fragen dazu:
    [list=1][*]Brauche ich für gen2vdr eigentlich den gentoo-de-overlay zwingend ? Mir kommt vor, daß das Meiste im normalen gentoo Repository schon enthalten ist (vielleicht nicht die aktuellsten Entwicklerversionen) - hab ich mir aber im Detail noch nicht so genau angesehen.
    [*]Geht gen2vdr von einem minimal gentoo-Linux aus oder ist es mehr eine komplette Installation mit allem drum und dran (so ne Art fertiges stage-3 Paket) ?
    [*]Wie sieht's mit den bösten Dingen (zB das SC-plugin und camd3) aus - gibt's für die auch ebuilds oder muß man da dann wieder Hand anlegen ?
    [*]Unterm Strich: was ist besser wenn man auf eine neue Partition aufsetzen will (andere Partitionen müssen erhalten bleiben weil Videos und Reserve-System) gen2vdr oder gentoo + vdr manuell aufsetzen ? - wenn man mal von dem höheren Arbeitsaufwand absieht.
    [/list=1]
    Peter

    vdr-1: Gentoo-2008.0 mit vdr-1.6.0 auf ASUS A7N8X-VM400 mit Athlon mobile XP2500+ und 2x TT-S2300 mit hw-wakeup mit Software V1.5
    vdr-2: yavdr 64-0.5.0 mit vdr-1.7.27-5 + xineliboutput 1.0.7 auf ASUS M4A88TD-M/USB3 mit Athlon II-X2-20e + Zotac GeForce G210 und Cine S2 Dual Tuner V6


  • Hi


    Um die ebuilds kümmern sich Zzam und hd.brummy + Zuschläger. Die machen einen Super-job.


    http://www.gentoo.org/proj/en/desktop/video/vdr/


    Das alte Overlay wird so nicht mehr gepflegt:


    deswegen:
    http://www.gentoo.org/proj/en/…vdr/doc/overlay-guide.xml


    gen2vdr-User nutzt das Overlay eh nicht viel, weil helau zum Updaten einen anderen Weg geht via scripts. Die ebuilds sind eher für ein "händisch" aufgesetztes System gedacht.


    Böse Sachen, wie vdr-** und c**d3 werden hier nicht diskutiert.



    Gruß
    Martini

  • Hi, vielen Dank für die Infos. Das sollte keine Kritik sein, nur ist die Entwicklung anscheinend an mir vorbeigegangen. Außerdem sind die Infos im Wiki nicht mehr so ganz aktuell ("Wie kann ich meine eigenen Ebuilds bei gentoo.de einbringen?"). Und ein Hinweis unter bugs.gentoo.de wäre vielleicht auch angebracht...


    Danke nochmals und vg pls

  • Hi und vielen Dank auch von mir...


    Ich seh schon, muß das ganze einfach mal ausprobieren. Zentraler Punkt ist, daß ich alle meine Computer (dzt. vier) nun auf Gentoo umstellen will und der VDR nun der letzte im Bunde ist. Handarbeit stört mich dabei eigentlich nicht - ganz im Gegenteil: ich bin von SuSE über Fedora und LFS zu Gentoo gewechselt weil es einfach das flexibelste, transparenteste und dennoch einfach aufzusetzenste System ist (meine persönliche Meinung).


    Und wo's keine ebuilds gibt, muß man selbst Hand anlegen - das macht auch Spaß und vor allem lernt man viel dabei...


    In diesem Sinne, einen guten Rutsch in ein gesundes, erfolgreiches und vor allem gutes neues Jahr 2008!


    Peter

    vdr-1: Gentoo-2008.0 mit vdr-1.6.0 auf ASUS A7N8X-VM400 mit Athlon mobile XP2500+ und 2x TT-S2300 mit hw-wakeup mit Software V1.5
    vdr-2: yavdr 64-0.5.0 mit vdr-1.7.27-5 + xineliboutput 1.0.7 auf ASUS M4A88TD-M/USB3 mit Athlon II-X2-20e + Zotac GeForce G210 und Cine S2 Dual Tuner V6


  • Ni,


    so seit ca. einer Woche bin ich auch fix dabei. Habe meinen linvdr auf der zweiten Partition noch einen gentoo-2008.0 - vdr-1.6.0-r1 zur Seite gestellt und bin nun gestern voll darauf umgestiegen - mit allem drum und dran.


    Läuft alles bestens - Gratulation und vielen Dank. :prost2


    Es gab nur zwei wesentliche Hürden [list=1]
    [*]DeepBlue Skin => text2skin sucht unter /usr/share/vdr/text2skin und nicht unter /etc/vdr/plugins/text2skin
    [*]bei jedem env-update (also praktisch immer wenn man etwas emerged) wird die /etc/profile.env neu geschrieben und da fehlt dann bei LC_ALL das export davor => der vdr kann somit nur Englisch . liegt aber am gentoo-2008.0
    [/list=1] Hat wer ne Idee wie man das ganze abspecken kann - mit 2 GB komme ich gerade mal so aus, wenn ich /usr/portage und /usrt/temp auslagere und unnötige Teile aus dem Kernel Tree lösche.


    Peter

    vdr-1: Gentoo-2008.0 mit vdr-1.6.0 auf ASUS A7N8X-VM400 mit Athlon mobile XP2500+ und 2x TT-S2300 mit hw-wakeup mit Software V1.5
    vdr-2: yavdr 64-0.5.0 mit vdr-1.7.27-5 + xineliboutput 1.0.7 auf ASUS M4A88TD-M/USB3 mit Athlon II-X2-20e + Zotac GeForce G210 und Cine S2 Dual Tuner V6


  • Dein Post ist zwar schon recht alt, aber jetzt antworte ich auch mal.


    Zitat

    Original von prolineserver
    Naja, die ebuilds zu updaten ist eigentlich eine Kleinigkeit, wenn jemand Zugriff hat ist das Repository hat ist das eine Arbeit von wenigen Minuten.


    Meistens ja. Aber nur, wenn der Mensch mit Zugriff davon weiß. Also am besten selber mal testen, und dann Bescheid geben. Wenn Änderungen notwendig sind auch einen Patch mitliefern. Dann können wir das wirklich schnell abhaken.
    Am besten einfach auf bugs.gentoo.org einen Bug aufmachen.


    Zitat


    Meistens sind es so Kleinigkeiten, die mir auffallen. Aktuell nervt mich z.B., dass ich den Patch für das Serial-Plugin bei einer Installation immer von Hand einbasteln muss. Leider hat Ralf keine Lust mehr, sich weiter um das Plugin zu kümmern.


    Also ich les jetzt hier zufällig davon. Es gibt eben Plugins die setzen wir Entwickler einfach nicht ein. D.h. wir merken nicht obs geht oder nicht ohne explizit das zu testen.
    Aber hier auf vdr-1.4.7-r12 und auf vdr-1.7.0 compiliert vdr-serial-0.0.6a-r1 ganz gut. (Bis auf QA-Warnungen).
    Was tut denn der Patch sonst noch? - Muss der ins ebuild?


    Zitat


    Weiterhin wollte ich evl. ein ebuild fuer das x11-out-plugin schreiben, da man damit ja prinzipiell auch recht nette dinge machen kann.


    Nur zu :)


    Zzam

  • Zitat

    Zitat: Meistens sind es so Kleinigkeiten, die mir auffallen. Aktuell nervt mich z.B., dass ich den Patch für das Serial-Plugin bei einer Installation immer von Hand einbasteln muss. Leider hat Ralf keine Lust mehr, sich weiter um das Plugin zu kümmern. Also ich les jetzt hier zufällig davon. Es gibt eben Plugins die setzen wir Entwickler einfach nicht ein. D.h. wir merken nicht obs geht oder nicht ohne explizit das zu testen. Aber hier auf vdr-1.4.7-r12 und auf vdr-1.7.0 compiliert vdr-serial-0.0.6a-r1 ganz gut. (Bis auf QA-Warnungen). Was tut denn der Patch sonst noch? - Muss der ins ebuild?


    hi,


    ne ich glaube eher das er ein patch fuer das plugin hat und dann das ebuild per hand anpassen mus .. das hab ich auch leider bei einigen plugins ..


    schoen waere aehnlich wie beim vdr ein patchdir wo man die ablegen kann . .dann muss man nicht immer das ebuild mit ziehen ..



    zu dem bug einstellen .. ich find das einfach zu kompliziert da so nen ding zu melden ..
    haette ja auch einige die so nicht in gentoo sind ... aber das ist mir echt zu bloed die da einzu tragen als bug .. das wird fuer einige ne huerde sein .. nicht nur fuer mich ..


    lg mentox :-)

  • mentox :


    Ich hab schon verstanden, dass er einen Patch für das Plugin hat. Aber was tut der Patch, bzw. muss man den mit einbauen?


    Es gibt das patchdir auch für die Plugins. :) Schau einfach mal in /usr/portage/eclass/vdr-plugin.eclass


    Was ist an einem Bug anlegen so kompliziert? Gut, ich hab schon einige angelegt.
    Aber generell: Erstmal suchen ob es schon einen gibt. Und wenn nicht, dann einen neuen anlegen.
    Der muss einfach nur, wie eine E-Mail, ein gutes Subject und sinnvollen Text beinhalten.


    Oder B: Sendet uns eine E-Mail an vdr@gentoo.org
    Oder C: Tretet der Mailingliste gentoo-vdr bei (siehe http://www.gentoo.org/main/en/lists.xml)
    Oder D: Macht hier ein Topic auf mit eueren Änderungsvorschlägen - und weißt uns notfalls irgendwie darauf hin, falls niemand reagiert.


    Da wird doch nun wirklich für jeden etwas dabei sein.
    Zzam

  • Zitat

    Original von mentox
    schoen waere aehnlich wie beim vdr ein patchdir wo man die ablegen kann . .dann muss man nicht immer das ebuild mit ziehen ..


    Zitat

    Original von Zzam
    Es gibt das patchdir auch für die Plugins. :) Schau einfach mal in /usr/portage/eclass/vdr-plugin.eclass


    Genau, und um das mal etwas genauer darzustellen, hab ich mal einen Screenshot gemacht


    VDR_LOCAL_PATCHES_DIR ist vdr/patches
    Darin siehst du die Verzeichnisse für VDR und eins für das Vodcatcher-Plugin Version 0.1.1


    Also ne ganz einfache Kiste.