Silverstone LC 16 und iMON VFD

  • Hallo,
    habe mir frisch die Version EasyVDR 0.5 RC1 installiert. Läuft wirklich super. Nur wie bekomme ich das VFD und die Fernbedienung zum laufen? Habe einiges für die Version 0.4 gefunden, aber auch damit habe ich das VFD nicht zum Leuchten bewegen können. Und die Fernbedienung rührt sich auch nicht. Habe auch mal testweise IMEDIAN auf Windows installiert. Damit lief das VFD und die Fernbedienung. Also kann ich Hardwaredefekt ausschliessen.
    Wenn ich unter:
    VDR - System - VDR-Setup - LCD Display Einstellungen - LCD Einstellung
    auf "lcdproc" stelle, start mein VDR dauernd neu.
    Wie ich gesehen habe, besitzen einige ein LC16. Ich hoffe ihr könnt mir helfen. Bin doch so vom EasyVDR begeistert.
    Habe übrigens noch einmal neu installiert.


    cu Noreia

  • hi noreia


    bist du sicher, das du ein vfd hast?
    gibt nämlich auch silverstones mit lcd.


    bitte erstmal prüfen.


    neuinstallation wäre nicht nöti gewesen.
    hier steht, wie du die einstellung wieder hättest rückgängig machen können:
    http://www.easy-vdr.de/forum/i…ic=2847.msg22382#msg22382


    lies dir ruhig mal den kompletten thread durch, dort sollte eigentlich alles stehen, was du brauchst.
    wenn nichts hilft, dann bitte mal deine logs posten
    (logread, dmesg)


    bye
    strgalt

  • Ist wirklich ein VFD und kein LCD. Dieser Artikel ist mir bekannt. Danach hatte ich schon mehrmals den VDR gestopt. Nur habe ich neu installiert um jetzt ein sauberes System zu haben.


    cu Noreia

  • Hier mal ein paar Logs:


    Lirc_on_imon.log

    Code
    1. Dec 3 00:40:59 easyVDR lircd: lircd(all) ready
    2. Dec 3 00:41:04 easyVDR lircd: accepted new client on /dev/lircd
    3. Dec 3 00:41:04 easyVDR lircd: could not get file information for /dev/lirc0
    4. Dec 3 00:41:04 easyVDR lircd: default_init(): No such file or directory
    5. Dec 3 00:41:04 easyVDR lircd: caught signal


    Syslog:


    Und die dmesg hänge ich mal an.


    cu Noreia

  • Für den Weg hierfür wäre ich sehr Dankbar.


    Ich versuche nun schon seit Stunden die Fernbedienung und das Display an laufen zu bekommen.
    Unter Windows läuft alles auf anhieb unter Linux sehen die Ausgabe wie bei Noreia aus.
    Ein /dev/lcd0 gibt es nicht auch der lircd beendet sich sofort wieder nach dem starten.


    Ich habe nun schon diverse Anleitungen, auch mit patches für lirc und lcdproc durchprobiert aber alles ohne Erfolg.


    Das Gehäuse ist ein Silverstone LC16-M und die Fernbedienung das iMon Pad. Siehe auch hier
    Das Display hat 16x2 Felder ist also kein voll Grafik Display.


    Der ganze USB Anteil des Gehäuse wird als hiddev0 und hiddev1 gefunden

    Code
    1. lrwxrwxrwx 1 root root 0 Dec 29 00:32 hiddev0 -> ../../devices/pci0000:00/0000:00:13.4/usb5/5-1/5-1:1.1/usb/hiddev0/
    2. lrwxrwxrwx 1 root root 0 Dec 29 00:32 hiddev1 -> ../../devices/pci0000:00/0000:00:13.4/usb5/5-2/5-2:1.1/usb/hiddev1/


    Und nochwas bevor man nach fragt, es ist ein VFD Display, zumindest zieht es nicht wie ein LCD aus und auf der Platine steht auch VFD drauf.


    Das Display und die Fernbedienung sind identisch mit diesen

    Gruß
    Frodo

    Dieser Beitrag wurde bereits 4 Mal editiert, zuletzt von Frodo ()

  • Ich habe mal etwas weiter geforscht und festgestellt das die USB ID nicht im LIRC oder imon_vfd Module bekannt ist. Das gilt auch für das aktuelle LIRC CVS.


    Mein IR/VFD:
    lsusb: Bus 003 Device 003: ID 15c2:0036 SoundGraph Inc.


    Im LIRC gefundene IDs:
    { USB_DEVICE(0x0aa8, 0xffda) }, /* IR & VFD */
    { USB_DEVICE(0x0aa8, 0x8001) }, /* IR only */
    { USB_DEVICE(0x15c2, 0xffda) }, /* IR & VFD */
    { USB_DEVICE(0x15c2, 0xffdc) }, /* IR & VFD */
    { USB_DEVICE(0x04e8, 0xff30) }, /* ext IR only */


    Leider hat ein einfaches hinzufügen meiner ID nicht das gewünschte Ergebnis gebracht...


    dmesg produziert folgende Ausgaben

    Code
    1. usbcore: registered new interface driver hiddev
    2. input: USB HID v1.01 Mouse [HID 15c2:0036] on usb-0000:00:13.2-1
    3. hiddev96: USB HID v1.00 Device [HID 15c2:0036] on usb-0000:00:13.2-1
    4. input: USB HID v1.10 Keyboard [USB-compliant keyboard] on usb-0000:00:13.2-2
    5. input,hiddev97: USB HID v1.10 Mouse [USB-compliant keyboard] on usb-0000:00:13.2-2
    6. usbcore: registered new interface driver usbhid

    Gruß
    Frodo

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Frodo ()

  • Leider nein.
    Das einzige was ich hinbekommen habe sind die Steuertasten am Gehäuse zu aktivieren.
    Drehrad, Fernbedienung und VFD funktionieren nicht.

    Gruß
    Frodo