TT S2-3200 HD / SkyStar HD Hardware- und Treiberfragen

  • Hi alle,
    von mir noch eine vielleicht interessante Rückmeldung:


    Ich hatte eine Weile erhebliche Probleme mit dem Empfang,
    vor allem tuning-Probleme (erstmal kein Lock) und Bildaussetzer (TS-conituity-error, etc).


    Das konnte ich im wesentlichen Beheben. in dem ich
    das "alte" noname LNB (dual mit 0,6 db Rauschmass), gegen eines der neuen
    (quad 0,1 db) getauscht habe (Bezugsquelle)


    Umschalten ist prima seitdem.
    (Obwohl mein "Prod"-System mit FF und Nova keine Empfangsprobleme an der
    selben Antenne hatte). Die tt3200 ist da wohl etwas zickiger.
    Nicht empfindlich genug und/oder leichter durch Rauschen zu stören.


    Grüsse,
    Bitz


    PS: nur xv funzt immer noch nicht auf der %&$!*# ati (hd2600) in 1080 (576 geht)

  • Die letzten tage hab ich mich mit meiner WinTV Noha HD S2 gespielt. Im Anhang findet ihr einen patch gegen manus multiproto tree ( http://jusst.de/hg/multiproto ). Den Support hab ich aus dem originalen hvr4000 tree genommen.

  • Hallo alle,


    Versuche eine installation zu machen per http://www.vdr-wiki.de/wiki/in…E_DVB-S2_-_Betriebssystem
    bekomme aber ein kompilier problem nach patchen mit
    patch -p1 -i /data/installfiles/vdr/vdr-1.5.10-dvbs2-h264-syncearly-framespersec.diff
    Fehlermeldung:
    In file included from audio.c:12:
    dvbdevice.h:38: error: ‘dvbfe_delsys’ does not name a type
    make: *** [audio.o] Error 1
    -------
    auch hier dvb-s karte und h264, welcher patch? wird das problem beschrieben, aber ich habe v4l-dvb fur den S2-3200 wie in der anleitung installiert, jedoch in eine 2.6.17 kernel, konnte das das problem sein ?


    Wenn ich den spateren also ohne DVBS-2 benutze habe ich dass problem nicht.
    Was werde ich da falsch gemacht haben, alles per cut & paste gemacht kan also nich viel schiefgehen dachte ich mir.
    Ich verwende Mandriva 2008 und habe es sowohl mit gcc 3.36 als auch mit 4.2.2 versucht, aber beide gehen nicht.


    Henk Schoneveld
    Niederlande

  • Hallo belcampo,


    schau mal hier.
    Beta version of vdr with dvb-s2 support


    Wichtige ist das du das Include vom Treiber benutzt!


    bis dann LordZodiac


    Vdr1: vdr-1.7.0 HDe, Nexus 2300-S und TT S2-3200
    Vdr2: vdr-1.4.7 Nexus CA, Terratec Cinergy 1200s
    Plugins: dvd-0.3.6b03+, femon-1.1.3
    System: Suse 9.1 Kernel 2.6.28


    Testkarten: Dxr3, Hauppauge DVB-c 2.1, Terratec Cinergy 1200c, Nova-t
    Alphacrypt Light 3.11
    AMD Sempron 2400+ 512MB Epox 8RDA3I Pro
    Pentium III 384MB BX440
    Panasonic SA-XR 15 EG-S :)

  • Hi,


    Quote

    Original von belcampo
    In file included from audio.c:12:
    dvbdevice.h:38: error: ‘dvbfe_delsys’ does not name a type
    make: *** [audio.o] Error 1


    Die Fehlermeldung zeigt an, dass noch eine Include-Datei des "alten" DVB-Treibers verwendet wird, in der die neue Struktur delsys noch nicht definiert ist.


    Quote

    Original von belcampo
    Was werde ich da falsch gemacht haben, alles per cut & paste gemacht kan also nich viel schiefgehen dachte ich mir.


    Kontrolliere nochmals den Abschnitt über die Anpassungen an VDRs Makefile (DVBDIR, ...).


    Bye.

  • Hallo belcampo,


    keine Ahnung was bei dir schief geht. Das DVBDIR sollte aber auf den multiproto Treiber zeigen damit die neuen API beim compilieren benutzt wird.


    @all


    Falls es jemanden interessiert. Der Multiprototreiber läuft jetzt auch mit "alten" Karten.
    Das Tuning der DVB-S Sender läuft im Moment auch stabil. :D


    Wenn es dort Probleme gibt bitte bescheid sagen.


    Wer die TT S2-3200 in Verbinung mit einer FF Karte benutzt, sollte bei HDTV Sendern vorsichtig sein. Das kann zum Absturtz des ARM führen.


    bis dann LordZodiac


    Vdr1: vdr-1.7.0 HDe, Nexus 2300-S und TT S2-3200
    Vdr2: vdr-1.4.7 Nexus CA, Terratec Cinergy 1200s
    Plugins: dvd-0.3.6b03+, femon-1.1.3
    System: Suse 9.1 Kernel 2.6.28


    Testkarten: Dxr3, Hauppauge DVB-c 2.1, Terratec Cinergy 1200c, Nova-t
    Alphacrypt Light 3.11
    AMD Sempron 2400+ 512MB Epox 8RDA3I Pro
    Pentium III 384MB BX440
    Panasonic SA-XR 15 EG-S :)

  • Dank fur eure schnelle antworte.


    Folgendermasen gelosst:


    ---
    LOCDIR = /usr/local/src/vdr/locale
    DVBDIR = /usr/local/src/dvb/linux


    ifdef DVBDIR
    INCLUDES += -I$(DVBDIR)/include
    endif


    LIBS = -ljpeg -lpthread -ldl -lcap -lfreetype -lfontconfig
    INCLUDES = -I/usr/include/freetype2 -I/usr/local/src/dvb/linux/include
    ----


    Henk

  • Hi,



    So hätte es wohl aussehen sollen:



    Bye.

  • Hallo zusammen,
    was muss ich alles tun, damit eine TT S3200 funktioniert ?
    Ich hab mir, wie in http://www.vdr-wiki.de/wiki/in…SuSE_DVB-S2_-_DVB_Treiber beschrieben, Firmware und hg-Treiber geholt, compiler.h verlinkt etc.
    Module werden beim Reboot automatisch geladen


    Code
    1. Linux crossfire 2.6.23-gentoo-r1 #4 SMP PREEMPT Wed Nov 14 09:45:36 CET 2007 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 4000+ AuthenticAMD GNU/Linux


    Wenn ich aber mit szap2 einen Sender einstellen will, schreibt der dvbcore Trace-Informationen auf den Monitor und szap2 zuckt nicht / will nicht tunen. Fehlen mir noch Patches ? Fuer i2c oder so ? Ich hab da mal was in diesem Fred gelesen, weiss aber nicht, ob das noch aktuell ist.
    Gruss
    Michael

    Meine VDR:

  • moin


    hast du dein gentoo auf amd64 oder x86 laufen?


    gruesse mentox

  • i686, also 32bit x86. 64bit war mir fuer diese Tests noch zu "alpha".


    Das steht ubrigens in den messages:


    Meine VDR:

    The post was edited 1 time, last by Magic Michael ().

  • Tuned szap2 garnicht oder nur nicht bei HD? Falls zweiteres: Hast du die Parameter für S2 (-t 2 glaube ich) und 8PSK (könnte unnötig sein, weiss ich aber nicht) angegeben?


    EDIT:
    Oops, ein Oops... Das sieht natürlich eher weniger gut aus...

  • Zu grosser Lag beim editieren, 'tschuldigung.
    Ich bekomm auch einen Oops, wenn ich mit dvbscan rumspiele, mithin also bei jedem Zugriff auf die Karte / Module.
    Deswegen noch mal die Frage: Muss ich noch Patches auf die hg-Treiber oder etwas anderes knallen oder sollten diese Grundfunktionen auch ohne da sein ?
    Karte: TT S3200

    Meine VDR:

    The post was edited 1 time, last by Magic Michael ().

  • Hmm, hilft auch nix. Ich bin den drei Links in ollos Post gefolgt, hab die Aenderungen gemacht, und bekomme immer noch den Oops. Karte in den anderen PCI-Slot stecken bringt auch keine Punkte.


    Zum OT: Ich waere sehr dafuer, je einen Thread fuer S2-Treiber, S2-VDR und xine zu haben. Ist ja kaum noch durchschaubar mit den ueberall verteilten Informationshaeppchen.

    Meine VDR:

  • LordJaxom

    Quote

    Hätte jemand etwas dagegen wenn ich die letzten 10 Treiber-Beiträge und die letzten 10 Xine-Beiträge in zwei neue Threads packe und diesen schließe?!)


    Ich glaube das ist besser. Hier findet sowieso keiner mehr was. :)


    Magic Michael


    kann sein das du Kerneltreiber und Multiprototreiber gemischt hast?


    bis dann LordZodiac


    Vdr1: vdr-1.7.0 HDe, Nexus 2300-S und TT S2-3200
    Vdr2: vdr-1.4.7 Nexus CA, Terratec Cinergy 1200s
    Plugins: dvd-0.3.6b03+, femon-1.1.3
    System: Suse 9.1 Kernel 2.6.28


    Testkarten: Dxr3, Hauppauge DVB-c 2.1, Terratec Cinergy 1200c, Nova-t
    Alphacrypt Light 3.11
    AMD Sempron 2400+ 512MB Epox 8RDA3I Pro
    Pentium III 384MB BX440
    Panasonic SA-XR 15 EG-S :)

  • Quote

    Original von LordZodiac
    kann sein das du Kerneltreiber und Multiprototreiber gemischt hast?


    Aeh, nee. Kernel / -module sind ohne v4l und dvb gebaut, /lib/modules/... vorher geloescht. Dann hg-Module gezimmert. Hab mir nur Wiki-gemaess die /usr/src/linux/include/linux/compiler.h in mein hg-Verzeichnis gelinkt.
    Oder meinst Du noch andere Treiber als v4l und dvb ?

    Meine VDR:

  • :moin Magic Michael


    also am multiproto repository liegt es nicht - bei mir tut der aktuell ausgecheckte Treiber nämlich (Ubuntu 7.10 kernel 2.6.22-? als AMD64). Mir scheint eher Dein Gentoo kernel spuckt da in die Suppe?!


    Gruß, ollo

  • Quote

    Original von ollo


    also am multiproto repository liegt es nicht - bei mir tut der aktuell ausgecheckte Treiber nämlich (Ubuntu 7.10 kernel 2.6.22-? als AMD64).


    Kannst du deine angaben etwas verfeinern? Ich hab hier das neueste multiproto über hg mit standart ubuntu 2.6.22-[12|14], brav mit make übersetzt krieg aber immer den fehler, den Magic Michael geschrieben hat...


    Magic Michael : geht es jetzt für dich? Wenn ja, was hast du genau gemacht?


    thanks. bn