Trixbox und Asterisk mit PBX-Weboberfläche...

  • Hallo,


    jaja, alles fängt er an und nix bekommt er hin. Demnächst hat der Ollie keinen Job mehr und wird wohl auch keinen mehr bekommen, da er ja auch schon 39 ist. Heute ist man ja schon mit knapp 30 zu alt und zu teuer für den deutschen Arbeitsmarkt. Naja, seine alte Dalmilady ist jetzt auch bald 13 1/2 und wird wohl aufgrund einiger Gesäugetumore, eines epileptischen Anfalls und immer schwächer werdenden Hinterbeinchen auch nicht mehr lange zu leben haben. Es ist echt ein Jammer :-(


    Aber das Drama ist ja nichts neues. Wenn man schon untergeht, sollte man es wenigstens stilvoll tun. Daher habe ich gestern Mama´s letzte Flasche Prosecco aus dem Keller geholt, diese nacheinander ins Glas gefüllt, über mein mittlerweile immer mehr verpfuschtes und immer mehr aus dem Router äh Ruder laufendes Leben nachgedacht und geheult wie ein Schlosshund angesichts der schönen, alten Zeiten. Nebenbei: Wann wird man alt...? Antwort: Wenn man anfängt, in der Vergangenheit zu leben.


    Dann hab ich dieser Tage noch zwei Router (daher wohl gerade die Tippfehler) durch den Schornstein geheizt und bekomme meinen neuen nach der "Installation" (ich nenne Sie jetzt mal bewusst so) nicht mehr über´s Webinterface konfiguriert. Na, sei´s drum. Ins Internet komme ich. WLAN geht auch, angeblich hab ich sogar die WPA-2 Verschlüsselung hinbekommen, also was soll´s. Da macht es dann nicht wirklich was, wenn der eine D-LINK nach nem Flaschenupdate (Flash, I know) nicht mehr wirklich will und der andere meint, er hätte kein W-LAN mehr und jetzt nur noch als LAN-gebundener Router funktioniert. Naja, vielleicht kann ja mal irgendjemand mir zu Weihnachten aus zwei Routern wieder einen ganzen bauen. Ob sich das bei nem DI-524 wirklich lohnt, ist allerdings ne andere Frage.


    Aber ich sollte kurz zum wirklichen Thema und meiner eigentlichen Frage(n) kommen:


    Asterisk und Trixbox...tscha...eigentlich scheint es mir am einfachsten zu sein, diese Installation mit dem CD-Image von Trixbox.org zu machen. Ich hab jetzt nebenbei noch nen Eisfair-Testrechner stehen und ne Ubuntu-Installation (nicht, dass ich das alles begreifen oder verstehen würde), aber immerhin lief der Eisfair fast out of the Box und dank der guten Doku hab ich´s sogar via Windows und Putty geschafft, die Kiste über´s Netzwerk zu administrieren. Aber es ist schon etwas kompliziert für mich. Ubuntu...naja, recht einfache Installation von der Live-CD, nur beim Booten wählt er jedes Mal eine Auflösung mit der mein TFT nicht zurechtkommt. Okay, ist sicher irgendwo in der Grub-Boot-Zeile etwas drin, was die Kiste überfordert (vga=irgendwas oder so). Laufen tut´s ja. Jetzt sind die Installationsanleitungen für Ubuntu-User und Asterisk mit PBX natürlich auch etwas dünn gesät (zumindest für 7.10) und man weiss ja, dass Version X nicht mit Y und Z nicht mit W geht. Von distri-spezifischen Eigenheiten immer mal wieder abgesehen.


    Tscha, Trixbox...wäre schon cool. CD einlegen, nen bisschen einstellen und schon gehts. Zumindest mal schauen, ob´s wirklich so ist. Jetzt fangen die Probleme an: 2.2.4er Image...Installation hängt sich auf...2.2.5a genauso. Desgleichen für die 2.3.2.65...


    Was hängt sich genau auf ? Nuja, also die CD bootet...man kann irgendwo mal die Zeile erkennen. k8-powernow cpuid 662 not supported. Liest sich ja nicht wirklich toll.


    Was aber nichts macht, weil das weder mit dem PIII 600 Mhz meines ASUS P3-BF Boards geht, noch mit dem Athlon-XP 2000er (auf 1 Ghz gedrosselt) meines ECS K7S5A.


    Egal, was man da reintastet...der Anaconda-Installer kommt maximal bis zur Installation von Perl, bricht aber auch schon mal vorher bei Glibc oder so ab.


    Mir ist zudem aufgefallen, dass man bei einer unter Windows formatierten Festplatte gefragt wird, was man alles installieren will. Ist dann die Installation einmal durchgelaufen bzw. hakte an der eben beschriebenen Stelle, dann erscheint dieser Part, welche Pakete auf die Platte sollen, nicht mehr. Auch nicht dann, wenn man vorher alles wieder platt machen will.


    Die CD defekt, verbrutzelt ? Unwahrscheinlich, zumindest sagt die Prüfroutine, dass die CD in Ordnung ist und die Checksummen passten auch. Aber na jut, wenn die Installationsroutine schon nix taugt, wieso sollte da die CD-Prüfroutine besser sein ? Grundsätzlich stimmen die Dateigrössen und die Gesamtgrösse des ISO-Files schon, so dass der Fehler hier eigentlich nicht sein kann.


    Ehrlich, ich hab ja nicht wirklich die grosse Ahnung, okay, aber ich weiss, das das ASUS P3BF und das ECS K7S5A jetzt nicht wirklich die Hammerboards waren oder sind, aber sie haben einen grossen Verbreitungsgrad und werden absolut sicher von Linux generell unterstützt.


    Wieso das weder mit CentOS 4.5 noch mit 5 gehen soll, wissen die Götter. Wie kann man jetzt also so ne Trixbox-ISO-CD ans Laufen bekommen ?


    Ich hab sogar, weil ich an zu alte Hardware dachte, mein A7V8X-X eingesponnen, okay, das ist auch nicht gerade superneu, aber das man für ne Trox-(Schrott-)box heuer nen Ahtlon XP-64 Dual-Core X2 braucht mit Minimum 3 GB RAM und S-ATA-Raid-Architekture, wäre mir neu. Das scheint für so ne einfache Telefonanlage doch nun etwas oversized zu sein.


    Aber da hat die Installation natürlich auch nicht geklappt.


    Beim Start des Installers hab ich auch mal linux i586 oder nur i586 und auch athlon-xp eingegeben. Ich hab auch mal bei google nachgeschaut, ob´s irgendnen Beitrag gibt, der einem sagt, was man jetzt nun bei der Startinstallation an Parametern mit übergeben muss, damit das alles geht.


    Aber so richtig viel und erschöpfendes hab ich nicht gefunden. Ich weiss sehr wohl, dass dieser Beitrag hier nicht wirklich hingehört, aber da ich ja einen gewissen Altstatus habe, eine mehr oder weniger anerkannte Berühmtheit bin, wenngleich sicherlich keine ruhmreiche und immer wieder höre, dass meine Pleiten-Pech- und Pannenbeiträge die Olaf-Fangemeinde hier und da zum Schmunzeln bringen, dachte ich mir, es wäre sicherlich okay, wenn ich das ganze hier reinschreibe...


    Weil im IP-Phone-Forum, wo man sich auch mit sowas beschäftigt, war die Resonanz auf meine Anfrage nicht wirklich so toll.


    Vielleicht gibbet hier ja auch für Asterisk und Co. den ein oder anderen Experten...


    Gruss Olaf

    Ollie jetzt auch im Internet !!! ->> http://www.ohms.ws << VDR mit ASUS A7V8X-X, Athlon XP 2 Ghz, 512 MB DDR-RAM und gentoo 2008.0 Linux, ner Menge Platten (1 TB), 2 Brennern und Karten-Vollausstattung (1 X Nexus 4 MB Mod, 3 x Nova, 1 PVR 350) , TFT/Sony PSOne, Nvidia Graka und und und * Linux - wir geben ihrem Computer das Leben zurück *

    The post was edited 2 times, last by olafhenkel ().

  • ich vermute das die HW wohl eher zu neu ist, was Du da vorhast, naja die E-Werke werden es Dir danken.
    Einen D-Link Router würde ich mir nie kaufen oder meine Zeit mit verschwenden, die 2 letzten von der Arbeit haben wir verschenkt.
    Sollen sich da andere mit rumärgern schon der Netzteile wegen :( .

    Software: gen2vdr V3 ( Beta8 ) / gen2vdr V2
    Hardware: Intel 5200EE - 5N7A-VM - Scythe Shuriken - BeQuiet(Netzteil) - X10-USB Remote
    SMT 7020S & P3@900 - Testsystem mit FF und X10-USB Remote
    Links für Neueinsteiger


    "Jetzt, wo ich weiß wie es geht, versteh ich auch die Gebrauchsanleitung"

  • Hm, ich hätte ich noch nen K6-350 Mhz Board anzubieten, aber wenn andere das mit Athlon-Prozzis machen, dann kann die Hardware ja wohl kaum zu neu sein.


    Wenn CentOS oder Trixbox zudem 64er Athlons und Opterons und so nen "neuen Schrott" supporten, dann kann ja man wohl ein normaler Athlon XP kaum "zu neu" sein, oder ?


    Naja, die E-Werke. Ich hab das jetzt in nem Siemens Scenic Gehäuse drin, das eins von diesen geregelten 145 Watt Netzteilen hat. Dazu ne olle SV1296D von Samsung, nen paar Karten, der Prozessor runtergeschaltet auf 1 Gig, das geht einigermassen. Ist mir eigentlich scheissegal. Glaubste, bei meiner Stromrechnung fällt das ins Gewicht ? Nein...da saugt meine Heizung mehr (50.000 kWh/p.A.)


    Ansonsten seh ich meine Gurken so wie in dieser Werbeanzeige hier...


    Ich mag Werbung im Web auch nicht sonderlich, aber die ist ganz nett...und passt in die Situation...


    http://www.fujitsu-siemens.de/…ldserver/tx120/index.html


    Greets Olaf

    Ollie jetzt auch im Internet !!! ->> http://www.ohms.ws << VDR mit ASUS A7V8X-X, Athlon XP 2 Ghz, 512 MB DDR-RAM und gentoo 2008.0 Linux, ner Menge Platten (1 TB), 2 Brennern und Karten-Vollausstattung (1 X Nexus 4 MB Mod, 3 x Nova, 1 PVR 350) , TFT/Sony PSOne, Nvidia Graka und und und * Linux - wir geben ihrem Computer das Leben zurück *

    The post was edited 2 times, last by olafhenkel ().