zendeb 0.2.2 (Etch für SMT / S100)

  • Quote

    Original von guxxu
    ...upps! Ich wusste gar nicht, dass es so viele Debian-VDR Distributionen gibt, dachte, Zendeb sei irgendwie ein Nachfolger von Det/Decembersoul's Version. Dann bin ich hier wohl im falschen Thread?


    Eine kleine Versionshistorie:
    Grundlage für so ziemlich alle Distries für die S100/SMT ist zenslack von giga_san. Hier war besonders der VDR eine selbstkompilierte Sache und auch das Nachrüsten von Systemerweiterungen war kompliziert und unhandlich.


    Daraufhin habe ich erstmal für mich eine Debian Net-Install auf meiner SMT gemacht und dann die Hardwarespezifischen Änderungen von zenslack "minimalinvasiv" auf debian übertragen und e-tobis vdr Repository eingebunden, weil ich der Meinung bin, dass man nicht das Rad 1000 mal neu erfinden muss und vdr + plugins aus e-tobis Repository für die meisten Angelegenheiten wunderbar funktionieren.
    Auf Nachfragen in diesem Forum (unter anderem von det) habe ich dann Patches bereitgestellt und eine Anleitung wie man debian auf die Kisten kriegt. Damals mit der klaren Aussage, dass man Debian Erfahrung braucht um das hinzukriegen.
    Eigentlich sollte es das damals gewesen sein, aber irgendwie wurde ich in einer Woche zig mal gefragt ob es ein Iso geben wird oder zumindest ein tar aller zenslack mit schon installiertem Debian.


    Daraus wurde dann zendeb.


    Da meine Vorstellungen von einem perfekten System aber nunmal meine sind - und jeder seine eigene Meinung haben darf, fand sich jemand, der das alles zu Userunfreundlich fand und überhaupt gerne seinen vdr selbst kompilieren wollte - det.


    Daraufhin hat er seine eigenen Distrie ins leben gerufen, die völlig debian untypisch im Bereich vdr nicht auf Pakete sondern auf Eigenkompilationen aufbaute. Wenn ich an meine Diskussionen von damals mit det zurückdenke, in denen ich immer bedenken äusserte ob er wohl ähnlich kontinuierlich und zukunftssicher Updates für die zig Plugins für seine Distrie verbreiten wird fühle ich mich heute, wo bei seiner distrie nichts mehr passiert, ziemlich bestätigt.


    Nachfolgend und parallel erschienen noch einige andere Distries (aufbauend auf anderen Linux Derivaten) .
    So z.B. gen2vdr Anpassungen
    oder zen2vdr.



    Das hängt schwer von deinen Vorkenntnissen, deinen Zielen und deinem Geschmack ab.


    Generell ist allerdings der Ausgang beider Boxen eher für PAL Fernsehen in PAL Aulösung an 50 Hz Röhrenfernsehern wesentlich besser geeignet als für irgendwelche anderen Auflösungen und Refreshraten, da du sonst immer massiv Probleme mit Interlacing/Deinterlacing erfahren wirst.



    P.S.:
    Nachdem du meinen Aufforderungen zu Reparatur von zendeb gefolgt bist um irgendwas selbstgebasteltes von det zu reparieren tippe ich leider darauf, dass die Installation so nicht mehr funktioniert.

    Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
    1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
    3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
    mit yavdr 0.4.0

    The post was edited 1 time, last by Egalus ().

  • Quote

    ...t ippe ich leider darauf, dass die Installation so nicht mehr funktioniert.

    und wahrscheinlich auch nicht mehr zu retten ist. Macht aber eigentlich nichts, ich hab ja nichts eigenes dazugetan. Dann installier ich halt neu (die 0.2.2, oder?). Ich denke, mit Debian werde ich schon klarkommen. Das Paketzeugs ist einfach cool. Cool fand ich n.b. auch das besagte Backup-Plugin in Det's Distri.


    Ja, vielen Dank auch für die erhellenden Ausführungen. Sorry, dass ich da so zwischen die verschiedenen Gleise geraten bin.


    Dank und Gruß,
    Guxxu

    auffem Schirm: ZenDeb,ZenSlack,ZEN2MMS,S100, SMT-7020S, DBox2, Fritzbox, WLHDD

    The post was edited 1 time, last by guxxu ().

  • Ob du die alte 0.2.2, die etwas neuere um MMS erweiterte 0.3.x oder eine der Beta-Versionen 0.4.x nimmst bleibt dir überlassen.
    Bei der 0.4.1-beta1 ist einiges neu und Support für die S100 von mir nicht komplett getestet - insbesondere WLAN - dafür gibts da die aktuelle VDR Version, neueren Kernel, neue MMS Version und Unterstützung für das SMT-Wakeup Board.
    Wobei der Kernel alles für die S100 mitbringt - nur fehlt mir momentan die S100 um die neuen WLAN Treiber zu testen ;)


    Sind alle nach dem gleichen Muster zu installieren und nutzen alle Debian Etch als Unterbau.

    Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
    1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
    3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
    mit yavdr 0.4.0

  • Quote

    nur fehlt mir momentan die S100 um die neuen WLAN Treiber zu testen


    Will ich gern testen. Wenn ich hier weiterhin so gut unterstützt werde, probier' ich's gern nochmal mit der 0.4.


    Heut Abend...


    Gruß,
    Guxxu

  • Hallo,
    hab erst seit kurzen eine S100 und hab eine Technotrend TT-budget 1500S TV Karte eingebaut.
    Hab nun bereits verschiedene Versionen von zendeb installiert (0.2.2, 0.4.0, 0.4.1) und bekomme immer folgenden Fehler (bis auf 0.2.2, der Kernel ist glaub ich eh zu alt) - Auszug aus dmesg:



    Kann mir da jemand helfen, liegt das am Kernel?

  • Ich würde auch gerne den Betrieb über VGA nutzen wollen (zendeb0.4.0beta). Einerseits möchte ich gerne das Testen am TFT-Monitor betreiben, da der TV nicht immer verfügbar ist. Anderseits will ich eine zweite S100 hauptsächlich als MP3-Player in der Küche betreiben, und da steht halt max. ein TFT.


    EDIT 25.01.08


    Die Lösung für den TFT-Betrieb gibt es hier:
    xorg.conf



    Bin jetzt schon das ganze Wochenende am experimentieren. Nach einigen Rückschlägen funktioniert der Betrieb Betrieb jetzt halbwegs.
    MMS startet in der richtigen Seitenverhältnis. Daten werden vom Server über NFS gemountet. Bilder, MP3 werden angezeigt. Der Wechsel zwischen den Verzeichnisen dauert aber eine halbe Ewigkeit. Auch ein Zugriff über ssh dauert ewig. Hier habe ich aber noch mein Netzwerk in Verdacht. Wenn ich an meinem Arbeitsplatz mit einem Switch arbeitet geht ssh recht zügig. Ob MMS ebenso schnell ist, kann ich leider ohne TFT Anzeige leider nicht beurteilen. Mein eigentliches Problem ist aber der VDR.


    Beim Wechsel von MMS zum VDR bekomme ich erstmal das Bild no signal. Wenn ich den Kanal wechsel bekomme ich EPG-Information aber kein Bild. Bezweifel derzeit noch ob es sich um aktuelle Infos handelt. Die Reihenfolge der Kanäle stammt jedenfalls nicht von meiner channel.conf. Mir ist nicht klar (mache ich zum erstenmal) wie ich nun den client dazu überrede, auf die Daten des VDR zuzugreifen. Meine Ausgangslage:


    Server:

    • debian etch mit vdr
    • streamdev-server
    • quicksearchonly
    • xineliboutput
    • epgsearch


    in der /var/lib/vdr/svdrphosts.conf ist folgender Eintrag:
    192.168.1.0/24


    Auf der S100
    /etc/fstab nfs-mount: mit meiner serverip, alle anderen auskommentiert
    /etc/zendeb/conf: unter wakeserver ip und mac geändert
    /etc/zendeb/etherwake: ip und mac geändert
    /etc/zendeb/mms/mms-config/config-S100 pfade angepasst
    /var/lib/vdr/setup-conf bei streamdev remote-ip angepasst


    Mir ist einfach nicht klar wie ich der S100 nun klar machen soll, wie es auf die Daten des Servers zugreifen kann. Jede Hilfestellung ist willkommen.

    ASROCK P4i65GV - 2000Mhz CPU - 512MB HS - 250GB HD - Hauppage FF 2.3 - Hauppage FF 1.5 - C't6 Kernelupdate 2.6.21


    testing
    medion pc 2GHz - Hauppauge WinTV-NOVA-s - als reiner server mit debian etch 4 und vdr
    S100-client mit zendeb

    The post was edited 1 time, last by hoarst ().

  • Habe den fernseher mal wieder kurzfristig zur Verfügung.


    auf der s100 mußte ich noch die folgende Datei verändern.
    /etc/resolve.conf mit der richtigen ip versehen.


    VDR startet mit no signal
    streamdev habe ich über das osd ausgeschaltet.
    Wie jetzt aber das xinelioutput zum Laufen bekomme ist mir immer noch ein Rätsel.
    Hänge mal die logs an:

    Files

    • messages.txt

      (19.01 kB, downloaded 120 times, last: )
    • user.log.txt

      (15.13 kB, downloaded 131 times, last: )
    • syslog.txt

      (36.76 kB, downloaded 139 times, last: )

    ASROCK P4i65GV - 2000Mhz CPU - 512MB HS - 250GB HD - Hauppage FF 2.3 - Hauppage FF 1.5 - C't6 Kernelupdate 2.6.21


    testing
    medion pc 2GHz - Hauppauge WinTV-NOVA-s - als reiner server mit debian etch 4 und vdr
    S100-client mit zendeb

  • Hallo Egalus,


    hab mir auch mal 'ne S100 zugelegt und zendeb 0.41 auf CF gepackt. Läuft soweit ganz gut. Da ich vdr auf einem server mit xineliboutput laufen habe ist auf der S100 kein vdr gestartet sondern nur vdr-sxfe.


    In der vdr-sxfe.sh musste ich den Verweis xvdr mit der localhost rausnehmen (lokal gibt's ja keinen vdr). Könnte man das zukünftig in di e Konfiguration auslagern oder habe ich hier was total verpeilt?


    Habe mal testweise mms-plugin-clock bzw. mms-plugin-weather per apt installiert, dann hagelts beim Start von mms segfaults. Ich habe die plugins dann wieder rausgenommen, ging einwandfrei, dann einzeln probiert, jedesmal segfault (error 4 in libstdc++.so.6.0.8..... ).


    Die FB scheint unter mms wohl nur rudimentär auf die S100 angepasst zu sein, aber ich muss mich erstmal durch diesen megathread quälen, eventuell hab ich ja was überlesen.


    Aber erstmal vielen Dank für diese Debianlösung.


    olkol


    Edit: ich depp sollte mal apt-get uprade machen....