Xfree4.3.0 und EM8400

  • Hallo Leute,


    habe gerade den Sigma EM8400 und den TVIA5005 Treiber unter linux am laufen.


    Bei dem Sigma weiss ich nicht, wie ich diesen Testen soll:

    Code
    1. VDR-Box root # lsmod
    2. Module Size Used by Tainted: P
    3. realmagic84xx 36992 1


    Geladen ist der Treiber als Modul (s.o.) und die devices /dev/realmagic0 - 30
    sind auch angelegt.


    Bei dem Tvia habe ich folgendes Problem:


    Das Bild flackert leicht. (Am Monitor die TV-Modes scheinen gut zu laufen, also das was am SCART raus kommt)
    Wer kann mir hier helfen ?!?!


    hier noch meine XF86Config


    (VDR01)
    Activy 570 mit folgender Hardware:


    Mainboard: ASUS P5KPL-AM
    CPU: C2D E6550
    RAM: 1GB
    HDD: SAMSUNG HD103SI 1TB
    DVD-Brenner: HL-DT-ST DVDRAM GSA-4163B
    Grafik: nVidia Corporation GT218
    DVB 1: TT S2-1600
    DVB 2: TT S2-3200


    Soft: gen2vdr V3 beta8
    (VDR02)
    Eigenbau:


    Mainboard: ASUS M3N78-EM
    CPU: AMD Sempron
    RAM: 1GB
    HDD: SAMSUNG 80GB


    Soft: gen2vdr V3 beta8 Streaming-Client

  • Moin mschmitz,


    also zum testen des Sigma8400 kannst du mal hier schaun


    HIER


    ist zwar nicht fuer die Activy speziell, aber es gibt dort ein Testprogramm für den Sigma8400. Leider habe ich im Moment nicht die Zeit mich selbst dran zu setzen


    so long


    Schnuller

  • Hallo @ALL Hallo Schnuller


    Also, der Sigma EM8400 scheint wirklich zu laufen.


    Ich habe allerdings ein Problem.


    Starte ich den dvdplayer, so sagt er mir das der "Overlay-Modus" nicht funktioniert, sollange das Flachbandkabel nicht angeschlossen ist.
    "Die Ausgabe findet auf dem TV-Bild statt!!!" <---- Fehlermeldung im Programm.


    Jetzt spielt auch der dvdplayer, aber ich sehe logischer weise nichts, da der TV-Ausgang durch die GraKa belegt ist.
    Wie bekomme ich jetzt den EM8400 dazu den "Overlay" einzuschalten ?!?!


    Danke und Gruß


    mschmitz

    (VDR01)
    Activy 570 mit folgender Hardware:


    Mainboard: ASUS P5KPL-AM
    CPU: C2D E6550
    RAM: 1GB
    HDD: SAMSUNG HD103SI 1TB
    DVD-Brenner: HL-DT-ST DVDRAM GSA-4163B
    Grafik: nVidia Corporation GT218
    DVB 1: TT S2-1600
    DVB 2: TT S2-3200


    Soft: gen2vdr V3 beta8
    (VDR02)
    Eigenbau:


    Mainboard: ASUS M3N78-EM
    CPU: AMD Sempron
    RAM: 1GB
    HDD: SAMSUNG 80GB


    Soft: gen2vdr V3 beta8 Streaming-Client

  • HAllo @All,


    ich schieb das mal wieder nach oben.


    schnuller



    wie hast Du denn denn 1.4 Mhz in der Activy zu laufen gebracht ?
    Kannst Du mir mal Infos darüber geben.
    Danke



    Gruß


    mschmitz

    (VDR01)
    Activy 570 mit folgender Hardware:


    Mainboard: ASUS P5KPL-AM
    CPU: C2D E6550
    RAM: 1GB
    HDD: SAMSUNG HD103SI 1TB
    DVD-Brenner: HL-DT-ST DVDRAM GSA-4163B
    Grafik: nVidia Corporation GT218
    DVB 1: TT S2-1600
    DVB 2: TT S2-3200


    Soft: gen2vdr V3 beta8
    (VDR02)
    Eigenbau:


    Mainboard: ASUS M3N78-EM
    CPU: AMD Sempron
    RAM: 1GB
    HDD: SAMSUNG 80GB


    Soft: gen2vdr V3 beta8 Streaming-Client

  • mschmitz

    Zitat

    habe gerade den Sigma EM8400 und den TVIA5005 Treiber unter linux am laufen.


    Das interessiert mich ja dann doch ein wenig! Habe schon viel experimentiert mit dem TVIA5005, jedoch bis auf einen grünen Bildschirm nix raus bekommen?!
    Welchen Treiber/Modul und welche Distribution hast du verwendet?


    Gruss

    Activy300 mit DVB-C und VDR 1.2.6 (MLD 0.2.1)
    Plugins: alcd-0.0.10, dvd-0.3.4-rc10, mp3/mplayer-0.8.2, vcd-0.0.6b, prefermenu-0.5.3, sleeptimer-0.2

  • Hallo Ber5erker,


    Distribution ist eine Gentoo 1.4 mit Kernel linux-2.4.23_pre7-gss (wobei mit diesem Kernel ALSA nicht mehr läuft).
    Treiber sind die Tvia Linux/XFree86-4.3.0 Display Driver Version x4.3.0.3.00.
    Habe alles anhand der Readme installiert.


    Gruß


    mschmitz

    (VDR01)
    Activy 570 mit folgender Hardware:


    Mainboard: ASUS P5KPL-AM
    CPU: C2D E6550
    RAM: 1GB
    HDD: SAMSUNG HD103SI 1TB
    DVD-Brenner: HL-DT-ST DVDRAM GSA-4163B
    Grafik: nVidia Corporation GT218
    DVB 1: TT S2-1600
    DVB 2: TT S2-3200


    Soft: gen2vdr V3 beta8
    (VDR02)
    Eigenbau:


    Mainboard: ASUS M3N78-EM
    CPU: AMD Sempron
    RAM: 1GB
    HDD: SAMSUNG 80GB


    Soft: gen2vdr V3 beta8 Streaming-Client

  • HAllo @ALL


    ich brauche hier auch mal ein paar Antworten.


    Habt Ihr auch schon getestet ?!?


    Gibt es hier nicht so viele Activy(isten) ?!


    Berichtet mal.


    Danke.


    mschmitz

    (VDR01)
    Activy 570 mit folgender Hardware:


    Mainboard: ASUS P5KPL-AM
    CPU: C2D E6550
    RAM: 1GB
    HDD: SAMSUNG HD103SI 1TB
    DVD-Brenner: HL-DT-ST DVDRAM GSA-4163B
    Grafik: nVidia Corporation GT218
    DVB 1: TT S2-1600
    DVB 2: TT S2-3200


    Soft: gen2vdr V3 beta8
    (VDR02)
    Eigenbau:


    Mainboard: ASUS M3N78-EM
    CPU: AMD Sempron
    RAM: 1GB
    HDD: SAMSUNG 80GB


    Soft: gen2vdr V3 beta8 Streaming-Client

  • Hallo @All


    keiner da, der was dazu sagen kann ?!?!


    Schade


    @ Ber5erker


    Was machen Deine Tests ?!


    Gruß


    mschmitz

    (VDR01)
    Activy 570 mit folgender Hardware:


    Mainboard: ASUS P5KPL-AM
    CPU: C2D E6550
    RAM: 1GB
    HDD: SAMSUNG HD103SI 1TB
    DVD-Brenner: HL-DT-ST DVDRAM GSA-4163B
    Grafik: nVidia Corporation GT218
    DVB 1: TT S2-1600
    DVB 2: TT S2-3200


    Soft: gen2vdr V3 beta8
    (VDR02)
    Eigenbau:


    Mainboard: ASUS M3N78-EM
    CPU: AMD Sempron
    RAM: 1GB
    HDD: SAMSUNG 80GB


    Soft: gen2vdr V3 beta8 Streaming-Client

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von mschmitz ()

  • HAllo @ALL,


    ich drück das hier noch mal nach oben.


    Keiner da, der auch am testen ist mit der Activy ?!!?


    Gruß


    mschmitz

    (VDR01)
    Activy 570 mit folgender Hardware:


    Mainboard: ASUS P5KPL-AM
    CPU: C2D E6550
    RAM: 1GB
    HDD: SAMSUNG HD103SI 1TB
    DVD-Brenner: HL-DT-ST DVDRAM GSA-4163B
    Grafik: nVidia Corporation GT218
    DVB 1: TT S2-1600
    DVB 2: TT S2-3200


    Soft: gen2vdr V3 beta8
    (VDR02)
    Eigenbau:


    Mainboard: ASUS M3N78-EM
    CPU: AMD Sempron
    RAM: 1GB
    HDD: SAMSUNG 80GB


    Soft: gen2vdr V3 beta8 Streaming-Client

  • Zitat

    Das Bild flackert leicht.


    habe eine lösung dafür :
    Option "MemClock" "120MHz"



    Code
    1. Section "Device"
    2. Identifier "Standardgrafikkarte"
    3. Driver "tvia"
    4. BusID "PCI:1:6:0"
    5. # Option "UseFBDev" "true"
    6. Option "cyberpro_tv_on" "pal_720x576"
    7. Option "MemClock" "120MHz"
    8. # Option "VideoRamBus32"
    9. Option "xvimg_doublebuffer" "boolean"
    10. EndSection


    für das overlay problem:
    in XF86Config-4

    Zitat

    Load "v4l"


    eintragen v4l isr overlay




    oder
    X beenden und versuche ein *.mpg file unter konsole zu starten.


    http://www.gctglobal.com/Downl…YBACK/mpeg4_playback.html


    Code
    1. ./playfile s /root/video-files/my_movie.mpg



    ich habe nur den TVIA modul für XFree86_4.3.0 installiert, damit ich S-Video einschallten kann, aber leider ist mein Englisch null! :( und ich komme nicht weiter.


    KDE Desktop (TV-Out) ist etwas mehr nach Rechts
    gibt es für dieses problem irgendwelche Linux tools wie z.b. Powerstrip unter Windows, damit ich "Horizontale Lage" einstellen kann!


    Vielleicht Steht das auch in readme:( Sorry für diese frage aber kann mir das jemand übersetzen ?(:rolleyes:






    Download TVIA Modul für XFree86_4.3.0

  • Hi


    du siehst nix, denn der EM8400 und der TVIA sind weder ueber das Decoder Inferface am TVIA noch ueber den Feature connector-on Board miteinander verbunden. Lediglich ueber die synclock funktion kannst du direkt auf dem output des TVIAs sehen was der EM8400 macht. Dazu brauchst du aus dem TVIA SDK das synclock utility.
    Plan B ist es das Bild ueber Overlay anzusehen - ich weiss aber nicht wie das geht.
    Plan C ist es mittels des TDK einfach den Ausgang des EM8400 auf den SCART oder SVIDEO Ausgang umzuzschalten ... wenn sich jemand mal erbarmt und ein utility dafuer produziert.


    Gruss,


    Giga

  • gutes bild ist nur mit XFree86-4.2 (Debian Woody) und als modul vesa.


    mit XFree86-4.3 funktioniert das nicht



    XF86Config-4


    756x567 geht auch :-)


    Das bild am TV ist aber wie eine Lupe die ich mit maus Scrollen kann, finde ich aber gut so weil die Texte sehr gut zu erkennen sind

  • Hi,


    also wenn ich es richtig verstanden habe kann man Analog VIDEO/AUDIO vom EM8400 auf den Scart AUX legen (Direct MPEG output CVBS or Y/C) oder ueber Port A des CyberPro via Overlay, Port B des CyberPro ist vorne Links auf dem Motherboard der 300er unbestückt(bei den neuen scheint es den VIP nicht mehr zu geben. Den SPDIF vom EM8400 kann man scheinbar auch direkt auf den Ausgang der Activy Schalten.


    CU
    9000h

    Es ist eagl in wlehcer Reiehnfogle die Bchustebaen in Woeretrn vokrmomen. Huapstache der estre und leztte Bchustbae sitmmen.

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von 9000H ()

  • morgen,


    ich habe da mal ne kleine frage :D


    ich habe von sigma eine xcard basierend auf dem em8475 chip, könntet
    ihr euch vorstellen das diese karte auch mit den treibern auf einem "normalen" pc läuft.
    offiziel gibt es für meine kärtchen keine linux treiber nur als developer version.


    danke

    :hat3
    Coolermaster ATC-620C-SX1,C3M266-L,VIA C3 1100Mhz, 256MB,DVB-S Rev.1.3, ss2, 80GB IBM, Toshiba DVD,LinVDR 0.6 + div. Modifikationen

  • Hallo @ALL,


    hat schon jemand treiber für den kernel 2.6 gefunden?



    Gruß
    mschmitz

    (VDR01)
    Activy 570 mit folgender Hardware:


    Mainboard: ASUS P5KPL-AM
    CPU: C2D E6550
    RAM: 1GB
    HDD: SAMSUNG HD103SI 1TB
    DVD-Brenner: HL-DT-ST DVDRAM GSA-4163B
    Grafik: nVidia Corporation GT218
    DVB 1: TT S2-1600
    DVB 2: TT S2-3200


    Soft: gen2vdr V3 beta8
    (VDR02)
    Eigenbau:


    Mainboard: ASUS M3N78-EM
    CPU: AMD Sempron
    RAM: 1GB
    HDD: SAMSUNG 80GB


    Soft: gen2vdr V3 beta8 Streaming-Client