Sleep-Timer restartet VDR

  • Hi!


    Ich habe auf meinem C'T VDR 6.0 das sleeptimer Plugin installiert. Wenn ich jedoch einen Timer einstelle, dann wird der PC nicht herrunter gefahren sonden nur der VDR (also nicht das ganze System) restartet.


    Code
    1. Sep 16 11:13:59 vdr vdr: [2685] confirm: Sleep-Timer in 2 Minuten aktivieren?
    2. Sep 16 11:13:59 vdr vdr: [2685] warning: Sleep-Timer in 2 Minuten aktivieren?
    3. Sep 16 11:14:00 vdr vdr: [2685] confirmed
    4. Sep 16 11:14:00 vdr vdr: [2762] sleeptimer: thread started (pid=2685)
    5. Sep 16 11:15:00 vdr vdr: [2762] confirm: Sleep-Timer in einer Minute
    6. Sep 16 11:15:00 vdr vdr: [2762] warning: Sleep-Timer in einer Minute
    7. Sep 16 11:15:00 vdr runvdr: restarting VDR
    8. Sep 16 11:15:00 vdr kernel: saa7146: unregister extension 'dvb'.
    9. Sep 16 11:15:00 vdr kernel: ACPI: PCI interrupt for device 0000:01:0a.0 disabled
    10. Sep 16 11:15:03 vdr kernel: saa7146: register extension 'dvb'.


    Wie man aus dem Log erkennen kann, kommt der VDR gar nicht bis zum Ablauf des Timers, stattdessen restartet er sobald der Timer versucht die 1-Minute-Warnung auszugeben.


    Hat jemand eine Idee wo genau das Problem liegt/wie man es beheben kann?

  • Hi,


    ich hab keine Lösung für das Problem gefunden, ich hatte das selbe Problem in folgendem Thread formuliert: sleeptime schaltet manchmal nicht ab


    Ist es bei Dir immer so, oder auch nur manchmal wie bei mir? Denn bei mir funktioniert das eigentlich meistens gut. Ich hab mir nun damit geholfen, dass der VDR um den es geht, sich nach 2 Stunden Inaktivität von alleine abschaltet. Nicht perfekt, aber da er nicht hörbar ist (obwohl er im Schlafzimmer steht) und als PII-450 nicht viel Strom frisst eine Lösung mit der ich leben kann. Der Fernseher hat sich ja mit seinem eigenen Sleeptimer dann schon längst abgeschaltet.


    Jakob

    Haupt-VDR: Silverstone LC11M, AMD XP2400+ auf einem K7VM2, 2xTT DVB-S (1xFF, 1xBudget), 256MB RAM, 320GB HDD, mit Ubuntu 10.04 LTS+yavdr/stable als Wohnzimmer-VDR
    Zweit-VDR: Silverstone SG02-F, AMD X2 215 auf einem Asus
    M4N78-VM, 2GB RAM, 16GB USB als root-fs mit yaVDR 0.4 als Netzclient
    Fileserver: AMD X2 4450e, 3GB RAM, 4*2TB HDD im SWRaid5, mit Ubuntu als Homeserver und Always-On-Zweitdesktop
    Mein Blog

  • Ursache: du hast deine Chanels.conf geändert
    Lösung: lösche den timer in /etc/vdr/timers.conf


    EDIT: Uups Blödsinn Sleeptimer nicht timer :(

    Software: gen2vdr V3 ( Beta8 ) / gen2vdr V2
    Hardware: Intel 5200EE - 5N7A-VM - Scythe Shuriken - BeQuiet(Netzteil) - X10-USB Remote
    SMT 7020S & P3@900 - Testsystem mit FF und X10-USB Remote
    Links für Neueinsteiger


    "Jetzt, wo ich weiß wie es geht, versteh ich auch die Gebrauchsanleitung"

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von Mr.N!ce ()

  • Zitat

    Originally posted by jakob42
    Ist es bei Dir immer so, oder auch nur manchmal wie bei mir?


    Ich hab den Sleeptimer erst gestern installiert. Nachdem der VDR heute morgen, nachdem ich aufgewacht bin, immer noch gelaufen ist, hab ich gemerkt dass etwas nicht stimmt.


    Bei ein paar Tests (4 oder 5) heute Vormittag konnte ich das Problem immer reproduzieren. D.h. bis jetzt hatte ich 100% "Erfolgsquote".