Windows XP Pro & Novell Netware 3.11

  • Hallo


    Ich weiß neu mit uralt...


    Bei uns in der Firma werkeln noch Uralt-Rechner die noch ihren Dienst einwandfrei Verrichten, aber dennoch soll neune Hardware in`s Haus kommen!


    Allerdings stehe ich vor einem riesen Problem, wie kriege ich die Daten vom Novell-Server runten mit einem XP Client, da die anderen DOS-Büchsen nur HDD-lose Clients sind und das Bandlaufwerk schon seit Jahren defekt ist!


    Habe schon 2 Tage verbracht mich in den Büchern von Novell ein zu Lesen, aber will mir nicht gelingen! Sämtliche Client-Software auf XP verweigern mir dem Zugang zum Server, nur weiß ich nicht ob es an der Client-Software liegt, oder an der Netzwerkkarte, ist übrigens eine Combo BNC/RJ45 und das Netzwerk ist halt noch BNC


    Was ich weiß ist, das IPX als Protocol eingesetzt wird, aber das ich auf XP nicht in der CLientsoftware von Novell auswählen kann, obwohl ich es Nachinstall habe...



    Ist halt alles alter Kram, nur wie komm ich an die Daten rann, ist halt schwer für mich so weit zurück alles zu lernen und zu Verstehen, wer kann mir mal Tips geben!


    ...Ach ja, der Server kann leider nicht abgeschaltet werden (HDD ausbauen zB.) also bleibt nur über LAN




    Mfg SVen

  • 1- yavdr 0.5 - DVB-C
    1- VDR-1.7.14 - Xine Pugin - XBMC - DVB-C
    2- Activy 300 mit Gen2VDR V2

    The post was edited 1 time, last by vdrchuck ().

  • Quote

    Original von s.krueger
    Ist halt alles alter Kram, nur wie komm ich an die Daten rann, ist halt schwer für mich so weit zurück alles zu lernen und zu Verstehen, wer kann mir mal Tips geben!


    Was mir dazu wieder einfaellt: Virtualisierung. Kann man fuer alles missbrauchen ;-)
    Ich wuerde also eine virtuelle WfW 3.11 installieren, den alten Novell Client drauf und das ganze auf eine lokale (virtuelle) HDD kopieren. Und darauf kannst Du dann ueber Windows SMB drauf zugreifen.


    Oder aber halt den Server virtualisieren und die DOS Kisten weiterleben lassen. Wobei, NW 3.11 wird auch von VMware nicht mehr unterstuetzt ;)


    Ansonsten duerfte das in der Tat etwas komplizierter werden. Andere Frage, mal ganz ehrlich, wer setzt denn noch heutzutage produktiv (!!!) ein NW 3.11 System ein? Das war vor 15 Jahren nur gerade noch so aktuell. Da kam kurz danach NW 4.0 raus. <KOPFSCHUETTEL>


    Ach ja, als Stichwort:
    Fuer 3.11 brauchst Du am Client vermutlich sowas wie "bindery-Emulation". Mit NW 4.0 wurde die NDS (quasi Vorlaeufer des Windows ActiveDirectory) eingefuehrt, davor nannt e sich die Benutzerverwaltung IMHO bindery. Wenn Du also was mit Bindery findest: aktivieren!

    Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
    Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

    The post was edited 1 time, last by knebb ().

  • Quote

    Original von s.krueger
    Ich weiß neu mit uralt...


    Bei uns in der Firma werkeln noch Uralt-Rechner die noch ihren Dienst einwandfrei Verrichten, aber dennoch soll neune Hardware in`s Haus kommen!


    Ah, ein Museumsstück. ;)


    Quote


    Allerdings stehe ich vor einem riesen Problem, wie kriege ich die Daten vom Novell-Server runten mit einem XP Client, da die anderen DOS-Büchsen nur HDD-lose Clients sind und das Bandlaufwerk schon seit Jahren defekt ist!


    Habe schon 2 Tage verbracht mich in den Büchern von Novell ein zu Lesen, aber will mir nicht gelingen! Sämtliche Client-Software auf XP verweigern mir dem Zugang zum Server, nur weiß ich nicht ob es an der Client-Software liegt, oder an der Netzwerkkarte, ist übrigens eine Combo BNC/RJ45 und das Netzwerk ist halt noch BNC


    Ist zwar schon lange her, aber:
    Achte darauf, daß IPX-Frameformat ("Rahmentyp") und IPX-Netznummer richtig gesetzt sind. Wenn dies nicht übereinstimmt, ist kein Zugriff möglich.


    CU
    Oliver


    P.S.:
    Es ist sicher nicht notwendig auf Windows for Workgroups 3.11 zurückzugehen. Mit Windows 98 hat das noch hervorragend funktioniert. Keine Ahnung, wie's mit XP aussieht.

  • Novell 3.11 abschalten? Welche Schande :-)


    Aber ganz ehrlich: mit XP auf 3.11 zuzugreifen, dürfte kein Problem sein (hab hier auch noch einen 3.12er Server stehen). Der Client der bei XP dabei ist (CSNW -> Client Service for Netware) muss ausreichen. Das IPX-Protokoll wird automatisch hinzugefügt.
    Ein Fehlerquelle könnte wirklich das "Rahmenformat" sein. Wahrscheinlich musst du auf "802.3" umstellen. Die Einstellung kannst du aber alles auf der Serverkonsole nachschauen.
    Passt die BNC-Verkabelung? Funktioniert BNC auch wirklich auf dem XP-Rechner?


    Die Festplatte aus dem Novell-Server ausbauen und umkopieren, kannst du übrigends eh vergessen. Wenn der Server nicht läuft, kommst du auch nicht an die Novell-Partition ran (jedenfalls kenne ich keinen Weg).


    Gruss

  • Wäre noch zu erwähnen das eventuell der Netzwerkkarte (dem Treiber) mitgeteilt werden muß das der BNC-Anschluß benutzt werden soll.




    Lars



    PS: wenn du wirklich auf die Idee kommst den Server abzuschalten, besorg dir vorher ein fuktionierendes Netzteil. Nach so vielen Jahren Dauerbetrieb kanns durchaus passieren das es beim Einschalten stirbt

  • Danke erstmal für eure zahlreichen Tips!


    Ich habe mir alle Posts gründich durchgelesen und dabei festgestellt, das ich all das schon ausgereizt habe! Das einziege was bei mir nicht klappen will ist das ich in dem "Novell Netware Clients 4.90 SP1" IPX als Only auswählen kann unter Eigenschaften Protokoll, geht immer nur IP (hoffe habe mich richtig ausgedrückt), obwohl ich bei der Install ausdrücklich nur IPX angewählt habe! Das IPX Protocol mußte ich auch Händisch nachinstall!
    Ramentypen habe ich auch schon alle durchprobiert, der Server arbeitet mit 803.2 (laut Server-Console "config"), das einzige was ich bis jetzt erreicht habe, das auf der Server-Console Fehlermeldungen kommen mit der IPX Nr. vom XP Client, das irgend was mit der Route nicht stimmt, nur leider ist mein Englisch nicht ausreichend genug das zu Interpretieren!?!


    Dann kommt noch dazu, das ich mit IPX bis dato noch nix gemcht habe!
    Als Info noch erwähnt, die NW-Karte ist ja eine Combo und ich habe die auch auf BNC-Base2 umgestellt, habe auch noch AU-Irgendwas zur Auswahl...



    Das mit der Virtuellen Geschichte von Knebb ist mich auch schon in den Sinn gekommen, aber ich glaube es klemmt nur an der NW-Karte, bzw. Konfig der Gleichen


    Ich bin schon drauf und drann mir Win98 zu Install, konnte nur die Verflixte CD nicht finden



    Nur zum Verständniss, die IPX Nr. von Server lautet 00000002 und die Interne Nr vom Server 00000001! Welche Nr. muß auf dem Client? Vieleicht liegt ja da der Haase im Pfeffer, hab da 00000005 angegeben und als Intern 00000006 oder so...



    Ihr seht ich steh auf dem Schlauch und mein Chef mir in dem Nacken und nebenbei muß ich auch noch Arbeiten (KFZ-Schrauber), bin halt nur wenn nix los ist am Rechner zu gange



    wie gesagt, danke soweit für eure Hilfe und ich denke mit eurer Hilfe krieg ich die Daten runter und es kommen endlich Rechner und Software ins Haus die ich auch Admin kann, nur leider dann Windoof, ausser es würde nach meinen Wünschen gehen... :)




    Mfg SVen


    /edit


    Was mich noch aufgefallen ist, ich kann die Protokolle nicht binden an die verschieden Services, wie ich es in anderen Anleitungen gefunden habe, der Rergister fehlt kommplett bei mir...


    Ach und ich habe echt zu lange mit der Windoof-Geschichte nix gemacht und seid SP2 ist eh vieles anders


    edit/

  • Quote

    Original von mikeM
    Wie wäre es den mit einer DOS-Bootdisk? siehe hier


    Gruß
    Michael, der auch gerade 'viel' Spaß mit einem 3.12 Server hatte.


    Klingt interessant, aber ich seh` den Waldt vor Bäumen nicht mehr, was brauche ich von der Seite genau dazu und wie muß ich vor gehen?



    Mfg SVen


  • Hehe, die CD hab ich schon, aber wie kann ich mich mit dem Ding auf dem Server einlogen?



    Mfg SVen

  • Welche die DOS oder die Windows? Bei beiden sind die Tools von der erstgenannten Seite eingebaut. Zumindest in der aktuellen Version. Bei der DOS Variante findest Du die unter den DOS-Images und bei der Windows Version muss Du mal schauen. Eventuell auch auf der erstgenannten Seite.


    Gruß
    Michael

  • Hallo SVen,


    wie weit bist du denn jetzt eigentich?
    Laut deinem vorletzten Post siehst du den Server ja schon. Dann müsstest du nur noch ein Netzlaufwerk verbinden (ausser die Boot-CD macht das automatisch).
    Der Default-Admin heisst "Supervisor". Das Passwort brauchst du natürlich.
    Ich befürchte aber, dass du den Server noch nicht siehst. Was war das für ein Router-Fehler? Hast du Netzwerkfehler in der Console? Was hängt eigentlich alles an der BNC-Verkabelung mit dran? Und keine Angst vor IPX: schnell und einfach. Ein Traum gegenüber IP.


    Gruss

  • Wie weit ich bin?...


    Dem Verzweifeln nahe, mit der BootCD wird das auch nix! Habe in der Mittagspause die HDD vom Server ausgebaut und mit "dd" auf eine andere HDD gespiegelt und mit Home genommen!
    Schön währe es wenn ich das Ding Mounten könnte...


    Ich will jetzt mal Versuchen den Server hier bei mir in VMWare laufen lassen IP nachinstall und dann die Daten runter holen, na mal sehen...




    Mfg SVen

  • Hi !


    Auch wenn alles uralt ist --- es geht !! Und zwar sehr gut - das weiss ich, weil es bei mir läuft.


    1. Dreh und Angelpunkt ist die Netmask. Da schaue am besten bei NV auf den "monitor" unter Lan. Da steht z.B. 10000001 oder 00000001 oder so. Diese im XP eintragen.
    2. In der Systemsteuerung wirst du einen Gateway konfigurator finden. Hier musst du den Servernamen eintragen und noch die Ausführung des Login skriptes einschalten.
    3. Boot und es geht !


    Micha

  • Quote

    1. Dreh und Angelpunkt ist die Netmask. Da schaue am besten bei NV auf den "monitor" unter Lan. Da steht z.B. 10000001 oder 00000001 oder so. Diese im XP eintragen.


    Ist damit die Interne Netzwekr-Nr. gemeint?


    Quote

    2. In der Systemsteuerung wirst du einen Gateway konfigurator finden. Hier musst du den Servernamen eintragen und noch die Ausführung des Login skriptes einschalten


    Sei mir nicht böse, aber was meinst du damit genau?!


    edit/
    auch jetzt weiß ich, im Client von Orginal XP (alles klar)
    edit/


    Aber was ich schon einmal geschrieben habe, ich kann in den Client-Einstellungen das IPX nicht anwählen, bzw. schon, aber für IPX ist nix blau hinterlegt, wie nei IP



    Danke dir für deine Hilfe, aber ich kriegs nicht alleine gebacken
    ...und danke für dein Tel-Angebot, aber das wird zu teuer, in DE kein Prob

  • Hi,



    So hier habe ich mal die Fehlermeldung vom Server.


    Quote

    1.1.112 Router configuration error detected
    Router at node 00400554BEB7 claims network 00000002 sholod be 00000005


    00000002 ist der Server 00000005 ist der XP-Client



    Hoffe einer kann was damit anfangen





    Mfg SVen

  • Hi,


    das ist eigentlich kein Client Fehler. Den Fehler hast du, wenn du ans gleiche Kabel 2 Server mit unterschiedlichen externen Netzadressen hängst. Deshalb noch mal die Frage zu deiner Verkabelung. Was hängt da alles dran?
    Und auch noch mal: unter XP reicht der mitgelieferte Novell-Client völlig aus! Einfach "Client Service für Netware" installieren. Der installiert automatisch 2 "NWLink" Einträge mit. Höchstens noch das Rahmenformat einstellen. Nach einem Restart muss der Client dann schon den Server anzeigen!


    Gruss

    __________________________________
    yavdr mit satip im Antec Fusion

    The post was edited 1 time, last by mue ().