Hat jemand Eagle unter Etch, KDE zum laufen gebracht?

  • Hallo, ich bin gerade beim Umstieg von SuSE auf Debian (Etch) und auf das folgende Problem gestossen:


    Bei den Programmen "Eagle" und "Simetrix" ist die Schrift praktisch unlesbar (siehe Anhang).
    Stellt man als Standardschrift (Kontrollzentrum bzw. ~/.qt/qtrc) eine Bitmap-Schrift ein sind die Menüs lesbar.
    Allerdings haben dann auch alle anderen Programme diese Schrift, was mich nicht sonderlich begeistert. Da anscheinend keine Kantenglättung möglich ist sieht der Desktop doch recht Bescheiden aus und die Lesbarkeit leidet deutlich.
    Unter SuSE9.0, das hatte ich bislang drauf, hat es dieses Problem nicht gegeben. KDE hatte eine Truetype Standardschrift und die Menüs von "Eagle" und "Simetrix" waren trotzdem lesbar, wenn auch etwas "pixeliger" als die der meisten anderen Programme.


    Ich schätze das Problem wird bei allen QT1-Programmen auftreten.
    In den Konfigurationsdateien sind mir aber keine grossen Unterschiede aufgefallen und :suche (ich weiss eigentlich nicht mal so richtig wo nach) hat mich nicht weiter gebracht.


    Mit dem VDR hat das ganze zwar direkt nichts zu tun, aber da ich auf die Programme hier im Forum aufmerksam geworden bin, hoffe ich, dass einer von euch eine Idee hat.

    Images

    Gruss
    SHF


  • Hier lauft eagle unter etch, aber in einer Gnomeumgebung und trotzdem ohne Fontprobleme :]


    Ich zitiert mal was in news.cadsoft.de/eagle.support.ger zu finden ist :


  • Hallo!


    Installiere mal das Paket "gtk-qt-engine", dann kannst du im Kontrollzentrum von KDE die Schrift und einiges andere von GTK-Programmen anpassen.

    VDR 1.7.15 - Debian Squeeze/Kernel 2.6.32
    Rebach-Gehäuse, Intel Atom330, Extension HD, Technisat Cablestar2

  • Quote

    Installiere mal das Paket "gtk-qt-engine", dann kannst du im Kontrollzentrum von KDE die Schrift und einiges andere von GTK-Programmen anpassen.

    Ist installiert, hat aber keinen Einfluss.
    Soweit ich das überblicke ist Eagle mit Qt (oder evtl. Xtk ?) und nicht GTK erstellt.


    Quote

    Original von beagle
    Bei mir sieht das so aus (Debian SID):
    Ich sehe da eigentlich keine Probleme.

    Die Schriftarten sehen bei mir genau so aus, nur Eagle halt nicht :(.


    Quote

    Original von beagle
    Hier lauft eagle unter etch, aber in einer Gnomeumgebung und trotzdem ohne Fontprobleme

    Das macht zumindestens Hoffnung.
    Ich hab übrigens mit einer Standardinstallation mit "KDE-Desktop" (Irgendwo konnte man das als Parameter angeben) begonnen, inzwischen ist noch ein bischen Software dazugekommen.


    Quote

    1. EAGLE nutzt 75dpi Helvetica und Courier Fonts. Sind diese verfügbar?

    Ja, sind verfügbar. So wie es aussieht sind es die, die die aus dem Paket "xfonts-75dpi" kommen.

    Quote

    2. Ist qtconfig installiert? Prüfen Sie dort die Eisntellungen.

    Eben nachgeholt, die Einstellungen sehen eigentlich gut aus.

    Quote

    3. Gibt es in Ihrem home-Directory ein .qt Unterverzeichnis und
    befindet sich darin die Datei qtrc? Was passiert, wenn Sie diese mal
    umbenennen bzw. löschen?

    Ist da, löschen bringt aber nichts.

    Quote

    4. Wie siehts mit den Font-Pfaden aus? Befehl: xset q Die Ausgabe
    sollte so ähnlich aussehen:

    Die Pfade führen zu den Fonts, sollte also passen.

    Quote

    Falls sich die angezeigten Fonts beim Zoomen etwas "seltsam" verhalten,
    kann man die 75dpi-Fonts von "unscaled" in "scaled" ändern.

    ... das macht es aber eher schlechter :( (siehe Anhang).


    Dank euch für eure Mühen!

    Images

    Gruss
    SHF


  • Quote

    Ist da, löschen bringt aber nichts.

    Da muss ich mich korrigieren, es hat doch einen Einfluss (siehe Anhang).
    Den selben Effekt hat das Auskommentieren der folgenden Zeile:

    Quote

    font=Sans Serif,10,-1,5,50,0,0,0,0,0


    Quote

    Ja, sind verfügbar. So wie es aussieht sind es die, die die aus dem Paket "xfonts-75dpi" kommen.

    Ich hab jetzt testweise das Paket "xfonts-75dpi" deinstalliert, das ging problemlos :schiel. Anscheinend wird es von keinem Anderen benötigt.
    Am Erscheinungsbild von Eagle und Co hat das allerdings auch nichts geändert.
    Echt mysteriös das ganze, ich versteh' einfach nicht was da schief läuft :weinen.

    Images

    Gruss
    SHF


    Edited once, last by SHF ().

  • Ich hab das Problem beseitigt bekommen, ein Alias in der "fonts.alias" im Verzeichnis "/usr/X11R6/lib/X11/fonts/Type1" war schuld. Ich hab die Zeilen mit "helvetica" in der Datei gelöscht und den X-Server neu gestartet, nun gehts.


    Übrigens:
    Wenn man bei Google nach "eagle" "font" und "unlesbar" sucht, steht dieser Thread an Platz 1 :rolleyes:.

    Gruss
    SHF


    Edited once, last by SHF ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!