ctvdr 6 ist draußen

  • So, der Briefträger brachte mir gerade meine neuste ct... Die beigelegte DVD hat ctvdr6 drauf.


    Infos schon mal auf der üblichen Seite:
    http://www.heise.de/ct/projekte/vdr/


    und hier: http://www.heise.de/ct/projekte/vdr/news/12052007.shtml


    Neu ist die eingerichtete Basis, bezeichnet als Onlineangebot:
    http://www.heise.de/ct/projekte/machmit/ctvdr



    Ich würde sagen, alles Feedback und die hoffentlich nur in geringer Anzahl vorhandenen Bugs können wir in diesem Thread sammeln.


    Ich mach jetzt erstmal eine Probeinstallation. Später mehr dazu.

  • Da bin ich ja mal auf die ersten Comments hier gespannt. Leider liefen bei mir die letzten c't cd's nie besonders gut, gab immer massenweise Probleme bei der Installation, die letzte Gute war bei mir die 2er oder so.

  • Ja die 5er war ANfangs etwas störrisch... Viel Handarbeit war notwendig. Die 3er, die 4er und die 4.5 waren alle okay.


    Die 2er fand ich damlas okay, hatte mich aber noch nicht so "gepackt"


    Mein Zwischenstand:
    Also habe erstmal mit jigdo aktualisiert. Man sollte vielleicht das Verzeichnis auf die HDD packen, da er sonst fast ne Stunde braucht die DVD zu durchsuchen. Nach getaner Arbeit hat man ein iso mit 390.934.528 Bytes

  • Der Schweizer C't Versand (Thali) ist immer ein wenig lahm. War noch nichts im Briefkasten. Wird wohl frühestens Montag bis ich die DVD in meinen Händen habe. Werde wohl Thali kündigen und wieder über Heise in Deutschland bestellen, da war sie immer am Samstag im Kasten (auch als ich schon in der Schweiz wohnte).


    Ich bin gespannt auf Etch-Unterbau und ob es anfangs Schwierigkeiten gibt.

  • Also, habe jetzt erstmal eine Probeinstallation mit der graphischen Oberfläche gemacht und die lief gut durch. Habe mal durchgezappt, aber noch keine Plugins getestet. Erfahrungsgemäß ist ja immer etwas Handarbeit notwendig...


    Bis jetzt ist also alles im Grünen :-)

  • Viel Glück ;-)
    Habe nie groß damit rumexperimentiert, da die FF-Karten-Lösung vermutlich immer noch kompfortabler ist. Aber wie gesagt, kann nicht viel sazu sagen.


    Mein Zwischenstand:


    + VDR bootet vom Einschalten bis zum Bild auf einem PIII in 32s. Passt gut :-)
    + Plugins wie mplayer, mp3, femon, epgsearch sind getestet und funktionieren
    + NVram funktioniert


    - der EPG zeigt bei Pro7 doppelte Einträge

  • Meine C't war doch da. Postbote war heute später da. Juchu.
    Habe mir schon mal die C't VDR 6 unfree erstellt. Installation erfolgt frühestens nächste Woche. Im Momement laufen ersteinmal die Tests wegen der C-1500. Mit der 5.x scheint es bisher am besten zu laufen. Deshalb don't touch.
    Werde deswegen mal den Thread hier vorerst verfolgen.

  • Quote

    Original von Lanzi
    Viel Glück ;-)
    Habe nie groß damit rumexperimentiert, da die FF-Karten-Lösung vermutlich immer noch kompfortabler ist. Aber wie gesagt, kann nicht viel sazu sagen.


    Seit ich mir mal unter Kubuntu eine VDR-Aufzeichnung mit Xine und Greedy2 Frame Deinterlacing auf meinen LCD-TV über DVI angesehen habe, will ich das auch direkt mit dem VDR haben. :D

  • Also, ich habe mich gerade durch die Installation gekämpft:
    ich hab einen VDR in dem eine FF-Karte unter c't VDR 4.5 mit allen Tobi-Schikanen läuft.
    Dort habe ich apt-get install vdr-plugin-xineliboutput gemacht und den VDR-Daemon neu gestartet.
    Dann habe ich auf einem hardwarestarten Client-PC c't VDR 6 installiert:
    bei Angabe der Kanalliste habe ich "Keine" gewählt.
    Nach dem Login dann apt-get install xorg xineliboutput-sxfe,
    gefolgt von xinit -e vdr-sxfe -f xvdr:tcp://ip-meines-vdr-servers
    und ich hatte zum ersten Mal ein vernünftiges Bild. :tup


    Jetzt habe ich ein großes Problem:
    vom Client aus geht weder die Tastaturbedieung ("m" erzeugt keienrlei Reaktion") noch die Fernbedienung.
    Ich habe probeweise eine alte Nexus 2.1 in dem Client installiert um mit Hilfe des remote-Plugin fernbedienen zu können, aber es geht nüscht.
    Nur wenn ich am Server mit der Fernbedienung oder via VDRAdmin schalte geht es.
    Was mache ich da falsch?
    Auf dem Client unter /dev/input/event[0-2] befindet sich keinerlei IR on-card receiver wie auf meinem VDR-Server

  • ich kann das xine-liboutput-sxfe nicht installieren. Habe mir ebenso die unfree CD per jigdo gebaut, standard installation so weit keine Probleme, VDR laeuft, aber wie gesagt die in der c't beschriebe installation der Pakete xorg und xine-liboutoutput-sxfe wird mit
    E: Konnte Paket xine-liboutput-sxfe nicht finden
    kommentiert.
    Habe inzw. die /etc/apt/sources.list um e-tobi Eintrag
    #
    # Tobi's Experimental VDR Repository for Etch (multipatch)
    #
    deb http://e-tobi.net/vdr-experimental etch base addons vdr-multipatch


    erweitert. Hat aber auch nicht mzum Erfolg gefuehrt.


    OK, ok, es muss xineliboutput-sxfe heissen, ohne "-" nach xine, also
    "apt-get install xorg xineliboutput-sxfe"


    Trotzdem, kann jemand mal seine aktuelle source.list posten?
    Unten meine aktuelle


    Danke
    Gruss
    Bolino


    ******* /etc/apt/sources.list ************


    # Tobi's Experimental VDR Repository for Etch (multipatch)
    #
    deb http://e-tobi.net/vdr-experimental etch base addons vdr-multipatch


    deb http://ftp.de.debian.org/debian/ etch main non-free


    deb http://mirror.home-dn.net/debian-multimedia etch main


    #deb cdrom:[c't Debian VDR Distribution 6]/ stable contrib main non-free
    #deb cdrom:[c't Debian VDR Distribution 6]/unfree/ stable main

  • Quote

    Original von Lanzi
    schau mal in die /etc/default/vdr


    Da musst du am ende folgendes einfügen:
    KEYB_TTY="/dev/tty8"


    Dort steht
    KEYB_TTY="/dev/tty8"
    KEYB_TTY_SWITCH=1


    Quote


    Wenn das nichts hilft, vielleicht das hier:
    Mal wieder: Xine per Keyboard geht nicht


    Hmm, ich muss also irgendwo --enable-vdr-keys setzen?
    Wenn ja, wo? :)


    Quote

    Original von wilderigel
    Tastatur funktioniert nur wenn in der remote.conf die richtigen Einträge stehn.


    In der remote.conf des Servers oder des Client?


    In der des Client habe ich folgendes stehen:


    Und wg. der Fernbedienung - scheinbar läd er den DVB-Treiber nicht richtig:

    Code
    1. May 13 14:30:49 vdr-dg kernel: saa7146: register extension 'dvb'.
    2. May 13 14:30:49 vdr-dg kernel: ACPI: PCI Interrupt Link [APC1] enabled at IRQ 16
    3. May 13 14:30:49 vdr-dg kernel: ACPI: PCI Interrupt 0000:04:08.0[A] -> Link [APC1] -> GSI 16 (level, low) -> IRQ 58
    4. May 13 14:30:49 vdr-dg kernel: PCI: Setting latency timer of device 0000:04:08.0 to 64
    5. May 13 14:30:49 vdr-dg kernel: saa7146: saa7146_init_one(): ioremap() failed.


    Code
    1. May 13 03:29:28 vdr-dg vdr: [16597] initializing plugin: remote (0.3.9): Remote control
    2. May 13 03:29:28 vdr-dg vdr: [16597] ERROR: invalid primary device number: 1
    3. May 13 03:29:28 vdr-dg vdr: [16597] ERROR: no primary device found - using first device!
    4. May 13 03:29:28 vdr-dg vdr: [16597] ERROR: invalid primary device number: 1
  • bolino
    Würde den Namen mal überdenken:

    Code
    1. libxine-xvdr - Xine input plugin for vdr-plugin-xineliboutput streams
    2. libxineliboutput-fbfe - Local Frambebuffer frontend for the xineliboutput plugin
    3. libxineliboutput-sxfe - Local X-Server frontend for the xineliboutput plugin
    4. vdr-plugin-xineliboutput - VDR plugin for Xine based sofdevice frontends
    5. xineliboutput-fbfe - Remote Framebuffer frontend for vdr-plugin-xineliboutput
    6. xineliboutput-sxfe - Remote X-Server frontend for vdr-plugin-xineliboutput
  • rüsseltier
    Läuft am Clienten überhaupt ein VDR?
    von wo bekommt der seine Daten?
    Auf welchen VDR verbindest du mit der IP?


    Würd die XKeySym.* Einträge in beiden einfügen.
    Brauchen tuts der Server der grad für dein vdr-sxfe zuständig ist.
    Ob das dein Server oder dein Client ist musste selber wissen.