Mahlzeit-ISO 4.0beta2

  • Zitat

    Original von Dr. Seltsam
    So wie ich es verstehe, würde der Patch von UFO vielleicht das Problem mit der TT-Karte beheben, aber dann wäre der flexcop-Support für die Rev. 2.7 futsch. Insofern macht es m.E. keinen Sinn, wenn ich den jetzt einbaue und neu kompiliere.


    Der Patch ist sicher. Er beeinträchtigt den flexcop in keiner Weise, denn der zurückgeänderte else-Zweig wird ausschließlich vom budget-Treiber verwendet. Bitte den Patch also mal ausprobieren.


    CU
    Oliver

  • wenn ich das richtig verstehe hat sich das ja wohl für mich erübrigt mit linuxtv-ML. Ah wo ich mal schauen müsste was das überhaupt ist...
    Tja bzgl. Problemen mit Timeshift stehe ich wohl allein da. Nochmal zum Problem: wenn Timeshift aktiv ist sind Aufnahmen nicht mehr möglich.
    ich habe hier nocheinmal den Auszug aus der Timeshift vom letzten Jahr. Da dürfte sich nichts dran geändert haben.


    Mein 2. momentanes Problem ist das meine bessere Hälfte wieder da ist, und ich meine experimentierphase wohl wieder auf Montag nachmittag verlegen muss


    Tja, wen ich da so heutehinschaue solls wohl mal wieder an meiner Nova-SE liegen. Dummerweise hatte ich gestern den Timeshift mit neuem Kernel und ohne Budget-Karte probiert. Allerdings ist er da auch abgeschmiert und war mit aktiviertem Timeshift kaum noch bedienbar.
    Leider habe ich da nicht die Logreadeintäge gecheckt, und komme (siehe oben) erst am Montag zu meiner "Bastelstunde".


    @ ke2705
    hattest Du auch derartige Probleme mit dem älteren Kernel und Timeshift.


    Ähem, oder lese ich das was da oben steht nur falsch...?
    Naja, wenn ich mir selbst glauben darf hatte ich mit Mahlzeit 3.2 dieses Problem nicht gehabt.


    Vielleicht kann mir ja jemand vor meiner Bastelstunde noch einen Tip geben das Problem ohne Änderungen an der Hardware einzugrenzen.


    Ich bin jetz mal ganz optimistisch und bedanke mich schoneinmal im vorraus.


    Chiao

    DVB-S TT 1.6
    VDR: mittlerweile MVDR 1.2
    Board: Asrock K7VM2 Rev.3. Bios 1.9
    CPU: Athlon Mobile XP, 1150MHz bei FSB 100MHz, Vcore 1,2V
    512 MB Ram
    Gehäuse: Francis Francis X1
    HDD Samsung 120GB 5400UPM
    FB X10 Funk

  • Zitat

    Original von UFO


    Der Patch ist sicher. Er beeinträchtigt den flexcop in keiner Weise, denn der zurückgeänderte else-Zweig wird ausschließlich vom budget-Treiber verwendet. Bitte den Patch also mal ausprobieren.


    bin gerade am Kompilieren

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • @ ke2705:


    ich hab den Frontend-Treiber mit dem Patch von UFO neu kompiliert.
    http://drseltsam.device.name/v…nel-2.6.25.11-s5h1420.tgz


    nachdem das 2.6.25.11-Paket installiert wurde, anschließend:
    tar xvfz linvdr-kernel-2.6.25.11-s5h1420.tgz -C /
    und am besten rebooten


    mal schauen, ob die Karte dann erkannt wird

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • @ VDR-Dau: ich habe deine diversen Threads durchgelesen, aber ehrlich gesagt habe ich immer noch nicht genau verstanden, was Du mit "aktiviertem Timeshift" meinst. Wir reden jetzt nicht vom lifebuffer-Patch?


    mir fallen ein paar Dinge ein, denen Du nachgehen könntest:


    Wenn Du ein Programm schaust und dann eine Aufnahme startest, wird diese auf der 2. Karte abgewickelt, die zuvor nicht empfangen hat. Wenn auf dieser Karte der Empfang zu schlecht ist (was diverse Gründe haben kann) wird vdr die Aufnahme stoppen und neu starten. Die Empfangsquallität der 2. karte kannst Du mit dem femon-Plugin prüfen. Ein Wechsel der Karten ist mit den links-Rechts-Tasten möglich


    Der aktivierte noad könnte Probleme machen. In den Logs sah es so aus, als wenn der Rechner immer abschmiert, wenn noad startet.


    Hohe Festplattenaktivität als Grund für das Abschmieren kann wiederum andere Ursachen haben. Google mal nach hdparm und teste mal die Schreib- und Lesegeschwindigkeit Deiner Platte.


    Letztlich wäre auch ein update auf das vdr-1.4.7-ext4Paket anzuraten.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • @ Dr.Seltsam
    ahäm,doch... :whatever
    Naja, nu isses raus, JA ich meine diesen Livebuffer-Patch.


    Naja, der Empfang ist mit der kleinen Nova eigentl. ziemlich gut und keineswegs schlechter als mit der FF.
    Na und das mit dem Testen der Schreib und Lesegeschw. werde ich mal prüfen. Allerdings kann ich problemlos zwei Aufnahmen laufen lasen und nebenbei MP3´s von der HD hören.
    Hmm, das mit dem Update auf vdr-1.4.7-ext4 werde ich nochmal überdenken, aber ich befürchte bei meinem Geschick läuft dann nix mehr.

    DVB-S TT 1.6
    VDR: mittlerweile MVDR 1.2
    Board: Asrock K7VM2 Rev.3. Bios 1.9
    CPU: Athlon Mobile XP, 1150MHz bei FSB 100MHz, Vcore 1,2V
    512 MB Ram
    Gehäuse: Francis Francis X1
    HDD Samsung 120GB 5400UPM
    FB X10 Funk

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von VDR-Dau ()

  • Schei...


    Nu isses passiert!!!
    Also, es lag ganz klar am veralteten vdr-Paket. mich wurmt dabei dass ich das
    1. nicht eher bemerkt habe, und
    2. dass ich alter Oberdepp nun das Problem behoben habe.
    Das Problem daran ist dass ich seit geraumer Zeit so ein gewisses "Bad-Plugin" verwende. Naja, nu isses wieder schwarz und ich muss zusehen wo da jetz der Lichtschalter hängt. Aber da muss ich wohl erstmal alleine ran und hoffe woanders notfalls geholfen zu werden.


    Chiao

    DVB-S TT 1.6
    VDR: mittlerweile MVDR 1.2
    Board: Asrock K7VM2 Rev.3. Bios 1.9
    CPU: Athlon Mobile XP, 1150MHz bei FSB 100MHz, Vcore 1,2V
    512 MB Ram
    Gehäuse: Francis Francis X1
    HDD Samsung 120GB 5400UPM
    FB X10 Funk

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von VDR-Dau ()

  • Ok, andere Frage, woher bekomme ich bitte die vdr-1.4.7-ext34 ?
    kann ich die irgendwo downloaden?
    Auf vdr-online.org gibt es sie ja nichtmehr.
    Wäre echt nett wenn ich erstmal dahin updaten könnte.


    Danke schonmal im vorraus


    Chiao



    Edit: Naja, die ext30 habe ich ersteinmal wieder drinnen, würde gerne die 34 mal testen, aber im Herbst wird ja eh der Strom abgestellt, und dann kann ich ja wieder auf die ext40 renovieren ;-)

    DVB-S TT 1.6
    VDR: mittlerweile MVDR 1.2
    Board: Asrock K7VM2 Rev.3. Bios 1.9
    CPU: Athlon Mobile XP, 1150MHz bei FSB 100MHz, Vcore 1,2V
    512 MB Ram
    Gehäuse: Francis Francis X1
    HDD Samsung 120GB 5400UPM
    FB X10 Funk

    Dieser Beitrag wurde bereits 4 Mal editiert, zuletzt von VDR-Dau ()


  • OK, werde ich gleich mal testen. Muss allerdings den VDR wieder umbauen, da ich mir ja mittlerweile 'ne Skystar2 angelegt habe (die uebrigens von der Empfangsqualitaet deutlich besser als die Nova S SE ist - zumindest sagt femon das).


    Melde mich wieder.


    Eberhard

    VDR1: Humax iCord HD :evil:


    VDR2: easyVDR 0.6 / Silverstone LC20 / AMD Geode NX 1750 PC-Chips M811 / TT Prem 2300 mod + CI / Nova-S SE / PSOne TFT / ATRIC IR


    VDR3: Mahlzeit 3.3pre4 / Activy300 / DVB-S FSC 1.3 + CI

  • Moin Doc,


    also, hab' jetzt nochmal umgebaut. Aber irgendwas scheint mit dem Paeckchen (linvdr-kernel-2.6.25.11-s5h1420) nicht zu stimmen: Sobald ich das einspiele, wird beim booten ueberhaupt keine DVB Karte (sogar die LAN Karte) nicht mehr erkannt :-(


    Mir ist aufgefallen, das alle Files unter /lib/modules/2.6.25.11 sogut wie leer sind und das eigentliche Kernelmodul (s5h1420.ko) Faktor 10 mal groesser!


    Checkst Du das nochmal?


    Gruss
    Eberhard

    VDR1: Humax iCord HD :evil:


    VDR2: easyVDR 0.6 / Silverstone LC20 / AMD Geode NX 1750 PC-Chips M811 / TT Prem 2300 mod + CI / Nova-S SE / PSOne TFT / ATRIC IR


    VDR3: Mahlzeit 3.3pre4 / Activy300 / DVB-S FSC 1.3 + CI

  • oh, da hätten in /lib/modules/2.6.25.11 keien dateien sein dürfen. Das Paket sollte wirklich nur ein einziges Modul in /lib/modules/2.6.25.11/kernel/drivers/media/dvb/frontends enthalten und ersetzen. Die Größe ist nachrangig, das wäre bei einer Installation noch gestrippt worden. Ich wollte hier aber kein "make install" absetzen.


    Neues Ergänzungspaket ist hochgeladen. Erstd as Kernelkpaket 2.6.25.11 installieren, dann das Ergänzungspaket, das exakt ein Modul enthält.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Bingo, geht!


    Code
    1. Kernel 2.6.25.11 vom 10.08.08:
    2. Aug 24 07:47:43 vdrdev user.info kernel: [ 13.673564] DVB: registering new adapter (TT-Budget/WinTV-NOVA-S PCI)
    3. Aug 24 07:47:43 vdrdev user.warn kernel: [ 13.696805] adapter has MAC addr = 00:d0:5c:23:72:54
    4. Aug 24 07:47:43 vdrdev user.warn kernel: [ 13.792314] budget: A frontend driver was not found for device 1131/7146 subsystem 13c2/1016
    5. Kernel 2.6.25.11 vom 10.08.08 mit neuem Kernelmodul s5h1420.ko:
    6. Aug 24 09:40:07 vdrdev user.info kernel: [ 13.943338] DVB: registering new adapter (TT-Budget/WinTV-NOVA-S PCI)
    7. Aug 24 09:40:07 vdrdev user.warn kernel: [ 13.966605] adapter has MAC addr = 00:d0:5c:23:72:54
    8. Aug 24 09:40:07 vdrdev user.warn kernel: [ 14.064407] DVB: registering frontend 1 (Samsung S5H1420/PnpNetwork PN1010 DVB-S)...


    Soll das in der ML bestaetigt werden? Koenntest Du das evtl. uebernehmen - Du kennst Dich besser aus :-)


    Ist nochmal ein Test erforderlich oder kann ich wieder zurueck bauen?



    Danke & Gruss
    Eberhard

    VDR1: Humax iCord HD :evil:


    VDR2: easyVDR 0.6 / Silverstone LC20 / AMD Geode NX 1750 PC-Chips M811 / TT Prem 2300 mod + CI / Nova-S SE / PSOne TFT / ATRIC IR


    VDR3: Mahlzeit 3.3pre4 / Activy300 / DVB-S FSC 1.3 + CI

  • es wäre nett, wenn Du das da nochmal als Resultat postest. Das Modul wurde mit dem Patch von UFO aus http://linuxtv.org/pipermail/l…b/2008-August/028075.html behandelt.


    Vielleicht kommen die in der ML ja noch auf weitere Ideen, und es sind noch mehr Tests erforderlich. Wäre schön, wenn Du da als Tester noch zur Verfügung stündest.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Zitat

    Original von Dr. Seltsam
    Vielleicht kommen die in der ML ja noch auf weitere Ideen, und es sind noch mehr Tests erforderlich. Wäre schön, wenn Du da als Tester noch zur Verfügung stündest.


    OK, dann werde ich die Nova S SE in meinen Entwicklungs-VDR einbauen - somit steht dann ein Testsystem zur Verfuegung.


    Gruss
    Eberhard

    VDR1: Humax iCord HD :evil:


    VDR2: easyVDR 0.6 / Silverstone LC20 / AMD Geode NX 1750 PC-Chips M811 / TT Prem 2300 mod + CI / Nova-S SE / PSOne TFT / ATRIC IR


    VDR3: Mahlzeit 3.3pre4 / Activy300 / DVB-S FSC 1.3 + CI

  • Ich habs auch mal eingespielt, und nu läufts auch bei mir.
    Ich befürchte allerdings dass ich von meinem Wissensstand her als Tester nicht viel tauge. Ich werde also, wenn ich nen Fehler bemerke, dies einfach hier posten und sofern er nix dagegen hat mich mit ke2705 per PN kurzschließen.
    Aber sowie ich das sehe bin ich für die nächste Zeit glücklich.


    Somit vielen Dank an den Doc und ke2705 der zur klärung beigetragen hat.



    OT: Wäre noch die Frage ob mir jemand die "vdr-1.4.7-extp34" zur Verfügung stellen könnte?


    Ciao

    DVB-S TT 1.6
    VDR: mittlerweile MVDR 1.2
    Board: Asrock K7VM2 Rev.3. Bios 1.9
    CPU: Athlon Mobile XP, 1150MHz bei FSB 100MHz, Vcore 1,2V
    512 MB Ram
    Gehäuse: Francis Francis X1
    HDD Samsung 120GB 5400UPM
    FB X10 Funk

  • Zitat

    Original von VDR-Dau
    OT: Wäre noch die Frage ob mir jemand die "vdr-1.4.7-extp34" zur Verfügung stellen könnte?


    Ciao


    Muss mal suchen, ob's ich noch hab.


    Ciao

    VDR1: Humax iCord HD :evil:


    VDR2: easyVDR 0.6 / Silverstone LC20 / AMD Geode NX 1750 PC-Chips M811 / TT Prem 2300 mod + CI / Nova-S SE / PSOne TFT / ATRIC IR


    VDR3: Mahlzeit 3.3pre4 / Activy300 / DVB-S FSC 1.3 + CI

  • Hab's gefunden - mehr per PN


    Gruss
    Eberhard

    VDR1: Humax iCord HD :evil:


    VDR2: easyVDR 0.6 / Silverstone LC20 / AMD Geode NX 1750 PC-Chips M811 / TT Prem 2300 mod + CI / Nova-S SE / PSOne TFT / ATRIC IR


    VDR3: Mahlzeit 3.3pre4 / Activy300 / DVB-S FSC 1.3 + CI

  • So, nun hat's mich doch noch erwischt....


    Zitat

    Original von VDR-Dau


    @ ke2705
    hattest Du auch derartige Probleme mit dem älteren Kernel und Timeshift.


    Bei mir crasht der VDR sporadisch wenn er aufnimmt.


    Zur Vorgeschichte: VDR TT1.4.7ext34 mit Kernel 2.6.20.1 laeuft seit langem problemlos. Nun Kernelupdate auf 2.6.25.11 wg. Full-TS Mod (Karte ist noch nicht gemodded). Dabei zusaetzlicher Aufwand wg. Kernelmodul fuer Nova-S SE (siehe weiter oben).


    An der HW wurde nichts veraendert - trotzdem nun dieses Problem. Was ich im Log kurz vor dem Crash erkenne:
    - Video Data Stream broken
    - Initializing emergency exit


    Ausgerechnet dann, wenn die bessere Haelfte guckt! Also, ratzfatz den Kernel 2.6.20.1 wieder drauf und alles ist gut. Selbst paralleles aufnehmen (Timeshift) ist kein Problem!!!


    Doc Seltsam: Hast Du eine Idee, wo ich suchen koennte? Ist evtl. der TT1.4.7ext40 besser fuer den neuen Kernel?


    Gruss
    Eberhard

    VDR1: Humax iCord HD :evil:


    VDR2: easyVDR 0.6 / Silverstone LC20 / AMD Geode NX 1750 PC-Chips M811 / TT Prem 2300 mod + CI / Nova-S SE / PSOne TFT / ATRIC IR


    VDR3: Mahlzeit 3.3pre4 / Activy300 / DVB-S FSC 1.3 + CI

  • Zitat

    Original von ke2705
    - Video Data Stream broken
    - Initializing emergency exit


    ich glaub nicht, das das was mit der vdr-Version zu tun hat. Diese Probleme hatte ich bisher nur mit dem performance-Patch von UFO, aber nie mit einem ungepatchten dvb-ttpci und bisher auch nie mit dem Fullts-mod.
    Und paralleles Aufnehmen sollte natürlich auch kein Problem darstellen.


    Ich kann natürlich nochmal ein aktuelles v4l-dvb Paket ohne den full-TS-Mod, aber mit dem Patch für die Nova-S SE machen. Das Problem ist halt nur, dass diese Abstürze nicht immer gleich auftreten, sondern immer dann wenn es eine wichtige Aufnahme ist. Ich habe zum provozieren immer zwei Aufnahmen auf der FF gestartet und meist noch eine 3. auf der Budget dazu. Manchmal crasht es dann nach 10 Minuten, manchmal nach 2 Stunden.


    Aber wie gesagt, hier läuft der Treiber bislang völlig störungsfrei.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Zitat

    Original von Dr. Seltsam


    Ich kann natürlich nochmal ein aktuelles v4l-dvb Paket ohne den full-TS-Mod, aber mit dem Patch für die Nova-S SE machen. Das Problem ist halt nur, dass diese Abstürze nicht immer gleich auftreten, sondern immer dann wenn es eine wichtige Aufnahme ist. Ich habe zum provozieren immer zwei Aufnahmen auf der FF gestartet und meist noch eine 3. auf der Budget dazu. Manchmal crasht es dann nach 10 Minuten, manchmal nach 2 Stunden.


    Aber wie gesagt, hier läuft der Treiber bislang völlig störungsfrei.


    Also bei mir war's gestern so, das er eine Timer Aufnahme auf ZDF (hohe Bitrate) machen sollte, und spaetestens nach 1 Min in die Knie ging. Das lief dann in einer Schleife, denn nach dem Restart hat er sofort versucht wieder aufzunehmen. Im Log sah ich auch, das die Aufnahme ueber die Budget lief, deshalb wuerde ich den Full-TS Mod zunaechst ausschliessen wollen.


    Das es mit der VDR Version zusammenhaengt, glaube ich auch nicht. Irgendwie habe ich das Gefuehl, es gibt einen Zusammenhang mit Festplatten IO. Ich hatte vorgestern mehrmals vergeblich versucht, eine Aufnahme in ein DVD Image umzuwandeln. Auch hier ist der VDR immer sporadisch gecrasht. Gestern Abend, mit dem alten Kernel ohne Probleme.


    Testen wuerde ich schon, fall's Du einen Kernel ohne Full-TS-Mod bauen wuerdest, obwohl das urspruengliche Ziel von mir der Full-TS-Mod war. Dann sollte man aber aus dem VDR noch mehr Debug-Info's herauskitzeln.


    Gruss
    Eberhard

    VDR1: Humax iCord HD :evil:


    VDR2: easyVDR 0.6 / Silverstone LC20 / AMD Geode NX 1750 PC-Chips M811 / TT Prem 2300 mod + CI / Nova-S SE / PSOne TFT / ATRIC IR


    VDR3: Mahlzeit 3.3pre4 / Activy300 / DVB-S FSC 1.3 + CI