Schlechter Empfang der TT C-1500 im Vergleich zur Satellco EasyWatch PCI DVB-C

  • Zitat

    Original von UFO
    Übel ist auch, daß es zwei stv0297 Frontend-Treiber gibt. Das trägt alles nicht gerade zur Qualität der Treiber bei. Funktioniert die Cablestar (stv0297_cs2) eigentlich besser?


    Der stv0297_cs2-Part ist von vor dem PLL-Refactoring und läßt sich seit ca. 2 Jahren nicht mehr kompilieren. Prinzipiell gibt es Unterschiede in der Initialisierung des stv0297 der einzelnen Karten. Ohne eine Spec zu haben, betrifft es die Initialisierung der AGC (Polarität bzw. Invertierung?) und das Output-Interface (Bit-Order und/oder Polarität vom Sync-Signal?).


    Bei der TT-C1500 spekuliere ich mehr auf die Tuner-Initialisierung.


    Gruß
    e9hack

  • Zitat

    Original von e9hack


    Der stv0297_cs2-Part ist von vor dem PLL-Refactoring und läßt sich seit ca. 2 Jahren nicht mehr kompilieren.


    D.h. die Cablestar verwendet den normalen stv0297.c und funktioniert damit?


    Zitat


    Prinzipiell gibt es Unterschiede in der Initialisierung des stv0297 der einzelnen Karten. Ohne eine Spec zu haben, betrifft es die Initialisierung der AGC (Polarität bzw. Invertierung?) und das Output-Interface (Bit-Order und/oder Polarität vom Sync-Signal?).


    Bei der TT-C1500 spekuliere ich mehr auf die Tuner-Initialisierung.


    Hm...


    CU
    Oliver

  • Zitat

    Original von Hein Blöd
    Ein zweiter PC mit Windows ist auch kein Problem. Morgen haben wir Feiertag. Das Päckchen geht dann noch diese Woche raus.


    Die Karte ist heute angekommen. Ich habe sie unter Linux kurz getestet. Sie funktioniert mit QAM64 eigentlich problemlos. Im VHF Bereich (113 u. 346MHz) gibt es keine Unterschiede zur TT-C2300. Bei 458 u. 466MHz ist der BER Wert deutlich höher. UNC bleibt auf 0. Bei 450MHz und QAM256 ist der BER Wert auch deutlich höher und es gibt UNC Werte bis 5. Bei BER Werten in der Größenordnung hat die TT-C2300 immer UNC 0. Was merkwürdig ist, bei UNC >0 habe ich bei der TT-C2300 immer Artefakte und Tonaussetzer gehabt. Bei der TT-C1500 sieht man das nicht. Möglicherweise liegt das aber am Transfermode.


    Windows muß ich erst wieder installieren. Ich oder Linux hat zwischenzeitlich die Linux-Partition geschreddert und ich habe dann gleich neu partitioniert.


    Gruß
    e9hack


    Nachtrag: Meine höchste Frequenz liegt bei 466MHz. Wies im oberen UHF-Bereich aussieht, kann ich daher nicht sagen.

  • Ich hatte mal eine TT 2300C von einem Arbeitskollegen verbaut - im gleichen Setup. Die Karte war deutlich schlechter im Empfang, auch bei QAM64. Hat dir keine Ruhe gelassen die C1500 mal zu testen ;)
    Hätte ich das gewusst, hätte ich dir das CI mit beigelegt.


    Verstehe ich dich richtig, dass die C1500 bei dir auch bessere Ergebnisse als die C2300 bringt?


    Ich hatte übrigens mit Wirbelscan die besten Ergebnisse.


    Konntest du gut löten? Sah mir dann doch sehr eng aus.


    Grüsse aus der Schweiz
    Oliver

  • Zitat

    Original von Hein Blöd
    Hat dir keine Ruhe gelassen die C1500 mal zu testen ;)


    Ich hoffe, Du erwartest nicht, daß ich die 3 Strippen anlöte und Dir die Karte sofort zurück schicke.


    Zitat


    Verstehe ich dich richtig, dass die C1500 bei dir auch bessere Ergebnisse als die C2300 bringt?


    Das verstehst Du falsch. Die C2300 ist besser.


    Zitat


    Konntest du gut löten? Sah mir dann doch sehr eng aus.


    Ich habe noch nicht angefangen. Um das EEPROM ist aber viel Platz.


    Gruß
    e9hack

  • Du kannst ruhig eine Weile testen. Der Rückversand eilt nicht.

  • Zitat

    Original von e9hack
    Windows muß ich erst wieder installieren.


    Windows ist jetzt neu installiert. QAM64 funktioniert. QAM256 hat deutliche Hänger, obwohl die Signalqualität mit 100% angezeigt wird. Wenn Windows auch Probleme bei QAM256 hat, wird man da wohl nichts für Linux ableiten können. Ich werde aber noch am I2C-Bus lauschen.


    Gruß
    e9hack

  • Hi,


    können alle mit einer TT-C1500 mal folgenden Patch testen:


    Olivers (Hein Blöds) TT-C1500 hat dann bei QAM256 deutlich niedrigerere BER Werte und UNC bleibt auf 0. Ich habe dann mal bei der TT-C2300 Register 0x53 auf 0x13 gesetzt. Die BER-Werte bei QAM256 verdoppeln sich und ich bekomme UNC Werte im Bereich 0..9.


    Gruß
    e9hack

  • Bei mir empfängt die C1500 unter Windows einwandfrei. Keinerlei Artefakte, geniales Bild.


    e9hack
    Was soll der neue Patch bewirken? Ist damit der Empfang besser? Viel fehlt bei mir nicht zum stabilen QAM256 Bild unter Linux. Immerhin hatte ich von allen hier das beste Bild.

  • Zitat

    Original von Hein Blöd
    Was soll der neue Patch bewirken? Ist damit der Empfang besser? Viel fehlt bei mir nicht zum stabilen QAM256 Bild unter Linux.


    Ohne den Patch sieht es bei meinem einzigen sichtbaren QAM256 Kanal so aus:

    Mit dem Patch dann so:


    Ich habe einfach nochmal die Init-Tabellen für den stv0297 verglichen und ein paar Schnelltests gemacht. Den Windows-Treiber werde ich dann Sa/So belauschen. Wenn das Wetter weiter so bescheiden bleibt, habe ich ja viel Zeit dafür.


    Gruß
    e9hack

  • Zitat

    Original von HTPC-Schrauber
    Meinst Du auch die, mit einer alten C1500? Ich hab noch ne C1500 der ersten Serie. Die hat kaum Probleme mit QAM256.


    Da man die Karten (alt oder neu) vom Treiber her nicht unterscheiden kann, sollte so eine Veränderung bei funktionierenden Karten nicht zur verschlechterung führen.


    Gruß
    e9hack

  • Hi,


    ich habe die Karte verlötet. Der Monitor funktioniert mit Einschränkungen. Der Windows-Treiber gönnt sich keine Pause währen der Initialisierung vom stv0297, sodaß der Puffer im ATMega überläuft. Die serielle Schnittstelle ist mit 115kBaud einfach zu langsam. Ich werde das ganze auf einen FT232 umrüsten müssen. Da ist dann die doppelte Baudrate drin. Rein rechnerisch müßte das dann für 275kHz I2C-Bitrate ausreichen. Allerdings habe ich keinen FT232 mehr, sodaß alles noch ein klein wenig warten muß.


    Gruß
    e9hack

  • Zitat

    Original von e9hack
    Ich werde das ganze auf einen FT232 umrüsten müssen. Da ist dann die doppelte Baudrate drin. Rein rechnerisch müßte das dann für 275kHz I2C-Bitrate ausreichen. Allerdings habe ich keinen FT232 mehr, sodaß alles noch ein klein wenig warten muß.


    Wie wäre es denn mit einem Handy Datenkabel mit PL2303 z.B. für Siemens? Einfach den Handystecker abbauen/abschneiden und man hat GND, RX und TX zum direkten Anschluß an den Microcontroller.

  • Zitat

    Original von sle85276
    Wie wäre es denn mit einem Handy Datenkabel mit PL2303 z.B. für Siemens? Einfach den Handystecker abbauen/abschneiden und man hat GND, RX und TX zum direkten Anschluß an den Microcontroller.


    Man kann sicher auch ein Datenkabel nehmen, nur habe ich da auch keins da. Der FT232 hat noch ein paar mehr Vorteile:
    - der Quarzoszi kann entfallen und der UART läuft synchron zum USB-Chip
    - es ist bis 3MBaud Datenrate möglich
    - die 5V Versorgung kann direkt über USB erfolgen
    - der FT232 liefert 5V CMOS Pegel
    - ich kenne den Chip (habe bisher ca. 10 Stück verbaut)


    Wenn CSD-Electronics mitspielt, habe ich die Chips bis Mittwoch od. Donnerstag.


    Der Chip hat natürlich auch einen Nachteil, ein SSOP Gehäuse läßt sich nicht so einfach 'verfädeln'. Wenn man aber sieht, was andere drauf haben...


    Gruß
    e9hack

  • Also, ich bin endlich zum Testen gekommen.
    e9hack : Man kann Dir gratulieren. Die Auswirkungen auf der alten C1500 sind genauso. D.h. deutlich geringere BER. Obwohl die vorher schon nicht allzu hoch waren. Aber sieh selbst.


    Mit Original LinuxTV Treiber:


    Mit Deinem Patch:

  • Ich hab gerade nochmal die einzige Frequenz bei mir getestet, bei der ich höhere BER hatte. Das ist 402 MHz. Scheint übrigens ein besonderes Problem der C1500 zu sein. Denn mit ner Satelco Easywatch hab ich auf der Frequenz keine anderen Werte als sonst. Mit der Easywatch hab ich immer BER und UNC 0. Egal auf welcher Frequenz.


    Jedenfalls hatte ich auf 402 MHz mit der C1500 BER 300 - 400 ziemlich schwankend und gelegentliche UNC. Nach dem Patch hab ich da BER 160-170 recht stabil und UNC stabil 0.


    Also m.E. auch für die alte C1500 eine Bereicherung.


    Die beiden Kanäle waren übrigens QAM256. Bei QAM64 hab ich nach wie vor BER und UNC dauerhaft 0.


    Übrigens scheint mir die STR und SNR bei der C1500 genau rückwärts zu laufen. Sprich 0000=maximum und ffff=minimum. Ich hatte die Karte kürzlich an nem anderen Kabelanschluss. Und hab mit den Werten einer FF bei mir und dort verglichen. Das schien genau rückwärts zu laufen.

  • Zitat

    Original von HTPC-Schrauber
    Übrigens scheint mir die STR und SNR bei der C1500 genau rückwärts zu laufen. Sprich 0000=maximum und ffff=minimum. Ich hatte die Karte kürzlich an nem anderen Kabelanschluss. Und hab mit den Werten einer FF bei mir und dort verglichen. Das schien genau rückwärts zu laufen.


    Das kann ich so nicht bestätigen. Bei mir werden laut Kabeltreiber die QAM256 Kanäle mit 4dB höherem Pegel eingespeißt:

    Code
    1. C2300 C1500
    2. QAM64 (458MHz) 70 2e5
    3. QAM256 (450MHz) 6b 306


    Bei der C1500 gilt: größerer Wert = größerer Pegel. Bei der C2300 ist es anders herum.


    Für die C2300 habe ich den Zusammenhang auch über den Antennenverstärker. Um das für die C1500 zu testen, müßte ich erst den VDR wieder aus dem Schrank zerren.


    Richtig hohe Werte, wie bei anderen Karten, kann es nicht geben, da die Werte nur 10Bit haben und nicht auf 16Bit hochgerechnet werden.


    Bei den SNR Werten gebe ich Dir Recht: kleinerer Wert = besseres S/N-Verhältnis bei beiden Karten


    Gruß
    e9hack


  • Send Patches. ;)


    Die Wertebereiche sollte ausgeschöpft werden (0 = min, FFFF = max), und richtig herum sollte es natürlich auch sein. Man kann ja einfach um 6 Bits nach links schieben...


    CU
    Oliver