vdr-1.2.5 und AutoPID-1.2.5

  • Ich hatte ein kleines Problem Radiosender aufzunehmen. Letztlich fand ich heraus, daß es bei Sendern, die durch AutoPID "betreut" werden. Probleme gibt, die sich folgendermaßen geäußert haben.


    Habe ich bei diesen Sendern eine Aufnahme Programmiert, ging alles soweit gut (incl. der Aufnahme). Probleme gab es nur, wenn die der UPT-Fehler zuschlug. Dann mußte der VDR neu gestertet werden. Auch bei manuellem starten kam dann immer der Fehler:


    Code
    1. Oct 7 21:50:52 cat vdr[8537]: ERROR: channel S19.2E-1-1073-28208 not defined


    In der channels.conf steht der Sender mit:

    Code
    1. MDR KULTUR:12110:h:S19.2E:27500:0:801:0:0:28208:1:1073:16387


    drin.


    Das 13. Feld (letztes), ist für AutoPID (sog. RID) reserviert. In diesem wird abgespeichert, ob der Sender und/oder die PIDs aktualisiert werden.


    Die Lösung war nach etwas suchen gefunden. Ich nehme beim laden der Timer einfach die Kontrolle der RID heraus.


    Ob das nun wirklich "die" Lösung ist, weiß ich nicht, aber jetzt brauche ich keine Angst mehr zu haben, daß der VDR sich bei einem Neustart in einer Start-Endlos-Schleife verfängt und nichts mehr macht.

    Dateien

    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Hi


    das Problem hat man grundsätzlich, wenn vdr (inkl. Autopid) neustartet. Aber zum Thema UPT gab es eine Diskussion auf der vdr-ML wobei vor kurzem dazu ein Patch gesendet wurde (Old Descriptorhandling with vdr 1.2.5). Ich habe den seit knapp 1 Woche installiert und bisher noch keinen einzigen UPT-Fehler. Davor hatte ich sie am laufenden Band.


    Vielleicht hilft er auch in deinem Fall...


    Gruss


    Joe

    Debian Etch 2.6.16.16, vdr 1.4.6, v4l-dvb vom hg 16.5.2006, ivtv trunk vom 16.5.2006, Hauppauge DVB-C FF, Hauppauge PVR500, Alternative Channel Patch, diverse Plugins

  • Unknown-Picture Type - Error.


    Der verursacht Klötzchenbildung meist auf einer nicht-primären Karte. Steht dann auch ein Eintrag im Syslog.


    Joe

    Debian Etch 2.6.16.16, vdr 1.4.6, v4l-dvb vom hg 16.5.2006, ivtv trunk vom 16.5.2006, Hauppauge DVB-C FF, Hauppauge PVR500, Alternative Channel Patch, diverse Plugins

  • Zitat

    Original von mrjoe
    das Problem hat man grundsätzlich, wenn vdr (inkl. Autopid) neustartet.


    Mit meinem Patch ja nicht mehr :)


    Zitat

    Original von mrjoe
    Ich habe den seit knapp 1 Woche installiert und bisher noch keinen einzigen UPT-Fehler. Davor hatte ich sie am laufenden Band.


    Den Patch habe ich auch gesehen und zum anwenden auch fertig liegen, habe mich aber noch ein wenig gescheut ihn anzuwenden. Aber wenn Du sagt, daß es funktioniert, versuche ich es auch. Dazu ist ja auf der ML nichts weiter mehr zu lesen gewesen. Nur halt das es wahrscheinlich mit den vielen Umschaltungen im dvb-Treiber zusammenhängen könnte.


    Zitat

    Original von mrjoe
    Vielleicht hilft er auch in deinem Fall...


    Vom Prinzip her nicht, da der VDR nicht mehr startet, wenn ein AutoPID-Sender in der timers.conf drin steht. Und meiner Freundin kann ich dann nicht zumuten, sich an den Laptop zu setzen und per Telnet diesesn einen Eintrag (vielleicht sind es ja auch noch meherere) per joe oder gar vi zu löschen.

    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Zitat

    Den Patch habe ich auch gesehen und zum anwenden auch fertig liegen, habe mich aber noch ein wenig gescheut ihn anzuwenden. Aber wenn Du sagt, daß es funktioniert, versuche ich es auch. Dazu ist ja auf der ML nichts weiter mehr zu lesen gewesen. Nur halt das es wahrscheinlich mit den vielen Umschaltungen im dvb-Treiber zusammenhängen könnte.


    AFAIK hat es nichts mit den Umschaltungen zu tun. Das Problem trat bei mir z.B. auch 10 min nach Neustart des vdr's auf. Wie aber auf der ML zu lesen war/ist, gibt es unterschiedliche Ursachen für den UPT-Error. Nur wie gesagt hilft der Patch bei mir ohne Probleme. Es gibt bis jetzt keinerlei Seiteneffekte.


    Zitat

    Vom Prinzip her nicht, da der VDR nicht mehr startet, wenn ein AutoPID-Sender in der timers.conf drin steht.


    Hmm, vdr prüft nicht ohne Grund die timer-Einträge und ausserdem ist es besser, einen Fehler an der Wurzel zu packen und nicht einen Workaround zu schreiben. Wobei iMo der Patch noch nicht das endgültige sein kann, da er nicht den UPT-Fehler direkt beseitigt, sondern im Problembereich "nur" die alte Funktionalität von vdr <= 1.1.27 wiederherstellt.

    Debian Etch 2.6.16.16, vdr 1.4.6, v4l-dvb vom hg 16.5.2006, ivtv trunk vom 16.5.2006, Hauppauge DVB-C FF, Hauppauge PVR500, Alternative Channel Patch, diverse Plugins

  • Zitat

    Originally posted by mrjoe
    [...]wobei vor kurzem dazu ein Patch gesendet wurde (Old Descriptorhandling with vdr 1.2.5).


    Koenntest du einen Link zu diesem patch veroeffentlichen ?


    Danke, Joachim

    [size=11]

    AmateurCall: DF9SR, VDR: yaVDR-0.3a @ZOTAC-IONITX-PE,MystiqueSatixS2dual,IntelSSD-80GB,Samsung-2TB,picoPSU90

  • Den Beitrag in der ML gibt es hier


    Evtl. könnte man ihn auch hier zum Download anbieten. Autor vorher fragen? Mir hat er jedenfalls geholfen: keinen einzigen UPT-Fehler mehr, keine Neustarts des vdr... ;-)


    Joe


    Nachtrag: War einer schneller... :-)

    Debian Etch 2.6.16.16, vdr 1.4.6, v4l-dvb vom hg 16.5.2006, ivtv trunk vom 16.5.2006, Hauppauge DVB-C FF, Hauppauge PVR500, Alternative Channel Patch, diverse Plugins

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von mrjoe ()

  • Zitat

    Original von mrjoe


    Hmm, vdr prüft nicht ohne Grund die timer-Einträge und ausserdem ist es besser, einen Fehler an der Wurzel zu packen und nicht einen Workaround zu schreiben. Wobei iMo der Patch noch nicht das endgültige sein kann, da er nicht den UPT-Fehler direkt beseitigt, sondern im Problembereich "nur" die alte Funktionalität von vdr <= 1.1.27 wiederherstellt.


    :rolleyes:


    Mein Patch hat aber nichts mit UPT zu tun (Bei UPT wird nur der VDR neu gestartet und da kommt dann erst das Problem). Es geht dabei nur um die RID in der channels.conf. Wenn es UPT nicht geben würde hättest Du auch das Problem, wenn Du aus geigel einfach mal den VDR neu startest (bei entsprechendem Timer-Eintrag, siehe code-Sequenz mit channel not defined).


    Und bei diesem Patch nutze ich nur eine schon im VDR eingebaute erweiterte Funkionalität der GetByChannelID-Methode, die schon an anderen Stellen im VDR angewendet wird.

    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1

  • Zitat

    Mein Patch hat aber nichts mit UPT zu tun (Bei UPT wird nur der VDR neu gestartet und da kommt dann erst das Problem). Es geht dabei nur um die RID in der channels.conf.


    Da hast du absolut Recht. Nur wenn kein Neustart erfolgt, dann tritt auch dieses Problem nicht auf. Wenn aber aus einem anderen Grund neu gestartet wird, dann hat man das von dir beschriebene Problem nach wie vor. Da ist dann dein Patch von nöten...

    Debian Etch 2.6.16.16, vdr 1.4.6, v4l-dvb vom hg 16.5.2006, ivtv trunk vom 16.5.2006, Hauppauge DVB-C FF, Hauppauge PVR500, Alternative Channel Patch, diverse Plugins

  • Zitat

    Original von mrjoe
    Nur wenn kein Neustart erfolgt, dann tritt auch dieses Problem nicht auf. Wenn aber aus einem anderen Grund neu gestartet wird, dann hat man das von dir beschriebene Problem nach wie vor. Da ist dann dein Patch von nöten...


    Ich kann nicht davon ausgehen, daß mein VDR nicht aus irgend einem Grund nicht mehr neu gestartet werden braucht (Stromausfall). Aber wie Du ja schon richtig sagtest: ;)

    Zitat

    Original von mrjoe
    ... ausserdem ist es besser, einen Fehler an der Wurzel zu packen und nicht einen Workaround zu schreiben. Wobei iMo der Patch noch nicht das endgültige sein kann ...


    Dieser Patch kommt mit in den neuen VDR :) (siehe HIER).

    VDR-Server: Gentoo (AMD64/Core-i7) / VDR-1.7.23 / Digital Devices Octopus CI & 2xDuoFlex S2 HDTV (Rev. V3)
    VDR-Client: Gentoo (AMD64/Atom-D525) / VDR-1.7.23 / Chieftech & iMON-Pad / ASUSTeK - AT5IONT-I / 4GB-RAM & 65GB-SSD
    Alt: 3xTT-1.5 / linuxtv-dvb-1.1.1 + test_av-1.28 + FW-2622 / vdr-1.3.37 / viele Plugins / LFS-4.1