Mehrere Dinge anderes, wenn VDR direkt nach dem Booten startet

  • Hi!


    Habe meinen VDR normalerweise durchgehend laufen. Jetzt hatte ich aber auch ein paar Tests mit dem automatischen Ausschalten durchgeführt.


    Jetzt tritt bei mir folgendes auf:
    Das burn-Plugin funktioniert direkt nach dem Booten von VDR nicht. Zum einen kennt VDR dann nicht den vollen Pfad (/usr/local/bin fehlt, wo die vdrbrun-*-Skripte liegen). Gut, das lässt sich beheben wenn ich die Skripte nach /usr/bin verschiebe.
    Als nächstes kennt VDR die Variabeln JAVA_HOME usw. nicht mehr (weiß garnicht wo die bei gen2vdr gesetzt werden). Da müsste ich wieder am Skript basteln.


    Wenn ich aber alles lasse wie es ist und VDR beende und neu starte (über /etc/init.d/...), dann läuft alles. Was kann da beim Booten anders sein dass die Dinge nicht erkannt werden.
    Habe testweise VDR vom Boot-Runlevel in den Default-Runlevel verschoben, aber das hat nichts gebracht.


    Gruß,
    Brougs78

    - -- --- ================================================================ --- -- -
    Antec Fusion, Intel E5200, Asus P5N7A-VM (VDPAU), DD CineS2 v6 + DD DuoFlex CI // yavdr-0.6.1
    - -- --- ================================================================ --- -- -

  • Hi Helmut!


    Ja ok, da habe ich etwas gebastelt. ;-)
    Aber an und für sich ist es schon das halbwegs akteulle Gen2vdr mit einigen Updates von dir. Und wie gesagt kommt es auch zu anderen Problemen dass die Umgebungsvariablen nicht gesetzt sind bei einem direkten automatischen Start von VDR nach dem Booten.
    Hättest du eine Idee wo ich da nachschauen könnte damit ich das Problem herausfinde?


    Gruß,
    Brougs78

    - -- --- ================================================================ --- -- -
    Antec Fusion, Intel E5200, Asus P5N7A-VM (VDPAU), DD CineS2 v6 + DD DuoFlex CI // yavdr-0.6.1
    - -- --- ================================================================ --- -- -

  • Hallo Brougs78,


    bei gentoo geht das über /etc/env.d.


    Mehr Infof findest Du unter:


    http://www.gentoo.de/doc/de/handbook/handbook-x86.xml?part=2&chap=5


    Gruß


    Dony

    PROD-VDR: FSC Esprimo E5600 (VERSION B!!! / 2xFull-PCI + 1 x PCI-e), 2x Technotrend FF 1.6, gen2vdr 2.0 (+ U1-U15), internal USB-Cardreader, touchTFT (pollin / an FF-Karte), SATA 2 TB, ASUS DVD-Brenner mit Light-Scribe (funzt).
    TEST-VDR: ASUS at3iont-i mit TT S2-6400 in SCNIC E600 Gehäuse, gen2vdr-V3-U10, SATA 2 TB, ASUS SATA DVD-Brenner mit Light-Scribe

  • Hi!


    Ok, danke. Werde mal sehen ob da die JAVA-Umgebungsvariable gesetzt wird.


    Aber seltsam ist das doch dass der start von VDR unterschiedlich ist. Was läuft da wohl schief ...


    Gruß,
    Brougs78

    - -- --- ================================================================ --- -- -
    Antec Fusion, Intel E5200, Asus P5N7A-VM (VDPAU), DD CineS2 v6 + DD DuoFlex CI // yavdr-0.6.1
    - -- --- ================================================================ --- -- -