[solved] DVB Karten vertauschen sich

  • Hallo,


    mein VDR läuft soweit ganz gut, nur leider vertauschen sich die DVB Karten manchmal beim Booten.


    Das Steckt im VDR
    - FuSi (FF, die lange da)
    - KNC1 DVB-C (Budget)
    Kernel 2.6.18 (gentoo-sources)


    Also beim Booten wird manchmal zuerst die KNC erkannt und manchmal die FuSi, was normal nicht so schlimm wäre, nur kann die FuSi nicht alles Sende (QAM256 Problem) darum habe ich in der channels.conf die Sender welche die FuSi nicht packt fest auf die zweite DVB (KNC1) gehängt.


    Über Modules.Autoload.d lade ich zuerst das dvb-ttpci und danach das budget-av modul, leider hilft mir das nicht.


    Über die Suche habe ich leider nichts so richtig brauchbares gefudnen, zumindest nichts was ich hätte anwenden können.


    Gruß
    Andreas

  • Ich kann dir leider nicht bei dem Problem helfen, warum die Karten mal so und dann wieder andersrum geladen werden.


    Aber ein Workaround wäre hier.


    HIER


    oder


    HIER

    MAIN: La Scala SST-LC04 Gehäuse / Asus P5N7A-VM / Intel E7500 / YaVDR 0.1 / TT-DVB-S2 / IR-Einschalter Atric / Wakeup-On-Call


    ICH: Bin Microsoft, Cisco, VMware und NetApp zertifiziert

  • Hi Andreas,


    genau das gleiche Problem hatte ich auch. Ich habe nen VDR mit ner Nexus 2.3 und ner Terratec 1200 (==KNC) unter Gentoo hochgezogen und dann auch den Effekt gehabt das die Module dvb_ttpci (Nexus) und budget_av (KNC) immer in unterschiedlicher Reihenfolge geladen wurden. Die Infos die ich im Netz gefunden habe (modules.autoload.d und die ganzen anderen Tipps), haben mich auch nicht weiter gebracht, aber dann bin ich zufällig über eine Zeile der vorherigen DXR3 Modulekonfiguration gestolpert die sich leicht abgewandelt als sehr hilfreich erwiesen hat.


    Und zwar habe ich im Verzeichnis /etc/modprobe.d eine Datei namens budget_av angelegt und dort folgendes eingetragen:


    install budget_av /sbin/modprobe dvb_ttpci && /sbin/modprobe --ignore-install budget_av


    Das sorgt dafür das, wenn das budget_av module geladen (install) werden soll, erstmal ein modprobe dvb_ttpci gemacht wird, d.h. erstmal der Treiber der FF-Karte geladen wird. Danach wird ganz normal mit dem laden der KNC weitergemacht, die dann immer schön die Nummer 2 unter den DVB Devices bleibt.


    Ist nicht die eleganteste Methode, aber hey.... sie funktioniert! (Bei mir zumindest) ;) Probier doch mal aus, ein Versuch ist sicherlich Wert.

  • Hey Ioannis,


    ich hab das jetzt mal getestet, also nach dem Neustart ist die Sortierung wieder wie sie sein soll, das heißt die KNC ist Karte #1 und die FuSi Karte #0.


    Also 2 Test-neustarts hat die Configuration so auch überlebt, schaut sehr gut aus :-)


    Ich finde die Lösung jetzt nicht so unelegant, sie überlebt nen modules-update und muß nicht ständig neu eingetragen werden.


    Danke für den Tipp :-)


    Gruß
    Andreas

  • sorry wenn ich sonen alten schinken hochhole - die zeile ist wohl nicht allgemeingültig, kann mir einer helfen, dass ich sie auf eine tt-ff-karte und eine tt-budget-karte hinbekomme?

    Produktivsystem:
    Server: yaVDR 0.3 0.5 0.6 im Chieftec HM-01SL Board: Asus M3N-H/HDMI Athlon64 X2
    streaming clients: windows-Rechner, Ubuntu-Rechner, 3xRaspberryPI I, 1x RasPi II mit aktuellem Openelec, Kodi + VNSI-PVR auf div. Android-Clients

  • Anstelle von "budget_av" musst Du halt den Treiber eintragen denn deine Budget Karte verwendet. Wenn Du also z.B . ne Nova-S Budget karte hast, dann muß da cx8800 hin:


    install cx8800 /sbin/modprobe dvb_ttpci && /sbin/modprobe --ignore-install cx8800

  • Ich zitiere mich mal selber:


    Zitat

    Original von Ioannis
    install budget_av /sbin/modprobe dvb_ttpci && /sbin/modprobe --ignore-install budget_av


    Das sorgt dafür das, wenn das budget_av module geladen (install) werden soll, erstmal ein modprobe dvb_ttpci gemacht wird, d.h. erstmal der Treiber der FF-Karte geladen wird. Danach wird ganz normal mit dem laden der KNC weitergemacht, die dann immer schön die Nummer 2 unter den DVB Devices bleibt.


    Die Zeile sorgt halt dafür das wenn dein System die Budgettreiber lädt, erstmal die Treiber der TT geladen werden (und diese damit Nr. 1 wird), danach erst wird der eigentlich Budgettreiber geladen. Wenn Du verschiedene Budgetkarten hast (die also verschiedene Budgetreiber benötigen) musst dafür jeweils ne extra Zeile angeben.

  • ... steckt eigentlich in den Modulen selbst drin.


    modinfo budget_av
    oder
    modinfo dvb_ttpci


    bringt diese, oder ähnlich lautende, Zeile hervor:


    parm: adapter_nr: DVB adapter numbers (array of short)


    Was kann man damit anfangen? Ganz einfach


    cd /etc/modprobe.d/


    nano budget-av.conf (mcedeit, vi oder M$ Editor gehen auch ;) )


    folgendes eintragen


    options budget_av adapter_nr=1


    damit wird dem module beim laden, egal in welcher reihenfolge dvb-ttpci, budget_av geladen werden
    immer das frontend 1 verpasst.


    Gleichartiges geht auch mit dvb-ttpci,


    nano -w dvb-ttpci.conf ( der name spielt eine untergerordnete rolle, dient nur der übersichtlichkeit)


    folgendes eintragen


    options dvb_ttpci adapter_nr=0


    je nach portage version ist nach dem erstellen des/der files noch ein


    update-modules --force und/oder neuladen der/des modules notwendig


    ein reboot bringt auf jedenfall das zweifelsfrei in Ordnung.


  • also bei mir geht das LEIDER nicht so...



    Und beim starten hab ich dann nur eine Karte (die ff).. über dmsg gabs das:

    Code
    1. [ 7.041753] budget_av: Unknown parameter `adapter_nr'


    Schade eigentlich.. fand dies wäre ne saubere Lösung...

  • Zitat

    Original von aLiEnTxC


    Und beim starten hab ich dann nur eine Karte (die ff).. über dmsg gabs das:

    Code
    1. [ 7.041753] budget_av: Unknown parameter `adapter_nr'


    Schade eigentlich.. fand dies wäre ne saubere Lösung...


    sieht so aus, als sei das erst kürzlich ins Modul budget_av gekommen:
    http://linuxtv.org/hg/v4l-dvb/rev/d9248e8255c2


    Versuch mal die Option dem Modul budget-core zu übergeben

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • @ aLiEnTxC


    Oh, sorry,
    ich geh immer davon aus das der neuste Kernel verwendet wird :)


    Aber wie Dr. Seltsam schon schrieb hat sich da was in den Kernelversionen bezüglich des Parameter geändert.


    Die Übergabe an budged-core geht natürlich auch, wenn das vom treiber unterstützt wird.


    Schau dir einfach mal alle deine DVB Karten relevanten module per modinfo an.


    Es reicht wenn Du die FF oder die Budged's festlegst.


    Die nicht festgelegten richten sich dann danach beim laden und nehmen dann das freie device.


    Bei mehreren budget's geht auch


    options budget_av adapter_nr=1, 2, 3, 4 usw.


    device 0 würde dann zwangsweise der FF / ttpci zugeteilt werden.

  • Zitat

    Original von hd.brummy
    Es reicht wenn Du die FF oder die Budged's festlegst.


    Die nicht festgelegten richten sich dann danach beim laden und nehmen dann das freie device.


    Ja, aber wenn man drei verschiedene Karten hat und bei dann festlegt, TypA bekommt adapter0, TypB bekommt adapter1, und TypC nicht festlegt, hat man ein Problem wenn der Treiber für TypC zuerst geladen wird und sich adapter0 schnappt.
    Im Fall, dass man die festlegungen für höhere adapter-Nummern trifft, und nummer 0 frei lässt wird das dann von TypC belegt.


    Generell ist das Verfahren aber anfällig, falls man eine neue Karte einbaut, oder einen neuen usb-dvb-stick ansteckt.


    Gruß
    Zzam