timer wake up

  • Hallo zusammen,


    ich habe einmal ein paar Fragen zum Timer Wakeup von Linvdr. Was benutzt linvdr da eigentlich. Ist ja standartmäßig nicht NVRAM, oder?


    Ich frage deswegen, weil es bei mir eigentlich immer funktioniert hat. Jedoch seit kurzem nicht mehr geht. (Ich habe nichts geändert!).


    Jetzt würde ich gerne mal reinschauen woran das liegt. Weiß aber nicht genau, nach wa sich suchen soll. Bin also für jeden Tipp dankbar.


    Viele Grüße
    Jo

  • guckst Du hier: /usr/bin/poweroff.pl guckst Du weida: # 0 = ACPI-Wakeup, 1 = settime


    Code
    1. my $WAKEUP_MARGIN = 5;
    2. my $TWOOCLOCK = 0;
    3. my $METHOD = 0; # 0 = ACPI-Wakeup, 1 = settime
    4. sub true() { 1; }
    5. sub false() { 0; }

    Hardware:MSI K8N NEO-FSR V2.0,AMD Sempron 3000+,BeQuiet Pro 530W,Infineon 512MB DDR CL3,2xSP2514N,1xSP2014N,1xSP1614N
    0-AGP/1..5-PCI Slots:0:MSI Nvidia MX400,1:RT8139,2:Hauppauge Nexus-S Rev.2.1,3+4:Hauppauge Win-TV Nova-S SE2(cx88_dvb),5:frei
    BIOS:Auto Einstellungen,FSB:200MHz, alle IO-Devices: disabled
    System:easyVDR 0.4, XXV 0.80,ACPI WakeUp
    Status seit dem 04.06.2007::lovevdr läuft traumhaft

    The post was edited 1 time, last by Fuselfasel ().

  • OK, wie ich sehe benutze ich ACPI. Aber in der /proc/acpi/alarm steht leider nichts. Durch was wird das geschrieben und wie kann ich das wieder aktivieren?


    linvdr:~# ll /proc/acpi/alarm
    -rw-r--r-- 1 root root 0 Nov 13 23:09 /proc/acpi/alarm


    Viele Grüße
    Jo

  • Falsch, sorry. Es steht folgendes drin:


    linvdr:~# cat /proc/acpi/alarm
    2006-00-00 17:35:35


    Warum 00-00? Ist das mit dem Tag und Monat richtig? Laut obigem Bericht vom Linux Magazin könnte ich mir das schon vorstellen. Aber irgendwie scheint's trotzdem nicht hinzuhauen. Ist übrigens seit der Zeitumstellung so. Aber hwclock und dat stimmen.


    Grüße
    Jo

  • Hallo,


    hm, aber es ging schonmal, wie ich es wollte. Das Einzige, was geändert ist war die Zeitumstellung. Und ich habe eine Hauppauge DVB-C Karte gegen eine Terratec getauscht. Alles ging ohne Probleme. Außer daß jetzt mein Wakeup nicht mehr geht. :-(


    Woran könnte das denn noch liegen?


    Grüße
    Jo

  • Mal ne Frage für Blödies, hab mir schon ne Menge Threads durch gelesen und bin und bleibe verwirrt...


    Welche der beiden Methoden soll man denn benutzen, wenn man nen Einschalter (k-data) verwendet). Doch eigentlich keine der beiden, oder?


    Aber im Zusammenhang mit k-data und Co. wird trotzdem auch immer auf dieses Perlskript verwiesen, ich werd da aber nicht schlau drauß :-/



    Was genau braucht meine Karre denn, damit ich die Aufweckzeit auf das serielle Device schreibe. Manuell bekomme ich es nämlich gut hin. .. (echo ZEIT>TTYS0 irgendwas).



    Danke und gut's Nächtle,
    Marcus

    Hardware: Zalman HD160XT; Asus H97M-Plus, 1024MB RAM, Digital Devices Cine S2 (rev 7), Atric-Einschalter, NEC3520 DVD-Laufwerk, Samsung 256 GB SSD-Festplatte --> darauf yaVDR 0.6
    Hifi: Denon AVR4306, Samsung UE40ES6300

  • Quote

    Original von joe0815
    Das Einzige, was geändert ist war die Zeitumstellung.
    [..]
    Woran könnte das denn noch liegen?


    Hmm, wie genau hast du denn die Uhr umgestellt?
    Wenn das die einzige Änderung ist, dann lass das doch evtl. erst mal mit dem Karten austauschen, das kann dann ja nicht die Ursache sein.


    Beschreib mal, wie du die Uhr umgestellt hast.
    Evtl. lässt sich der Fehler ja umzingeln ;-)

    Hardware: Zalman HD160XT; Asus H97M-Plus, 1024MB RAM, Digital Devices Cine S2 (rev 7), Atric-Einschalter, NEC3520 DVD-Laufwerk, Samsung 256 GB SSD-Festplatte --> darauf yaVDR 0.6
    Hifi: Denon AVR4306, Samsung UE40ES6300

  • Also die Uhr hat sich automatisch richtig eingestellt. Ich ziehe nämlich die Zeit über EPG (ARD). Und das hat auch wunderbar geklappt. Aber hast Recht. Ich baue die Karte mal heute Abend aus und probiere es nochmal.


    Grüße
    Jo

  • Tja, hat leider nicht geklappt. Kann es sein, daß bei einem Board einfach nur das Wake Up kaputt geht? Ich kann es nämlich auch nicht mehr über lan aufwecken wie früher...


    :-(


    Grüße
    Jo

  • joe0815 : Ich kenne beide Aufwachprobleme (ACPI/SETTIME) - mit Lösung 1: ACPI (du siehst im Bios NICHTS, aber entweder geht die Kiste an oder bleibt aus) oder mit Lösung 2: SETTIME (du siehst im Bios die VERSTELLTE UHRZEIT, aber entweder geht die Kiste an oder bleibt aus).


    Hast Du definitiv BEIDE Varianten geprüft? Startet der Rechner mit dem per Hand eingestellten Bios Alarm (also OHNE LinVDR, ... nur über BIOS).


    Hast Du definitiv den LinVDR bei Deinen Tests über die Fernbedienungs-PowerOff-Taste ausgeschaltet und die WakeUp Margin (Default: 5 min vor Timerstart) mit einkalkuliert?


    Hast Du die autom. Uhrzeitaktualisierung im LinVDR mal ausgestellt und dann alle WakeUp-Varianten getestet?


    [NACHTRAG]: WOL geht auch nicht mehr, trotz dem "Enabled" Schalter im BIOS? Lade doch mal aus Spass die "Bios Default Settings" erneut ein und aktiviere nur die WOL-Funktion im BIOS und überprüfe dann, ob Dein MAC-ID WakeUp Broadcast über die 255.255.255.255 Dein Rechner anwerfen kann ...

    Hardware:MSI K8N NEO-FSR V2.0,AMD Sempron 3000+,BeQuiet Pro 530W,Infineon 512MB DDR CL3,2xSP2514N,1xSP2014N,1xSP1614N
    0-AGP/1..5-PCI Slots:0:MSI Nvidia MX400,1:RT8139,2:Hauppauge Nexus-S Rev.2.1,3+4:Hauppauge Win-TV Nova-S SE2(cx88_dvb),5:frei
    BIOS:Auto Einstellungen,FSB:200MHz, alle IO-Devices: disabled
    System:easyVDR 0.4, XXV 0.80,ACPI WakeUp
    Status seit dem 04.06.2007::lovevdr läuft traumhaft

    The post was edited 1 time, last by Fuselfasel ().

  • OK, dann hatte ich immer ACPI Wake Up benutzt. Sah man nämlich nichts im BIOS.


    Bios Alarm funktioniert. Weiß aber nicht wie ich auf settime umstellen kann. Eine 1 im poweroff.pl genügt wohl nicht.


    Das mit den 5 Minuten davor habe ich natürlich auch ausprobiert. Bringt aber nichts.


    Die Uhrzeitaktualisierung habe ich auch einmal ausgeschaltet. Aber wie gesagt. Das lief auch vorher damit. Brachte aber leider auch keinen Erfolg.


    Die Bios Default Settings habe ich schon tausend Mal geladen. Brachte nichts. :-(


    Geht irgendwie alles nicht. Weiß noch jemand was? An sonsten baue ich mir eine Floppy ein und Flasche das Bios nochmal...


    Danke für Eure Hilfe
    Jo

  • Nein, eine 1 im poweroff.pl genügt mit Sicherheit nicht. Der Bios Alarm muss zusätzlich auf 00:00:00 Uhr am 1. des Monats oder am 01.06.2004 (wenn das BIOS es erlaubt) eingestellt werden.


    Hinweis unter: /usr/bin/settime.sh:

    Shell-Script
    1. #!/bin/bash
    2. # Der Wakeup-Zeitpunkt im BIOS muss auf den 1. des Monats um 00:00:00 Uhr
    3. # eingestellt werden
    4. BiosWakeup="2004-05-31 23:59:59"


    Du hast nicht geschrieben, ob durch das WakeUp mit SETTIME Deine BIOS Uhr entsprechend verstellt wurde ...
    Wenn Du alles richtig gemacht hast und die Kiste immer noch nicht anspringt, fällt mir leider nix weiteres dazu ein. Das Nvram-Prozedere habe ich nie probiert, weil es mir zu "kompliziert" für LinVDR erschien.

    Hardware:MSI K8N NEO-FSR V2.0,AMD Sempron 3000+,BeQuiet Pro 530W,Infineon 512MB DDR CL3,2xSP2514N,1xSP2014N,1xSP1614N
    0-AGP/1..5-PCI Slots:0:MSI Nvidia MX400,1:RT8139,2:Hauppauge Nexus-S Rev.2.1,3+4:Hauppauge Win-TV Nova-S SE2(cx88_dvb),5:frei
    BIOS:Auto Einstellungen,FSB:200MHz, alle IO-Devices: disabled
    System:easyVDR 0.4, XXV 0.80,ACPI WakeUp
    Status seit dem 04.06.2007::lovevdr läuft traumhaft

    The post was edited 1 time, last by Fuselfasel ().

  • Hallo,


    OK, das Bios hatte ich so nicht eingestellt. Das werde ich mal machen. Aber im Bios habe ich nichts gesehen von der Zeitverstellung bei Nutzung von Settime. Ich sehe nur die eingestellte Zeit bei cat /proc/acpi/alarm


    Grüße
    Jo

  • Hi Jo,


    wenn Du die BIOS Einstellung zurückgesetzt hast, könnte es sein das diese Timer Funktionalität im BIOS wieder aktiv wurde. Diese muß aber bei den meisten Boards ausgeschaltet sein damit ACPI Wakeup funktioniert.


    Eine Ausnahme ist mir heute untergekommen, das ASUS A7V600. Bei dem Board mußte ich die Wakeup-at-Time Funktion einschalten damit es geht.


    Wenn der LinVDR mal wieder oben ist mach mal folgendes:


    - /etc/init.d/runvdr stop
    - echo "2006-11-16 20:10:00" > /proc/acpi/alarm => ein Datum & Uhrzeit in der näheren Zukunft!
    => Je nach Board könnte der Rechner mit diesem Befehl sofort ausgehen. Hatte ich mal bei einem "ECS P6BXTA+". Also nicht erschrecken wenn es so ist.
    - Wenn der Rechner noch läuft, #> poweroff


    Dann schau 'mer mal ob der Rechner wieder zu dem eingegeben Zeitpunkt wieder startet.


    Bis dann
    hummingbird_de

    HowTo: APT pinning

    The post was edited 3 times, last by fnu ().

  • Hallo,


    ich weiß noch, daß es bei mir funktionierte, wenn ich im Bios die Einstellungen für ACPI aktiviert hatte. Ich hab's aber auch mit deaktiviertem ACPI probiert. (Alles auch nach dem Bios reset).


    das mit dem echo... hatte ich schon die ganze Zeit so getestet. Was mir jetzt aber auffällt ist, daß ich zuvor nie runvdr stop ausgeführt hatte. Sag bloß, daß ist wichtig?!?! Dann war ich vielleicht einfach nur ein DAU! Ich probier's heute Abend gleich mal aus. Danke auf alle Fälle mal für den Tipp.


    Grüße
    Jo

  • Hi,


    nun mit dem vorherigen Stop vom VDR verhinderst Du, das der VDR einen anderen Termin (aus Timer) in "/proc/acpi/alarm" setzt.
    [EDIT]Blödsinn von mir, poweroff ist poweroff.pl und setzt den Wakup-Zeitpunkt.[/EDIT]


    ACPI muß natürlich eingeschaltet sein, heißt ja schließlich ACPI-Wakeup ;)


    Aber, wenn Dein BIOS bei WakeUp Events oder so ähnlich die Möglichkeit anbietet, den Rechner zu einem bestimmten Tag im Monat zu starten muß diese bei 99% aller Boards ausgeschaltet sein.


    Probiers mal aus.


    Bis dann
    Frank

    HowTo: APT pinning

    The post was edited 1 time, last by fnu ().