gelöst!! Fritz USBStick wird nach reboot nicht mehr geladen

  • Hallo,


    nach ewigem rumprobieren habe ich meinen Frits WLAN USBStick nun endlich zum Laufen bekommen.
    Leider nur wenn ich alles manuell eingebe.
    Meine config sieht folgendermaßen aus:
    # more /etc/wpa_supplicant.conf
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    ap_scan=2
    eapol_version=1
    fast_reauth=1
    network={
    ssid="FRITZ!Box Fon WLAN 7170"
    key_mgmt=WPA-PSK
    proto=WPA
    pairwise=TKIP
    group=TKIP
    psk="xxxxxxxxxxxxxxxx"
    #psk=xxxxxxxxxxxxxxxxxxxxxxxxxxx
    }


    # more /etc/network/interface
    This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).


    # The loopback network interface
    auto lo
    iface lo inet loopback


    # This is a list of hotpluggable network interfaces.
    # They will be activated automatically by the hotplug subsystem.
    #mapping eth0
    # script grep
    # map eth0


    # The primary network interface
    #allow-hotplug eth0
    #iface eth0 inet dhcp


    auto wlan0
    iface wlan0 inet static
    address 192.168.178.25
    netmask 255.255.255.0
    gateway 192.168.178.1
    post-up /usr/sbin/wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -Bw
    #post-up sleep
    post-down killall wpa_supplicant
    post-down rm -r /var/run/wpa_supplicant


    # more /etc/default/wpasupplicant
    # /etc/default/wpasupplicant


    # WARNING! Make sure you have a configuration file!


    ENABLED=1


    # Useful flags:
    # -D <driver> Wireless Driver
    # -i <ifname> Interface (required, unless specified in config)
    # -c <config file> Configuration file
    # -d Debugging (-dd for more)
    # -w Wait for interface to come up


    OPTIONS="-i wlan0 -D wext -c /etc/wpahttp://lists.eit21.de/pipermail/bglug/2006-March/000139.html_supplicant.conf i-dd -w"



    Nach dem booten kommt das WLAN leider nicht alleine hoch.
    Nach depmod -a, modprobe ndiswrapper und
    ifconfig wlan0 inet xxxx netmask xxx up
    route add default gw xxxx
    läuft es wieder.
    Irgend etwas läuft falsch in den Startscripts.
    Kann mir jemand helfen?


    Gruss
    hsp

    ---------------
    VDR : ct`vdr Version6.1, Asus M2NPV-VM, AMD Sempron 3200+EE, Thermalright SI-128, 1 GB Ram, Samsung 250 GB SATA-HD, Pioneer DVR-112 Super, TechnoTrend-FF 2.3, Hauppage Nova-S, Silverstone LC SST-LC17-S


    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von hsp ()

  • Helfen kann ich Dir leider nicht, aber mich würde die Lösung brennend interesieren, wie der Stick denn installiert wird.
    Für eine Hilfestellung wäre ich dankbar.


    Gruß
    denkerD

    Gruß denkerD

    Software: EasyVDR 0.8
    Hardware:
    ASUS M2NPV-VM; Sempron 3000+; TT2300-S mit CI und Irdetoi;

  • Hi,
    dein USB-WLAN-Stick (wlan0) ist noch nicht initialisiert, wenn dein network-Skript versucht das device zu konfigurieren. Abhilfe ist einfach: Kommentier den o.g. Parameter "auto wlan0" aus deinem network-Skript und hänge ein weiteres Init-Skript ein, dass vor dem konfigurieren prüft, ob das Device auch wirklich vorhanden ist. Bei mir schaut's bspw. so aus:


    [...]
    #
    # setup wlan device and start WPA-Supplicant
    #
    COUNT="0"
    MAXCOUNT="10"
    while [ ! -e "proc/net/ndiswrapper/wlan0" ]; do
    sleep 1
    if [ $COUNT = $MAXCOUNT ]; then
    break
    else
    COUNT=`expr $COUNT + 1`
    fi
    done
    /sbin/ifup --force wlan0
    /usr/sbin/wpa_supplicant -Bw -c/etc/wpa_supplicant.conf -iwlan0
    /usr/sbin/sshd
    : exit 0

  • Hi,


    hab nach langem googeln eine Loesung gefunden.


    Dies ist nun meine /etc/network/interfaces


    # /etc/network/interfaces
    .
    auto wlan0
    iface wlan0 inet dhcp
    pre-up grep -q ndiswrapper /proc/modules || modprobe ndiswrapper


    Habe mir noch einen Link in /etc/rcS.d nach /etc/init.d/wpasupplicant eingericht.
    # cd /etc/rcS.d
    # ln -s ../init.d/wpasupplicant S39wpasupplicant


    nun funzt es!!


    Danke dbrenken für deine Lösung, werde sie bei Gelegenheit ausprobieten.
    Werde in Kürze ein HowTo für die Installtion eines Fritz WLAN USBSticks einstellen.


    -------------------------------------------------------------------------------------------------------------------------
    Software: c't-VDR 5 (2.6.16-ct-1)
    Hardware: Silverstone LC 17-S, ASUS M2NPV-VM, AMD Sempron 3200+EE (35W), Thermalright SI 128 Heatpipe, SP2504C, 1024 MB Ram, Technotrend 2300 modded, WinTV Nova-S Plus


    Gruss
    hsp

    ---------------
    VDR : ct`vdr Version6.1, Asus M2NPV-VM, AMD Sempron 3200+EE, Thermalright SI-128, 1 GB Ram, Samsung 250 GB SATA-HD, Pioneer DVR-112 Super, TechnoTrend-FF 2.3, Hauppage Nova-S, Silverstone LC SST-LC17-S