ACPI Wakeup und HWCLOCKACCESS

  • Ich habe einen c't VDR 5.0 mit ACPI Wakeup auf einem PC SNI Scenic xB PIII-933 installiert.


    Dazu habe ich folgende Anpassungen gemacht:
    "/etc/vdr/vdr-addon-acpiwakeup.conf":
    ACPI_ENABLED=yes


    "/etc/default/rcS":
    HWCLOCKACCESS=no


    "/etc/defaults/vdr":
    HWCLOCKACCESS=yes


    Mit dieser Konfiguration läuft ACPI-WakeUp, aber die Hardwareuhr wird nicht mehr gestellt und läuft langsam weg.
    Setze ich in "/etc/default/rcS":
    HWCLOCKACCESS=yes
    wird die Hardwareuhr beim runterfahren gestellt, aber ACPI Wakeup funktioniert nicht mehr.


    In "/etc/defaults/vdr" hat
    HWCLOCKACCESS=yes/no
    keinen Einfluss.
    Wie kann ich den VDR dazu bringen, die Hardwareuhr zu stellen (vielleicht schon vor dem runterfahren), ohne dass ACPI Wakeup gestört wird?

  • Also ich habe mal in das shutdown-script von acpiwakeup ein

    Quote

    hwclock --systohc


    eingebaut, aber die Uhrzeit kann nicht gespeichert werden, weil der vdr nicht mit Administratorrechten läuft.
    Daraufhin habe ich ein

    Quote

    chmod 6775 /sbin/hwclock


    gemacht. Die Rechte sind jetzt

    Quote

    hwclock rwsr-sr-x root root


    d.h. eigentlich müsste hwclock mit "set user or group ID on execution (s)" ausgeführt werden, also als Administrator. Wenn ich aber hwclock als normaler user aufrufe, bekomme ich immer noch "keine Administratorrechte".


    Was mache ich falsch?


    Viele Grüße, Phantom67

  • Heda,


    wenn ich die Start-Stop-Mechanik von Linux richtig verstanden habe, werden bei einem
    "shutdown -h..." (also ein init 0) alle Stop-Scripte (die mit K??* anfangen) im Verzeichnis /etc/rc0.d ausgeführt.


    Wenn nun das K-Script für den VDR später drankommt als das K-Script für die hwclock, wird die BIOS-Zeit nach dem Setzen des Wakeup-Timers durch den VDR gesetzt...und nix geht mehr...


    Man müsste den K??hwclock vor dem K??vdr starten (also das Script ausführen)...


    Also in etwa:


    root@VDR:/etc/rc0.d# mv K22hwclock K02hwclock


    Ich habs mal bei mir umgebaut, leider keine Zeit zum testen...


    Ich berichte später...vielleicht probierts schon mal jemand...


    Martin

    :borg

    VDR-PC: Fujitsu-Siemens, yaVDR 0.5, WinTV-Nova-S2 HD

    CUTTER-PC: Selfmade PC mit WIN 7 HomePremium 64bit

  • Quote

    Original von martinoelge
    Wenn nun das K-Script für den VDR später drankommt als das K-Script für die hwclock, wird die BIOS-Zeit nach dem Setzen des Wakeup-Timers durch den VDR gesetzt...und nix geht mehr...


    Du übersiehst das die ACPI aufwachzeit in den shutdown scripten von VDR gesetzt wird.
    Also BEVOR init x ausgeführt wird.


    Die reihenfolge der kill scripte ist daher irrelevant.


    gruss Peter

    Mein anderer VDR ist (auch) ein EPIA
    1)VIA M10000-Nehemiah, 160+120G Samsung; NEC 1300A; YY A106; LCD20x4 ...
    2) ctvdr+e-tobi ; C3M266+1,2GHz-Nehmiah; 160G Samsung + 4x500G Seagate SATA; NEC3500; TT-Case; DVB-S 1.3+4MB + Nova ; gLCD 240x128 ...
    . . .TB rulez. . .

    The post was edited 1 time, last by PeterD ().

  • PeterD


    Jupp, soweit hab ichs auch rausgefunden... also nix mit Kill-Script...


    Desweitern hab ich mal den Ansatz von goldfish verfolgt und das Script getestet.
    Fazit: es geht nur eins: entweder hwclock oder acpi-wakeup...:schiel


    Ist das wirklich so oder bin ich mal wieder blind...


    fragt sich
    Martin

    :borg

    VDR-PC: Fujitsu-Siemens, yaVDR 0.5, WinTV-Nova-S2 HD

    CUTTER-PC: Selfmade PC mit WIN 7 HomePremium 64bit

    The post was edited 4 times, last by martinoelge ().

  • So jetzt hab ichs, wer lesen kann, ist klar im Vorteil: RTFW (read the fucking wiki)


    wie immer im Leben gibts mehrere Möglickeiten:


    1. ACPI-Wakeup geht garnicht (dann sind wir hier im Thread aber falsch)
    2. ACPI-Wakeup geht, aber nur mit HWCLOCKACCESS=no in /etc/default/rcS
    3. ACPI-Wakeup geht auch mit hwclock (ohne HWCLOCKACCES gesetzt!)


    Bisher hab ich mich mit Punkt 2. zufrieden gegeben...
    Aber:
    Wenn man in der /etc/init.d/hwclock.sh den Parameter:


    Code
    1. # Set this to any options you might need to give to hwclock, such
    2. # as machine hardware clock type for Alphas.
    3. HWCLOCKPARS="--directisa"


    setzt, gehts...
    Letztendlich hab ich diesen Hinweiss von hier:


    Linux-Magazin


    bye
    Martin

    :borg

    VDR-PC: Fujitsu-Siemens, yaVDR 0.5, WinTV-Nova-S2 HD

    CUTTER-PC: Selfmade PC mit WIN 7 HomePremium 64bit

    The post was edited 7 times, last by martinoelge ().

  • Jetzt hat es geklappt. Mein vdr stellt die Hardwareuhr und gleichzeitig funktioniert ACPI Wakeup. Hier noch mal meine kompletten Anpassungen für ACPI Wakeup:


    "/etc/vdr/vdr-addon-acpiwakeup.conf":
    ACPI_ENABLED=yes


    "/etc/default/rcS":
    HWCLOCKACCESS=yes


    "/etc/defaults/vdr":
    HWCLOCKACCESS=yes


    "/etc/init.d/hwclockfirst.sh":
    HWCLOCKPARS="--directisa"


    "/etc/init.d/hwclock.sh":
    HWCLOCKPARS="--directisa"
    Außerdem muss hier in jeder Zeile mit hwclock der Parameter
    $HWCLOCKPARS
    hinzugefügt werden.


    Phantom67

  • Quote

    Original von Phantom67
    Jetzt hat es geklappt. Mein vdr stellt die Hardwareuhr und gleichzeitig funktioniert ACPI Wakeup.


    Na siehste, geht doch :-)


    Quote


    Hier noch mal meine kompletten Anpassungen für ACPI Wakeup:


    "/etc/vdr/vdr-addon-acpiwakeup.conf":
    ACPI_ENABLED=yes


    ok, hab ich auch!


    Quote


    "/etc/default/rcS":
    HWCLOCKACCESS=yes


    Schön, aber nicht notwendig, da auf yes nicht getestet wird...Man kann es weglassen!


    Quote


    "/etc/defaults/vdr":
    HWCLOCKACCESS=yes


    Das ist überflüssig, wird nirgends ausgewertet! Ist wohl in einem anderen Thread mal erwähnt worden...


    Quote


    "/etc/init.d/hwclockfirst.sh":
    HWCLOCKPARS="--directisa"


    "/etc/init.d/hwclock.sh":
    HWCLOCKPARS="--directisa"


    Das war der wichtige Punkt!!!


    Quote


    Außerdem muss hier in jeder Zeile mit hwclock der Parameter
    $HWCLOCKPARS
    hinzugefügt werden.


    Echt? In meinen Scripten waren die schon alle drinne...
    Hatte es deswegen nicht extra erwähnt...
    Naja, hab auch ne ziemlich neue Kanotix-2006-RC4...

    :borg

    VDR-PC: Fujitsu-Siemens, yaVDR 0.5, WinTV-Nova-S2 HD

    CUTTER-PC: Selfmade PC mit WIN 7 HomePremium 64bit

    The post was edited 1 time, last by martinoelge ().

  • Habe hier testweise ein FSC D1107 am laufen, hatte das Problem, daß der vdr zu spät aufgewacht ist.
    Dank diesem Thread läuft nun das ACPI-wakeup einwandfrei, yippi :)


    Distri: ctvdr5


    und zwar so:

    Zeile 72:
    /sbin/hwclock --hctosys $GMT $BADYEAR $HWCLOCKPARS
    Zeile 104:
    /sbin/hwclock --systohc $GMT $BADYEAR $HWCLOCKPARS
    Zeile 119:
    /sbin/hwclock --show $GMT $BADYEAR $HWCLOCKPARS


    Gruß, Aman

    USER: EX-Aman
    seit kurzem produktiv: VDR SZ: Geh.: MS-Tech LC-02 / Asus M3N78-EM / DVB-S: 2xCTX929 / IR-Einschalter / nvidia-vdpau / USB-Boot... easyVDR 1.0
    zZ noch produktiv VDR-WZ: Low-Budget -- Asus A7V133/1700+/Nova-S/GeForce 5500/4:3 Röhre - XBMC + easyVDR 0.8 ohne vdpau
    zZ Testsystem: Digitainer-Gehäuse / Asus M3N78-EM / DVB-S: 2xNova-S / Medion X10 / nvidia-vdpau / USB-Boot... easyVDR 1.0
    Bastelstatus: O2 Joggler - YaVDR
    ... Dockstar für Aufnahmen ...

  • Hallo Leutz,


    habe versucht eure Tips umzusetzten nur das Ding geht nicht an :-(
    Manuelles Zeit setzen klappt nur die Übergabe vom VDR an ACPI scheint nicht zu klappen.


    Findet sich jemand hilfsbereites ;-) ?


    GLG

    <-- Der Ehrgeiz gibt zu letzt auf. -->


    - ASUS P2-M2A690G / 2x2,2Ghz / 2GB RAM /250 GB / FF-Karte TT S2300 / VDR 1.6.0-2 ctvdr8 - ct-Distri v7.0 und Debian v5.0 - 2.6.28
    - ACER 5520 - VDR 1.6.0-2 - Debian v5.0 Lenny - 2.6.28-2 - XINELIBOUT
    :portal4