Div. Problem

  • Hallo,
    ich habe noch folgende Probleme :


    Oct 25 20:15:16 linvdr user.err vdr: [1423] dvdswitch: no translation found for 'Open' in language 1 (Deutsch)
    Oct 25 20:15:16 linvdr user.err vdr: [1423] WARNING: source base /dev/cdrom expands to /dev/hdc
    Oct 25 20:15:16 linvdr user.err vdr: [1423] WARNING: source base /dev/hdc is not a directory
    Oct 25 20:15:16 linvdr user.err vdr: [1423] ERROR: /dev/lircd: Connection refused
    Oct 25 20:15:16 linvdr user.err vdr: [1423] ERROR: remote control LIRC not ready!
    Oct 25 20:16:01 linvdr auth.err PAM-env[1442]: Unable to open config file: No such file or directory
    Oct 25 20:16:01 linvdr auth.err PAM-env[1456]: Unable to open config file: No such file or directory



    Vielleicht kann mir jemand helfen bei den Fehlern !! Mein LINVDR funzt zwar aber ich will keine err Meldungen in meinem Log.



    danke für eure unterstützung
    leonie

    Derzeit läuft bei mir noch alles im TEST !!! Baue gerade alles auf yaVDR um.


    Testumgebung: yavdr64-0.4.0-pre1
    Hardware: Noname PC mit Mystique SaTiX-S2 V2 CI Dual

  • Wobei ist denn daran dein echtes Problem? Wenn man mal davon absieht, dass bei dir keine Fernbedienung via LIRC funktioniert bzw. überhaupt vorhanden ist.

  • Ich habe überhaupt kein Problem bis auf die LIRC und halt die Fehlermeldungen in dem log, also ich möchte wirklich keine err Meldungen in meinem log haben weil im fehlerfall es ziemlich viel arbeit ist alle durchzusehen, ich habe noch ein Problem das ich ein Cam Modul an meine Hauppauge Nexus-s Rev. 2.1 angeschlossen habe, aber dies gibt keinerlei Meldungen nicht einmal Fehlermeldungen.


    leonie

    Derzeit läuft bei mir noch alles im TEST !!! Baue gerade alles auf yaVDR um.


    Testumgebung: yavdr64-0.4.0-pre1
    Hardware: Noname PC mit Mystique SaTiX-S2 V2 CI Dual

  • Quote

    Original von leonie
    Ich habe überhaupt kein Problem bis auf die LIRC und halt die Fehlermeldungen in dem log, also ich möchte wirklich keine err Meldungen in meinem log haben weil im fehlerfall es ziemlich viel arbeit ist alle durchzusehen, ich habe noch ein Problem das ich ein Cam Modul an meine Hauppauge Nexus-s Rev. 2.1 angeschlossen habe, aber dies gibt keinerlei Meldungen nicht einmal Fehlermeldungen.


    leonie


    ..aber es gibt doch auch nur die Lirc Fehlermeldung :rolleyes:


    Oder bin ich blind !!


    Nur weil user.err vdr eine Meldung ausgibt, handelt es sich doch nicht zwangsläufig um einen Fehler. Es gibt schließlich auch noch WARNINGS und Hinweise.


    Gruß
    Wicky

  • Und du möchtest wegen der Meldungen im log z.B. das dvdswitch Plugin neu kompilieren? Ist dir das an Arbeit wert?

  • Nein, aber ich will unbedingt mein CAM Modul ans laufen bringen, und ausserdem will ich die blöde Fehlermeldung von der Fernbedienung wegbekommen. danke für eure hilfe !!!


    leonie

    Derzeit läuft bei mir noch alles im TEST !!! Baue gerade alles auf yaVDR um.


    Testumgebung: yavdr64-0.4.0-pre1
    Hardware: Noname PC mit Mystique SaTiX-S2 V2 CI Dual

  • Quote

    Original von leonie
    Nein, aber ich will unbedingt mein CAM Modul ans laufen bringen, und ausserdem will ich die blöde Fehlermeldung von der Fernbedienung wegbekommen. danke für eure hilfe !!!


    leonie


    AAAAh, jetzt verstehe ich. Du willst nicht primär die Fehlermeldung beseitigen, sondern möchtest deine Fernbedienung nutzen können.


    Dann solltest du imho


    a) den Thread-Titel ändern oder einen neuen Thread aufmachen.
    b) uns mit Informationen versorgen. Denn z.Z. benötigen wir noch eine massiv getunte Glaskugel. ;)


    Gruß
    Wicky

  • Quote

    AAAAh, jetzt verstehe ich. Du willst nicht primär die Fehlermeldung beseitigen, sondern möchtest deine Fernbedienung nutzen können.


    Ich habe ne originale Hauppauge FB am laufen diese funzt perfekt, also ich will diese Fehlermeldung wegbekommen !!


    :hilfe


    danke leonie

    Derzeit läuft bei mir noch alles im TEST !!! Baue gerade alles auf yaVDR um.


    Testumgebung: yavdr64-0.4.0-pre1
    Hardware: Noname PC mit Mystique SaTiX-S2 V2 CI Dual


  • ...dann sollte die Lösung recht einfach sein.


    Für deine Hauppauge FB benötigst du imho kein lirc sondern das remote-plugin.


    Aus diesem Grunde habe ich gerade mit setup (auf der Konsole eingeben) im Menüpunkt IR die Verwendung einer Original-Hauppauge FB mit <YES> bestätigt.


    Nach einem Neustart wurde die von dir gepostete Fehlermeldung bei mir vom VDR nicht erzeugt.


    Außerdem wurden auch keine lirc Module geladen. Dies verwundert auch nicht, da die /etc/init.d/runvdr den Parameter USE_INTERNAL_IR auswertet. Ist der gleich yes, so werden keine lirc Module geladen. Außerdem wird in diesem Falle auch noch zusätzlich das remote Plugin geladen.


    Nachvollziehen kannst du dies an der Datei /etc/init.d/runvdr


    Gruß
    Wicky

  • Also, leider hat das nix gebracht, ich hab im Setup IR auch auf Standard FB schon gestellt gehabt, jetzt noch mal versucht und es bringt leider überhaupt nix !! Ich bin euch sehr dankbar für eure hilfe !!!!
    remote_plugin hab ich leider keins !!


    leonie

    Derzeit läuft bei mir noch alles im TEST !!! Baue gerade alles auf yaVDR um.


    Testumgebung: yavdr64-0.4.0-pre1
    Hardware: Noname PC mit Mystique SaTiX-S2 V2 CI Dual

    The post was edited 1 time, last by leonie ().

  • leonie


    Dann sehe ich drei Möglichkeiten für dich:


    1. ignoriere die Fehlermeldung


    2. Finde heraus, wie man dem vdr Prozess beipuhlen kann, dass er lirc nicht verwendet.


    3. (Ungetestet) Lade das Modul lirc_serial bevor der vdr gestartet wird.
    So kannst du testen ob dies erfolgreich seien kann:
    - vdr beenden mit /etc/init.d/runvdr stop
    - lirc_serial laden mit: modprobe lirc_serial
    - vdr starten mit /etc/init.d/runvdr start
    - Schauen obs hilft mit logread
    Fall ja:
    in die runvdr eine Zeile mit modprobe lirc_serial einbauen (ziemlich händisch und ich finde es nicht wirklich clever)
    Falls nein:
    Siehe 1. und 2.


    Gruß
    Wicky


    P.S. zu 2. schaue ich gerade nach

  • Voll super, echt cool ich bedanke mich bei euch 1000 mal. danke!!!
    Ich glaub der Aufwand steht wirklich nich dafür !!


    leonie

    Derzeit läuft bei mir noch alles im TEST !!! Baue gerade alles auf yaVDR um.


    Testumgebung: yavdr64-0.4.0-pre1
    Hardware: Noname PC mit Mystique SaTiX-S2 V2 CI Dual

  • Quote

    Original von leonie
    Voll super, echt cool ich bedanke mich bei euch 1000 mal. danke!!!
    Ich glaub der Aufwand steht wirklich nich dafür !!


    leonie


    Ok, dann scheinst du dich für 1. entschieden zu haben. Ich glaube die Entscheidung ist vernünftig. ;)


    Noch viel Spaß mit dem VDR und Gruß
    Wicky

  • Wollte nur mitteilen, dass ich gerade unter SuSE10.1 auch ständig die
    "ERROR: /dev/lircd: Connection refused" -Fehlermeldung bekommen habe.
    Der Fehler war, ich hatte nur lirc über yast installiert und die kernel Module ingnoriert -
    tja selbst schuld. Nachdem ich lirc-kmp-default nachinstalliert hatte, ging es.


    vielleicht hilft das ja jemandem....


    Colonel

  • Wer diese Fehlermeldung wegbekommen möchte, braucht VDR einfach nur ohne LIRC-Unterstützung zu compilieren -- oder LIRC starten, auch wenn kein serieller IR-Empfänger dran hängt.


    Ignoriert das einfach.


    Viele Grüße, Mirko