Alte leichen werden nicht gelöscht.

  • Hallo,


    ich habe da ein kleines Problem. Ich habe mehrfach Verzeichnisse mit als zu löschenden Dateien gefunden, die teilweise ein halbes Jahr alt sind. Ich habe den Rechner mehrfach über das Menue neugestartet und habe da auch die Bereinigunsanzeige gesehen.


    Kennt noch jemand das Problem? Ich habe diese Verzeichnisse nun per Hand gelöscht. Nur wie kann ich das hier verhindern? Ich wunderte mich das die Platte so voll war ;).


    Nunja, dann werde ich das wohl des öfteren machen müssen, oder?



    Volker

  • ... keine Angabe, welche Software du benutzt, welche Dateien du meinst, wo du sie gefunden hast ... ungefähr wie "Ich musste mein Auto reparieren, das machte so komische Geräusche. Ob ich das jetzt häufiger habe?"


    Viele Grüße, Mirko

  • Cooper schrieb:



    ... keine Angabe, welche Software du benutzt, welche Dateien du meinst, wo du sie gefunden hast ... ungefähr wie "Ich musste mein Auto reparieren, das machte so komische Geräusche. Ob ich das jetzt häufiger habe?"

    Viele Grüße, Mirko


    -----


    O.K. war schon spät und ich habe die wichtigsten angaben vergessen.


    Also mirko, es ist Mahlzeits LinVDR Iso, ich meine die Videodateien welche vdr auf dem Rechner abspeichert. Gefunden habe ich diese in den Verzeichnissen Video0 und Video1.


    Wenn ich diese Dateien mit vdradmin gelöscht habe, wurden Sie auch nicht mehr im Verzeichnis vom vdr angezeigt. Die Kennzeichnung .del haben diese Dateien bzw. Ordner gehabt. Das komische ist halt das diese auch nach der bereinigung weiter vorhanden waren und Platz verbrauchten.


    Vielleicht liegt das an den etwas verwurschtelten Linvdr.

  • Hmmm, wenn ich das richtig im Kopf habe gab es mal bei irgend einer VDR-Developer-Version das Problem, dass er nicht richtig gelöscht hat.


    Du kannst ihm im Prinzip ja im Shutdown-Script mit einem automatisierten "rm" auf alle ".del" nachhelfen. Da solltest du dann aber zweimal hinsehen, ob der Code auch stimmt, nicht dass du versehentlich alles entsorgst...


    Viele Grüße, Mirko

  • Hallo,


    das Problem wurde hier schon mehrfach angesprochen. Ich habe es auch immer noch.


    Lösung gab es bisher noch keine.


    Ich schaue halt meine Platten ab und zu manuell durch und lösche dann manuell.


    Nur nach .del zu suchen nützt nichts wenn man mehr als eine Festplatte hat.


    Grüße Bernd

    VDR : POV Atom 330-1 Mainboard, MSI TV@nywhere Satellite II, 2 GB RAM, natürlich mit yaVDR 0.61. Heimkino mit Onkyo AVR, Nubert-Surround-Boxen und JVC Beamer mit 4K und HDR. HD-VDR für Newbies: www.partyfotos.de/vdr

  • Hallo Volker,
    hatte das gleiche Problem.
    Schau mal ob in deinem /video Verzeichnis ein toter Softlink liegt.
    Bei mir war es so. Hatte irgendwann mal ein wenig rumexperimentiert...
    Nach dem Entfernen des Softlinks hat VDR wieder so gelöscht wie immer.


    Andre´


    Hoppla, hab nicht richtig gelesen.
    Bei mir blieben nur die leeren Verzeichnisse stehen, die Dateien selber wurden gelöscht.

    Mediaportal mit QDI Board, Via Ezra 900, 128MB RAM, TT 1.3 und TT-Budget

    The post was edited 1 time, last by mortimer ().

  • Hallo zusammen, folgende Ausgangssituation:
    /video0 ist bei meinem VDR (LinVDR) auf eine Windows-Maschine (NAS) verlinkt.


    Der VDR nimmt auf, spielt ab, alles scheint zu funktionieren. Auf der Windows-Maschine habe ich die User linvdr und root angelegt. Mitlerweile habe ich dem User "Jeder" sogar alle Rechtegegeben, aber trotzdem habe ich folgendes Problem beim löschen von Aufzeichnungen über das OSD.


    Wenn ich nun einen Film lösche, dann passiert folgendes:


    Log START
    ...
    Oct 6 17:43:23 linvdr user.info vdr: [1371] confirm: Aufzeichnung löschen?
    Oct 6 17:43:23 linvdr user.info vdr: [1371] warning: Aufzeichnung löschen?
    Oct 6 17:43:25 linvdr user.info vdr: [1371] confirmed
    Oct 6 17:43:25 linvdr user.info vdr: [1371] deleting recording /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.rec
    ...
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] remove deleted recordings thread started (pid=2193, tid=2193)
    Oct 6 17:50:39 linvdr user.info vdr: [2193] removing recording /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/001.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/002.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/003.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/004.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/005.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/006.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/007.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/008.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/index.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/info.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/marks.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del/marks0.vdr
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1/2006-10-03.20.05.99.99.del
    ...
    Oct 6 17:50:39 linvdr user.debug vdr: [2193] removing /video0/Der_Staatsfeind_Nr._1
    Oct 6 17:50:39 linvdr user.err vdr: [2193] ERROR: /video0/Der_Staatsfeind_Nr._1: Device or resource busy
    ...
    Log ENDE


    Von Hand (als root) das leere Verzeichnis löschen funktioniert!
    rm -R /video0/Der_Staatsfeind_Nr._1/


    Mittlerweile habe ich ein Menge so leerer Verzeichnisse, die nicht gelöscht werden. Was kann ich machen?
    Welches script löscht denn die Filme? Ich kenn mich leider mit den at-Sachen nicht so gut aus.


    Hat jemand eine Idee ??? :prost2

    _ALEX_ verwendet LinVDR 0.7 (1.3.44 ISO) 1000MHz-AMD mit 512MB, (/video0 und /pub auf 600GB NAS); 1 x Nexus-S, 1 x Nova-S; IR-Einschalter rev.4

  • Sorry, das scheint ein Samba- bzw. Windows-Problem zu sein -- weil busy kann er das Verzeichnis nicht löschen, dafür kann VDR nichts. Er hat's versucht.


    Du kannst mit lsof versuchen rauszukriegen, wer das Verzeichnis noch besetzt hält -- ich glaube aber nicht, dass du damit weit kommst.


    Viele Grüße, Mirko

  • Hallo Mirko,
    da kann ich dir nur zustimmen. Der liebe VDR kann nichts dafür, aber das böse Windows ...
    Ich habe mittlerweile auch gemerkt, dass manchmal die Aufnahmen nicht vollständig sind. Im Log heisst es "Puffer overflow" oder so ähnlich. Auch wenn sonst nichts los ist auf dem Netzwerk.
    Jetzt habe ich mal testweise eine Platte in den VDR eingbaut, das Video0-Verzeichnis vom NAS rüberkopiert und siehe da, alles geht so problemlos wie immer (meistens).
    Ich nuss noch anmerken, dass mein NAS ein mit nLite gebasteltes WinXP Software Raid5 ist. Wer weiss was da alles nicht geht ;-)
    Ich arbeite zwar mit grossen 3D-Daten, und habe da ich absolut keine Zugriffsprobleme, aber in Echzeit Video schreiben ist halt doch noch mal was anderes. Probiere weiter ...

    _ALEX_ verwendet LinVDR 0.7 (1.3.44 ISO) 1000MHz-AMD mit 512MB, (/video0 und /pub auf 600GB NAS); 1 x Nexus-S, 1 x Nova-S; IR-Einschalter rev.4

    The post was edited 1 time, last by _ALEX_ ().