Parameter an Plugin übergeben

  • Hi,
    für das audiorecorder-Plugin muss der Pfad beim Start an das Plugin übergeben werden. Leider habe ich keine Ahnung, wo dies geschieht.


    Ich habe es mal in der runvdr (Z. 174) versucht:

    Code
    1. $BINDIR/vdr -L $PLUGINDIR $PLUGINS $COMMON_PARAMETER -v /video0 -c $CONFDIR -w 900 -E /ramdisk/epg.data -s /usr/bin/poweroff.pl -r /usr/bin/noadcall.sh -P'audiorecorder -r /pub/mp3' < /dev/tty$VDRTTY


    Hat nichts gebracht.
    Wo mach ich das dann?


    Danke, meteosat

    VDR: Silverstone LC17, 200GB + 400 GB Samsung HDD, DVD-Brenner LG 4163, AMD Geode NX1750, uralt-Netzteil, Technotrend FF 2300, easyvdr 0.6

  • Die Fehlermeldung mit logread -f ist "parameter -r not given". Diesen Parameter muss ich also wohl irgendwo eintragen, damit der audiorecorder beim Start weiß, wo er die Daten ablegen soll.


    Beim Eintrag in die runvdr und nicht aktivieren im Setup finde ich tatsächlich einen Eintrag im Menü "audiorecorder (on)", aber die Konfiguration ist nicht möglich und auf dem ARD-Bouquet nimmt er auch nicht auf, wie er das doch eigentlich müsste.

    VDR: Silverstone LC17, 200GB + 400 GB Samsung HDD, DVD-Brenner LG 4163, AMD Geode NX1750, uralt-Netzteil, Technotrend FF 2300, easyvdr 0.6

  • Du kannst das Plugin nicht im Setup konfigurieren ?
    Da must Du nämlich eintragen von wievielen Karten er aufnimmt.....


    Gruß Marcus

    VDR: DD 5.5 mit 4 Tunern , Intel 847 mit nvidia Kepler 630 , 4GB RAM , 1x 1TB , yavdr 0.5 X10 Fernbedienung von Pollin zu Steuerung, Diverse XBMC (openelec + Windows) im Haus als Clients

  • Dann sind die einfachen Hochkommata wohl die falschen ;) - also " probieren.


    Und das plugin wie von wilderigel angemerkt nicht über die Pluginliste aktivieren.


    arghgra

  • Hi,
    ich komme einfach nicht weiter:


    -P'audiorecorder -r /pub/mp3' (shift-#) - Plugin wird geladen, aber kein Setupmenü, Anzeige im OSD
    -P''audiorecorder -r /pub/mp3'' (2 mal shift-#) - Plugin wird geladen, aber kein Setupmenü, Anzeige im OSD
    -P"audiorecorder -r /pub/mp3" (Anführungszeichen) - Plugin wird geladen, aber kein Setupmenü, Anzeige im OSD
    -P´´audiorecorder -r /pub/mp3´´ (Apostroph nach oben) - Plugin wird nicht geladen
    -P``audiorecorder -r /pub/mp3`` (Apostroph nach unten) - Plugin wird nicht geladen
    Wenn das Plugin geladen wurde, habe ich auch noch versucht, im Setup das Plugin auszuwählen. Da kam dann imer der altbekannte "parameter -r not given" Hinweis.


    Auf welcher Leitung steh ich?


    P.S.: Bei geladenem Plugin nimmt es mir brav BR3 auf und konvertiert in mp2

    VDR: Silverstone LC17, 200GB + 400 GB Samsung HDD, DVD-Brenner LG 4163, AMD Geode NX1750, uralt-Netzteil, Technotrend FF 2300, easyvdr 0.6


  • Is doch soweit ok - PluginMenu is dann ne andere Baustelle - welche Version?


    arghgra

  • Quote

    Original von arghgra
    Is doch soweit ok - PluginMenu is dann ne andere Baustelle - welche Version?


    Und welche Version ist dann korrekt? Anführungszeichen oder Doppel-shift#?


    Bei mir läuft vdr1.4.2 (sorry, Signatur ist geändert)


    Gruß, meteosat

    VDR: Silverstone LC17, 200GB + 400 GB Samsung HDD, DVD-Brenner LG 4163, AMD Geode NX1750, uralt-Netzteil, Technotrend FF 2300, easyvdr 0.6


  • Sauber wären Version 1&3 - warum du kein Plugin-Menü unter Einstellungen->Plugins siehst, kann ich dir adhoc nicht beantworten.


    arghgra

  • Sorry, eine nochmalige Suche hat die Lösung gebracht:
    Da das Plugin nicht aus dem Setup-Menü, sondern per runvdr gestartet wird, finde ich es nicht unter a wie audiorecorder, sondern ganz am Schluss der Pluginliste. Muss man erst mal drauf kommen. Ich hatte nie ganz nach unten gescrollt.
    Danke, schon wieder was gelernt.


    Falls das ein generelles Phänomen ist, sollte ich vielleicht mal den Weg über die runvdr inst wiki schreiben. Das hat mir persönlich nicht geholfen.

    VDR: Silverstone LC17, 200GB + 400 GB Samsung HDD, DVD-Brenner LG 4163, AMD Geode NX1750, uralt-Netzteil, Technotrend FF 2300, easyvdr 0.6

  • Ok, hier ist wieder ein Neuling der genau das Problem hat und aus den Antworten nicht schlau wird :-(


    Wo zum teufel muss ich die Parameter von dem audiorecorder beim starten von linvdr übergeben ?


    Welche Datei muss ich wie editieren ?


    Munter bleiben, Markus

  • Hi,
    es gibt bis jetzt nur die unkomfortable Lösung über die runvdr:
    P"audiorecorder -r /pub/mp3" (Anführungszeichen)
    bei den Plugins einfügen.
    Plugin erscheint bei mir dann in der Pluginliste ganz am Schluss, also nicht alphabetisch. Herbis hat angekündigt, dass er in der nächsten Version ein default-Verzeichnis einfügt, das dann das aktivieren über das Setup erlaubt (muss bisher deaktiviert sein, da es sich sonst mit der runvdr in die Quere kommt. Plugin wird doppelt geladen).

    VDR: Silverstone LC17, 200GB + 400 GB Samsung HDD, DVD-Brenner LG 4163, AMD Geode NX1750, uralt-Netzteil, Technotrend FF 2300, easyvdr 0.6

  • Aha.


    Habe in meiner /etc/init.d/runvdr


    for PLUGIN in `unique.pl $PLUGINLIST`;
    do
    PLUGINS="$PLUGINS -P$PLUGIN"

    P"audiorecorder -r /pub/mp3/audiorecorder"

    done


    gesetzt. Das Verzeichniss existiert, trotzdem sagt er beim starten:


    /etc/init.d/runvdr: line 46: Paudiorecorder -r /pub/mp3/audiorecorder: No such file or directory
    /etc/init.d/runvdr: line 46: Paudiorecorder -r /pub/mp3/audiorecorder: No such file or directory
    vdr:/pub/mp3/audiorecorder#


    Was mache ich falsch ?


    Munter bleiben, Markus

  • Hast Du im Setup "audiorecorder" abgewählt? Sonst startet er es von dort ohne parameter

    VDR: Silverstone LC17, 200GB + 400 GB Samsung HDD, DVD-Brenner LG 4163, AMD Geode NX1750, uralt-Netzteil, Technotrend FF 2300, easyvdr 0.6

  • Habe vorhin erstmal aufgehört zu probieren, das Wetter war zu schön...


    Jetzt habe ich mich nochmal rangesetzt und den Fehler gefunden:


    in der /etc/init.d/runvdr gibt es weiter unten einen extra Bereich wo die Plugins gestartet werden (ach nee werden jetzt einige sagen) dort habe ich den audiorecorder mit -P"audiorecorder -r /pub/mp3/audiorecorder" hinzugefühgt und siehe da er ist im OSD zu sehen.


    Das muss einem Neuling ja gesagt werden. Jetzt suche ich gerade wo ich die Sender einstellen kann die er aufnimmt. Max. 5 sind möglich aber wo wähle ich diese 5 aus ?


    Ein kurzer Kommentar im Wiki könnte nicht schaden. Wo trage ich bei linvdr den Startparameter ein und wie wähle ich die zu empfangenen Sender. Das ist doch die Basis...


    Munter bleiben, Markus

  • Quote

    Original von mielmann
    Ein kurzer Kommentar im Wiki könnte nicht schaden. Wo trage ich bei linvdr den Startparameter ein und wie wähle ich die zu empfangenen Sender. Das ist doch die Basis...


    Hindert dich keiner dran es einzutragen nachdem du es herausgefunden hast.

  • ... und ich hoffe auch, dass auch der Autor des Plugins eine Mail bekommen hat, indem du die umständliche Bekanntgabe des Audio-Verzeichnisses über Kommandozeilenparameter bemängelt hast.


    Sowas gehört nämlich grundsätzlich ins Plugins-Setup und nicht auf die Kommandozeile. Deswegen unterstützen wir auch keine Kommandozeilenparameter für Plugins, und in LinVDR 0.8 werden Plugins, die nur mit Angabe eines Kommandozeilenparameters funktionieren, kategorisch rausgeworfen.


    Viele Grüße, Mirko