vdrrip geht nicht mehr sauber seit Upgrade auf mplayer 1.0.pre8

  • Hallo zusammen,


    irgendwie fällt mein vdr seit dem letzten Upgrade langsam auseinander. Jetzt mag das vdrrip-Plugin nicht mehr vernünftig mitspielen.


    Beim Upgrade wurde mir statt bisher mplayer-k6 der neue mplayer 1.0.pre8 aufgespült. Prinzipiell ja eine feine Sache, da mein Athlon64 4000+ jetzt auch mit allen SSE/2-Erweiterungen genutzt wird.


    Aber: seitdem mag vdrrip keine schwarzen Ränder mehr erkennen und die Automatik-Funktion zur Anpassung der Auflösung geht auch nicht mehr. Weiterhin sind auf einmal nach Konvertierung ohne Auflösungsänderung gelegentlcih schwarze Artefakte im DivX drin, manchmal geht die Konvertierung gar nicht (hatte ich vorher mit vdrrip nie, dafür aber mit vdrconvert, was ich nie zum Durchlaufen bekommen habe)


    Hat da jemand ne Idee?


    Mein Basissystem ist ein Debian Sarge.


    Gruß, Flipsen

    VDR-Server: Pentium G3220, 8GB RAM, 60GB OCZ SSD, 2x 3TB WD Red (RAID1), 1x TeVii S482 Dual DVB-S2-Karte, 1x DVBshop DVBSky 952 Dual DVB-S2-Karte, Ubuntu 14.04.3LTS, VDR 2.2.0, yavdr-Repo, vnsi-server
    VDR-Client 1: Asus ATOM, 2GB RAM, KODI 15.2 Kodibuntu 14.04.3LTS, vnsi-client
    VDR-Client 2: Samsung Galaxy S5 mit Kodi



  • Hi,
    habe das gleiche Problem. Nach dem letzten Update vor ein paar Tagen erkennt vdrrip keine schwarzen Ränder mehr und ließt keine Seitenverhältnisse mehr aus (Asp.: 0.00), was wahrscheinlich auch der Grund für die fehlerhafte Erkennung der Ränder ist. Hoffe es gibt eine Lösung für dieses Problem???


    Gruß Heiko

  • Anscheinend schon der Mplayer schuld?
    Hab aber nicht herausgefunden, wie das Plugin selber die Infos besorgt.
    Man beachte die Infos von ID_VIDEO_ASPECT, jeweils die selbe Datei.


    mplayer 1.0pre8:


    Mplayer 1.0pre7try2:

  • Falls es am Mplayer liegt, wäre wohl die einzige Möglichkeit sich wieder eine ältere Version zu installieren? oder sollte ich darauf warten das der Bug behoben wird, denn es scheint ja offentsichtlich ein Fehler zu sein???

  • Hallo


    gibt es hier bereits eine Lösung?


    Möchte gerne mit Vdrrip und Mplayer 1.0 pre8 Filme nach Xvid umwandeln.
    Leider wird das Seitenverhältnis nicht erkannt und so fehlen oben und unten die schwarzen Streifen beim umgewandelten Film. Sieht natürlich alles lang gezogen aus.


    Gibt es nicht evtl. eine Möglichkeit in Vdrrip das Seitenverhältnis von Hand einzustellen?

    Hardware: POV ION 330, TT Budget S2 1600 , MCE Philips Fernbedienung,
    Software: yaVDR 0.2

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Lanze ()

  • Hallo Lanze,


    tut mir leid, ich lebe im Moment auch damit, dass er das Seitenverhältnis so nimmt, wie es ist.


    Kann man dann nur mit schwarzen Rändern konvertieren und dann beim Abspielen mittels mplayer -x 720 -y 576 ... korrigieren.


    Wenn jemand eine Idee hätte, wie man das mal wieder sauber kriegt, wäre ich sehr dankbar!


    Gruß, Flipsen

    VDR-Server: Pentium G3220, 8GB RAM, 60GB OCZ SSD, 2x 3TB WD Red (RAID1), 1x TeVii S482 Dual DVB-S2-Karte, 1x DVBshop DVBSky 952 Dual DVB-S2-Karte, Ubuntu 14.04.3LTS, VDR 2.2.0, yavdr-Repo, vnsi-server
    VDR-Client 1: Asus ATOM, 2GB RAM, KODI 15.2 Kodibuntu 14.04.3LTS, vnsi-client
    VDR-Client 2: Samsung Galaxy S5 mit Kodi



  • ich hatte das gleiches problem aber habe so zu sagen eine art lösung gefuenden. Bei mir der mplayer auf gentoo hat 2 probleme:


    crop boarders geht nicht weil der neue mplayer gibt keine crop info mehr mit der parameter -really-quiet; loesung ist:
    in der file movie.c zeile 25
    #define CROPCMD "%s \'%s\'%s -vo null -ao null -really-quiet -ss %i -frames %i -vop cropdetect 2>/dev/null | grep \"crop=\" | sed \"s/.*crop\\(.*\\)).*/\\1/\" | sort | uniq -c | sort -r"


    editieren und parameter -really-quiet löschen


    #define CROPCMD "%s \'%s\'%s -vo null -ao null -ss %i -frames %i -vop cropdetect 2>/dev/null | grep \"crop=\" | sed \"s/.*crop\\(.*\\)).*/\\1/\" | sort | uniq -c | sort -r"


    Für der zweiten problem mit die VIDEO_ASPECT habe ich noch keine vernunftige lösung aber praktisch alle sendungen sind in 4:3 format (nur ZDF glaube ich sendet manchmal im 16:9) so immer in der file movie.c zeile 532 so editieren:


    if (s) {
    Aspect = 1.333333333333;
    /*Aspect = atof(s);
    if (Aspect == (double)(int)Aspect) {
    if (strchr(s, '.')) {
    *strchr(s, '.') = ',';
    } else if (strchr(s, ',')) {
    *strchr(s, ',') = '.';
    }
    Aspect = atof(s);
    }*/
    } else {Aspect = -1;}


    d.h. der string s nicht mehr parsen und aspect fest zu 1.3333 setzen, das funzt nur mit sender und filme mit aspect 4:3, falls jemand eine idee hat wie man der aspect herausfinden kann mit die neue mplayer sollte dann einfach sein der plugin zu fixieren :-)

  • Hallo erm,


    in welcher movie.c schreibst du denn da rum? Im Plugin oder direkt in den mplayer-Sourcen?


    Ich werd mal versuchen, an den Autor von vdrrip ranzukommen (weiß jemand, wer sich dafür verantwortlich fühlt?), so dass das mit aufgenommen wird.


    Gruß, Flipsen

    VDR-Server: Pentium G3220, 8GB RAM, 60GB OCZ SSD, 2x 3TB WD Red (RAID1), 1x TeVii S482 Dual DVB-S2-Karte, 1x DVBshop DVBSky 952 Dual DVB-S2-Karte, Ubuntu 14.04.3LTS, VDR 2.2.0, yavdr-Repo, vnsi-server
    VDR-Client 1: Asus ATOM, 2GB RAM, KODI 15.2 Kodibuntu 14.04.3LTS, vnsi-client
    VDR-Client 2: Samsung Galaxy S5 mit Kodi



  • in der plugin source, ich habe die patches für gentoo vorbereitet und sind schon im http://bugs.gentoo.org/show_bug.cgi?id=150217.


    diese ist der patch für den plugin: http://bugs.gentoo.org/attachment.cgi?id=98911


    könnte auch nicht klappen bei dir falls du die fix-aspect patch schon abgespielst hast.


    einfach http://bugs.gentoo.org/attachment.cgi?id=98911 herunterladen und dann im vdrrip plugin source verzeichnis mit
    patch<mplayercmd.diff
    abspielen.



    Das problem liegt naürlich an mplayer ich habe auch den bug dort gemeldet mussen wir aber warten. Der plugin author habe ich natürlich auch benachrichtig.

  • Ok, prima.


    Mal sehen, wann Tobi die Änderung im Repository drin hat. Ich hab Debian laufen mit den Paketen von Tobi.


    Warten wir's mal ab...

    VDR-Server: Pentium G3220, 8GB RAM, 60GB OCZ SSD, 2x 3TB WD Red (RAID1), 1x TeVii S482 Dual DVB-S2-Karte, 1x DVBshop DVBSky 952 Dual DVB-S2-Karte, Ubuntu 14.04.3LTS, VDR 2.2.0, yavdr-Repo, vnsi-server
    VDR-Client 1: Asus ATOM, 2GB RAM, KODI 15.2 Kodibuntu 14.04.3LTS, vnsi-client
    VDR-Client 2: Samsung Galaxy S5 mit Kodi



  • Ich hatte auch andere probleme mit der queuehandler.sh meistens mit mencoder optionen, das großte war dass wenn man encodiert einen stream (die sind praktisch immer interlaced) sollte entweder eine deinterlace option benutzen oder die parameter ":ildct:ilme" für lavc bzw. ":interlacing" für xvid benutzen. Steht klar in mencoder man page dass mann solte entweder deinterlace oder eine encoding kompatibel mit interlace benutzen, und die ergebnisse ohne deinterlace und ohne ildct:ilme sind viele artefakten besonders mit motion detection. Ich versuche noch einen patch dafür bereitzustellen und dan schicke es auch zu a-land.de, der website ist doch noch aktiv ....


    Patch für queuehandler erlaubt benutzer definierte parameter für lavc und xvid und automatisch setzt ildct:ilme für interlaced streams.
    http://bugs.gentoo.org/attachment.cgi?id=99011

  • Leider in movie.c, ist festkodiert
    Ganz am anfang findest du:
    #define IDENTCMD "%s \'%s\'%s -identify -vo null -ao null -frames 0 2>/dev/null
    | sed -e \'s/[`\\!$\"]/\\&/g\'"


    Da soll der -frames parameter ein


    #define IDENTCMD "%s \'%s\'%s -identify -vo null -ao null -frames 1 2>/dev/null
    | sed -e \'s/[`\\!$\"]/\\&/g\'"


    Die mplayer leuten werden das nicht korrigieren weil es ist kein fehler sondern eine feature :-)

  • Funktioniert hier mit nem original mplayer 1.0rc1 genauso wenig.
    mit 1.0pre7try2-1 funkts weiterhin.


    rc1:


    Wertet anscheinend das erste ID_VIDEO_ASPECT aus, das 2. wird ignoriert.

  • stimmt, noch immer der FIXME kommentär....
    Und strgrep tatsächlich liest nur der ersten .... mmh
    dafür brauche ich mehr zeit aber was ist mit der autor? kummert er sich nicht mehr um den plugin?


    Mit diesen patch in movie.c bei mir funzt gut, sucht der erste ID_VIDEO_ASPECT nicht 0, falls nicht gefuenden wird zu 1.33333 gesetzt ....



    Aspect = -1;
    while(s = strcol(strgrep("ID_VIDEO_ASPECT", p), "=", 2)){
    Aspect = atof(s);
    if (Aspect != 0) break;
    }
    if (Aspect == 0) {Aspect = 1.333333;}