ACPI-wakeup

  • I'm using linvdr 0.7 with some pathces. ACPI-wakeup works really nice on my
    Asus CUBX motherboard. But, when I use Debian 3.1 on the same machine and same poweroff.pl script--> acpi-wakeup is not working....!?!?!?!


    ACPI is enabled on 2.6.16.3 kernel and APM is disabled.


    Anyone... anyone... :)

  • Quote

    Original von kompunortti
    I'm using linvdr 0.7 with some pathces. ACPI-wakeup works really nice on my
    Asus CUBX motherboard. But, when I use Debian 3.1 on the same machine and same poweroff.pl script--> acpi-wakeup is not working....!?!?!?!


    ACPI is enabled on 2.6.16.3 kernel and APM is disabled.


    the linvdr poweroff.pl calls the busybox poweroff - afaik there is no busybox on debian3.1 - so you have to change that line ...

    Gruß


    sdu

    *******************************************************************
    gen2vdr 2.0
    TT1.3, Skystar 2.6c, activy300, STBs AVBoard
    *******************************************************************

  • this is the line


    Code
    1. sub PowerOff {
    2. # system("/bin/busybox poweroff") if(!$DEBUG);
    3. # there is no busybox
    4. system("/sbin/poweroff") if(!$DEBUG);
    5. }

    Gruß


    sdu

    *******************************************************************
    gen2vdr 2.0
    TT1.3, Skystar 2.6c, activy300, STBs AVBoard
    *******************************************************************

  • Maybe Debian syncs the hardware time with the current system time AFTER programing the Bois Timer. ( echo WAKEUPTIME > /proc/acpi/alarm)


    Look for
    HWCLOCKACCESS=no in /etc/default/rcS or an existing /etc/adjtime file


    also have a look to /etc/init.d/hwclock.sh

    Powered by Point of View ION330 und Mystique SaTiX-S2 Dual
    Geguckt wird auf einem 52PFL5605H/12 per HDMI mit Atmolight Quattro
    Audio optisch per Yamaha RX-V459 auf einem Teufel Concept P
    Non-TV content über XBMC und boblight
    Remote Harmony 525 durch Atric-IR
    Remote und Streaming mit Motorola XOOM und AndroVDR sowie Daroon Player
    Streaming auf ZBOX ID-81 und Desktop per streamdev
    All based on selfbuild OpenenELEC master


    Nebenbei noch ein par andere VDRs

  • At a normal Debian shutdown process the hardware clock is synced. This may be you problem.


    The essence is -- you can't just copy the poweroff.pl to a Debian system and expect it to work. You have to find the right position for setting the alarm clock in the Debian init scripts and implement it there. Due it's a simple "echo" to /proc/acpi/alarm, that's not very difficult.


    Greetings, Mirko

  • please try:


    /etc/init.d/hwclock.sh:

    LG
    fb


    VDR 1.4.3-3 (vdr-install-script-0.9.5.8 ), VDRAdmin-AM 3.5.2 unter Debian Sarge auf ASUS A8V Deluxe mit Athlon 3000+ (Venice), TT 1.5 + Skystar2