mal wieder: vdradmin und deutsch...

  • Hallo,
    ich bekomme zum verrecken meinen vdradmin nichtdazu, mit mir deutsch zu sprechen. Nichts zu machen, keine Möglichkeit. Weder in der Konfiguration des vdradmins selbst, noch über die Einstellung in der runvdr. Kann man sonst noch wo da was machen?


    Was ich feststellen konnte: Er nimmt alle html-sites, die in der /user/share/vdradmin/template/default stehen, egal eas ich veruche zu konfgurieren...


    Bitte helft mir!


    Ach so: es handelt sich um die 3.4.6beta (siehe auch Signatur!)


    Allzeit guten Empfang
    Bernd

    :] easyVDR 0.6.04 -Spezialedition (steht da so!!!) :]
    :] Albatron KX18D Pro; AMD Athlon 3200+ :]
    :] 1024 MB Arbeitsspeicher, TT 1.6, WinTV Nova-SE2 Budget :]
    :] Ausgabe via xineliboutput (HDMI) auf Phillips 9603:]

  • Es genügt inzwischen im Punkt "Konfiguration" von VDR Admin (bei mir läuft 3.4.6beta2) bei "Sprache" den Wert "de_DE" einzutragen und zu speichern.


    Starter

    --------------------------------------------------------------------------------------------
    Mein :vdr1 : Hermes 845GL Celeron 1.7GHz, 256MB RAM, 400GB Samsung-HD + Brenner, DVB-S 1.6 + Nova Budget, flüsterleise durch Lüfterumbau (Bildergalerie), Hardware-Wakeup nach Rasputin (meine Update-Website dazu) , LinVDR 0.7 + Toxic Tonic Update 1.4.7 :)

  • Hallo,


    genau das hab ich auch gerade probiert - ich vermute mal daß der vdradmin neu gestartet werden muß damit er auch die setups neu lädt (geht bei mir gerade nicht weil Stargate Atlantis und dann Andromeda läuft - bin aber zuversichtlich, daß er morgen Deutsch mit mir spricht...)


    Peter

    vdr-1: Gentoo-2008.0 mit vdr-1.6.0 auf ASUS A7N8X-VM400 mit Athlon mobile XP2500+ und 2x TT-S2300 mit hw-wakeup mit Software V1.5
    vdr-2: yavdr 64-0.5.0 mit vdr-1.7.27-5 + xineliboutput 1.0.7 auf ASUS M4A88TD-M/USB3 mit Athlon II-X2-20e + Zotac GeForce G210 und Cine S2 Dual Tuner V6


  • Hallo,
    genau das sollte so funktionieren, tut es aber (bei mir) leider nicht!
    Nun ja, ich kriege das auch auf neudeutsch geregelt, ist eher ein Luxusproblem....
    Aber schön wärs schon!


    Schönen Abend noch (nach dem bescheidenen Fußballspiel zwischen NL und ARG).


    Bernd

    :] easyVDR 0.6.04 -Spezialedition (steht da so!!!) :]
    :] Albatron KX18D Pro; AMD Athlon 3200+ :]
    :] 1024 MB Arbeitsspeicher, TT 1.6, WinTV Nova-SE2 Budget :]
    :] Ausgabe via xineliboutput (HDMI) auf Phillips 9603:]

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von barny32 ()

  • Hallo,


    Zitat

    Original von barny32
    Hallo,
    ich bekomme zum verrecken meinen vdradmin nichtdazu, mit mir deutsch zu sprechen. Nichts zu machen, keine Möglichkeit. Weder in der Konfiguration des vdradmins selbst, noch über die Einstellung in der runvdr. Kann man sonst noch wo da was machen?


    Kommt darauf an, was Du schon alles gemacht hast. Über :suche gibt es Menge Threads, die das gleiche Thema behandeln.


    Zitat

    Was ich feststellen konnte: Er nimmt alle html-sites, die in der /user/share/vdradmin/template/default stehen, egal eas ich veruche zu konfgurieren...


    "user" soll wohl "usr" heißen. Aber was paßt Dir daran nicht und welche Einstellung denkst Du sollte da was ändern?


    Gruß,
    Andreas

  • Hallo zusammen,
    also jetzt hab ich wohl was falsch gemacht....
    Ich hab jetzt alles was mit dem VDRADMIN zu tun hatte, gelöscht. Dann die 3.4.6beta neu installiert. Jetzt hab ich nur noch die Verzeichnisse "default" und "default.png" in usr/share/vdradmin/template/default. Von "Deutsch" usw. ist keine Spur mehr. Da nützt wohl auch keine Einstellung unter "Configuration" im vdradmin selbst. Ich kann nur die Icons ändern, indem ich wechsel zwischen default und default.png. Da war sonst auch noch "Bilder", "Copper" und nochwas zu finden (in den Einstellungen im VDRADMIN).


    Ich bin jetzt wohl weiter entfernt vom deutschen vdradmin wie vorher.


    Vielleicht weiß Andreas, was ich da machen kann.....


    Lieben Gruß
    Bernd

    :] easyVDR 0.6.04 -Spezialedition (steht da so!!!) :]
    :] Albatron KX18D Pro; AMD Athlon 3200+ :]
    :] 1024 MB Arbeitsspeicher, TT 1.6, WinTV Nova-SE2 Budget :]
    :] Ausgabe via xineliboutput (HDMI) auf Phillips 9603:]

  • Zitat

    Original von amair
    ... Über :suche gibt es Menge Threads, die das gleiche Thema behandeln.


    Ja das stimmt aber leider keine Lösung die bei mir funktioniert => bei mir ist

    • in /etc/vdramin/vdradmin.conf ein Eintrag mit LAND = de_DE
    • in /init.d/runvdr der Aufruf mit sleep 5 && LANG=de_DE nice -n 5 vdradmind.pl &
    • ich habe auch mal probiert in der runvdr eport LANG=de_DE zu setzen
    • auch vorher auf der Konsole export LANG=de_DE und dann erst vdradmind.pl gestartet

    leider alles vergeblich - er mag mich nicht auf Deutsch...


    Aber wie gesagt, es ist nur ein Schönheitsfehler - falls Doch jemand eine Lösung kennt oder findet - her damit...

    vdr-1: Gentoo-2008.0 mit vdr-1.6.0 auf ASUS A7N8X-VM400 mit Athlon mobile XP2500+ und 2x TT-S2300 mit hw-wakeup mit Software V1.5
    vdr-2: yavdr 64-0.5.0 mit vdr-1.7.27-5 + xineliboutput 1.0.7 auf ASUS M4A88TD-M/USB3 mit Athlon II-X2-20e + Zotac GeForce G210 und Cine S2 Dual Tuner V6


  • Moin


    Hatte mal ein ähnliches Problem.
    In den Verzeichnissen usr/share/locale/de/LC_MESSAGES
    und /usr/lib/locale/de/LC_MESSAGES
    fehlten bei mir die vdradmin.?? dateien.


    Vielleicht hilfts


    Gruß Dirk


    VDR-1: MS-Tech MC1200 , DH77EB , G2030 4GB 1TB, 2xDD-S2 ,IR-Ein Rev4 , yaVDR 0.6


    VDR-2: Mozart , FSC1567 Cel.2G 1GB 1TB, 4xS3200 , IMon ,IR-Ein Rev4 , yaVDR 0.6


    TestVDR: NUC5i3 , Octopus 4xS2 , Octopus Net 8xS2


  • Zitat

    Original von verleihnix
    ...In den Verzeichnissen usr/share/locale/de/LC_MESSAGES
    und /usr/lib/locale/de/LC_MESSAGES
    fehlten bei mir die vdradmin.mo dateien....


    Bingo Bongo - Das wars ==> einfach folgenden Code eingeben und dann klappt's auch in Deutsch....


    Code
    1. ln -s /usr/share/vdradmin/locale/de/LC_MESSAGES/vdradmin.mo /usr/lib/locale/de/LC_MESSAGES/vdradmin.mo
    2. ln -s /usr/share/vdradmin/locale/de/LC_MESSAGES/vdradmin.mo /usr/share/locale/de/LC_MESSAGES/vdradmin.mo
    3. vdradmind.pl -k
    4. vdradmind.pl start


    Super, Danke für den Tip


    Peter

    vdr-1: Gentoo-2008.0 mit vdr-1.6.0 auf ASUS A7N8X-VM400 mit Athlon mobile XP2500+ und 2x TT-S2300 mit hw-wakeup mit Software V1.5
    vdr-2: yavdr 64-0.5.0 mit vdr-1.7.27-5 + xineliboutput 1.0.7 auf ASUS M4A88TD-M/USB3 mit Athlon II-X2-20e + Zotac GeForce G210 und Cine S2 Dual Tuner V6


  • Hallo,



    Es ist korrekt, dass in den aktuellen Betas nur noch der "default" Skin einzustellen ist. Die Sprache kannst Du aber weiterhin einstellen. Je nachdem, ob der Befehl /usr/bin/locale existiert oder nicht, als Auswahlfeld oder als Textfeld.
    Die Verzeichnisse "Deutsch" etc. in den (ganz) alten Templates gibt's schon lange nicht mehr, da die Übersetzung nun wie üblich mit gettext() gemacht wird.


    Dazu brauchst Du natürlich die entsprechenden Kataloge.
    Wieso dass diese bei einigen nicht installiert wurden, ist mir schleierhaft. Mit "install.sh" sollte das passen. Wenn Ihr es händisch macht, dann dürft Ihr natürlich das "locale" Verzeichnis nicht vergessen...


    Gruß,
    Andreas

  • Zitat

    Original von amair... Wieso dass diese bei einigen nicht installiert wurden, ist mir schleierhaft...


    Ich gehe mal davon aus, daß das ein Überbleibsel von linvdr 0.7 ist => zumindest ich basiere darauf und cody's bzw. tarandor's patch bzw. libs dürften das auch nicht ändern.


    cooper (falls Du zufällig darüber stolpers) => für linvdr 0.8 bitte checken...


    Peter

    vdr-1: Gentoo-2008.0 mit vdr-1.6.0 auf ASUS A7N8X-VM400 mit Athlon mobile XP2500+ und 2x TT-S2300 mit hw-wakeup mit Software V1.5
    vdr-2: yavdr 64-0.5.0 mit vdr-1.7.27-5 + xineliboutput 1.0.7 auf ASUS M4A88TD-M/USB3 mit Athlon II-X2-20e + Zotac GeForce G210 und Cine S2 Dual Tuner V6


  • Hi,


    Zitat

    Original von STPTECH


    Ich gehe mal davon aus, daß das ein Überbleibsel von linvdr 0.7 ist => zumindest ich basiere darauf und cody's bzw. tarandor's patch bzw. libs dürften das auch nicht ändern.


    Hat mit dem LinVDR nichts zu tun. Die Übersetzungen werden im Original VDRAdmin-AM mitgeliefert und müssen immer neu installiert werden.
    Wenn diese also abgehen und ihr ein vorgefertigtes Paket eingespielt habt, dann müßt ihr dessen Ersteller mal frage, wieso das fehlt.


    Gruß,
    Andreas



  • Vielen, vielen Dank für den Tipp!!!
    Mir ging es wie barny32. Ich hatte mich schon damit abgefunden, dass mein Linvdr kein Deutsch spricht.



    Gruß,


    maboda

  • Hi ,


    Die 3.4.6 geht auf Linvdr auf Jedenfall auf Deutsch auf Fransösisch geht es leider erst mit der linvdr0.8 wegen locale
    Ich habe einfache die vdramin.mo aus fr auf die de kopiert so geht es ... Na ja :)


    Aber gibt es eine Lössung dafür ???
    /usr/bin/vdradmind.pl
    "bind_textdomain_codeset" is not exported by the Locale::gettext module at /usr/bin/vdradmind.pl line 53
    Not using bind_textdomain_codeset(). Please update your Locale::gettext perl module!
    vdradmind.pl 3.4.6 wurde mit der ProzeýID 1883 gestartet.


    Gruss Patrice


    Diskless Client: SMT 7020S und S100 128SDRAM 32DOM zendeb 0.4.0 beta1 mit MMS 1.0.8.5
    Hardware: Pundit-R Celeron 2.4 256DDRAM Samsung SATA 400 Gbyte Festplatte Hauppage Nexus-S Rev 2.3 Nova-S Plus DVD-RAM LG
    Software: EasyVDR 0.6.0 (vdr-1.6.0-2-ext64), LinVDR 0.7 1.4.7 Mahlzeit, SUSE-Server 10.2 1.6.0-1
    Test System: Shuttel AMD Athlon 2.6 Ghz 256DDRAM Samsung 250Gbyte Hauppage Nexus-S Rev 2.3 DVD-RAM LG ......

    :fans :welle

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von pat ()

  • Hi,


    Zitat

    Original von pat
    Hi ,


    Die 3.4.6 geht auf Linvdr auf Jedenfall auf Deutsch auf Fransösisch geht es leider erst mit der linvdr0.8 wegen locale


    Gibt'S die v0.8 schon?


    Zitat

    Aber gibt es eine Lössung dafür ???
    /usr/bin/vdradmind.pl
    "bind_textdomain_codeset" is not exported by the Locale::gettext module at /usr/bin/vdradmind.pl line 53
    Not using bind_textdomain_codeset(). Please update your Locale::gettext perl module!
    vdradmind.pl 3.4.6 wurde mit der ProzeýID 1883 gestartet.


    Gruss Patrice


    Wie die Meldung schreibt: Locale::gettext aktualisieren, aber das geht mit einem Standard-LinVDR 0.7 nicht. Die Meldung kannst Du aber ignorieren, wenn Du keine Probleme mit Umlauten/Sonderzeichen hast.


    Gruß,
    Andreas

  • Hallo,


    bei mir war auch auf einmal alles in Englisch, obwohl ich nichts am VDR gemacht habe. Dank der Suche habe ich das hier gefunden :)


    Zitat

    Bingo Bongo - Das wars ==> einfach folgenden Code eingeben und dann klappt's auch in Deutsch....


    ln -s /usr/share/vdradmin/locale/de/LC_MESSAGES/vdradmin.mo /usr/lib/locale/de/LC_MESSAGES/vdradmin.mo
    ln -s /usr/share/vdradmin/locale/de/LC_MESSAGES/vdradmin.mo /usr/share/locale/de/LC_MESSAGES/vdradmin.mo
    vdradmind.pl -k
    vdradmind.pl start


    Super, Danke

    Mein VDR = ASUS M4N78-AM, AMD Sempron 140 AM3 2.70GHz, 160 GB HDD, GraKa Gainward 210, 2x TechnoTrend TT Budget S2-1600, Ausgabe über Philips 42"