Lautsprecher-PINs für LED-Ansteuerung?

  • Hallo,
    ich suche nach einer extrem einfachen Möglichkeit, eine Gehäuse-LED via Rechner (Epia ME6000) anzusteuern. Serielle oder parallele Schnittstellen wollte ich dafür nicht "opfern". Ich dachte, es müßte doch auch gehen, den Lautsprecheranschluß dafür zu mißbrauchen. Im Wohnzimmer ist das Piepen ohnehin nicht wirklich gewünscht (jedenfalls bei mir). Leider habe ich keine Info, was man da beachten müßte. Erste Messungen des Lautsprecherausgangs bei aktivem "beep" waren extrem erfolglos (mein Multimeter zeigte nichts (!), hat aber ohnehin auf den letzten Digits ein gewisses Rauschen drauf).
    \EDIT:
    Lautsprecheranschluß bezieht sich auf die Front-Pin-Leiste auf dem Mainboard und nicht auf AC97-Ausgang :)
    /EDIT
    Weiß jemand Rat?


    Grüße
    kenwood_vdr


    Wohnzimmer-System: Psile-Gehäuse, yaVDR 0.2, Zotac GeForce 9300 ITX, Intel Pentium E5300, 4GB Ram, Mystique SaTiX-S2 V2 CI Dual
    Früherer Wohnzimmer-Rechner: Kenwood-CD Player (entkernt), mit EPIA ME6000, TT 1.5, Samsung 160 GB, 256 MB RAM , DVD Toshiba SD 1602, AV-Board 1.3, LinVDR 0.7, 1 Papst-Lüfter, trotzdem schön leise :)
     

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von kenwood_vdr ()

  • das multimeter stand vermutlich auf gleichspannung und hat deshalb nichts angezeigt.
    ohne das ich selber schonmal nachgemessen habe denke ich das der pegel für eine led sowieso nicht ausreichen wird weswegen eine passive schaltung nicht funktionieren würde.
    du müßtest eine einfach transistorstufe,bestehend aus zwei widerständen und einem transistor drannschalten welcher dann die led ansteuert.
    als versorgungsspannung kannst du 5v oder 12v irgendwo am board abgreifen.

  • Eine LED (rot, grün und gelb) bracht ca. 2Volt Gleichspannung und 10mA Strom (blaue LED 3 bis 4Volt).


    Am Laustsprecheranschluss kommt Wechselspannung raus.
    Sehr wenig wechselspannung!
    Kanns ja mal einen Brückengleichrichter bauen und eine LED anschliesen, wird aber wohl nicht funktionieren.

    easyVDR-2.5, VDR 2.2.0, Kernel 3.16


    VDR1: FSC Esprimo P710, NVIDIA GeForce 605, 2x Technisat Skystar S2, PollinX10, 128GB SSD, 3x2TB HDD
    VDR2: Lenovo M55p, DVB-S FF TT S-2300
    VDR3: FSC Esprimo E5730, NVIDIA GeForce 605, Technisat Skystar S2
    VDR4: FSC Esprimo P5915, NVIDIA GeForce 605, Technisat Skystar S2
    VDR5: HP-RP 5700, DVB-S FF TT S-2300 Stremdev-Client mit deaktiviertem Tuner !!!
    testVDR: FSC Esprimo P710, NVIDIA GeForce 605, Technisat Skystar S2 o. Technotrend FF DVB-S rev1.3 o. TBS 6981

  • Hallo,
    danke für die Hinweise. Ich habe das Multimeter natürlich auf Wechselspannnung gesetzt und die Frequenz bei "beep" auf 50 Hz.
    Dennoch kam da nix an. Eine kleine Schaltung mit Transistor sollte ja nicht das Problem sein. Mich wundert nur, daß das SO WENIG rauskommt - und der Lautsprecher doch recht markant piept.
    Grüße
    kenwood_vdr


    Wohnzimmer-System: Psile-Gehäuse, yaVDR 0.2, Zotac GeForce 9300 ITX, Intel Pentium E5300, 4GB Ram, Mystique SaTiX-S2 V2 CI Dual
    Früherer Wohnzimmer-Rechner: Kenwood-CD Player (entkernt), mit EPIA ME6000, TT 1.5, Samsung 160 GB, 256 MB RAM , DVD Toshiba SD 1602, AV-Board 1.3, LinVDR 0.7, 1 Papst-Lüfter, trotzdem schön leise :)
     

  • Hallo,
    ja, es war ein Digitalmultimeter. Ich werde das heute mal mal neu probieren (mit dem Widerstand bzw. mit einer kleinen sympathischen Transistorschaltung. Das müßte doch zu schaffen sein. Ich habe das Problem mal vor Wochen festgestellt und mir heute mal einen Ruck gegeben, es öffentlich zu machen.
    Grüße
    kenwood_vdr


    Wohnzimmer-System: Psile-Gehäuse, yaVDR 0.2, Zotac GeForce 9300 ITX, Intel Pentium E5300, 4GB Ram, Mystique SaTiX-S2 V2 CI Dual
    Früherer Wohnzimmer-Rechner: Kenwood-CD Player (entkernt), mit EPIA ME6000, TT 1.5, Samsung 160 GB, 256 MB RAM , DVD Toshiba SD 1602, AV-Board 1.3, LinVDR 0.7, 1 Papst-Lüfter, trotzdem schön leise :)
     

  • Danke SledgE,
    so in etwa hatte ich mir das jetzt auch gedacht :)
    Grüße
    kenwood_vdr


    Wohnzimmer-System: Psile-Gehäuse, yaVDR 0.2, Zotac GeForce 9300 ITX, Intel Pentium E5300, 4GB Ram, Mystique SaTiX-S2 V2 CI Dual
    Früherer Wohnzimmer-Rechner: Kenwood-CD Player (entkernt), mit EPIA ME6000, TT 1.5, Samsung 160 GB, 256 MB RAM , DVD Toshiba SD 1602, AV-Board 1.3, LinVDR 0.7, 1 Papst-Lüfter, trotzdem schön leise :)
     

  • Na wenns denn schon sowas sein muss, dann spendier wenigstens noch ne Diode und nen Kondensator an der Basis, damit du das Flimmern wegintegrierst..

  • Hallo,
    ich bin gerade an der selben Sache. Der Lautsprecheranschluss des Mainboards ist eine oft unterschätzte Schnittstelle.


    Ich habe die Anschlüsse von 2 Mainboards dazu gemessen jeweils mit einen konstanten Ton von 1000Hz. Es liegt keine echte Wechselspannung an, weil die Spannung nie unter 0 geht. Der Spannungswert liegt bei ca. 2Volt eben mit 1khz getaktet, was eine für eine LED ausreichend glatten Versorgungsspannung ist. Zur Sicherheit sollte man eine Vorwiderstand benutzen.


    Zu Testzwecken habe eine grüne LED allerdings direkt angeschlossen: Keine Probleme.


    Dann habe ich einige Änderungen am Record-Script ( Parameter -r bei vdr) gemacht um den Aufnahmestatus zu auszugeben. Ein kleins externes Programm wertet das aus und gibt entweder einen Dauer- oder ein Intervallsignal. D.h. bei Aufnahmen blinkt die LED.


    FRAGE: Mit welchem Befehl oder Programm kann ich einen Dauerton ausgeben?

  • Ja, mit dem keyboard controler geht das sehr gut. Und dann noch das statusled plugin und ich war fast glücklich.


    Leider steurt das stautsled nur eine (ausfnahmeLED) über z.b. den blinkd. Man hat also noch 2 LEDs frei. Und blinken geht auch ganz easy mit "blink".


    Aber was ich nicht geschafft habe ist einfach "an". Idee dahinter: VDR im Keller und TV aus. Dann könnte man sehen ob der an ist oder nicht.


    ich hatte mal was sehen, aber jetzt ist das vergraben.


    V_R

    VDR1: POV ION 330 mit Media-Pointer MP-S2 auf yaVDR 0.3.1 - enermay 370 Watt - 80GB SSD + 500GB HD - CoolerMaster ATX-620 - VGA2Scart + HDMI
    VDR2: Zotak ZBOX ID40 auf yaVDR unstable - Sundtek DVB-S2 + remote Sundtek - 60GB SSD - HDMI
    VDR3
    : Zotak ZBOX ID40 auf yaVDR unstable - remote Sundtek - 500GB HD - DVI
    Atom 2700 mit 13W, Ubuntu PP, 60GB SDD + 240GB SSD, 2x Sundtek DVB-S2

  • Hallo,


    das mit dem beeper könnte ich eigentlich mal in das serled PLugin einbauen. Da hab ich die Möglichkeit andere LED-Ansteuerungen einzubauen schon vorgesehen.


    Vielleicht schaff ich das nächstes Wochenende. Das beep-Programm sieht ja nicht so kompliziert aus.


    Viele Grüße


    Euer frausch

  • Hallo,
    schön, daß es noch mehr Leute interessiert. Ich bin leider noch nicht dazu gekommen, den guten Vorsätze auch Taten folgen zu lassen. Der Hinweis mit den 2V ist sehr hilfreich, meine Sorge war, daß der Wert womöglich unter 0,6-0,7V liegt (damit wäre die LED/Transistoransteuerung aufwendiger).
    Nebenbei: das statusled-plugin läßt sich auch so umprokeln, daß es alle drei LED's nutzt (, die dann konstant leuchten, wenn eine, zwei oder drei Aufnahmen laufen- hab ich mal gemacht), der notwendige Code ist ja in der Plugin source enthalten :)
    Daher habe kann ich allerdings die Keyboard-LED's nicht mehr nutzen (sind sozusagen auch schon "belegt"), langsam wird's eng..
    Grüße
    kenwood_vdr


    Wohnzimmer-System: Psile-Gehäuse, yaVDR 0.2, Zotac GeForce 9300 ITX, Intel Pentium E5300, 4GB Ram, Mystique SaTiX-S2 V2 CI Dual
    Früherer Wohnzimmer-Rechner: Kenwood-CD Player (entkernt), mit EPIA ME6000, TT 1.5, Samsung 160 GB, 256 MB RAM , DVD Toshiba SD 1602, AV-Board 1.3, LinVDR 0.7, 1 Papst-Lüfter, trotzdem schön leise :)
     

  • Hi k_vdr,


    aj, die Idee ist so naheliegens, dass ich noch nicht drauf gekommen bin. Die sourcen des Plugins....! KLAR!


    Danke, ich werde mir das mal ansehen. Jetzt brauche ich noch schöne aber preiswerte Taster. Diese Vadalismus-Teile bei Reichelt sehen nett aus, abe rzu dem Preis. Und die bekannten Farben müssen ja auch noch her.


    V_R

    VDR1: POV ION 330 mit Media-Pointer MP-S2 auf yaVDR 0.3.1 - enermay 370 Watt - 80GB SSD + 500GB HD - CoolerMaster ATX-620 - VGA2Scart + HDMI
    VDR2: Zotak ZBOX ID40 auf yaVDR unstable - Sundtek DVB-S2 + remote Sundtek - 60GB SSD - HDMI
    VDR3
    : Zotak ZBOX ID40 auf yaVDR unstable - remote Sundtek - 500GB HD - DVI
    Atom 2700 mit 13W, Ubuntu PP, 60GB SDD + 240GB SSD, 2x Sundtek DVB-S2

  • ich habe es doch noch gefunden.


    z.b. setleds -L +num < /dev/console


    wie passend der Befehl doch ist. ;-)


    V_R

    VDR1: POV ION 330 mit Media-Pointer MP-S2 auf yaVDR 0.3.1 - enermay 370 Watt - 80GB SSD + 500GB HD - CoolerMaster ATX-620 - VGA2Scart + HDMI
    VDR2: Zotak ZBOX ID40 auf yaVDR unstable - Sundtek DVB-S2 + remote Sundtek - 60GB SSD - HDMI
    VDR3
    : Zotak ZBOX ID40 auf yaVDR unstable - remote Sundtek - 500GB HD - DVI
    Atom 2700 mit 13W, Ubuntu PP, 60GB SDD + 240GB SSD, 2x Sundtek DVB-S2

  • Hallo!


    Mich würde interessieren, ob mittlerweile jemand erfolgreich eine LED am Beeper-Anschluss nutzt?


    Da ich auf der Suche bin, nur eine LED als Record LED anzuschließen, erscheint mir diese Methode am unkompliziertesten und wenigsten verschwenderisch...

    VDR auf Basis eines Siemens D1215 mit Celeron 700 Mhz passiv gekühlt, Artec Passiv-Netzteil aus Scenic-S, Noiseblocker S1 Gehäuselüfter, 512 MB SDRAM, 160 GB Seagate-HDD (ST3160022ACE), DVB-S 1.3 (Fujitsu-Siemens).
    LinVDR (Mahlzeit-Iso 0.4), Kernel 2.6.20.1.

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von nosi ()

  • Zitat

    Originally posted by nosi
    Mich würde interessieren, ob mittlerweile jemand erfolgreich eine LED am Beeper-Anschluss nutzt?


    Da ich auf der Suche bin, nur eine LED als Record LED anzuschließen, erscheint mir diese Methode am unkompliziertesten und wenigsten verschwenderisch...


    Das würde mich auch interessieren, daher hier mal der Versuch Rückmeldungen zu erhalten, auch wenn das Thema jetzt zwei Jahre her ist.


    Das serled-Plugin scheint ja jetzt entsprechende Unterstützung für den Speaker-Anschluss zu enthalten.