[ANNOUNCE] linvdr-dxr3.deb -> dxr3-System in 15min

  • Hallo zusammen,


    ich habe ein deb-Installations Paket für die dxr3 und linvdr erstellt. Die Installation des Pakets ist dank Menüführung sehr einfach geraten.


    Vorteile des Pakets

    • Es muss keine einzige Datei manuell bearbeitet oder erstellt werden. Darum kümmert sich das Paket.
    • Die dxr3-Modulparameter können während der Installation mit dxr3config erstellt werden. Alternativ kann aber auch eine bestehende dxr3-Konfiguration übernommen werden.
    • Die Installation ist vollständig Menü geführt (ähnlich Linvdr-setup, nur ein wenig schlichter ;) )
    • AC3 funktioniert (ab VDR Version 1.3.37)
    • Das Paket unterstützt mehrere VDR-Versionen und Kernel (s.u.)
    • Das Paket enthält einen an die dxr3 angepassten mplayer. Dieser kann optional installiert werden. Er wird dann automatisch konfiguriert.
    • Das Paket enthält das externalplayer-plugin. (Nur VDR 1.3.37)
    • Das Paket installiert nur die Dateien, die für die vorhandene VDR-Version notwendig sind.
    • Alte Konfigurationsdateien werden als *.before.dxr3 gesichert !


    Im Paket enthaltenen Versionen:


    dxr3-Plugin:

    • VDR 1.3.17: 0.2.4
    • VDR 1.3.37: 0.2.4 mit AC3
    • VDR 1.3.47: 0.2.6 cvs mit AC3
    • VDR 1.4.0-x: 0.2.6-final mit AC3


    dxr3-Kernel-Module:

    • Kernel-UpdateCD (2.6.15.1): 0.15.3
    • Linvdr0.7-Kernel (2.6.9): ???? (Dr.Seltsam ;( Welche Version ist das??)


    Die Plugins und Kernel-Module stammen von Dr.Seltsam. Und das ist gut so. :]


    Unterstützte VDR-Versionen

    • 1.3.17, 1.3.37, 1.3.44, 1.3.47
      und seit dem 1.05.06 auch:
    • 1.4.0, 1.4.0-1 und 1.4.0-2
    • Das Paket funktioniert auch mit Toxic-Tonics VDR-Updates


    Unterstützte Kernel

    • Kernel-UpdateCD von Cooper (Kernel 2.6.15.1)
    • Original Linvdr0.7 Kernel (Kernel 2.6.9)
    • alle Kernel, die em8300 Module beinhalten, also insbesondere die Dr.Seltsam Kernel

    Hintergrund Infos:
    Das Paket enthält eine runvdr die nur dann die dxr3-Module lädt und entlädt, wenn das dxr3-plugin aktiviert ist. D.h. wenn man auf eine FF-Karte umsteigt muss man die runvdr nicht ändern. Die geänderte runvdr wird allerdings nur dann installiert, wenn man keine vorhandene dxr3-Konfiguration übernimmt.


    Download
    http://free.pages.at/wicky4vdr/
    Das aktuelle Paket ist übergangsweise auch hier erreichbar:
    https://luphi.dyndns.org/public/vdr/linvdr-dxr3v8.deb
    Danke an luphi :] für den WebSpace.


    Installationsanleitung
    [HOWTO] dxr3 - Installation in 15min


    Gruß
    Wicky

  • Klingt Hübsch! Möchtest du das DXR3 für den 1.3.47 auch haben? Habe ich schon fertig!


    Gruß


    Toxic

    Registrierter VDR-User #1275


    VDR-Server: Proxmox 7.1 - LXC Container - Debian 11.5 - eTobi-VDR 2.6.0

    DVB-Hardware: Digital Devices - Cine S2 V5.5 und V6

    VDR-Clients: FireTV Sticks 2 bis 4K Max und Kodi 19.4

  • Quote

    Original von Wicky
    P.S. @Dr.Seltsam und Toxic-Tonic: Habt ihr AC3 getestet. Ohne AC3 bringe ich nichts raus.


    ich habe wie gewohnt den ac3-patch (der gleiche wie in 1.3.44) sowie eine Optimierung für das imageplugin reingepatcht. Das Plugin ist die 0.2.6-CVS-Version von heute. Selbst getestet habe ich ac3 nicht, sollte aber nicht besser oder schlechter als bei 1.3.44 laufen

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

    Edited once, last by Dr. Seltsam ().

  • Quote

    Original von Dr. Seltsam
    ich habe wie gewohnt den ac3-patch (der gleiche wie in 1.3.44) sowie eine Optimierung für das imageplugin reingepatcht. Das Plugin ist die 0.2.6-CVS-Version von heute. Selbst getestet habe ich ac3 nicht, sollte aber nicht besser oder schlechter als bei 1.3.44 laufen

    Das höhrt sich gut an. Dann werde ich es jetzt schnell noch integrieren und dann auch gleich online stellen.


    Gruß
    Wicky

  • Doc


    Wo hast du denn die optimierung für Image gefunden?


    Gruß


    Toxic

    Registrierter VDR-User #1275


    VDR-Server: Proxmox 7.1 - LXC Container - Debian 11.5 - eTobi-VDR 2.6.0

    DVB-Hardware: Digital Devices - Cine S2 V5.5 und V6

    VDR-Clients: FireTV Sticks 2 bis 4K Max und Kodi 19.4

  • Quote

    Original von Toxic-Tonic
    Doc


    Wo hast du denn die optimierung für Image gefunden?


    ich mache immer noch das hier, was mal in der ML stand:



    Es ist nicht offiziell eingeflossen, weil es den Entwicklern gegen den Strich geht (sie sehen das Problem beim imageplugin)

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Ach so! Das habe ich auch drin! Hat sich am CVS in den letzten zwei Wochen was verändret? Habe immernoch die 1.3.44-Version compiliert!


    Gruß


    Toxic

    Registrierter VDR-User #1275


    VDR-Server: Proxmox 7.1 - LXC Container - Debian 11.5 - eTobi-VDR 2.6.0

    DVB-Hardware: Digital Devices - Cine S2 V5.5 und V6

    VDR-Clients: FireTV Sticks 2 bis 4K Max und Kodi 19.4

  • Hi,


    wollte meine alte DXR3 mal wieder testen. Verwende linvdr-cody-1.3.44. Das setup funktioniert und die Karte wird richtig erkannt, das Bild ist korrekt. Mit dem MPlayer kann ich Videos korrekt über die DXR3 abspielen. Allerdings beim Start des VDR bleibt der Monitor schwarz und das Bild kommt nur über die DVB-Karte. Da dachte ich mir, bestimmt ist die DVB Karte das primäre Device. Allerdings wenn ich versuche dies zu ändern (d.h. im Setup-Menu auf DVB-Einstellungen gehe) stürzt jetzt der VDR immer ab (und respaned dann). Jemand eine Idee, wo das Problem seien könnte?

  • Quote

    Original von Mr.Lugosi
    beim Start des VDR bleibt der Monitor schwarz und das Bild kommt nur über die DVB-Karte. Da dachte ich mir, bestimmt ist die DVB Karte das primäre Device. Allerdings wenn ich versuche dies zu ändern (d.h. im Setup-Menu auf DVB-Einstellungen gehe) stürzt jetzt der VDR immer ab (und respaned dann). Jemand eine Idee, wo das Problem seien könnte?


    am Monitor kann die dxr3 kein BIld ausgeben. Deaktiviere im setup bitte die Bildausgabe über den Monitor (das geht nur mit FF-karten). Notfalls ändere das primary device in der /etc/vdr/setup.conf manuell (vorher vdr mit /etc/init.d/runvdr stop beenden)

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Mr.Lugosi,


    ich vermute mal du meinst nicht Monitor sondern TV. (Falls du jedoch wirklich Monitor meinen solltest, dann schau was Dr. Seltsam geschrieben hat)


    Mach mal folgendes:
    1. VDR beenden mit /etc/init.d/runvdr stop
    2. mcedit /etv/vdr/setup.conf
    3. In der setup.conf findest du den Parameter PrimaryDVB. Setze ihn mal auf 2.
    (In der setup.conf gibt es noch den Parameter PrimaryLimit. Was er bedeutet weiß ich nicht, aber vielleicht ist er relevant)
    4. vdr neu starten mit /etc/init.d/runvdr start


    Falls es zu Fehlern kommt, dann poste mal das log (logread)


    Eine Frage: Mir ist nicht ganz klar geworden, ob du das Paket von mir verwendest. Meinst du mit setup die Installation des Pakets und dort im speziellen dxr3config?


    Gruß
    Wicky

  • Hi Wicky,


    sag mal, welche Version des Externalplayer-Plugins ist denn in dem Paket enthalten?


    Joachim

    Registrieter VDR User Nr. 1237


  • Danke, es lag am OSD :O mit einem kleineren war das gleich kein Problem :)


    Leider ist der Ton noch etwas (teilweise arg) leise und bei einigen Aufnahmen komisch krächtzend. Zumindest über SP/DIF analog habe ich noch nicht getestet.

  • Quote

    Original von Mr.Lugosi
    Danke, es lag am OSD :O mit einem kleineren war das gleich kein Problem :)


    Leider ist der Ton noch etwas (teilweise arg) leise und bei einigen Aufnahmen komisch krächtzend. Zumindest über SP/DIF analog habe ich noch nicht getestet.


    Na dann dreh den Ton des VDR doch lauter !! Nicht am Reciver sondern den Ton des VDR. Der digital-Ton ist bei mir hervoragend. Ist dein Digital-Kabel vielleicht nicht OK?


    Gruß
    Wicky

  • Quote

    Original von joachim-h
    Hi Wicky,


    sag mal, welche Version des Externalplayer-Plugins ist denn in dem Paket enthalten?


    Joachim


    ich antworte mal für Wicky :)


    es sind nur für vdr 1.3.17 und 1.3.37 die Plugins im Paket, da externalplayer bei 1.3.17 noch ganz fehlte und bei 1.3.37 passend zum gepachten vdr neu kompiliert werden musste. Für aktuellere vdr-Versionen könnt Ihr das Plugin aus dem Cody-Paket nehmen. Es dürfte immer noch die erste Version sein, weil die neuere ja bekanntlich mit gcc 2.95 nicht kompiliert.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • ... das könnte ich zum Anlass nehmen die 1.3.47er Version in mein Paket aufzunehmen. Aber ehrlich gesagt weiß ich nicht wozu, denn das DVD-Plugin funktioniert und wer freevo oder xmms via externalplayer starten will, der richtet den externalplayer im Fluge ein.


    Gruß
    Wicky

  • Hallo zusammen,


    ich habe Probleme bei der Installation.
    Nachdem ich Linvdr 0.7, dann MT, dann cody 1.3.47 eingespielt habe, passiert das hier:

    Code
    linvdr:/ramdisk/ext/pub# debtool -f linvdr-dxr3v6.deb
    cp: unable to open `/lib/modules/2.6.15.1/em8300/adv717x.ko': No such file or directory
    cp: unable to open `/lib/modules/2.6.15.1/em8300/bt865.ko': No such file or directory
    cp: unable to open `/lib/modules/2.6.15.1/em8300/em8300.ko': No such file or directory
    cp: unable to open `/lib/modules/2.6.9/em8300/adv717x.ko': No such file or directory
    cp: unable to open `/lib/modules/2.6.9/em8300/bt865.ko': No such file or directory
    cp: unable to open `/lib/modules/2.6.9/em8300/em8300.ko': No such file or directory


    Ich bekomme auch kein Testbild. An der Hardware kann es nicht liegen. Die alte Dr.Seltsam-Version funktioniert.


    Ratlos,
    Uwe

    Test-VDR: Asrock J4205 (Intel-Grafik), 4GB RAM, 30GB SSD, Cine S2 PCIe twin tuner + DuoFlex an Durline UK119 SCR LNB

    Edited once, last by videopix ().

  • videopix


    Die Fehlermeldung deutet auf nicht vorhandene Dateien hin. Sie ist mir momentan völlig unklar, denn


    a) ich habe das Paket getestet und bei mir lief alles glatt durch. Sprich alle Dateien sind vorhanden.
    b) Die Zeilen mit denen das Paket die Module kopiert sehen so aus:

    Code
    cp -f $tmpDir/modules/2.6.15.1/* /lib/modules/2.6.15.1/em8300/
    cp -f $tmpDir/modules/2.6.9/* /lib/modules/2.6.9/em8300/

    $tmpDir ist dabei durch /dxr3_deb_tmp zu ersetzen. In dieses temporäre Verzeichnis werden viele Dateien kopiert, u.a. auch die Module. Nach der Installation wird das Verzeichnis dann wieder gelöscht. Ich hab auch noch mal nachgeschaut ob die Module an der richtigen Stelle im Paket stehen. Sie stehen an der richtigen Stelle. Ich muss mir das Morgen noch mal in Ruhe anschauen. Denn ich kann es jetzt nicht recht verstehen.


    Nachtrag: Die Fehlermeldung ist mir jetzt klar geworden, bei dir existieren die Verzeichnisse /lib/modules/xxx/em8300/ nicht, da du nicht die KernelUpdateCD benutzt. Dann wirst du allerdings auch nicht in den Genuss der 0.15.3er Kernel-Module kommen. Aber nichts desto Trotz, es handelt sich um einen Bug. Ich werde ihn so bald wie möglich fixen.


    Nachtrag2: Falls du nicht warten möchtest, bis das bugfix online ist, kannst du auch einfach die Verzeichnisse
    /lib/modules/2.6.15.1/em8300/
    /lib/modules/2.6.9/em8300/
    anlegen. Dann sollte es funktionieren. Aber nochmals die 0.15.3er Module sind nur für den KernelUpdateCD-Kernel enthalten !!!


    Bis dann
    Wicky

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!