AMD Geode 1750 NX und Alternativen

  • Da in den anderen AMD Geode Threads bisher das PC-Chips Board M811und dessen Möglichkeiten im Vordergrund stand, geht es in diesem Thread um alternative Boardvarianten mit dem AMD Geode NX.


    Hier möchte ich mal eine solche Variante vorstellen.


    Mein VDR1 brauchte eine Verjüngungskur (dem bisherigen Motherboard K7VZA fehlte bsw. UDMA 133 und USB2.0) . Darum entschloss ich mich zu einem Motherboard Wechsel . Weiterhin wollte ich den bisherigen CPU Lüfter einsparen und auch das NT auf passiv umstellen (Vicor VI-261). Um dies realisieren zu können, habe ich mich nach weiteren Alternativen zu den Stromsparmöglichkeiten mit dem Prozessor AMD Geode 1750 NX umgesehen.
    Hierzu habe ich ein Motherboard von ASUS A7V333 getestet. Auf diesem läßt sich die Vcore bis 1,125Volt manuell einstellen. Weiterhin bietet es die Möglichkeit, FSB und Multiplikator in weiten Grenzen zu wählen.
    Im BIOS habe ich Vcore auf 1,125Volt eingestellt und FSB 133Mhz x 7,5 verwendet (MoBo Hardware Rev. 2.0, BIOS Rev 1018-Beta).


    Als Konfiguration (für diesen Testaufbau) dient ein Laptop NT + Board Wandler PW70, Speicher 256MB DDR, Grafikkarte PCI Elsa Gladiac 311 und zum booten des Linux Kanotix 03/05 ein DVD LW DSL 710A sowie eine PS/2 Tastatur. Der Kühlkörper auf der CPU hat die Abmaße 80x60x40 mm.


    Im BIOS ergab sich mit dieser Konfiguration ein Stromverbrauch von 32,7 Watt an 1,15Volt Vcore.


    Nach dem booten des BS betrug der Stromverbrauch im Idle Modus (Stpgnt, HLT enable) 26,9 Watt. Die CPU wird im Freiluftbetrieb/Idle (passiv) 32-34°C warm, unter Vollast erreicht sie ca. 50°C. Im VDR wird der Kühlkörper dann über einen Air Tunnel vom zentralen Gehäuselüfter mitgekühlt.


    Gruß Fr@nk



    .
    .
    .

  • bei den händlern wird nen Board namens "Tyan Tomcat K7M 2498AGNN" empfohlen


    allerdings nur 2 pci, dafür aber GB-Lan und graka onboard

    Dirk

    21.jpg

  • Das A7V133 hatte ich auch mal mit dem Geode getestet. Da der Verbrauch aber 10W höher
    als mit dem M811 war, hatte ich es wieder aussortiert. Die Board Revision ist allerdings 1.01.
    Vielleicht hängt es damit zusammen... Ansonsten sind Deine Werte ja sehr ermutigend.


    Hast Du schonmal PowerNow! mit Deiner Kombination getestet?

  • Zitat

    Original von kilroy
    Hast Du schonmal PowerNow! mit Deiner Kombination getestet?


    das habe ich auch noch vor. Bis jetzt habe ich aber alle Tests mit der Kanotix Live CD gemacht, da die negativen Tests mit dem KT133 Chipsatz vom A7V133 mir schon eine HDD Installation auf Grund von Datenverlusten gekostet haben. Morgen werde ich das Board nochmal intensiv mit der Live CD testen und dann eine HDD ranhängen. Dann kann ich auch einen Kernel patchen und mal sehen was powernow so anstellt.


    Gruß Fr@nk

  • So, die Tests mit dem A7V333 sind bis jetzt zufriedenstellend gelaufen. HDD Install und div. Burn-ins sind ohne Ausfälle durchgelaufen. Ich habe mir jetzt mal das powernow (msr) modul gebastelt und getestet. Doch kann ich damit nicht so viel anfangen.


    Mar 27 17:59:16 test kernel: powernow: PowerNOW! Technology present. Can scale: frequency and voltage.
    Mar 27 17:59:16 test kernel: Detected 1001.310 MHz processor.
    Mar 27 17:59:16 test kernel: powernow: No PST tables match this cpuid (0x781)
    Mar 27 17:59:16 test kernel: powernow: This is indicative of a broken BIOS.
    Mar 27 17:59:16 test kernel: powernow: Trying ACPI perflib
    Mar 27 17:59:16 test kernel: powernow: ACPI perflib can not be used in this platform
    Mar 27 17:59:16 test kernel: powernow: ACPI and legacy methods failed
    Mar 27 17:59:16 test kernel: powernow: See http://www.codemonkey.org.uk/p…cpufreq/powernow-k7.shtml
    Mar 27 17:59:16 test kernel: powernow: Building frequency table from MSR info.
    Mar 27 17:59:16 test kernel: powernow: Minimum speed 1001 MHz. Maximum speed 1401 MHz.


    Das bedeutet, daß das Board im idle mit 1000Mhz weiterläuft und bei Last auf 1400Mhz geht. Dies tut es dann auch (nBench) und konsumiert dann 12 Watt mehr (insgesamt 39 Watt) . Das wäre ja noch nicht so schlimm, aber 1400Mhz bei 1,15 Volt sind sicher nicht so prickelnd obwohl der nBench damit ca. 10min unter Vollast auch gelaufen ist. Das Problem ist vielmehr die dann doch größere Erwärmung der CPU die dann über 60°C steigt.


    Ich habe dann mal im BIOS den Multiplikator auf 5x gestellt.


    Mar 27 19:26:28 test kernel: powernow: PowerNOW! Technology present. Can scale: frequency and voltage.
    Mar 27 19:26:28 test kernel: Detected 667.616 MHz processor.
    Mar 27 19:26:28 test kernel: powernow: No PST tables match this cpuid (0x781)
    Mar 27 19:26:28 test kernel: powernow: This is indicative of a broken BIOS.
    Mar 27 19:26:28 test kernel: powernow: Trying ACPI perflib
    Mar 27 19:26:28 test kernel: powernow: ACPI perflib can not be used in this platform
    Mar 27 19:26:28 test kernel: powernow: ACPI and legacy methods failed
    Mar 27 19:26:28 test kernel: powernow: See http://www.codemonkey.org.uk/p…cpufreq/powernow-k7.shtml
    Mar 27 19:26:28 test kernel: powernow: Building frequency table from MSR info.
    Mar 27 19:26:28 test kernel: powernow: Minimum speed 667 MHz. Maximum speed 1401 MHz.



    das ist aber auch nicht das Wahre, denn nun bootet der Rechner ( da hier noch keine Freq Skalierung) gemütlich mit 667 Mhz und geht dann doch bei Vollast auf 1400Mhz.


    Kann man diese MSR Info beeinflussen, sodass bei 1000Mhz Schluss ist?


    Ansonsten bringt der Betrieb mit 66/Mhz nicht viel ( gerade mal ein halbes Watt). Das liegt aber bei mir daran, das ich schon STPGNT und HLT eingeschaltet habe und laut Datenblatt verbraucht die CPU im Modus STPGNT,HLT enable gerade mal 3 Watt. Da wird das Absenken des Taktes nicht mehr viel holen können.


    Gruß Fr@nk

  • Wie hast du die Vcore so niedrig bekommen? Ich habe ebenfalls das A7V333-X mit nem Geode in Betrieb und im BIOS kann ich minimal 1,425V einstellen, wenn ich den Wert manual setze. Ich habe BIOS-Version 1004 (die aktuellest Nicht-Beta-Version) Im Manual gibt es einen Hinweis auf einen Overvolt-Jumper, aber der setzt den einstellbaren Bereich auf 1,7V bis 2,05V, das will ich ja nun gerade nicht ;)

    :vdr2  HTPC Desktop EPR-G100, AMD Geode 1750, Asus A7V333, 512MB RAM, Samsung SP2514N, Philips PBDV1628, Hauppauge NEXUS-S 2.1 + NOVA-S, ctvdr4.5


    :vdr2 Asus Pundit silber, Celeron 1,7 GHz, 256MB RAM, ExcelStor Technology J8160, NEXUS-S 2.?, etch + e-tobi, Noiseblocker UltraSilentFan S2/S3, LCD 16x2 LED

  • Zitat

    Original von aro
    Wie hast du die Vcore so niedrig bekommen? Ich habe ebenfalls das A7V333-X mit nem Geode in Betrieb und im BIOS kann ich minimal 1,425V einstellen, wenn ich den Wert manual setze. Ich habe BIOS-Version 1004 (die aktuellest Nicht-Beta-Version) Im Manual gibt es einen Hinweis auf einen Overvolt-Jumper, aber der setzt den einstellbaren Bereich auf 1,7V bis 2,05V, das will ich ja nun gerade nicht ;)


    Ja, leider sind die UC Möglichkeiten meistens nicht dokumentiert. Also JEN von Jumper Free auf Jumper Mode und dann nur VID1 auf 2-3, alle anderen runter. Dann sollte im BIOS bei Vcore manual die Spannung im Bereich von 1,125V aufwärts einstellbar sein. Kann sein, das Du auch die BIOS Version noch ändern mußt, das war bei mir das erste, was ich getan hatte. Nachher werde ich noch ein paar Fotos von den Jumpern hier reinstellen.


    Gruß Fr@nk

  • Schade, mein Board (A7V333-X) hat diese Jumper nicht. Habe gerade nochmal das Manual vom A7V333 (ohne -X) geladen, das Layout ist ein ganz anderes. Definitiv keine VID oder JEN-Jumper ;(


    Danke für die Mühe!

    :vdr2  HTPC Desktop EPR-G100, AMD Geode 1750, Asus A7V333, 512MB RAM, Samsung SP2514N, Philips PBDV1628, Hauppauge NEXUS-S 2.1 + NOVA-S, ctvdr4.5


    :vdr2 Asus Pundit silber, Celeron 1,7 GHz, 256MB RAM, ExcelStor Technology J8160, NEXUS-S 2.?, etch + e-tobi, Noiseblocker UltraSilentFan S2/S3, LCD 16x2 LED

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von aro ()

  • hallo,



    ich habe mal noch ein wenig weiter gesucht und bin über die Anregungen dieser Seite (HIER) auf die Idee gekommen, die Frequenzen direkt in den Quellen festzulegen. Das habe ich dann so getan:


    Auszug powernow-k7.c



    Nun kann ich im BIOS 7,5x 133Mhz CPU Takt einstellen. Damit bootet der Rechner mit 1000Mhz... Powernow überschreibt diese Parameter


    Apr 8 15:34:43 test kernel: powernow: PowerNOW! Technology present. Can scale: frequency and voltage.
    Apr 8 15:34:43 test kernel: Detected 1001.310 MHz processor.
    Apr 8 15:34:43 test kernel: powernow: Minimum speed 666 MHz. Maximum speed 1266 MHz.




    test:/usr/sbin# ./powernowd -v
    powernowd: PowerNow Daemon v0.96, (c) 2003-2005 John Clemens
    powernowd: Settings:
    powernowd: verbosity: 1
    powernowd: mode: 1 (AGGRESSIVE)
    powernowd: step: 100 MHz (100000 kHz)
    powernowd: lowwater: 20 %
    powernowd: highwater: 80 %
    powernowd: poll interval: 1000 ms
    powernowd: Found 1 cpu: -- 1 thread (or core) per physical cpu
    powernowd: cpu0: 666Mhz - 1266Mhz (4 steps)
    powernowd: step1 : 1266Mhz
    powernowd: step2 : 933Mhz
    powernowd: step3 : 800Mhz
    powernowd: step4 : 666Mhz
    test:/usr/sbin#


    idled mit 666Mhz und im Vollastbetrieb arbeitet er mit 1266Mhz


    Gruß Fr@nk

  • Zitat

    Original von lola
    idled mit 666Mhz und im Vollastbetrieb arbeitet er mit 1266Mhz


    Hmm, das ganze ist also noch ausbaufähig. Sehr schön :) Muß ich mir in einer ruhigen Minute
    doch auch mal angucken.

  • Hi Lola, das sind ja Traumwerte auf deiner Messuhr. Hab hier zwar keinen Geode aber einen XP-M 2400+ der mit 800Mhz idelt und laut sensors mit 1,22V läuft. 1,22V deshalb weil er mit 1800Mhz bootet und dann auf 800 runtertaktet. Siehe auch Sig. Das was du im Bios an Vcore einstellst ist bei mir immer etwas höher mit sensors, bei dir auch?
    Trotz aller Bemühungen zeigt meine Messuhr von Reic....t immer um die 100W an. Natürlich habe ich einige Karten drin. Da wären Matrox G400 10W SBlive+Netzkarte ca.5W DVB-s FF und DVB-s Budget ca. 15W und ne Seagate 200GB ca. 10W macht zusammen um die 40W. Da Frage ich mit wo die restlichen 60W verbraten werden? Wenn ich mal 30W für MOBO und XP-M (800Mhz Idle) + RAM ansetze komme ich auch nur bis 70W. Sollte mein Netzteil wirklich so ein besch... Wirkungsgrad haben? Is´n das für ne Wandlerplatine bei dir genau?


    Elchi

    Asrock M3A785GHM/128, Athlon 64 240e, 2GB, 120 GB Samsung SSD plus 1000GB Nas im Raid und eine Nvidia Gt610 für VDPAU

    1x DD CineS2, UIR-Man, Androvdr, Ubuntu 14.04lTS, VDR: 2.2.0 (yavdr Quellen) und NVRAM Wakeup


     dabei seit Version 0.72 

  • Zitat

    Original von kilroy


    Hmm, das ganze ist also noch ausbaufähig. Sehr schön :) Muß ich mir in einer ruhigen Minute
    doch auch mal angucken.


    Und wenn das auch was für ungemoddete M811-Boards ist, bitte ich um Schnürung eines entsprechenden patches.

    LG
    fb


    VDR 1.4.3-3 (vdr-install-script-0.9.5.8 ), VDRAdmin-AM 3.5.2 unter Debian Sarge auf ASUS A8V Deluxe mit Athlon 3000+ (Venice), TT 1.5 + Skystar2

  • hallo Elchi,


    Zitat

    Original von Elchi
    Hi Lola, das sind ja Traumwerte auf deiner Messuhr. Das was du im Bios an Vcore einstellst ist bei mir immer etwas höher mit sensors, bei dir auch?


    Bei mir ist es umgekehrt also im BIOS auf 1,125V gestellt, dann zeigt Hardware Monitor und sensors 1,15 Volt an , also ca. 25 mV mehr. Ich habe auch festgestellt, das sensors ziemlich genau arbeitet, habe mal parallel die 12 Volt per Messgrät am 5,25" HDD Stecker mit sensors verglichen.


    Zitat


    Trotz aller Bemühungen zeigt meine Messuhr von Reic....t immer um die 100W an. Natürlich habe ich einige Karten drin. Da wären Matrox G400 10W SBlive+Netzkarte ca.5W DVB-s FF und DVB-s Budget ca. 15W und ne Seagate 200GB ca. 10W macht zusammen um die 40W. Da Frage ich mit wo die restlichen 60W verbraten werden? Wenn ich mal 30W für MOBO und XP-M (800Mhz Idle) + RAM ansetze komme ich auch nur bis 70W. Sollte mein Netzteil wirklich so ein besch... Wirkungsgrad haben?


    kann ich mir nicht so recht vorstellen. Zum Vergleich hatte ich mal ein None 200Watt NT dran, das hatte zu den obigen Werten 5 Watt mehr verbraucht.
    Allerdings idled das Board auch mit STPGNT und HLT, dort nimmt die CPU nur ca. 3 Watt.


    Zitat


    Is´n das für ne Wandlerplatine bei dir genau?
    Elchi


    auf dem obigen Bild hatte ich für die ersten Tests ein Laptop NT genommen ca. 80Watt bei 12 Volt und dazu einen Board Wandler PW70 (gibts bei mini-itx oder car-tft usw.) Momentan habe ich aber die Konfiguration zusammen welche in meinen VDR1 rein kommt (siehe Bilder unten). Dort wandle ich mit vicor 261 (siehe Thread HIER) auf 12 Volt und dann über ein PicoPSU -120Watt. PicoPSU hat einen Wirkungsgrad von ca. 94-96% , Vicor ca. 86-90% (je nach Last). Dies beides konnte die Stromaufnahme bei ansonsten gleichbleibenden Komponenten nochmals um ca. 1,5 Watt senken. Natürlich addieren sich dann noch meine weiteren Komponenten wie DVB, NIC, usw.



    Hier die Bilder:



    Aufbau mit Vicor 261 und PicoPSU:




    Vicor 261:




    PicoPSU-120:


  • Sieht gut aus.


    Zitat

    Allerdings idled das Board auch mit STPGNT und HLT, dort nimmt die CPU nur ca. 3 Watt.


    Woher nimmst du den Wert? STPGNT und HLT ? Ist es das was ahtcool auch macht?


    Elchi

    Asrock M3A785GHM/128, Athlon 64 240e, 2GB, 120 GB Samsung SSD plus 1000GB Nas im Raid und eine Nvidia Gt610 für VDPAU

    1x DD CineS2, UIR-Man, Androvdr, Ubuntu 14.04lTS, VDR: 2.2.0 (yavdr Quellen) und NVRAM Wakeup


     dabei seit Version 0.72 

  • Zitat

    Original von foobar42
    Und wenn das auch was für ungemoddete M811-Boards ist, bitte ich um Schnürung eines entsprechenden patches.


    Wollte ich mir eigentlich über Ostern mal angucken; aber nun hat $FAMILIE das "Fest" schon
    komplett verplant. 8o Aber ich bekomme nach Ostern noch neue M811 Boards 'rein, so daß
    ich hoffenltich dann etwas Zeit finde. Sollte es funktionieren, stelle ich die entsprechenden
    Patches natürlich gerne zur Verfügung. Vielleicht kann lola ja auch etwas passendes anbieten.

  • Zitat

    Original von kilroy
    Aber ich bekomme nach Ostern noch neue M811 Boards 'rein


    Plural? Versorgst du die ganze Sippe damit? ;)

    LG
    fb


    VDR 1.4.3-3 (vdr-install-script-0.9.5.8 ), VDRAdmin-AM 3.5.2 unter Debian Sarge auf ASUS A8V Deluxe mit Athlon 3000+ (Venice), TT 1.5 + Skystar2

  • Zitat

    Original von foobar42
    Plural? Versorgst du die ganze Sippe damit? ;)


    So ungefähr. ;) Das erste läuft jetzt im VDR. Zwei bekommen Freunde und eines benötige
    ich zum Testen.¹ Die Teile kosten ja nicht die Welt. Wenn nur die Geode etwas günstiger
    wären... 8)


    ¹ Der WAF geht leider schnell in den Keller, wenn ich andauernd den VDR aus der Anlage 
    rausreiße... :motz1


  • genau :)


    Zitat

    Original von kilroy
    Vielleicht kann lola ja auch etwas passendes anbieten.


    ich kann hier die modifizierte powernow-k7.c für 2.6.15.6 anhängen. Parameter braucht es dann keine mehr. Achso ohne Gewähr, keine Haftung für gegrillte Katzen etc ;) 
    Verfeinerung ausdrücklich erwünscht. So wie es im Original Patch zu sehen ist, kann wohl auch die Vcore beeinflusst werden, damit habe ich mich aber nicht weiter beschäftigt.


    Gruß Fr@nk