SOutCommand error?

  • Ich habe eine schwerzu findenen Fehler in meinem VDR System. Nach einiger Zeit (manchmal 2 Wochen, meistens 1-2 Tage) zeigt der TV nur noch pixelige Bilder. Das umschalten dauert dann relativ lange (ca 5 sekunden) und nach dem umschalten ist nur noch schwarz zu sehen.


    Im Log erscheint folgendes:


    kernel: OutCommand: timeout waiting for COMMAND idle
    kernel: SOutCommand error
    kernel: outcom error


    Und das widerholt sich dann ständig. Manchmal reicht ein neustarten des VDR, manchmal des PC und manchmal hilft nur ein paar Stunden warten.


    Ich hab erstmal auf einen Kabelfehler getippt und den Anschluss sauber neu gemacht, hat aber nicht geholfen. Das Problem bestehe jetzt schon über mehrere Treiber und VDR Versionen hinweg. Hat noch jemand eine Idee?


    Aktuelle VDR Version: 1.2.2
    DVB-Treiber: linuxtv-dvb-1.0.0
    Plugins: mp3, mplayer, streamdev und OSDTeletext

  • hallo!


    habe zwischendurch auch das genannte problem. leider habe ich bisher keine
    vernuenftige loesung gefunden.


    grueße,


    tobias

    DH67BLB3 m. Intel G630T
    2x Tevii S480 Dual DVB-S2
    GeForce 520
    yaVDR 0.4

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von KaptnKoma ()

  • Tscha,


    ich reihe mich in die Riege ein.


    Bei mir tritt das Problem ziemlich zügig auf, besonders bei Pro7.


    Habt Ihr mal in /var/log/messages geschaut?


    Ich bekomme da zwei EPG einträge die eventuell damit zusammen hängen:


    reading EPG data from /video/epg.data
    ERROR: illegal channel ID: S19.2E-1-0-898


    sowie


    =============
    EPG bugfix statustics
    =============
    IF SOMEBODY WHO IS IN CHARGE OF THE EPG DATA FOR ONE OF THE LISTED CHANNELS READS THIS: PLEASE TAKE A LOOK AT THE FUNCTION cEventInfo::FixEpgBugs() IN VDR/eit.c TO LEARN WHAT'S WRONG WITH YOUR DATA, AND FIX IT!
    =============
    Fix Hits Channels
    3 1136 SAT.1, N24, ProSieben, KABEL1
    6 497 N24
    =============


    BTW: Ich benutze Version 1.2.2.


    Bye
    John


    • VDR#1: CoolerMaster ATX-620, MR Fortron 350 Watt ichbinleise®, FSC 1562, Celeron 2GHz, 256 MB, HD400LD, silentmaxx HD-silencer, LG GSA-4160B, Nexus-S, IR rev.4 von hirc, One-For-All URC-7040, Debian Etch, vdr 1.6.0-8ctvdr1

    • VDR#2: passiv Gehäuse von Hewlett600, VIA MII-12000, 256 MB, HD400LD, TT 1.5, One-For-All URC-7040, Debian Etch, vdr 1.6.0-8ctvdr1

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von John Difool ()

  • john :


    Zitat

    reading EPG data from /video/epg.data
    ERROR: illegal channel ID: S19.2E-1-0-898


    Kann ich nicht bestätigen. Hab nix dergleichen im Log.


    Zitat


    =============
    EPG bugfix statustics
    =============


    Das habe ich allerdings, ist aber IMHO normal.



    Tja.. Ich habe leider immer noch nicht die leiseste Idee, woran das liegen könnte.. Habt ihr beide den die gleichen Plugins laufen wie ich?

  • Habe nach und nach alle plugins deaktiviert.


    Habe jetzt nur vdr ohne plugins am laufen.


    Das scheint's also nicht zu sein.


    Habe auch keine Patches installiert....


    Lässt du vdr als root oder als vdr user laufen? Ich probiers als vdr laufen zu lassen, vielleicht kommt's daher?


    Bye
    John


    • VDR#1: CoolerMaster ATX-620, MR Fortron 350 Watt ichbinleise®, FSC 1562, Celeron 2GHz, 256 MB, HD400LD, silentmaxx HD-silencer, LG GSA-4160B, Nexus-S, IR rev.4 von hirc, One-For-All URC-7040, Debian Etch, vdr 1.6.0-8ctvdr1

    • VDR#2: passiv Gehäuse von Hewlett600, VIA MII-12000, 256 MB, HD400LD, TT 1.5, One-For-All URC-7040, Debian Etch, vdr 1.6.0-8ctvdr1

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von John Difool ()

  • Der Thread http://www.vdr-portal.de/board/thread.php?threadid=4603&boardid=4&sid= hört sich ähnlich an. Hab da mal nachgefragt ob die SOutCommand errors da auch auftreten.


    Bye
    John


    • VDR#1: CoolerMaster ATX-620, MR Fortron 350 Watt ichbinleise®, FSC 1562, Celeron 2GHz, 256 MB, HD400LD, silentmaxx HD-silencer, LG GSA-4160B, Nexus-S, IR rev.4 von hirc, One-For-All URC-7040, Debian Etch, vdr 1.6.0-8ctvdr1

    • VDR#2: passiv Gehäuse von Hewlett600, VIA MII-12000, 256 MB, HD400LD, TT 1.5, One-For-All URC-7040, Debian Etch, vdr 1.6.0-8ctvdr1

  • hallo leute habe genau das gleiche problem,


    habe auch schon n dem board gepostet. aber noch zu keiner lösung gekommen.


    was mir aufgefallen ist das das problem oft in einer eben auftritt wenn ich z.b von rtl auf pro7 umschalte dann passiert es und da hilft manchmal nichts als warten, irgendwann geht´s von selber wieder!

    __________________________________________
    Personalführung ist die Kunst, den Mitarbeiter so schnell über den Tisch zu ziehen, dass er die Reibungshitze als Nestwärme empfindet.

  • Also seit dem ich obengenannte Lösung versucht habe, tritt der Fehler bei mir nicht mehr auf.


    Scheint also daran zu liegen..


    Ich seh grad, dass die Seite auf die der Lösungs-Link zeigt, nicht gerade selbsterklärend ist.. Also hier ist das Originalposting, zu dem die Lösung gehört:


    http://www.linuxtv.org/mailing…003/05-2003/msg00228.html


    Ihr könnte auch in google nach "SOutCommand" suchen und den ersten Treffer nehmen..

  • oh man ich verstehe nur bahnhof was soll ich den genau tun?

    __________________________________________
    Personalführung ist die Kunst, den Mitarbeiter so schnell über den Tisch zu ziehen, dass er die Reibungshitze als Nestwärme empfindet.

  • Zitat

    Original von eddie
    oh man ich verstehe nur bahnhof was soll ich den genau tun?


    wenn ich es richtig verstehe, dann soll dieser patch eingespielt werden:



    unter DVB/driver/av7110 oder wo auch immer sich das file av7110.c befindet.

  • @The Alamo: Also bei mir lief das ganze jetzt seit dem ich gepostet habe ohne Probleme (auch keine ARM crashes). Allerdings seh ich grad im Log, das der SOutCommand error wieder da ist.. Subjektiv hat das jetzt länger gedauert, aber perfekt ist es wohl doch nicht :(

  • Hab den Patch jetzt auch mal installiert. Sehe aber keine Verbesserung :(


    Hier ein Auszug was in /var/log/messages geschrieben wird:


    Aug 21 20:26:36 animah kernel: #########00000833######### addr 0 data 0x33 (keycode 51)
    Aug 21 20:26:37 animah kernel: OutCommand: timeout waiting for COMMAND idle
    Aug 21 20:26:37 animah kernel: SOutCommand error
    Aug 21 20:26:37 animah kernel: outcom error
    Aug 21 20:26:38 animah kernel: OutCommand: timeout waiting for COMMAND idle
    Aug 21 20:26:38 animah kernel: SOutCommand error
    Aug 21 20:26:38 animah kernel: outcom error
    Aug 21 20:26:39 animah kernel: OutCommand: timeout waiting for COMMAND idle
    Aug 21 20:26:39 animah kernel: SOutCommand error
    Aug 21 20:26:39 animah kernel: outcom error
    Aug 21 20:26:39 animah kernel: #########00000033######### addr 0 data 0x33 (keycode 51)
    Aug 21 20:26:39 animah last message repeated 2 times
    Aug 21 20:26:39 animah vdr[2686]: receiver thread started on device 1 (pid=2686)
    Aug 21 20:26:39 animah vdr[2670]: max. latency time 6 seconds
    Aug 21 20:26:39 animah vdr[2670]: switching to channel 4
    Aug 21 20:26:39 animah vdr[2686]: receiver thread ended on device 1 (pid=2686)
    Aug 21 20:26:40 animah kernel: CommandRequest: timeout waiting for COMMAND to complete
    Aug 21 20:26:40 animah kernel: StopHWFilter error
    Aug 21 20:26:41 animah kernel: OutCommand: timeout waiting for COMMAND idle
    Aug 21 20:26:41 animah kernel: CommandRequest error
    Aug 21 20:26:41 animah kernel: StopHWFilter error
    Aug 21 20:26:42 animah kernel: OutCommand: timeout waiting for COMMAND idle
    Aug 21 20:26:42 animah kernel: CommandRequest error
    Aug 21 20:26:42 animah kernel: StartHWFilter error


    • VDR#1: CoolerMaster ATX-620, MR Fortron 350 Watt ichbinleise®, FSC 1562, Celeron 2GHz, 256 MB, HD400LD, silentmaxx HD-silencer, LG GSA-4160B, Nexus-S, IR rev.4 von hirc, One-For-All URC-7040, Debian Etch, vdr 1.6.0-8ctvdr1

    • VDR#2: passiv Gehäuse von Hewlett600, VIA MII-12000, 256 MB, HD400LD, TT 1.5, One-For-All URC-7040, Debian Etch, vdr 1.6.0-8ctvdr1

  • Noch ein interessanter Link: http://www.mail-archive.com/li…linuxtv.org/msg10280.html


    Zitat:
    >transponders is rather low. It is enough to get a lock, but sometimes
    > the
    > lock is lost. Which is of cause not a problem of the driver, but I
    > experience strange behaviour in that cases, which range from outcom
    > errors
    > to StopHwFilter errors, Frozen pictures that do not recover after the
    > lock
    > is back and Arm crashes.


    Die schieben das also alles auf eine schlechte Signalqualität.. Hat jemand eine Ahnung, wie man das überprüft?

  • Hi McWizard,


    die Signalqualität soll man mit den DVB Tools genauer mit dvbtune testen können http://www.linuxstb.org/dvbtune/index.shtml 
    Leider ist das ein CVS download, komm ich gerade nicht dran sonst hätte ich das auch mal gescheckt.


    Hardware ist bei mir:
    MSI Hermes 651-P
    Hauppauge Nexus-S 2.1
    Linuxtv DVB 1.0.0
    VDR 1.2.2
    Und als OS SuSE 8.2 Professional


    Bye
    John


    • VDR#1: CoolerMaster ATX-620, MR Fortron 350 Watt ichbinleise®, FSC 1562, Celeron 2GHz, 256 MB, HD400LD, silentmaxx HD-silencer, LG GSA-4160B, Nexus-S, IR rev.4 von hirc, One-For-All URC-7040, Debian Etch, vdr 1.6.0-8ctvdr1

    • VDR#2: passiv Gehäuse von Hewlett600, VIA MII-12000, 256 MB, HD400LD, TT 1.5, One-For-All URC-7040, Debian Etch, vdr 1.6.0-8ctvdr1

  • Habe auch Hermes 651-P
    und Pundit von Asus.


    Habe eine Nexus Rev 2.1
    Und auch eine Siemens Rev 1.6 in der Pundit


    Treiber 25.062003
    VDR 1.2.1
    Suse 8.2 Pro

    __________________________________________
    Personalführung ist die Kunst, den Mitarbeiter so schnell über den Tisch zu ziehen, dass er die Reibungshitze als Nestwärme empfindet.