[Gelöst]Problem mit fbtv, vdr reagiert nicht auf tastatureingaben

  • Hallo, ich habe mir meinen vdr auf ubuntu 5.10 selbst zusammengefuscht.
    Lirc und Fernbedienung funktionieren prima.
    Das Bild gebe ich per fbtv auf dem monitor aus.
    Nun mein Problem:
    Der vdr reagiert nicht auf tastatureingaben. In meiner remote.conf liegen nur die codes für die fernbedienung. Müssten da nicht auch die codes für die tastatur rein? Wenn ja wie komm ich an diese ran? Eigentlich hab ich noch mehr fragen, aber ich will euch mit meinem ersten post nicht gleich überstrapzieren :)


    Danke für jede Hilfe


    rock_

  • Eigentlich sollte in der remote.conf auch die Tastatur zu finden sein ...


    Läuft denn fbtv auf der gleichen Konsole, auf der VDR seine Tastatureingaben erwartet (norm. die 8.) ?


    Man kann fbtv unabhängig von der verwendeten Konsole laufen lassen

    Code
    1. -k keep capture on when switching consoles.


    Ggf. die remote.conf bei nichtlaufendem VDR wegsichern und VDR neu starten ... hernach müßte VDR die Tastatur neu anlernen ...


    LG
    Roman

    Wohnzimmer (Client 1): C't Vdr (Sarge), 2.6.15-sl, 1.4.0-2, TT-1.5 FF, Hermes 651, 40 GB, 2Ghz Celeron, 512MB, PSOne TFT
    Server: C't VDR (Sid), 2.6.15-1-k7, 1.4.1-1, TT-1.6 FF, XP-2000+, 500GB, 512MB
    Schlafzimmer (Client 2): MediaMVP
    MediaMVP, Bose S 100, 400er Oldischlepptopp für den Garten

  • Danke erstmal, aber mein vdr reagiert auf keiner console auf die tastatur :rolleyes:
    weder auf die eine noch auf die andere.....
    Ich hab fbtv auf console 2.



    Nunja, das hier hab ich bei heise gefunden:


    "Noch einige Erläuterungen zum Beispiel: So wie hier dargestellt erscheinen die TV-Bilder auf der neunten Console. Die achte, auf die das System beziehungsweise das VDR-init-Skript beim Start automatisch wechselt, eignet sich nicht, weil sie schon zur Steuerung des VDR über die Tastatur benutzt wird. Für den Dauerbetrieb eines solchen Systems scheint es nicht praktikabel fbtv und Tastatursteuerung dauerhaft zu verwenden, weil beide auf einer Console nicht harmonieren."


    da ich nu lesen muss das mein unterfangen wohl vergebens ist. Habt ihr ideen wie ich das tvbild auf dem Monitor ausgeben kann ohne einen xserver aber wohl meine Tastataur zu benutzen?



    rock_


    //Nachtrag:
    Bei Linvdr hab ich das gefunden:


    "VDR liest Tastatureingaben von Konsole 10 (/dev/tty10, LinVDR schaltet beim Start dorthin um), so dass VDR auch per Tastatur bedient werden kann. Dort wird auch, wenn aktiviert, das Fernsehprogramm dargestellt (FBTV)."


    Irgendwie widerspricht sich das alles...


    //Nachtrag2:
    Wenn ich die remote.conf sichere und lösche und vdr neustarte will er zunächste die fb anlernen. ok lirc ausgemacht. Vdr wieder neugestartet und nun will er nix anlernen :(


    Muss da vielleicht was in der runvdr oder sonstwo stehen das er überhaupt auf die tastatur reagiert?

  • mh, ich bin mittlerweile auf vdrdevel umgestiegen.... weil da einiges auf anhieb klappte was bei meiner vorherigen version nicht klappte.


    So, mein problem mit der remotes.conf besteht leider nach wie vor.
    Wenn ich die remotes.conf lösche und VDR(devel) wieder starte fragt er brav die codes für die FB ab. Danach unternimmt er einen Versuch die Tastatur anzulernen, bricht dann aber ab.......... AHHHH!!!!! Mir kommt grad was ich falsch gemacht habe!!! sowas dummes, ne is klar :) das ist ja peinlich... is ja klar der kann nix anlernen weil er die tastatur nich mitbekommt weil ich ja auf ne andere konsile umgeschaltet hab... ?( ?(

  • Hallo rock_,


    das gleiche Problem hatte ich auch.


    Ich hab mir dann mal fbtv angeschaut und die ganze Tastatur-Verarbeitung rausgenommen.
    Den diff dazu findest Du in den HOWTO's in meinem Beitrag [Aufsetzen einer VDR-Maschine]


    Sorry, kann gerade keinen Verweis posten.

    Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

  • Daher meine Frage:


    Quote

    Läuft denn fbtv auf der gleichen Konsole, auf der VDR seine Tastatureingaben erwartet (norm. die 8.) ?


    LG
    Roman

    Wohnzimmer (Client 1): C't Vdr (Sarge), 2.6.15-sl, 1.4.0-2, TT-1.5 FF, Hermes 651, 40 GB, 2Ghz Celeron, 512MB, PSOne TFT
    Server: C't VDR (Sid), 2.6.15-1-k7, 1.4.1-1, TT-1.6 FF, XP-2000+, 500GB, 512MB
    Schlafzimmer (Client 2): MediaMVP
    MediaMVP, Bose S 100, 400er Oldischlepptopp für den Garten

  • Verdammt! Doch nicht gelöst!
    Zwar reagiert er nun auf die Tastatur, aber nun zeigt er in der framebufferausgabe die blinkende Eingabeaufforderung (weiss grad nicht wie das richtig heisst)
    Also fbtv ist jetzt mit -k -q gestartet.
    Kann ich dieses Blinken abstellen?


    MfG
    rock_

  • ist das blinken auch da, wenn du fbtv auf ner konsole startest und dann auf die eingabekonsole des vdr wechselst?


    LG
    Roman

    Wohnzimmer (Client 1): C't Vdr (Sarge), 2.6.15-sl, 1.4.0-2, TT-1.5 FF, Hermes 651, 40 GB, 2Ghz Celeron, 512MB, PSOne TFT
    Server: C't VDR (Sid), 2.6.15-1-k7, 1.4.1-1, TT-1.6 FF, XP-2000+, 500GB, 512MB
    Schlafzimmer (Client 2): MediaMVP
    MediaMVP, Bose S 100, 400er Oldischlepptopp für den Garten

  • Hallo
    @ wilderigel
    danke für den tip, aber leider habe ich in meinen repositories kein agetty finden können.


    Uatschitchun
    Ja, leider auf allen konsolen



    Also das blinken nervt mächtig, ich könnte damit ja leben aber meine bessere hälfte nicht ;)
    Das Blinken taucht nur auf wenn ich fbtv mit option -k starte


    Es wäre echt ärgerlich, müsste ich auf die tastatur verzichten. Ich hab mir nämlich extra ein Bedienfeld aus ner usbtastatur gebastelt und das war ne heidenarbeit.



    rock_

  • Quote

    Original von rock_
    Hallo
    @ wilderigel
    danke für den tip, aber leider habe ich in meinen repositories kein agetty finden können.


    Du sollst, wenn ich den Tipp richtig lese, die entsprechende Zeile auskommentieren (man beachte das "#" am Anfang der Zeile) ...


    oder das gleich mit dem von dir schon genannten Tipp von den heise-seiten kombinieren und statt einer eingabekonsole (getty) direkt fbtv starten per inittab


    Lg
    Roman

    Wohnzimmer (Client 1): C't Vdr (Sarge), 2.6.15-sl, 1.4.0-2, TT-1.5 FF, Hermes 651, 40 GB, 2Ghz Celeron, 512MB, PSOne TFT
    Server: C't VDR (Sid), 2.6.15-1-k7, 1.4.1-1, TT-1.6 FF, XP-2000+, 500GB, 512MB
    Schlafzimmer (Client 2): MediaMVP
    MediaMVP, Bose S 100, 400er Oldischlepptopp für den Garten

  • Wenn ich es wie bei heise mache, also:
    "9:2:respawn:/usr/bin/fbtv -q <> /dev/tty9" in die /etc/initab eintrage,
    verhält sich das ganze sehr merkwürdig.
    Ich habe dann auf allen konsolen fbtv obwohl option -k nicht dabei ist, und der cursor blink weiter vor sich hin...


    was das auskommentieren von "#c1:12345:respawn:/sbin/agetty 38400 tty1 linux" angeht, hab ich diese zeile leider garnicht. Meine inittab endet mit tty6.



    ok, ich glaub ich hab die richtige richtung gefunden.
    Ich habe erstmal tty8 in die inittab eingetragen wie alle anderen auch.
    VDR gestoppt.
    Dann habe ich auf tty8 gewechselt und "setterm -cursor off -blink off -store eingegeben"
    VDR gestartet
    Dann auf tty1 gewechselt und "fbtv -q -k" einegegeben. Funktioniert!!!!!!


    So, das ist schonmal äußerst erfreulich :D Vielen Dank für eure Tips.


    Jetzt muss mir nur noch ein weg einfallen das ganze zu automatisieren.... ideen?



    rock_

  • So, nu läuft die Kiste :D
    Wollte euch die Lösung nicht vorenthalten. Folgende Einstellungen funktionieren bestens, auch wenn die jungs von heise was andres behaupten.


    /boot/grub/menu.lst


    title Ubuntu, kernel 2.6.12-10-386
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.12-10-386 root=/dev/hda1 ro vga=0x311
    initrd /boot/initrd.img-2.6.12-10-386
    savedefault
    boot


    /etc/inittab
    # Format:
    # <id>:<runlevels>:<action>:<process>
    #
    # Note that on most Debian systems tty7 is used by the X Window System,
    # so if you want to add more getty's go ahead but skip tty7 if you run X.
    #
    1:2345:respawn:/sbin/getty 38400 tty1
    2:23:respawn:/sbin/getty 38400 tty2
    3:23:respawn:/sbin/getty 38400 tty3
    4:23:respawn:/sbin/getty 38400 tty4
    5:23:respawn:/sbin/getty 38400 tty5
    6:23:respawn:/sbin/getty 38400 tty6
    #8:23:respawn:/sbin/getty 38400 tty8
    8:2:respawn:/usr/bin/fbtv -q -k <> /dev/tty8




    Danke für die Hilfe
    rock_