VDRADMIN Datum auf 1970?

  • Hallo,


    habe mal seid langem ein aptget update/upgrade auf meinem Server gemacht, und config sieht im Moment so aus:





    installiert ist der vdradmin 0.97-am3.4.2


    und jetzt das Problem:


    unter
    Was läuft jetzt?
    Was läuft jetzt
    Zeitleiste
    taucht gar nichts auf, und in der Programmübersicht steht das Datum vom
    01.01.1970
    Was ist da passiert?
    Ich hatte in letzter Zeit nicht viel Zeit für meinen VDR und bin über eventuelle Probleme nicht mehr auf dem Laufenden, kann mir hier einer sagen was da geschehen ist, und wie ich es beheben kann?


    Danke schon mal an alle
    mfg
    Der Brumm-Baer

    MfG
    Der Brumm-Baer
    --------------------------------------------
    srv-vdr: HW: Dell T20 (Xeon) - SW: Openmediavault Erasmus, Frodo-VDR als Docker Container, EPGD als Docker Container


    med-og: HW: - SW: Libreelec
    med-sz: HW: SilverStone Milo ML03, BeQuiet SFX-300W, Asrock H61M-ITX, Intel G530, Asus G210 Silent, Asrock Smart Remote, 8GB USB-Stick - SW: Libereelec
    med-eg: HW: SilverStone Milo ML03, BeQuiet SFX-300W, Asrock H61M-ITX, Intel G530, Asus G210 Silent, Asrock Smart Remote, 8GB USB-Stick - SW: MLD 5.1

  • cut and paste:



    --- vdradmind.pl 2005-12-10 12:17:01.000000000 +0000
    +++ vdradmind.my.pl 2006-01-08 14:02:42.000000000 +0000
    @@ -735,7 +735,7 @@
    else {
    $bc++;
    while($_ = $SVDRP->readoneline) {
    - if(/^E (.*) (.*) (.*) (.*)/ || /^E (.*) (.*) (.*)/) {
    + if(/^E (.*?) (.*?) (.*?) /) {
    my($event_id, $time, $duration) = ($1, $2, $3);
    my($title, $subtitle, $summary);
    while($_ = $SVDRP->readoneline) {


    vdradmind.pl entsprechend anpassen und alles lüpt.....
    cu peje

    PCs
  • peje


    Vorsicht
    :deppenalarm
    Sorry, ich bin jetzt nicht so der Programmierer Typ,
    wo muss ich deinen Code Schnipsel Einfügen,
    und was muss in der vdradmind.pl noch angepasst werden?


    Tschuldigung, aber ganz so tief bin ich nicht in der Materie.


    MFG
    Der Brumm-Baer

    MfG
    Der Brumm-Baer
    --------------------------------------------
    srv-vdr: HW: Dell T20 (Xeon) - SW: Openmediavault Erasmus, Frodo-VDR als Docker Container, EPGD als Docker Container


    med-og: HW: - SW: Libreelec
    med-sz: HW: SilverStone Milo ML03, BeQuiet SFX-300W, Asrock H61M-ITX, Intel G530, Asus G210 Silent, Asrock Smart Remote, 8GB USB-Stick - SW: Libereelec
    med-eg: HW: SilverStone Milo ML03, BeQuiet SFX-300W, Asrock H61M-ITX, Intel G530, Asus G210 Silent, Asrock Smart Remote, 8GB USB-Stick - SW: MLD 5.1

  • such in /usr/bin/vdradmind.pl nach dieser Zeile:

    Code
    1. if(/^E (.*) (.*) (.*) (.*)/ || /^E (.*) (.*) (.*)/) {


    und ersetz sie durch diese:

    Code
    1. if(/^E (.*?) (.*?) (.*?) /) {


    Gruß googleGSM


    HW: Asus P5B, Intel Core2 Duo E6400 2x2.13GHz, 4096MB Ram, 1.4TB HDD, LG GSA-4165, LaScara LC13, WinTV Nexus-S, WinTV Nova-HD-S2, PCI CI + T-Rex Dragon CAM, Nvidia Geforce 7600 GS
    SW: Ubuntu 8.04, X-VDR

  • ggsm
    peje



    Danke, das war es! :applaus


    Aber woran lag es? Habe ich irgendwo was falsch gemacht, oder ist es ein genereller Fehler in der vdradmind.pl


    Nochmals Danke


    MfG
    Der Brumm-Baer

    MfG
    Der Brumm-Baer
    --------------------------------------------
    srv-vdr: HW: Dell T20 (Xeon) - SW: Openmediavault Erasmus, Frodo-VDR als Docker Container, EPGD als Docker Container


    med-og: HW: - SW: Libreelec
    med-sz: HW: SilverStone Milo ML03, BeQuiet SFX-300W, Asrock H61M-ITX, Intel G530, Asus G210 Silent, Asrock Smart Remote, 8GB USB-Stick - SW: Libereelec
    med-eg: HW: SilverStone Milo ML03, BeQuiet SFX-300W, Asrock H61M-ITX, Intel G530, Asus G210 Silent, Asrock Smart Remote, 8GB USB-Stick - SW: MLD 5.1

  • ist wohl ein Fehler in der aktuellen Version. Musste ich bei mir auch korrigieren.


    Gruß googleGSM


    HW: Asus P5B, Intel Core2 Duo E6400 2x2.13GHz, 4096MB Ram, 1.4TB HDD, LG GSA-4165, LaScara LC13, WinTV Nexus-S, WinTV Nova-HD-S2, PCI CI + T-Rex Dragon CAM, Nvidia Geforce 7600 GS
    SW: Ubuntu 8.04, X-VDR

  • Tag, habe die Änderung vorgenommen jedoch tut sich bei mir nichts. Bei mir wird in der Programmübersicht auch kein Datum angezeigt. Gibts da noch was anderes?


    Gruß Oga

    SW: c't VDR mit e-tobi, vdr 1.4.x, Kernel 2.6.18.1 (PowerNow! Patch + HG Treiber), Bootzeit: 45s
    HW: PC-Chips M811, AMD Geode NX 1750+@1.125V, 512MB RAM, 1GB CF, 100MBit LAN, DVD-ROM, TT2.3 modded (4MB + S-Video, IR, S/PDIF über J2), 1 x TT-Budget S1401, 2 x TT-Budget, 256x64 GVFD, WakeUP + 4x40 LCD
    Gehäuse: 8mm Alu, Netzteil: 300W passiv Umbau, Verbrauch|CPU|Gehäuse: @533Mhz(Idle) 59W|37°C|33°C, @1400Mhz(100%) 81W|46°C|41°C

  • Hi,

    Zitat

    Original von ggsm
    such in /usr/bin/vdradmind.pl nach dieser Zeile:

    Code
    1. if(/^E (.*) (.*) (.*) (.*)/ || /^E (.*) (.*) (.*)/) {


    und ersetz sie durch diese:

    Code
    1. if(/^E (.*?) (.*?) (.*?) /) {


    Das funktioniert bei mir auch nicht. Das sollte gehen:

    Code
    1. if(/^E (.*) (.*) (.*) (.*) (.*)/ || /^E (.*) (.*) (.*) (.*)/ || /^E (.*) (.*) (.*)/) {


    Gruß,
    Andreas

  • thx werd ich heut abend mal testen

    SW: c't VDR mit e-tobi, vdr 1.4.x, Kernel 2.6.18.1 (PowerNow! Patch + HG Treiber), Bootzeit: 45s
    HW: PC-Chips M811, AMD Geode NX 1750+@1.125V, 512MB RAM, 1GB CF, 100MBit LAN, DVD-ROM, TT2.3 modded (4MB + S-Video, IR, S/PDIF über J2), 1 x TT-Budget S1401, 2 x TT-Budget, 256x64 GVFD, WakeUP + 4x40 LCD
    Gehäuse: 8mm Alu, Netzteil: 300W passiv Umbau, Verbrauch|CPU|Gehäuse: @533Mhz(Idle) 59W|37°C|33°C, @1400Mhz(100%) 81W|46°C|41°C

  • Hi,


    vielen Dank. Hatte leider das gleiche Problem.


    bei mir ging es auch erst mit dem ändern in


    Zitat

    if(/^E (.*) (.*) (.*) (.*) (.*)/ || /^E (.*) (.*) (.*) (.*)/ || /^E (.*) (.*) (.*)/) {


    Gruss

    # als Server c't VDR v6 im Dauerbetrieb [P4-Dual 1GHz - 3xDVB-S (1xHauppauge Nexus-S, 1xHauppauge Nova-S Plus, 1xTechnotrend Budget) ]
    # als Clients - 1xHauppauge MediaMVP und 3xAP als Client

  • HI,


    sagt mir bitte mal, wie man so was raus bekommt ? ? ?
    Ich war froh, es hin zu bekommen, die Zeilen exakt auszutauschen...


    UND vielen Dank, das zweite Beispiel hat auch mein Problem behoben...


    Götter der Nacht!

  • Joho, das geht prima, wollt auch nochmal verspätet Danke sagen. Gruß Oga

    SW: c't VDR mit e-tobi, vdr 1.4.x, Kernel 2.6.18.1 (PowerNow! Patch + HG Treiber), Bootzeit: 45s
    HW: PC-Chips M811, AMD Geode NX 1750+@1.125V, 512MB RAM, 1GB CF, 100MBit LAN, DVD-ROM, TT2.3 modded (4MB + S-Video, IR, S/PDIF über J2), 1 x TT-Budget S1401, 2 x TT-Budget, 256x64 GVFD, WakeUP + 4x40 LCD
    Gehäuse: 8mm Alu, Netzteil: 300W passiv Umbau, Verbrauch|CPU|Gehäuse: @533Mhz(Idle) 59W|37°C|33°C, @1400Mhz(100%) 81W|46°C|41°C


  • Hallo,
    hat bei mir auch so geklappt.
    Vielen Dank.
    Manchmal wird mir dann doch klar, warum manch einer einen "konsumentenfreundlicheren" festplattenreceiver kauft...
    ;)


    grüße

    VDR1: yavdr 0.5.0 beta auf einem ASUS P5QPL-AM mit Tevii S480
    VDR2: debian-SERVER (dockstar) mit 3x Nova-T-USB-Sticks und yavdr 0.4 auf Zotac Ion-A als client

  • Zitat

    Original von Mr.N!ce
    Da kann es aber bei Firmwareupdates auch lustige Effekte geben :D


    Das sind "Kunden", die wissen doch gar nicht, dass es so was gibt...
    ;)

    VDR1: yavdr 0.5.0 beta auf einem ASUS P5QPL-AM mit Tevii S480
    VDR2: debian-SERVER (dockstar) mit 3x Nova-T-USB-Sticks und yavdr 0.4 auf Zotac Ion-A als client

  • Zitat

    Original von champpain


    Das sind "Kunden", die wissen doch gar nicht, dass es so was gibt...
    ;)


    geschweige denn das die dinger dann auch wirklich das tun was man möchte.



    btw: kommt da auch ein update für die "normale" vdradmin version?

    :: ctvdr45:: Kernel 2.6.12-rc4 :: Hauppauge DVB-s rev.1.3 :: Hauppauge Nova-CI-s :: CryptoWorks + ORF :: PII 400Mhz :: 280GB :: 20x4 LCD :: iR-Empfänger