Wo finde ich das pvrinput-Plugin für linvdr 0.7, Kernel 2.6.12.2, vdr 1.3.17

  • Moin moin!


    Kann mir jemand sagen, wo es vielleicht ein fertig kompiliertes Paket für das pvrinput-Plugin gibt bzw. wie ich es am besten selbst übersetzen kann?


    Das ist das letzte Puzzlestück, um meinen vdr endlich in Betrieb nehmen zu können... :-)


    mini.

  • hallo mini,


    ich fürchte, die 1.3.17 wird vom aktuellen pvrinput gar nicht unterstützt, da zu alt. ich rate Dir zu folgendem:


    Installiere dir den Patch von MarcTwain vom 18.05: (Ist vdr 1.3.24, auch wenn der Dateiname etwas anderes vermuten lässt.)


    Installationsanleitung für den Patch an sich:
    http://www.linvdr.org/wiki/?pagename=MarcTwainPatches


    Anschließend installierst Du mein update-Paket:
    http://www.vdrportal.de/board/thread.php?sid=&postid=363541#post363196


    Wenn Du NUR eine PVR350 drin hast (keine DVB-Karte), dann installiere zusätzlich die Anpassung gemäß http://www.linvdr.org/wiki/?pagename=MarcTwainPVR


    Ist die PVR zusätzlich zu einer FF-DVB-karte drin, darfst Du nicht nach o.g. Anweisung vorgehen, also pvr350.tgz NICHT entpacken. Stattdessen machst Du folgendes:


    Trage manuell in der Datei /etc/init.d/rcStart direkt vor der Zeile

    Code
    1. progress 80 "starting vdr"


    folgende Zeile ein:
    modprobe ivtv ivtv_std=2


    Im setup wählst Du dann noch pvrinput als Plugin aus. Zusätzlich ergänzt Du Deine channels.conf um die Einträge der analogen Sender gemäß Syntax des pvrinput-Plugins. Eine Muster-Datei ist in meinem o.g. Paket enthalten.


    Wenn noch Fragen sind, versuche ich gerne zu helfen! :)

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

    The post was edited 1 time, last by Dr. Seltsam ().

  • Ich sehe gerade, Du hast schon den 2.6.12.2 drauf. Bei mir habe ich damit die PVR nicht zum Laufen gekriegt; auch fand ich den darin enthaltenen unstable-ivtv-Treiber nicht so toll.


    Für Deinen Zweck wäre vielleicht mein Kernel 2.6.12.4 geeigneter:
    http://drseltsam.device.name/vdr/kernel26124.html

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

    The post was edited 1 time, last by Dr. Seltsam ().

  • Hi!


    Vielen Dank für die Tipps, ich werde sie in den nächsten Tagen vielleicht ausprobieren können, besonders den Kernel. Aber erst mal muss ich bei einem Umzug helfen...
    Ich bin dabei, einen VDR mit einer PVR150MCE und DXR3 aufzusetzen, und probier die verschiedenen Distributionen durch. Ich weiss, dass das nicht ohne ist, da ich aber mit Compiler und Linux umgehen kann und ich gerne rumbastel, hab ich Hoffnung, dass es irgendwann funktioniert... :-)
    Und wenn nicht, gibt's dann doch noch irgendwann eine FF-Karte, es muss dann nur DVB-T oder -C sein, da ich keine Schüssel anbringen kann.


    Ich melde eventuelle (Miss-)Erfolge.


    mini.

  • Hallo Mini,


    also gleich 2 Herausforderungen: dxr3 und die PVR150 :)


    Interessanter Versuch. Mit einer PVR250 und dem ivtv-stable-Treiber 0.2.0-rc3k (wie in meinem Kernel enthalten) läuft das. Die PVR150 braucht vermutlich den 0.3.x-Zweig. Aber auch da kann ich Dir helfen, denn ich habe gestern für meinen Kernel ein update-Paket auf ivtv-0.3.9 fertig gemacht. Link und Anleitung folgt heute order morgen.


    Gruß
    Dr. Seltsam

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Ich liebe Herausforderungen! :-)


    ivtv-0.3.9 hört sich gut an, da die 150MCE zum einen den Tuner Nr. 58 hat und es im 0.3er-Zweig doch noch einige Dinge hinzugekommen sind, die der 150MCE helfen. Zur Zeit hab ich die Verion 0.3.3k unter einem ct-vdr laufen, aber manchmal sind die Aufnahmen etwas zerrissen. Neuere Versionen hab ich da nie so richtig übersetzt bekommen, weil da noch ein Kernel 2.4.27 läuft. Es war schon ein unglückliches Gepatche, um dem Kernel den Tuner beizubringen...


    Ich bin gespannt!


    mini.

  • so,


    hier die Infos zum Kernelpaket:


    http://drseltsam.device.name/vdr/kernel26124.html


    update auf ivtv 0.3.9:
    http://drseltsam.device.name/vdr/kernelpaket-ivtv-0.3.9.tgz


    tar xvfz kernelpaket-ivtv-0.3.9.tgz -C /
    depmod -ae


    bzw. zurück auf 0.2.0-rc3k:


    http://drseltsam.device.name/v…paket-ivtv-0.2.0-rc3k.tgz
    tar xvfz kernelpaket-ivtv-0.2.0-rc3k.tgz -C /
    depmod -ae


    Eventuell musst Du mit den Modulen tveeprom.ko und tuner.ko mal experimentieren. Die liegen jeweils sowohl in /lib/modules/2.6.12.4/ivtv als auch /lib/modules/2.6.12.4/kernel/drivers/media/video


    Es ist immer nur eines aktiv, und das andere durch die endung .HIDE deaktiviert. Eventuell mal tauschen/umbenennen und danach ein depmod machen. Beim stable Treiber durfte z.B. NICHT das tveeprom von ivtv geladen sein, sonst ging eine Karte, die den bttv-Treiber benötigt, nicht mehr. Beim 0.3.9 habe ich hingegen gleich beide Module von ivtv als aktiv genommen.


    Falls Du den aktuellen MT-Patch 1.3.33 nutzt: Unter http://drseltsam.device.name/vdr/cody-plugins.tgz habe ich ein Paket mit analogtv (braucht man eigentlich nicht mehr) und pvrinput sowie pvr350 (das brauchst du nicht)

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • So, erst mal vielen Dank für die Hilfe!


    Der VDR läuft jetzt mit dem Kernel 2.6.12.4, vdr 1.3.24, mit den Modulen tuner.ko und tveeprom.ko aus dem ivtv-Verzeichnis. Der Empfang ist prima und aufnehmen funktioniert auch. Nur hör ich beim Abspielen keinen Ton (weder analog noch digital über die dxr3), aber da hatte ich letzte Nacht keine Lust mehr zu gucken. In den Aufnahmen ist der Ton jedenfalls enthalten, also ist es nur ein sekundäres Problem. Ein "mplayer /dev/video0 -vo dxr3" produziert Ton, also wird's wohl irgendwie mit dem DXR3-Plugin zu tun haben. Wahrscheinlich hab ich nur noch nicht den passenden Lautstärkeregler gefunden. :-)
    Jetzt muss ich nur noch überlegen, wo ich passende EPG-Daten herbekomme...


    Ein ganz anderes Problem hab ich mit dem Zugriff auf die Aufnahmen von meinem Windows-Rechner. Sobald ich versuche, eine Datei über die Freigabe zu kopieren, stürzt der PC ab und bootet neu. Das Verhalten habe ich allerdings auch mit meiner anderen Installation (c't vdr), aber erst seit drei Wochen, vorher hat's geklappt. Wenn ich ein Knoppix boote und das Video-Verzeichnis freigebe, kann ich wunderbar kopieren. Da muss ich noch mal ein wenig forschen, wo die Ursache liegt. Eine Sache, die ich geändert hatte, war, dass ich eine zweite Platte eingebaut habe.


    Wenn ich meine channels.conf vervollständigt habe, kann ich sie dir schicken, dann kannst du eine für den Flensburger Raum in dein Paket aufnehmen.


    mini.

  • Quote

    Original von mini73
    Wahrscheinlich hab ich nur noch nicht den passenden Lautstärkeregler gefunden. :-).


    ich hatte bei frischen Installationen tatsächlich immer das Phänomen, dass ich die vdr-Lautstärke immer erst aufdrehen musste !


    Quote

    Ein ganz anderes Problem hab ich mit dem Zugriff auf die Aufnahmen von meinem Windows-Rechner. Sobald ich versuche, eine Datei über die Freigabe zu kopieren, stürzt der PC ab und bootet neu.


    das dürfte ein XP-Problem sein, da hab ich auch mal irgendwo was gelesen... steht evtl. was bei www.linvdr.org ?


    Quote

    Wenn ich meine channels.conf vervollständigt habe, kann ich sie dir schicken, dann kannst du eine für den Flensburger Raum in dein Paket aufnehmen.


    besser noch, Du stellst sie in www.vdr-wiki.de, auch wenn es dort derzeit glaube ich noch keine analoge Rubrik gibt. Aber ruhig immer her damit :-)


    Die 0.3.9 ist derzeit übrigens unter heftiger Überarbeitung und soll die neue stable Version von ivtv werden. Ich beobachte das und werde ggf. neue Pakete bauen.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

    The post was edited 1 time, last by Dr. Seltsam ().

  • Das Ton-Problem ist gelöst:


    Ich hab CurrentVolume in der setup.conf auf 255 gesetzt, damit hab ich jetzt digitale Tonausgabe über die dxr3.


    Das Laden und Entladen der Kernelmodule für die dxr3 und ivtv hab ich in das runvdr-Script verschoben, dadurch werden evtl. Hänger gründlicher behoben.


    Von einem anderen Linuxrechner kann ich per smbclient problemlos die vdr-Dateien kopieren, mein XP-Rechner schiesst den vdr allerdings noch ab. Auch ein Deaktivieren des Webclient-Dienstes brachte noch keine Besserung. Mit pscp aus dem Putty-Paket kann ich übrigens keine Dateien kopieren, irgendwie kann er sftp nicht aktivieren (hab gerade nicht die vollständige Fehlermeldung). Ein Kopieren mit WinSCP schiesst den vdr auch ab. Ist schon irgendwie komisch...


    mini.

  • Quote

    Original von mini73
    Das Ton-Problem ist gelöst:


    Ich hab CurrentVolume in der setup.conf auf 255 gesetzt, damit hab ich jetzt digitale Tonausgabe über die dxr3.


    siehste :D


    Quote

    Das Laden und Entladen der Kernelmodule für die dxr3 und ivtv hab ich in das runvdr-Script verschoben, dadurch werden evtl. Hänger gründlicher behoben


    sowas habe ich in darkAngels 0.2.2.-Paket gesehen:


    Das fuser-binary muss dann noch nachinstalliert werden. ich wollte das demnächst auch mal probieren. Bisher scheint der Weg über die rcStart aber keine Probleme zu bereiten, weil der geladene Treiber sich offenbar selbst resettet.


    Poste doch mal Deine Lösung inkl. ivtv

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.


  • Ich entferne ivtv & co vor der Schleife, damit videodev und Konsorten entladen werden können.
    In Zeile 21 aktiviere ich den digitalen Ausgang der dxr3. Mag vielleicht unnötig sein, aber stören tut's auch nicht.
    fuser klingt interessant, das Tool kannte ich noch nicht. Wo kriegt man ein passendes Package zum Installieren?


    mini.

  • Hier meine channels.conf, ich hoffe, ich habe alle Sender mit der richtigen Service-Id versehen...


    mini.

  • Moin!


    Hab lange nichts von mir hören lassen... In meinem PC sind zwei Festplatten abgeraucht, deshalb musste ich ein paar Datenrettungsaktionen starten... Ist zum Glück noch gut gegangen.


    Leider läuft mein vdr nicht all zu stabil, das wird aber am Mainboard liegen. Die Elkos sehen nicht so gut aus, die sind ein wenig aufgeplatzt. Ein neues Board ist schon unterwegs, ein Asus MEW-AML, dann ist da auch noch Platz für meine DVB-T-Karte (Avermedia 771), die noch in einem anderen vdr steckt.


    Wenn die ganze Sache umgebaut und neu installiert ist, werde ich wieder schreiben. Da wird dann auch hoffentlich ein HowTo bei rausspringen... :-)


    mini.

  • Das Problem mit den Abstürzen beim Kopieren der Videodateien über's Netz war ein IRQ-Konflikt zwischen der Grafikkarte und der Netzwerkkarte. MicroATX-Boards haben einfach nicht genügend Slots...


    Mit dem Asus MEW-AML gibt's jetzt keine Probleme mehr.


    Nun fehlt noch die Integration der AverMedia 771, dann bin ich zufrieden. :-)


    mini.

  • Quote

    Original von mini73
    Nun fehlt noch die Integration der AverMedia 771, dann bin ich zufrieden. :-)


    da lauert eine böse Falle. Deine PVR150 braucht mit ziemlicher Sicherheit aktuelle ivtv-Treiber. (Mein aktueller kernel 2.6.14 hat inzwischen auch die stable 0.40-Treiber.)


    Das tveeprom.ko von ivtv hat aber eine Inkompatibilität zu den bttv-Treibern, die die Avermedia benötigt. Man kann die Avermedia dann nur nutzen, wenn man das tveeprom vom Kernel nimmt. ich weiss aber nicht, ob damit dann auch die PVR läuft....


    http://drseltsam.device.name/vdr/kernel2614.html


    Ich fürchte, das betrifft auch den 2.6.12.4 !


    Mein Rat: tausch die Avermedia in eine Airstar2 !

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

    The post was edited 1 time, last by Dr. Seltsam ().

  • Moin!


    So was ähnliches hab ich mir schon gedacht. Ich werde den neuen Kernel (wahrscheinlich am Wochenende) mal ausprobieren und melden, ob's funktioniert.
    Geld für eine andere DVB-T-Karte wollte ich eigentlich nicht ausgeben, da hier in Flensburg eh' nur die Öffentlich-rechtlichen senden. Aber da kommen die Spielfilme jedenfalls ohne Werbung...


    Mein Post zu deinem "Avermedia 771"-Thread kannst du dann getrost ignorieren... :-)


    mini.

  • Moin!


    So, es ist vollbracht! Mit dem Kernel 2.6.14 und dem tveeprom aus kernel/drivers/media/video funktionieren beide Karten.


    Ein großes herzliches Dankeschön für die Unterstützung! Ich bin jetzt glücklich und meine Frau ist es auch, weil es im Wohnzimmer wieder wohnlicher aussieht... ;-)
    Noch steht der vdr zwar in einem Standard-Minitower hinter'm Sofa in der Ecke, aber sobald ich mal für wenig Geld ein schönes Desktopgehäuse finde, kommt das Ding ins Hifi-Regal. Aber das ist ja nur noch Makulatur...


    mini.