LinVDR 0.7 GRUB Error 2 oder 15

  • Hab LinVDR 0.7 installiert. Früher testweise auf einem Mini Intel Board mit Pentium II 350 MHz Slot 1 und 64 MB RAM. Lief alles super. Installiert und ging! Sogar DivX hat das Ding ruckelfrei decodiert…


    Jetzt hab ich mir bessere Hardware zugelegt:


    Mainboard: Elitegroup K7SOM (GraKa, Sound und LAN onboard)
    CPU: AMD Duron 1200
    RAM: 128 MB SDRAM
    DVB: Technotrend Premium 1.3 DVB-S


    LinVDR CD reingeschoben, ohne Probleme installiert. Aber nach dem Reboot kam nur noch:


    Code
    1. GRUB Stage 1.5
    2. Error 2


    Manchmal auch:


    Code
    1. GRUB Stage 1.5
    2. Error 15


    Hab mehrmals installiert, dabei auch die Festplatte getauscht und vorher komplett platt gemacht (keine Partitionen), aber booten lässt er sich nicht. Die GRUB Fehlermeldungen hier sagen mir zwar, wo das Problem liegen könnte, nicht aber wie ich es wieder reparieren kann :-D


    Idee?

  • Von CD booten ( Knoppix oder so ) und prüfen , ob menu.lst an der richtigen Stelle und mit richtigem Inhalt - sprich root is , wos sein soll , der Kernel hat den richtigen Namen etc pp ...


    ggf korrigieren


    HJS

  • Wie kann das sein, dass LinVDR sich manchmal korrekt installiert und manchmal auch nicht? Liegt das evtl. an der veränderten Hardware?


    Mit Knoppix booten = klar. Also die Datei "menu.lst" sollte im Verzeichnis "/root" liegen? Welchen Namen sollte denn der Kernel haben?


    Danke!

  • Quote

    Original von droptix
    Wie kann das sein, dass LinVDR sich manchmal korrekt installiert und manchmal auch nicht? Liegt das evtl. an der veränderten Hardware?


    Eine mögliche Ursache ;)


    Quote


    Mit Knoppix booten = klar. Also die Datei "menu.lst" sollte im Verzeichnis "/root" liegen? Welchen Namen sollte denn der Kernel haben?


    nö - menu.lst ist bei LinVDR n Link auf ne Datei - Link und Datei liegen in /boot/grub .


    Der Kernel sollte den Namen tragen der auch in der menu.lst angegeben ist.


    Wie der heisst , ist nicht relevant - nur dass beide Einträge identisch sind - denn wenn du "Andreas" rufst , kommt auch nur manchmal "Andrea" ;)


    HJS

  • Hab mal mit Knoppix 3.7 gebootet... Ich beschreibe mal eben meine Vorgehensweise. Bitte korrigiert mich ggf. -> Danke!


    1) Nach dem Hochfahren einen Doppelklick auf "hda1", um sie zu mounten.
    2) Terminal öffnen
    3) su
    4) cd /mnt/hda1
    5) mc, um besser zu sehen :rolleyes:
    6) Ins Verzeichnis root wechseln -> ist leer!
    7) Ins Verzeichnis ../boot/grub wechseln -> da finde ich die Datei "menu.lst". In ihr suche ich nach der Zeile beginnend mit "kernel". Dort steht:


    Code
    1. kernel /boot/vmlinuz vga=0x314 root=/dev/hda1 quiet

    Im Verzeichnis /boot liegt auch der Symlink "vmlinuz", der auf /boot/vmlinuz-2.6.9 zeigt. Der Kernelname in der "menu.lst" stimmt also schonmal.


    Schlussfolgerung: Der Link auf die Datei im Verzeichnis /root fehlt also! Wie soll der eigentlich heißen? Ich komme nämlich grad ins Zweifeln ?( Der Symlink "grub.conf" (ebenfalls in /boot/grub) zeigt auf die "menu.lst".


    Und in den Ordner /root muss wirklich ein Link zu /boot/grub/menu.lst rein -> hab ich das so richtig verstanden? Wenn ja: Einen Symlink oder einen sog. harten Link?


    Nebenfrage: Wieso fehlt der Link? Kommt sowas öfter vor?


    P.S. Falls ich jetzt deinen Begriff "root" (also /) mit dem Verzeichnis /root verwechsle: Ich hab einfach noch folgendes gemacht:


    Code
    1. cd /root
    2. ln -s ../boot/grub/menu.lst menu.lst
    3. cd /
    4. ln -s boot/grub/menu.lst menu.lst

    Diese zwei Symlinks verweisen auf /boot/grub/menu.lst. Beide haben nichts gebracht. Momentan kommt bei mir immer die GRUB-Meldung "Error 2". Ich zweifle echt an mir... oder hab ich etwas total missverstanden? ;(


    Bitte rettet mich... daaaaaanke!

  • ich denke dass Du Dich auf das root=... beziehst, das gibt aber die root-Partition auf einer Platte an, das hat nix mit dem /root Verzeichnis zu tun.
    Hilf zu Grub findest Du hier.


    Ich hatte sowas auch mal, ich glaube unter LinVDR 0.6 und bei mir lag das an der Hardware und hatte glaube ich was mit der internen onboard-Grafik zu tun. Da habe ich - soweit ich mich erinnere - etwas am Parameter vga=0x314 ändern müssen.


    Ich guck mal, ob ich das noch finde ...

  • Hi, da bin ich wieder. Ich habe eine handgeschmierten Zettel gefunden, auf dem folgendes steht:
    Bootproblem nach Neuinstallation von LinVDR (ich habe keine Auhnung mehr, ob 0.6 oder 0.7), kann Rechner nicht booten, GRUB "no active partition" (das passt nicht so), Rechner Mainboard KSOM7 (hoppla!), Platte WesternDigital 4 GB
    Beheben: LinVDR installieren ... dann von CD installiertes System starten (das kannst Du eventuell umgehen, wenn Du per Knoppix startest und die hd mountest) ... dann grub aufrufen mit grub (da solltest Du sicherheitshalber die Konfigurationsdatei mit angeben) ...
    dann:
    root (hd0,0)
    setup (hd0)
    make active
    quit
    ...
    Ich bin mir nicht sicher, ob das Problem wirklich das gleiche ist, da die Meldung völlig anders ist, allerdings sind auch Parallelen zu sehen.


    Hast Du eigentlich die Platte bei der Installation völlig platt gemacht?


    Eventuell solltest Du auch mal das hier lesen.


    Sag Bescheid, ob das geholfen hat.
    Grüße
    Andi

  • /root hat nix mit dem Bootvorgang zu tun - wie andid schon festgestellt hat .


    Code
    1. grub
    2. root (hd0,0)
    3. setup (hd0)
    4. quit


    installiert grub auf hd0 - also hda für hd0,0 also im MBR .


    Wenn dei menu.lst in /boot/grub ist , den vorhandenen Kernel enthält und dieser ausführbar mit config und System.map in /boot ist , sollte das funzen .


    HJS

  • Dacht ich's mir doch :D


    Es hätte auch mich als relativen Linux-Anfänger gewundert, wenn in das Verzeichnis /root was reingemusst hätte...


    Jedenfalls hab ich euren Rat befolgt:


    1) Knoppix gebootet
    2) hda1 gemountet und schreibbar gemacht
    3) Terminal geöffnet, "su" und anschließend "grub" eingetippt, dann folgendes:


    Das veränderte meinen GRUB Error 2 auf Error 15. Schonmal ein Fortschritt? Booten lässt sich LinVDR trotzdem nicht. Habe GRUB einmal mit der config-Datei und dann ohne gestartet. Bei beiden Versuchen dasselbe Ergebnis.


    @andit: Ja, ich hatte die Festplatte vorher komplett (!) platt gemacht, also alle Partitionen gelöscht. Den MBR kann ich ja nicht platt machen, oder? Der Befehl "make active" bringt nix. GRUB will ihn nicht ausführen.


    hjs : Was meinst du mit:

    Quote

    dieser ausführbar mit config und System.map in /boot ist


    Übrigens: Hatte gestern einfach noch ein paar Male die HDD geplättet und anschließend LinVDR drauf gespielt. Einmal zwischendurch hat eine Installation geklappt und LinVDR hat gebootet -> Wieso diese Willkür bei der Installation? Weil ich aber nach der Installation die beliebte Meldung "LinVDR is respawning too fast. Sleeping one minute." bekam, habe ich LinVDR nochmal überspielt. Und dann war ich wieder beim Error 2.

  • Sehr lustig, das Ganze…


    Aus Verzweiflung hab ich gestern nochmal zum Spaß ein paar Mal LinVDR 0.7 drüber installiert. Nach ein paar Versuchen ging es dann plötzlich. Das Booten klappte und diese "…respawning too fast…" Meldung ist nun auch weg.


    Und alles nur, weil ich ein paar Male drüber gegangen bin. Habe allerdings mittlerweile eine Vermutung: Obwohl ich zwei verschiedene Festplatten dran hatte, will ich die HDD als Fehlerursache nicht ausschließen. Denn: Die eine hat 340 MB und die andere 1,2 GB. Ich wollte ursprünglich eine eigene kleine Platte für das System haben… D.h., dass beide seeeeehr alt sind und entweder durch fehlende Unterstützung dieser alten Dinger was nicht stimmte oder dass sie doch eine Macke haben. Wie oft kann man eigentlich den MBR einer Platte überschreiben?


    Heute habe ich eine 4 GB Platte reingeschoben. Die ging sofort und auf Anhieb, ist dazu noch um einiges schneller und macht einen besseren Eindruck… Ich werde mich wohl doch dazu entscheiden, nur eine einzige HDD einzusetzen. Da werde ich mir wohl bald was größeres reinhängen. Das spart außerdem Strom und Wärme und macht weniger Geräusche.