Wer hat Erfahrungen mit zwei PVR's ?

  • Hallo,


    da mein VDR (siehe Signatur) jetzt stabil läuft, habe ich mir überlegt, noch eine zweite PVR(150/250) einzubauen.
    Hat schon jemand so eine Konfiguration am laufen?
    Habe im Forum so recht nichts gefunden.


    Bin für jede Info dankbar.


    Gruss,
    Zerphod

    VDR: vdr-1.6.0-2 / Kernel 2.6.30 / ivtv / PVR350 & 500 & TT Cinergy 1200 DVB-C & EasyWatch DVB-C MK3 / Gigabyte GA-M720-US3 / Plugins: pvrinput, pvr350, text2skin, femon, recstatus, noepgmenu, dvd, burn, epgsearch, tvm2vdr, live, systeminfo, streamdev-server, vompserver/ Addons: noad / alles selbst kompiliert auf einem 64Bit Debian squeeze/sid für AMD64

  • Hallo MAK,


    sieht ja kompliziert aus.
    Ich glaub' ich probier mal mythtv aus.


    Danke,
    Zerphod

    VDR: vdr-1.6.0-2 / Kernel 2.6.30 / ivtv / PVR350 & 500 & TT Cinergy 1200 DVB-C & EasyWatch DVB-C MK3 / Gigabyte GA-M720-US3 / Plugins: pvrinput, pvr350, text2skin, femon, recstatus, noepgmenu, dvd, burn, epgsearch, tvm2vdr, live, systeminfo, streamdev-server, vompserver/ Addons: noad / alles selbst kompiliert auf einem 64Bit Debian squeeze/sid für AMD64

  • Hallo obifrz,


    ich habe folgende Erfahrungen gemacht:


    Ich benutze das pvrinput-Plugin, und habe auch mal eine PVR150MCE in den Rechner gesteckt. IVTV hat beide Karten erkannt. Der VDR startet und alles funktioniert auf der PVR350.
    Wenn eine Aufnahme startet, steht das LiveBild (kein Ton). Die Aufnahem aber wird korrekt durchgeführt. Ich gehe davon aus, das dieses Verhalten i.O. ist.
    Schalte ich nun auf einen anderen Kanal um, zeigt mir das OSD die Informationen von dem neuen Kanal. (steht auch so im message log) Ich sehe aber weiter das Standbild (kein Ton). Ich gehe davon aus, daß der VDR zwei Karten erkannt hat, aber die zweite Karte nicht 'benutzt' wird.


    Ich bin kein Programmierer, und kenne mich (noch) nicht so mit dem Zusammenspiel zwischen VDR<->Plugin<->IVTV aus. Vielleicht muß ich die channels.conf noch anpassen. Vielleicht muß das pvrinput-Plugin (läuft super) noch erweitert werden. Mal sehen...


    Gruss,
    Zerphod

    VDR: vdr-1.6.0-2 / Kernel 2.6.30 / ivtv / PVR350 & 500 & TT Cinergy 1200 DVB-C & EasyWatch DVB-C MK3 / Gigabyte GA-M720-US3 / Plugins: pvrinput, pvr350, text2skin, femon, recstatus, noepgmenu, dvd, burn, epgsearch, tvm2vdr, live, systeminfo, streamdev-server, vompserver/ Addons: noad / alles selbst kompiliert auf einem 64Bit Debian squeeze/sid für AMD64

  • Hallo Zerphod,


    du könnstest mal log level im setup auf 3 stellen. Dann VDR von der Konsole aus starten. Dann mal das was du beschrieben hast durchführen, also aufnahme starten und umschalten und die Ausgaben des Plugins hier posten.


    Andreas

  • Mit etwas Programmieraufwand wäre es auch mit analogtv möglich (das plugin müßte sich die erste freie pvr schnappen, nicht die in der channels.conf festgelegte), aber man müsste eben zwei Instanzen des plugins am Laufen haben denke ich.
    Es hat wohl bis jetzt kaum einer versucht.


    Ist pvinput eigentlich dafür ausgelegt? Analöogtv bis dato überhaupt nicht.

  • Auf jeden Fall müßte in


    bool cPvrDevice::ProvidesChannel(const cChannel * Channel, int Priority, bool * NeedsDetachReceivers) const


    eine Abfrage, ob eine freie pvr vorhanden ist (egal welche der beiden es ist)..


    No ja.., das wär noch machbar.

  • Quote

    Original von powarman
    prinzipiell ist pvrinput für mehrere pvr's ausgelegt, es fehlt denke ich mal nur an den richtigen Rückgabewerten für ProvidesTransponder/ProvidesChannel im jeweiligen Fall.


    Andreas


    das heißt doch das man dann in der channel.conf für jeden analogen sender unterschiedliche apids und vpids eintragen muß.
    oder?


    obifrz

  • powarman :


    ich habe mal ein paar kleine Tests gemacht.
    Nach einem Update auf ivtv 0.3.7(j) funktioniert auch die zweite PVR fast perfekt.
    LiveTV läuft immer auf der ersten Karte. Wird eine Aufnahme gestartet, wird das LiveBild auf die zweite Karte umgeschaltet. Bild ist ok, leider ist der Ton weg.
    Wird dann noch eine Aufnahme gestartet, wird auch diese Sendung aufgenommen, leider aber ohne Ton.
    Ich kann beide Sendungen auch ansehen, kein Standbild mehr.


    Ich werde gleich mal das neue pvrinput instalieren, dann noch mal testen, und dann auch mal das syslog posten.


    Gruss,
    Zerphod

    VDR: vdr-1.6.0-2 / Kernel 2.6.30 / ivtv / PVR350 & 500 & TT Cinergy 1200 DVB-C & EasyWatch DVB-C MK3 / Gigabyte GA-M720-US3 / Plugins: pvrinput, pvr350, text2skin, femon, recstatus, noepgmenu, dvd, burn, epgsearch, tvm2vdr, live, systeminfo, streamdev-server, vompserver/ Addons: noad / alles selbst kompiliert auf einem 64Bit Debian squeeze/sid für AMD64

  • Hallo,


    die neuen Versionen kommen ja schneller als man testen kann.


    Mit dem pvrinput(0.0.5), ivtv(0.3.7k) hat sich am Verhalten nichts geändert. Aufnahmen und LiveBild leider ohne Ton.


    Ich habe mal Auszüge aus meinem SYSLOG angehängt.
    (Ich hoffe, dass das klappt)


    Gruss Zerphod

    Files

    • syslog.txt

      (36.94 kB, downloaded 118 times, last: )

    VDR: vdr-1.6.0-2 / Kernel 2.6.30 / ivtv / PVR350 & 500 & TT Cinergy 1200 DVB-C & EasyWatch DVB-C MK3 / Gigabyte GA-M720-US3 / Plugins: pvrinput, pvr350, text2skin, femon, recstatus, noepgmenu, dvd, burn, epgsearch, tvm2vdr, live, systeminfo, streamdev-server, vompserver/ Addons: noad / alles selbst kompiliert auf einem 64Bit Debian squeeze/sid für AMD64

    The post was edited 3 times, last by Zerphod ().

  • wie schon gesagt, liegt das mit dem fehlendem Ton am Treiber, wie man auf der mailing liste nachlesen kann, gibt es da mit der PVR 150MCE noch Probleme.


    Hans Verkuil, momentan der wohl aktivste Entwickler am Treiber, will sich dem ganzen als nächstes widmen. Ich würde also noch ein paar ivtv-Versionen abwarten und dann nochmal testen.


    Andreas

  • Hallo,


    bis Hans das Problem gelöst hat, versuche mal dem tda9887-modul die Optionen

    Code
    1. port1=0 port2=0

    zu übergeben. Bei einer einzelnen PVR150MCE hat es zumindestens geholfen.


    EddieT

    PIII-866, 512 MB Ram, Avermedia 761 DVB-T, PVR150MCE, Debian unstable, vdr 1.3.38, Xine über Xorg auf GF2MX

  • Hallo,


    habe die Optionen in die modules.conf eingebaut. Hat aber leider keine Änderung gebracht.
    Ich werde wohl mal warten was sich auf der ivtv-Seite tut. Da ist ja auch ein Thread mit einem ähnlichen Problem.


    Ich denke auch,daß es ein ivtv-Problem ist, da auch ein 'dd of=/dev/video1 if=/dev/video16' ein LiveBild ohne Ton hervorbringt.


    Bei der ganzen Testerei ist aber eine Sache aufgefallen. Wie kann man eigendlich sehen, mit welchen Optionen/Paramtern ein Modul geladen wurde?


    Gruss,
    Zerphod

    VDR: vdr-1.6.0-2 / Kernel 2.6.30 / ivtv / PVR350 & 500 & TT Cinergy 1200 DVB-C & EasyWatch DVB-C MK3 / Gigabyte GA-M720-US3 / Plugins: pvrinput, pvr350, text2skin, femon, recstatus, noepgmenu, dvd, burn, epgsearch, tvm2vdr, live, systeminfo, streamdev-server, vompserver/ Addons: noad / alles selbst kompiliert auf einem 64Bit Debian squeeze/sid für AMD64

  • Hier ist noch der Thread von der ivtv-Mailingliste: http://www.gossamer-threads.com/lists/ivtv/devel/23514. Dort wird empfolen, noch ein weiterer Parameter zu setzen, der allerding auch automatisch erkannt werden sollte.
    Bei meiner Versuchen ist mir noch aufgefallen, das ich auch ohne die Parameter Ton bekommen konnte, indem ich mit ivtvctrl -q 1 den Audioeingang umgeschaltet habe. Bei Dir müsste es warscheinlich ivtvctrl -d /dev/video1 -q 1 heissen, zumindestens wenn die PVR150 die zweite Karte ist.


    Gruss,
    EddieT

    PIII-866, 512 MB Ram, Avermedia 761 DVB-T, PVR150MCE, Debian unstable, vdr 1.3.38, Xine über Xorg auf GF2MX

  • Jepp!


    Der Befehl war genau richtig.
    Ich habe jetzt Ton auf beiden Karten, auch bei den Aufnahmen.


    Jetzt kann ich noch ein paar Tests machen.


    Gruss,
    Zerphod

    VDR: vdr-1.6.0-2 / Kernel 2.6.30 / ivtv / PVR350 & 500 & TT Cinergy 1200 DVB-C & EasyWatch DVB-C MK3 / Gigabyte GA-M720-US3 / Plugins: pvrinput, pvr350, text2skin, femon, recstatus, noepgmenu, dvd, burn, epgsearch, tvm2vdr, live, systeminfo, streamdev-server, vompserver/ Addons: noad / alles selbst kompiliert auf einem 64Bit Debian squeeze/sid für AMD64