Lautstärke bei MPlayer

  • Hallo Leute,


    ich hab da ein Problem mit dem MPlayer Plugin und zwar ist der Ton WEHSENTLICH leiser als bei wiedergaben von "normalen" Aufnahmen.


    Weis jemand etwas über irgendwelche Einstellungen zur Lautstärke?


    Danke im Vorraus!!


    PS: Die Lautstärke bei der MP3 wiedergabe scheint normal, die MP3´s werden doch auch vom MPlayer wiedergegeben!?

    Server: Intel DQ67OWB3 - Core I5-2400 - 16GB RAM - 3x Samsung HD103UJ, 1x Hitachi HDS72202, 1x OCZ-ONX 64GB, 1x Seagate ST2000VX002-1AH1, 1x Seagate ST2000DL003-9VT1 - 1x DC-310e - 2x DigitalDevices CineS2


    Server Software: XUbuntu 11.10, 3.0.0-16-generic - VDR-1.7.23


    Clients: 1x ASRock ION330HT mit Ubuntu 11.10, VDR-1.7.23, Steht zum Verkauf ([VERKAUFE] ASRock ION 330HT)

  • pauli8585
    Schade, dass mann oft nur Manuallinks bekommt..... bin deinem Link gefolgt aber leider hat mir nix davon geholfen!


    kapplah
    Prima!!
    Das war mein Problem und es hat astrein geklappt... Habe vor einigen Monden Schonmal die Suche "vergewaltigt" aber leider nich über diesen Thread gestolpert...


    VIELEN VIELEN DANK!!!

    Server: Intel DQ67OWB3 - Core I5-2400 - 16GB RAM - 3x Samsung HD103UJ, 1x Hitachi HDS72202, 1x OCZ-ONX 64GB, 1x Seagate ST2000VX002-1AH1, 1x Seagate ST2000DL003-9VT1 - 1x DC-310e - 2x DigitalDevices CineS2


    Server Software: XUbuntu 11.10, 3.0.0-16-generic - VDR-1.7.23


    Clients: 1x ASRock ION330HT mit Ubuntu 11.10, VDR-1.7.23, Steht zum Verkauf ([VERKAUFE] ASRock ION 330HT)

  • Hallo,


    habe alle Lösungen probiert, aber mit -af, so heißt die option -aop jetzt wohl, ist der ton mit einer db Erhöhung um sagen wir 10db nur verzerrt, aber noch genauso leise wie vorher.
    Option hier: -af volume=10


    Ich habe diese Option innerhalb des VDR probiert, mit Ergebniss wie beschrieben, sowie auch nur mit dem nackten MPlayer. Mit nacktem Mplayer funktionierts, aber nicht innerhalb des VDR.


    Die andere Lösung -af list=volnorm funktioniert nicht, da meckert er, den Filter list könnte er nicht finden.



    Wer hat da eine Idee?


    Neuster mplayer, mplayer-plugin, vdr vorhanden.


    Danke,


    Gruß

  • Habe das gleiche Problem. Der Parameter -aop ist jetzt -af
    Die Option heisst nicht list=volnorm sondern volnorm=1 bzw . Siehe man mplayer


    Bei mir bringt weder volume=10:0 oder 1 noch volnorm=0 oder 1 in jeder Kombination irgendetwas.
    Mir ist allerdings etwas anderes aufgefallen. Ist der vdr neu gestartet ist der Ton beim ersten abspielen eines avi sehr oder normal laut. Stoppe ich die Wiedergabe und starte sie erneut ohne etwas an der vdr Lautaerke zu veraendern ist die mplayer Lautstaerke bei allen folgenden Abspielversuchen des gleichen videos sehr leise. Auch wenn ich die vdr Lautstaerke zwischendrin aendere verhaelt es sich so.


    Liegt das also ganz woanders begraben?


    System ist ctvdr 4.5 stable


    Gruss q-man

  • Da mich diese riesen Lautstärkeunterschiede auch immer schon gestört haben habe ich mir mal das MPlayer Manual angeschaut. Die Option volnorm ist folgendermaßen aufzurufen:


    Code
    1. -af volnorm=10.0:0


    Dies hebt das Signal um 10 DB an, ist aber für unser Problem das falsche Stellrad, da der Ton dadurch nicht wesentlich lauter wird aber deutlich verzerrt.


    Nach ein bisschen weiterlesen habe ich folgende Settings für mich herausgefunden und die Lautstärkeunterschiede nach beenden des MPlayer sind Vergangenheit. Auch Filme die vorher deutlich zu leise waren sind nun ok.


    Meine Options:

    Code
    1. -softvol -softvol-max 500 -volstep 5


    Die Schritte in der die Lautstärke geregelt wird unterscheiden sich zwar etwas vom VDR selbst, aber das passte vorher auch schon nicht. Um im MPlayer die maximal mögliche Lautstärke zu erreichen muss der Volume Regler einmal unter die hälfte und dann wieder voll aufgedreht werden.



    Probiert es mal aus.


    EDIT: Wem das immer noch zu leise ist der kann mal versuchen den -softvol-max Wert stufenweise bis max. 1000 zu erhöhen. Wenn es zuviel wird beginnt es auch hier zu verzerren. Man muss ein bisschen probieren um einen guten Mittelwertwert zu finden der für alle Videos passt.

  • Ich nochmal.
    Ich habe nun doch noch ein "-af volnorm" dazugetan. Diese Option hebt den Pegel des Audiosignals auf den maximal möglichen verzerrungsfreien Pegel an. Dies ist sehr nützlich bei Filmen die von sich aus schon einen sehr leisen Ton haben.


    Meine zusätzlichen Options sehen nun so aus.


    Code
    1. -af volnorm -softvol -softvol-max 400 -volstep 5


    Nun ist es für mich fast Perfekt.

  • Bringt hier leider auch nix. Mit softvol-max auf 1000 krieg ich allenfalls ein Fluestern rein wenn ich voll aufdreh....



    <ratlos sei>



    Korrektur:


    Es geht, allerdings verhaelt es sich strange. Wenn das avi startet ist erstmal der Ton weg. Ich muss ein wenig leise und dann wieder laut regeln und der Ton kommt ploetzlich.


    Danke Dir!

  • Hast du das "-af volnorm" dazu auch schon probiert ?


    Wenn das alles garnichts bringt wundert mich das schon, bei mir waren die Änderungen sehr deutlich merkbar. Bist Du sicher das du die richtige mplayer.sh.conf editierst die auch benutzt wird ?

  • Zitat

    Original von q-man


    Es geht, allerdings verhaelt es sich strange. Wenn das avi startet ist erstmal der Ton weg. Ich muss ein wenig leise und dann wieder laut regeln und der Ton kommt ploetzlich.



    Ja, das hatte ich ja oben geschrieben. Damit kann ich jedenfalls deutlich besser leben als mit diesen riesen Lautstärke unterschieden.


    Zitat


    Danke Dir!


    Bitte Bitte

  • Hmmm das hatte ich wohl ueberlesen mit dem hoch-runterregeln. Ich hab deinen Tip mal ins VDR-Wiki gestellt, damit die Leute nicht immer im Forum rumwuehlen muessen.


    Tadaaa Mein erster Wiki Eintrag. Ist Punkt 10.3 auf der mplayer-plugin Seite. Wenn was fehlt bitte adden.


    Das mit den Musikvideos ist bloed. Ich schau hier regelmaessig AMVs.
    Ohne volnorm funktioniert das aber bei mir ueberhaupt nicht. Dann ist der Ton bei allen Videos fast ganz weg.


    Gruss
    q-man

  • Hmm mal ne doof frage, wo versteckt sich denn die mplayer.sh.conf?


    Ich hab jetzt unter /usr/local/bin/mplayer.sh.conf und
    /etc/vdr/mplayer.sh.conf geschaut, nix zu gefunden.
    Danke im vorraus

    „Vielen Dank für die Beachtung aller Sicherheitsmaßnahmen.“


    easyVDR 0.6.06 Kernel: 2.6.22.15
    Videokarte(n): Air2PC/AirStar 2 DVB-T, Fujitsu Siemens DVB-C, Terratec Cinergy DVB-C ,Hauppauge PVR-350

  • Hi,


    wer suchet, der findet:

    Code
    1. linvdr:~# find / -name mplayer.sh.conf
    2. /usr/bin/mplayer.sh.conf

    yaVDR 0.4 * M4N78PRO * AMD Athlon II X2 240 * TT S2 3200 * 2 x SkyStar 2.6D * LianLi C33 * Atric IR Einschalter * KingSpec 16GB SSD * 2TB HDD * Samsung LE37B530

  • mit der Funktion (-af volnorm -softvol -softvol-max 400 -volstep 5) startet der mplayer erst gar nicht. Das mit -softvol bezieht sich doch nicht auf die Soundausgabe einer DVB-s Karte sondern über eine Soundkartenlösung, oder irre ich da? Hätte gern eine Lösung ohne extra Soundkarte.