[gelöst] NVRAM mit ECS661FX-M ???

  • Hallo,
    ich habe mir einen neuen Rechner zugelegt, mit 3 Gedanken:
    -schön leise (leises Netzteil im HPC-03A, Vorn/CPUKühler 80mm und Hinten 2x60mm Ausgetauscht zu je ~12 dba)
    -schnelles Booten (ECS661FX-M mit momentan 25s Linvdr-cody) aber Vorbild sind 17s von obi http://www.vdr-wiki.de/wiki/index.php/VDR_Bootzeiten
    -genug Leistung (Celeron 1,7 Ghz, 512MB RAM, 3d unter XP)


    Nur das Wakeup konnte ich noch nicht einrichten (obi habe ich schon geschrieben).


    Hat jemand ein Board mit dem Sis661 laufen?
    Geht NVRAM?


    Mein Versuch nach Sandmann:


    Das Board hat Wakeup mit Tag, Monat und Uhrzeit (+RESUME BY RING, RESUME BY MACPME... ?(). Wegen der Monatsangabe kam es vielleicht zu einen Fehler bei Installation nach Anleitung.
    Neu gesetzte Werte(min,mitte,max) brachten diese nvram_wakeup.conf:

    ################################################
    ## Mainboard autodetection information:
    ##
    ## - Mainboard vendor: ""
    ## - Mainboard type: "SiS-661"
    ## - Mainboard revision: ""
    ## - BIOS vendor: "Phoenix Technologies, LTD"
    ## - BIOS version: "6.00 PG"
    ## - BIOS release: "01/10/2005"
    addr_stat = 0x32 # but differs somewhere else
    addr_mon = 0x32 # but differs somewhere else
    shift_mon = 4
    addr_hour = 0x34
    addr_min = 0x35
    addr_sec = 0x36
    rtc_mon = 0x71 # but differs somewhere else
    reset_mon = ON

    Hat jemand eine korrekte nvram_wakeup.conf für ECS661FX-M?
    Bistr-o-Math kannst du mir weiterhelfen? hier meine debug


    Nando


    [Blocked Image: http://www.nando-hiller.de/dateien/HPC-03A.jpg]

    TEST FOXCONN 560A "Cool`n`Quiet"
    Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
    Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF


    Activy 300
    Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
    Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

    The post was edited 2 times, last by netz ().

  • Hallo,
    habe mal weiter probiert. Jetzt ist nur noch die frage, wie sieht die richtige nvram-wakeup.conf aus.???
    Sagt das debug unten alles ist gut so???


    :hilfe



    TEST FOXCONN 560A "Cool`n`Quiet"
    Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
    Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF


    Activy 300
    Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
    Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

  • Hallo,
    wie war das mit NVRAM und den Risiken? Kann ich meine nvram-wakeup.conf ohne Gefahr testen? (hochschieb als Hintergedanken ;))


    bis dann,
    Nando

    TEST FOXCONN 560A "Cool`n`Quiet"
    Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
    Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF


    Activy 300
    Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
    Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

  • Hallo,
    ich habe dann doch auf mein Risiko folgende nvram-wakeup.conf getestet.



    Code
    1. ./nvram-wakeup --configfile=/etc/nvram-wakeup.conf -s $((`date +%s` + 60 * 10 + 1))
    2. shutdown -r now

    und nach dem Neustart

    Code
    1. ./nvram-wakeup --configfile=/etc/nvram-wakeup.conf -d shutdown -h now

    (für abschalten des Timers)


    Der Rechner fuhr dennoch hoch ->
    NVRAM funktioniert also, braucht aber ein reboot.


    Jedoch bekomme ich noch eine Fehlermeldung

    Code
    1. cmos checksum error defaults loaded


    Kann mir nicht einer weiterhelfen??? Das ist noch nicht das Wahre.


    danke,
    Nando

    TEST FOXCONN 560A "Cool`n`Quiet"
    Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
    Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF


    Activy 300
    Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
    Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

  • Hallo Bistr-o-Math,
    danke für deine Hilfe. :D
    Ich habe nochmal die zwei Varianten, ganz frisch, mit guess-helper probiert.
    Es sind ja mehrere guess-error.log's und um ein Wirrwarr zu vermeiden habe ich alles in ein FTP-Verzeichniss gestellt. Die Daten aus root liegen alle unter
    NVRAM-Daten


    <<<edit>>>
    ?APIC Mode ist eingeschalten im Bios? (keine Ahnung ob es aus sein sollte)
    Ist es besser nach Checksum ERROR beim Booten ein CMOS Reset über Jumper zu machen, oder hat es keinen Einfluß? (geschah wie beschrieben nach deaktivieren der Wakeup-Funktion mittels "nvram-wakeup --configfile=/etc/nvram-wakeup.conf -d")


    Das im Verzeichniss ./monat_12_10_1_als_werte sind Daten des Versuches mit der Verwendung des Monat mit den Werten:
    Monat 12
    Tag 31
    Stunde 23
    Minute 59
    Sekunde 59


    Monat 10
    Tag 11
    Stunde 12
    Minute 13
    Sekunde 14


    Monat 1
    Tag 0
    Stunde 0
    Minute 0
    Sekunde 0


    und abgeschaltet.


    Das im Verzeichniss ./monat_n_a sind Daten des Versuches mit Monat n/a und den vorgegebenen Werten.


    bis dann,
    Nando

    TEST FOXCONN 560A "Cool`n`Quiet"
    Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
    Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF


    Activy 300
    Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
    Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

    The post was edited 1 time, last by netz ().

  • versuch mal das:


    um einen checksum error zu vermeiden, kannst du ja erst --nowrite benutzen, abschreiben, welche werte (inklusive Checksumme) nvram-wakeup gesetzt haette


    dann ins BIOS gehen und dieselben Werte eingeben, anschliessend nvram-wakeup laufen lassen und checken ob BIOS dieselbe Checksumme geschrieben hat wie nvram-wakeup dies zuvor gemacht haette.

  • Hallo Bistr-o-Math,
    :Dich bin fast glücklich :D Ich glaube deine nvram-wakeup.conf funktioniert.
    Ist das ein Record in der Länge der Datei (34 Zeilen)? :] Eingerichtet habe ich es jetzt mit reboot, war nicht gerade einfach.


    Eine kleine Frage noch, kann ein Fehler in der nvram-wakeup.conf für Zeitsprünge um wenige Minuten in der Bios-Uhr verantwortlich seien?


    Eine Änderung des defaults im Grub von einer Parallelinstallation aus, ist dir nicht bekannt, oder? Bei mir soll wieder Suse 9.3 (Grub 0.95) und linvdr (Grub 0.94) parallel laufen.


    --> Was jetzt läuft:
    linvdr-cody-1.3.27 mit nvram
    grub 0.94, linvdr, Kernel 2.6.12.2
    vdrshutdown von nvram-wakeup-0.97


    --> geänderte Dateien


    /etc/init.d/runvdr
    ... -E /ramdisk/epg.data -s /usr/bin/vdrshutdown ...


    /etc/modules
    ...
    #snd-pcm-oss
    nvram
    ...


    /etc/acpi/events/powerbtn
    event=button[ /]power
    action=/usr/bin/svdrpsend.pl HITK Power


    /usr/bin/vdrshutdown
    ...
    # Add here needed options like --configfile=...
    # (read 'man nvram-wakeup' and 'man nvram-wakeup.conf' for more details)
    $NVRAMCMD --syslog --directisa -C /etc/nvram-wakeup.conf --settime $1
    ...
    case $PIPESTATUS in
    0) # all went ok - new date and time set
    poweroff
    EXITSTATUS=0
    ;;
    1) # all went ok - new date and time set.
    #
    # *** but we need to reboot. ***
    #
    echo -e "savedefault --default=5 --once\nquit" | /sbin/grub --batch
    reboot
    EXITSTATUS=0
    ;;
    2) # something went wrong
    # don't do anything - just exit with status 1
    EXITSTATUS=1
    ;;
    ...


    /boot/grub/menu.lst
    ...
    title PowerOff
    savedefault 0
    halt

    TEST FOXCONN 560A "Cool`n`Quiet"
    Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
    Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF


    Activy 300
    Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
    Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

    The post was edited 2 times, last by netz ().

  • ...habs kappiert.


    "need_reboot = ON_ANY_CHANGE" muß in die nvram-wakeup.conf für die Fallunterscheidung -> Änderung reboot oder keine Änderung poweroff


    Fehler war in meiner geänderten vdrshutdown mit dem Grub-Befehl (glaube ich), deshalb kam es nicht zum reboot oder poweroff. Jetzt geht es. Ich habe es weiter oben geändert. Er fährt runter wenn er nix zu tun hat und startet für Timer. Bei Änderungen in nvram folgt ein reboot und ausschalten.


    bis dann,
    Nando

    TEST FOXCONN 560A "Cool`n`Quiet"
    Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
    Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF


    Activy 300
    Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
    Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

    The post was edited 2 times, last by netz ().