nvram geht, aber nicht unter VDR

  • Hallo Leute,


    ich habe kürzlich das ct VDR über auto26 (also 2.6er kernel) installiert (athlon 64 3000+, 512MB, Sata platte mit (im Moment) onboard sound des boards, 2 skystar2 budget karten, ausgabe über nvidia 5200 mittels xine).
    Habe das


    nvram-wakeup -s $((`date +%s` + 11 * 60)) --directisa


    ausgeführt und ohne Reboot startet der Rechner wieder hoch. Habe auch


    ENABLED=yes
    COMMANDLINE="--directisa"
    SPECIALSHUTDOWN="lilo -R PowerOff ; shutdown -r now"
    FORCE_REBOOT="yes"


    in der /etc/vdr/vdr-nvram-wakeup.conf eingetragen.
    Doch nach dem ich dem Timer eine Aufnahme gegeben habe, mit VDR shutdown gemacht habe, wacht der Rechner nicht mehr auf. Was habe ich vergessen? Könnt Ihr mir helfen?

  • Wenn er ohne reboot startet,dann brauchst Du doch das special SHUTDWNCMD nicht - oder ?


    Ich habe im Moment auch so meine Probleme mit nvram-wakeup (siehe meine aktuellen Threads hier ...) - das ist nur noch viel komischer, weil der Rechner gar nicht
    erst anhält, wenn ich den PowerOff-Reboot mache ... :rolleyes:

  • Hallo berni123,


    leider hat es auch ohne special SHUTDWNCMD nicht geklappt. Wie kann ich sehen, ob die /etc/vdr/vdr-nvram-wakeup.conf überhaupt gelesen wird? Also ob VDR das benutzt?


    Hallo Nippes,


    soll ich also doch einen SPECIALSHUTDOWN herstellen im grub? Das wird ja richtig lustig hier!

  • Hi,


    in /usr/share/vdr[devel]/shutdown-hooks findet sich das Skript S90.nvram-wakeup. Dort wird /etc/vdr[devel]/vdr-nvram-wakeup.conf ausgelesen.


    Wenn das Skript richtig aufgerufen wird, sollten sich in /var/log/messages entsprechende Nachrichten finden.


    Mit dem Befehl "grep nvram /var/log/messages" einfach mal nachschauen.


    Bei der ctvdr4 Version ist nvram-wakeup leider nicht implementiert. Man muß es von Hand nachtragen. :-( Siehe anderer Thread.


    Gruß

    yavdr 0.5, AMD Athlon(tm) II X2 240e, MSI 770-C45, 4GB, Cine S2, Terratec Cinergy S2 PCI HD, TechniSat SkyStar2 DVB-S, TechniSat AirStar2 DVB-T

  • Hallo nippes,


    danke für den Tipp! Habe nachgesehen was von nvram-wakeuo schon installiert war: es fehlte das vdrdevel-addon-nvram-wakeup. Habe es installiert. Und jetzt wenn ich den Timer programmiere und dann über VDR den Rechner auschalte sagt VDR:
    - shutdown abgebrochen
    - nvram-wakeup could not set time
    :rolleyes:


    Hier noch die /var/log/ messages


    Jul 24 15:00:28 Beatrice vdrdevel-shutdown: executing /usr/share/vdrdevel/shutdo wn-hooks/S90.nvram-wakeup as shell script
    Jul 24 15:00:28 Beatrice vdr-nvram-wakeup: /usr/sbin/nvram-wakeup -ls 1122212100
    Jul 24 15:00:28 Beatrice vdr-nvram-wakeup: nvram-wakeup: could not set time, shu tdown will be aborted
    Jul 24 15:00:28 Beatrice vdrdevel-shutdown: Shutdown aborted by /usr/share/vdrde vel/shutdown-hooks/S90.nvram-wakeup with exitcode 1
    Jul 24 15:00:31 Beatrice vdr[6185]: SVDRP message: 'nvram-wakeup could not set t ime'
    Jul 24 15:00:33 Beatrice vdr[6185]: info: nvram-wakeup could not set time
    Jul 24 15:00:49 Beatrice vdrdevel-shutdown: executing /usr/share/vdrdevel/shutdo wn-hooks/S90.nvram-wakeup as shell script
    Jul 24 15:00:49 Beatrice vdr-nvram-wakeup: /usr/sbin/nvram-wakeup -ls 1122212100
    Jul 24 15:00:49 Beatrice vdr-nvram-wakeup: nvram-wakeup: could not set time, shu tdown will be aborted
    Jul 24 15:00:49 Beatrice vdrdevel-shutdown: Shutdown aborted by /usr/share/vdrde vel/shutdown-hooks/S90.nvram-wakeup with exitcode 1
    Jul 24 15:00:52 Beatrice vdr[6185]: SVDRP message: 'nvram-wakeup could not set t ime'
    Jul 24 15:00:54 Beatrice vdr[6185]: info: nvram-wakeup could not set time



    Habe mit nvram-wakeup -s $((`date +%s` + 11 * 60)) --directisa überpruft ob das nvram noch get. Der Rechner geht nach 6 Min wieder an. Habe mich auch als Root eingeloggt und das Ganze durchgeführt um zu sehen ob ich zu wenig Rechte habe .. . war es aber nicht. :(
    Was fehlt den jetzt?

  • Hi,


    bei mir stand in /etc/vdr[devel]/vdr-nvram-wakeup.conf ein falscher COMMANDLINE Eintrag.


    COMMANDLINE="-C /etc/nvram-wakeup.conf" verweist auf eine Beispiel .conf-Datei.


    Bei dir könnte COMMANDLINE="-- directisa" richtig sein.


    Gruß.

    yavdr 0.5, AMD Athlon(tm) II X2 240e, MSI 770-C45, 4GB, Cine S2, Terratec Cinergy S2 PCI HD, TechniSat SkyStar2 DVB-S, TechniSat AirStar2 DVB-T

  • Hallo nippes,


    SUUPER mit deiner Hilfe habe ich es hinbekommen! :D
    Also folgendes war es:


    1. vdrdevel-addon-nvram-wakeup fehlt in der ct-VDR Distribution und muss nach-installiert werden


    2. in der /etc/vdr/vdr-nvram-wakeup.conf


    ENABLED="yes"
    COMMANDLINE="--directisa"
    SPECIALSHUTDOWN="lilo -R PowerOff ; shutdown -h now"
    FORCE_REBOOT="no"


    eintragen. Dabei beachten, dass bei meinem Rechner NICHT rebootet werden soll (rot markiert).


    3. in der /etc/vdr/vdr-nvram-wakeup.conf nachsehen dass keine weiteren COMMANDLINE="" und SPECIALSHUTDOWN="" vorhanden sind! ;D


    Gruss


    Alex