XXV und Suse 9.3

  • alle benötigten perl module installieren. Datenbank einrichten (user berechtigungen usw.) und dann xxv entpacken und konfigurieren und dann halt starten

    Aktuelle Systeme:
    VDR-Server: MSI KT6A Ultra FISR ; Athlon XP 2200+ ; GrKa Geforce 2 MX; 256MB DDR-SDRam Plugins: streamdev-server, remote
    2 x DVB-Budget Karte, Gentoo, Kernel 2.6.8 usw....

  • Sorry es war wohl nicht ausführlich genug. Es gibt bei Suse 9.3 die Problematik, dass xxv abstürzt.


    Stand der Dinge: Perl per Yast2 installiert, und die fehlenden Module mit cpan installiert --> funktioniert nicht bzw absturz.


    Hat es jemand erfolgreich am laufen, wenn ja wie?


    Emanuel

  • Mit dem durch Suse 9.3 mitgebrachten Perl funktionierte bei mir xxv auch nicht. Ich habe mir bei http://www.activestate.com/ das aktuelle 5.8er rpm Packet gezogen und installiert.
    Anschliessend habe ich folgende Dateien in /usr/bin umbenannt nach cpan.orig, perl.orig, perl5.8.6.orig, perlbug.orig, perlcc.orig, perldoc.orig und perlivp.orig. Anschliessend noch die umbenannten Dateien durch die durch ActiveState perl ersetzt. z.B. ln -s /usr/local/ActivePerl-5.8/bin/perl /usr/bin/perl
    Und nun müssen die cpan bzw. ppm Packete für xxv installiert werden.

    Gruß
    Frodo

  • Hi,


    also ich hab mich auch lange mit XXV&&SuSE 9.3 abgequält und konnte es nur mit Hilfe von Frank99 zum Laufen bekommen.


    Was hab ich gemacht?


    Ich hab mir Perl 5.9.2 aus den Sourcen mit "sh configure.sh -de" kompiliert und alles auf Default gelassen. Danach hab ich nur den Link /usr/bin/perl auf /usr/local/bin/perl5.9.2 umgebogen und die Perl-Module mit CPAN installiert. Bei mir musste aber auch das Modul "Mechanize-FormFiller" nochmal im ~/.cpan/build/ mit "perl Makefile.PL && make && make install" nochmal kompilieren lassen. Seitdem läuft es einwandfrei.


    Dass dann beim Starten mit perl 5.9.2 eine Fehlermeldung kommt, kann man ignorieren oder aber in der bemängelten Datei das "require 5.6.8" auskommentieren.


    Das man so einen Aufwand mit dem neuen SuSE betreiben muss störte mich auch gewaltig, zudem die Distri eigentlich was VDR betrifft einen sehr guten Eindruck macht.


    P.S.:Webmin läuft bei mir noch. Hab lediglich dass schon unter 5.6.7 installierte SSL Perl Modul neu machen müssen, aber das macht Webmin ja alles für dich ;)

    Gruß
    Habib


    --------------------------------
    Aufnahme-Server:
    Silverstone Lascala SST-LC10M
    Reel Stable 11.12.2, HDe, 1x 2TB HDD als Aufnahme Server, iVDR 0.3.2 (manuelle Fixe f. Aufnahmeverz.)
    Netceiver mit 3x DUAL DVB-S2
    Clients:
    3x REEL NetClients
    Reel Stable 11.12.2

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Habib ()

  • Hat hier jemand eine Ahnung, wieso das mitgelieferte Perl von der SuSE 9.3 defekt ist, bzw. wo dort das Problem liegt?


    Eventuell gibt es ja schon ein offizielles Update bevor man hier mühsam alles selber einspielt...

  • Hallo,


    Zitat

    Hat hier jemand eine Ahnung, wieso das mitgelieferte Perl von der SuSE 9.3 defekt ist, bzw. wo dort das Problem liegt?


    hat jemand schon eine Ahnung?


    Mfg Josef

    registered VDR-User: #1013


    Hardware: Asus A7V133 / 640 MB Ram / Athlon TB 1000 / SanDisk Ultra II 1GB / Samsung 120 GB + 160 GB/ Nec 1300 / TT 1.5 + Extension Board / TT Budget / GLCD 240x64


    Software: LinVDR 0.7 - vdr-1.4.3-2 - Kernel-2.6.18 auf CF-Card ... 384 MB LiveBuffer auf Ramdisk

  • Hallo,


    der Fehler tritt im Perl Modul Event auf. Auch ein aktualisieren des Event Moduls auf eine neuere Version löst das Problem leider nicht.
    Dies allerdings nur wenn Perl mit einem bestimmten Parameter kompiliert wurde, welcher genau ist noch unbekannt.
    Wer sich mal durch die Installation und die ganzen Abfragen einer Perl Installation durchgekämpft hat, kann verstehen warum noch keiner versucht hat den entsprechenden Parameter zu suchen ;-)


    Hier die Codestelle an der sich der Fehler bemerkbar macht im Modul HTTPD.pm ab etwa Zeile 154:



    Der Fehler tritt zwischen Schritt 5 und Schritt 6 auf.


    Bye,
    Frank

  • Hallo,
    Frank99 : Danke für Deine Antwort.


    Also ist die einzige Möglichkeit, wie ich perl und damit xxv unter Suse 9.3 anständigen zum Laufen bringen kann so vorzugehen, wie es Habib beschreibt: Die Sourcen ziehen und händisch installieren...



    Mfg Josef

    registered VDR-User: #1013


    Hardware: Asus A7V133 / 640 MB Ram / Athlon TB 1000 / SanDisk Ultra II 1GB / Samsung 120 GB + 160 GB/ Nec 1300 / TT 1.5 + Extension Board / TT Budget / GLCD 240x64


    Software: LinVDR 0.7 - vdr-1.4.3-2 - Kernel-2.6.18 auf CF-Card ... 384 MB LiveBuffer auf Ramdisk

  • Hallo Josef,


    es gibt bisher 2 Möglichkeiten:


    1) ActivePerl -> http://www.activestate.com/ -> siehe Frodos Posting weiter oben


    2) Perl 5.9.2 -> Habib Posting


    Zu Methode 1 kann ich dir nicht sagen aber siehe oben.


    Wen du die 2. Methode nutzen willst hier noch ein paar Tips:
    Unter Webmin -> Sonstiges -> Perl-Module (CPAN) VORHER per Copy&Paste dir die Liste der Module sichern.
    Nach der Installation von Perl 5.9.2 musst du nun ALLE benötigten Module wieder installieren auch die mitgelieferten von Suse!!! Dabei hilft dir die Liste der vorher vorhandenen Module. Im neuen Perl ist nämlich kein einziges Modul enthalten!
    Nicht erschrecken du hast dann unter Webmin die Module 2X drinn einmal für die alte und 1x für die neue Perl Version.


    Wenn du nicht die Möglichkeit hast die Modul per CPAN zu installieren vergiss diese Möglichkeit!!!
    Ich hatte einen halben Tag verschwendet die Module per Hand vom Source zu installieren, aber die Abhängigkeiten sind dann so komplex das ich aufgegeben habe und soweit wie möglich alles per CPAN installiert habe. Und ich gebe nur sehr selten auf ;-)


    Einen Bug hat diese Lösung aber noch, zumindest bei mir:
    Unter tvmovie2vdr steigt zeitweise mein RAM Verbrauch beim Import der Infossat Daten von etwa 60 auf 250 MB RAM!



    Bye,
    Frank

  • Hallo,
    Oje, das klingt ja ziemlich aufwendig....



    --> "Frodo - Methode" = Methode 1


    Emanuel :
    Wie sieht es bei Dir aus? Funktioniert mitlerweile alles wie gewünscht?



    --> "Habib - Methode" = Methode 2
    Frank99 :
    Ich schätze mal Du gehts davon aus, dass ich Perl schon installiert habe, oder? Hab eine minimal Installation ohne Perl etc. Muss ich jetzt erst Perl installieren, mir dann die Liste der Module holen? Kann ich Perl (von Suse) dann wieder deinstallieren?


    Die einzelnen Module, die in der Liste von Suse drinstanden hole ich mir mit CPAN (geht zum Glück) zusätzlich noch die Module für xxv und das Teil sollte rennen.


    Hab ich das jetzt soweit richtig verstanden?




    Mfg Josef

    registered VDR-User: #1013


    Hardware: Asus A7V133 / 640 MB Ram / Athlon TB 1000 / SanDisk Ultra II 1GB / Samsung 120 GB + 160 GB/ Nec 1300 / TT 1.5 + Extension Board / TT Budget / GLCD 240x64


    Software: LinVDR 0.7 - vdr-1.4.3-2 - Kernel-2.6.18 auf CF-Card ... 384 MB LiveBuffer auf Ramdisk

  • Emanuel
    leider nein, laut Hulk(Andreas) wäre das der ganz normale Aufruf für dieses Modul :-(


    JosefGierl
    Du hast wirklich ein Linux ohne Perl? Naja auch in Ordnung dann musst du nur die Module installieren die XXV benötigt.
    Mich stört es auf meiner Kiste nicht wenn noch die überreste der alten Perl Installation draufliegen.
    Mach trotzdem lieber vorher mit Partimage eine Sicherung, man weis ja nie ;-)


    So ich ärgere mich weiter mit dem blöden lirc um meine X10 endlich zum laufen zu bekommen...


    Bye,
    Frank

  • Hallo!


    Gibt es eigentlich eine Lösung, die das Paketsystem nicht sabotiert? Wenn ich Perl aus den Sourcen "an RPM vorbei" installiere, habe ich doch für immer RPM-Abhängigkeitsgenörgel oder Mehrdeutigkeiten zwischen RPM und /usr/local.


    Ich hatte das selbe Problem und versucht, es mit einem src-RPM zu lösen. Die globalen RPM-Bau-Optionen stehen in /usr/lib/rpm/rpmrc. Dort habe ich für meine Architektur vorübergehend das -g entfernt und perl per rpmbuild --rebuild perl-...-src.rpm gebaut. Das erzeugte RPM lässt sich problemlos installieren und die anderen SuSE-perl-Pakete scheinen auch noch zu passen.


    Damit verschwindet der Fehler bei event.pm und xxvd läuft halbwegs richtig los (musste -evtl. aus anderen Gründen- grab ausschalten). Bin mir leider nicht sicher, ob alles geht. Es war in letzter Zeit schon öfter die Datenbank kaputt und ich musste sie mit contrib/update-xxv wieder herstellen.


    Wollte ich nur mal loswerden, viele Grüße
    borg

  • Hallo,
    gibts eigentlich schon was Neues? Also evtl. ein "funktionierendes" Perl von Suse oder von jemand anderem?




    Mfg Josef

    registered VDR-User: #1013


    Hardware: Asus A7V133 / 640 MB Ram / Athlon TB 1000 / SanDisk Ultra II 1GB / Samsung 120 GB + 160 GB/ Nec 1300 / TT 1.5 + Extension Board / TT Budget / GLCD 240x64


    Software: LinVDR 0.7 - vdr-1.4.3-2 - Kernel-2.6.18 auf CF-Card ... 384 MB LiveBuffer auf Ramdisk

  • Hallo,


    Zitat


    Es gibt nichts neues, bei mir funktioniert alles mit der "Habib - Methode" = Methode 2.


    Dann werd ich das auch so machen. Wie Frank schreib ist es wohl am besten wenn man sich erst über webmin die ganzen perl-Module "aufschreibt". Bei mir (CDs) scheint das Paket nicht dabei zu sein.


    Werds mir dann hatl von webmin.com holen. Kanns leider nicht testen hobs funktioniert, darum frag ich erst (hab nur ISDN ;() Ist das das Richtige?
    webmin-1.220-1.noarch.rpm (RPM suitable for Redhat, Caldera, SuSE, Mandrake or MSC Linux, 9468 kB)


    Brauch ich die Source auch:
    webmin-1.220-1.src.rpm (Source RPM suitable for Redhat, Caldera, SuSE, Mandrake or MSC Linux, 8417 kB)



    Mfg Josef

    registered VDR-User: #1013


    Hardware: Asus A7V133 / 640 MB Ram / Athlon TB 1000 / SanDisk Ultra II 1GB / Samsung 120 GB + 160 GB/ Nec 1300 / TT 1.5 + Extension Board / TT Budget / GLCD 240x64


    Software: LinVDR 0.7 - vdr-1.4.3-2 - Kernel-2.6.18 auf CF-Card ... 384 MB LiveBuffer auf Ramdisk