Gelöst Rechner schaltet nach dem runterfahren nicht ab

  • Hallo Leute,


    leider schaltet sich mein c´tvdr (v 3.06) nach dem runterfahren nicht ab ;( 
    Alles Andere funktioniert soweit klaglos, nur nach dem Abschaltkommando fährt das Teil halt runter und bleibt dann mit der letzten Aufschrift: Power down weiter "unter Strom". Es ist noch kein so altes Board von MSI: MS-6309, mit neuestem BIOS, P III / 450MHz, Samsung HD 160GB, usw.


    Folgendes habe ich in /etc/lilo.conf bereits probiert:

    1: append = "apm = "apm=power-off no apic"
    2: append = "acpi=on"

    anschließend natürlich lilo auf der console aufgerufen, dabei gibt es eine Warnung:

    >Warning: COMPACT may conflict with LBA32 of some systems


    weiss einer Abhilfe hierfür? vielen Dank - Tobias

  • bei lsmod sollte auch das Modul apm dabeistehen.
    Wenn nicht, dann einfach mal laden ("modprobe apm") und dann den Rechner runterfahren.
    Wenn das klappt, kannst du das in die /etc/modules eintragen. Dann wird es beim Start automatisch geladen.


    Gruß
    Mag1c


  • Erstes ist nicht ganz korrekt:
    1. immer append "...."; bei dir sind zu viele "
    2. parameter sind falsch:

    • apm=[on|off|power-off]
    • acpi=[on|off|force]
    • noapic


    Müsste also richtig heissen:

    1: append = "apm=power-off noapic"


    Bei alten boards sollte man ACPI aber besser erzwingen:

    1: append = "apm=off acpi=force"

    Das sorgt auch dafür das apm wirklich nicht verwendet wird
    Hab damit ein altes P2 board am laufen wo bios noch nix von ACPI sagt.


    Alternativ dann mit APM:

    1: append = "apm=on acpi=off"



    Zitat

    mit lsmod wird kein Modul apm angezeigt und folgendes bei Eingabe von:


    >modprobe apm
    modprobe: Can´t locate module apm


    APM ist im kernel


    gruss Peter

    Mein anderer VDR ist (auch) ein EPIA
    1)VIA M10000-Nehemiah, 160+120G Samsung; NEC 1300A; YY A106; LCD20x4 ...
    2) ctvdr+e-tobi ; C3M266+1,2GHz-Nehmiah; 160G Samsung + 4x500G Seagate SATA; NEC3500; TT-Case; DVB-S 1.3+4MB + Nova ; gLCD 240x128 ...
    . . .TB rulez. . .

  • Hurra, es klappt :]


    PeterD
    vielen Dank, Deine ausführlichen Hinweise waren sehr hilfreich. Letzlich hat folgendes geholfen: im BIOS APM aktivieren (muss ich anfänglich übersehen haben) und die vorgeschlagene Zeile:

    append = "apm=on acpi=off"


    Mit meinen (noch) geringen Linux-Kenntnissen ließ sich acpi nicht verwenden, mit apm klappt es nun.


    Grüße vom glücklichen seaman 8)

  • Zitat

    Original von seaman
    Mit meinen (noch) geringen Linux-Kenntnissen ließ sich acpi nicht verwenden, mit apm klappt es nun.


    Für acpi:
    apt-get install acpid

    VDR 1.7.15 - Debian Squeeze/Kernel 2.6.32
    Rebach-Gehäuse, Intel Atom330, Extension HD, Technisat Cablestar2

  • Sorry, daß ich diesen Thread nochmal ausgrabe, aber ich komme einfach nicht weiter.


    Nachdem ich in meinem vdr2 das Mainboard getauscht habe, will der
    Rechner nach dem runterfahren nicht ausschalten.
    Mainboard vorher:
    Asus CUSL2-C - schaltet ab ohne apm/acpi-Parameter in der Kernel-Zeile.


    Mainboard neu:
    CUSL2 (ohne C) - will nicht ausschalten, stattdessen wird neu gebootet


    Habe nun einige Parameter, wie hier im Thread erwähnt, versucht aber
    leider keine Besserung.


    apm=on acpi=off
    Shutdown hdX ...
    System halted.
    -> Rechner geht nicht aus


    apm=power-off noapic
    -> Rechner startet neu


    apm=off acpi=force
    -> Rechner startet neu


    apm=on acpi=off
    Shutdown hdX ...
    System halted.
    -> Rechner geht nicht aus

    USER: EX-Aman
    seit kurzem produktiv: VDR SZ: Geh.: MS-Tech LC-02 / Asus M3N78-EM / DVB-S: 2xCTX929 / IR-Einschalter / nvidia-vdpau / USB-Boot... easyVDR 1.0
    zZ noch produktiv VDR-WZ: Low-Budget -- Asus A7V133/1700+/Nova-S/GeForce 5500/4:3 Röhre - XBMC + easyVDR 0.8 ohne vdpau
    zZ Testsystem: Digitainer-Gehäuse / Asus M3N78-EM / DVB-S: 2xNova-S / Medion X10 / nvidia-vdpau / USB-Boot... easyVDR 1.0
    Bastelstatus: O2 Joggler - YaVDR
    ... Dockstar für Aufnahmen ...

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Aman ()

  • GELÖST:


    Die BIOS-Option Wake-on-Lan war aktiv und das WOL-Kabel falsch
    gepolt, d.h. Standby-Spannung und WOL-Signal waren vertauscht,
    da hat das Board beim runterfahren 'gedacht', es liegt ein WOL-Signal an
    und es muß nun aufwachen ...

    USER: EX-Aman
    seit kurzem produktiv: VDR SZ: Geh.: MS-Tech LC-02 / Asus M3N78-EM / DVB-S: 2xCTX929 / IR-Einschalter / nvidia-vdpau / USB-Boot... easyVDR 1.0
    zZ noch produktiv VDR-WZ: Low-Budget -- Asus A7V133/1700+/Nova-S/GeForce 5500/4:3 Röhre - XBMC + easyVDR 0.8 ohne vdpau
    zZ Testsystem: Digitainer-Gehäuse / Asus M3N78-EM / DVB-S: 2xNova-S / Medion X10 / nvidia-vdpau / USB-Boot... easyVDR 1.0
    Bastelstatus: O2 Joggler - YaVDR
    ... Dockstar für Aufnahmen ...

  • ...Geilheit die mich packte!!!


    Hier die Bestätigung, daß es auch mit Grub klappt:


    In die Menu.lst

    Code
    1. apm=on acpi=off

    eingetragen


    in die Datei /etc/modules


    Code
    1. apm


    angehängt und läuft wie geschmiert. Ich war echt frustiert, weil der Rechner beim ctvdr4.5 vorher (fast*) einwandfrei runterfuhr!!!


    Dank an PeterD und Mag1c! Meine alte Möhre läuft jetzt wie die Wutz. :vdr1



    *fast deshalb, weil er dummerweise nicht über den sleeptimer, sondern nur über den direkten Befehl


    Code
    1. /usr/bin/poweroffvdr


    z.B. im crontab eingetragen runterfuhr!!

  • Hola DWOE,


    entschuldigung, für die lange Antwortphase....


    Die Parameter gehören alle in die Zeile wo der Linuxkernel geladen wird. (glaube da steht ein "KERNEL" zu Beginn der Zeile


    Code
    1. title VDR linux (2.6.18-10ctvdr_spezial_sonderkernel)
    2. root (hda 0,0)
    3. kernel /vmlinuz-2.6.18-10ctvdr_spezial_sonderkernel root = dev/hda5 apm=on acpi=off video=vesafb:1024x768-16@72 vga=791 ro
    4. initrd /initrd--2.6.18-10ctvdr_spezial_sonderkernelimg hdd=ide-scsi


    mit dem Teil:

    Code
    1. video=vesafb:1024x768-16@72 vga=791


    habe ich es dann sogar noch geschaft, daß mein Rechner auch mit dem Kernel 2.6 die höhere Auflösung nutzt.



    Begeisterung

    :strike1

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von rudibert ()