Asus P3B-F

  • Hallo zusammen,


    ich bin im Moment dabei, mir einen VDR zusammenzustellen. Im Moment versuche ich gerade den PC dazu zu bewegen sich automatisch anzuschalten. Ich orientiere mich dabei an der Anleitung von Hubertus Sandmann und an den Tipps hier aus dem Board.


    Habe die nvram-wakeup-version 0.90 runtergeladen und entpackt. Dazu noch die aktuelle nvram-wakeup-mb.c aus dem CVS. Mein Mainboard ist das Asus P3B-F, Bios 1006.


    Damit nvram-wakeup das Board erkennt musste ich die nvram-wakeup-mb.c abändern:


    Ohne Änderung:
    (Zeile 961
    { asus_tusl2, "asus_tusl2", "ASUSTeK Computer INC.", "P3B-F", NULL, NULL, NULL, NULL },
    )


    video:/usr/local/src/nvram-wakeup-0.90 # ./nvram-wakeup --debug
    nvram-wakeup: Printing debug messages enbled.
    nvram-wakeup: $Id: nvram-wakeup.h,v 1.21.2.6 2003/03/03 15:12:24 bistr-o-math Exp $
    nvram-wakeup: $Id: nvram-wakeup-mb.h,v 1.91.2.3 2003/03/03 13:08:57 bistr-o-math Exp $
    nvram-wakeup: $Id: nvram-wakeup.c,v 1.54.2.9 2003/03/04 13:22:14 bistr-o-math Exp $
    nvram-wakeup: Opening /dev/mem in O_RDONLY mode...
    nvram-wakeup: _DMI_ table found: base: 0xF1F50, size: 0x530, count: 45
    nvram-wakeup: Following DMI entries found:
    nvram-wakeup: - Mainboard vendor: ASUSTeK Computer INC.
    nvram-wakeup: - Mainboard type: <P3B-F>
    nvram-wakeup: - Mainboard revision: REV 1.xx
    nvram-wakeup: - BIOS vendor: Award Software, Inc.
    nvram-wakeup: - BIOS version: ASUS P3B-F ACPI BIOS Revision 1006
    nvram-wakeup: - BIOS release: 05/19/2000
    nvram-wakeup: Your mainboard is currently not supported.
    nvram-wakeup: Please try determining the addresses and sending the following
    nvram-wakeup: information back to the maintainers:
    nvram-wakeup: - The addresses you found out (read README.mb)
    nvram-wakeup: - Mainboard vendor: ASUSTeK Computer INC.
    nvram-wakeup: - Mainboard type: <P3B-F>
    nvram-wakeup: - Mainboard revision: REV 1.xx
    nvram-wakeup: - BIOS vendor: Award Software, Inc.
    nvram-wakeup: - BIOS version: ASUS P3B-F ACPI BIOS Revision 1006
    nvram-wakeup: - BIOS release: 05/19/2000



    Mit Änderung:
    (Zeile 961
    { asus_tusl2, "asus_tusl2", "ASUSTeK Computer INC.", "<P3B-F>", NULL, NULL, NULL, NULL },
    )


    video:/usr/local/src/nvram-wakeup-0.90 # ./nvram-wakeup --debug
    nvram-wakeup: Printing debug messages enbled.
    nvram-wakeup: $Id: nvram-wakeup.h,v 1.21.2.6 2003/03/03 15:12:24 bistr-o-math Exp $
    nvram-wakeup: $Id: nvram-wakeup-mb.h,v 1.91.2.3 2003/03/03 13:08:57 bistr-o-math Exp $
    nvram-wakeup: $Id: nvram-wakeup.c,v 1.54.2.9 2003/03/04 13:22:14 bistr-o-math Exp $
    nvram-wakeup: Opening /dev/mem in O_RDONLY mode...
    nvram-wakeup: _DMI_ table found: base: 0xF1F50, size: 0x530, count: 45
    nvram-wakeup: Following DMI entries found:
    nvram-wakeup: - Mainboard vendor: ASUSTeK Computer INC.
    nvram-wakeup: - Mainboard type: <P3B-F>
    nvram-wakeup: - Mainboard revision: REV 1.xx
    nvram-wakeup: - BIOS vendor: Award Software, Inc.
    nvram-wakeup: - BIOS version: ASUS P3B-F ACPI BIOS Revision 1006
    nvram-wakeup: - BIOS release: 05/19/2000
    nvram-wakeup: Using following bios info:
    nvram-wakeup: need_reboot = 0
    nvram-wakeup: addr_chk_h = 0x6C
    nvram-wakeup: addr_chk_l = 0x6D
    nvram-wakeup: addr_chk_h2 = 0x00
    nvram-wakeup: addr_chk_l2 = 0x00
    nvram-wakeup: addr_stat = 0x56
    nvram-wakeup: addr_mon = 0x00
    nvram-wakeup: addr_date = 0x00
    nvram-wakeup: addr_wdays = 0x00
    nvram-wakeup: addr_hour = 0x00
    nvram-wakeup: addr_min = 0x00
    nvram-wakeup: addr_sec = 0x00
    nvram-wakeup: shift_stat = 4
    nvram-wakeup: shift_mon = 0
    nvram-wakeup: shift_date = 0
    nvram-wakeup: shift_wdays = 0
    nvram-wakeup: shift_hour = 0
    nvram-wakeup: shift_min = 0
    nvram-wakeup: shift_sec = 0
    nvram-wakeup: rtc_time = 1
    nvram-wakeup: rtc_date = 0x7F
    nvram-wakeup: rtc_mon = 0x00
    nvram-wakeup: rtc_date_0_is_c0 = 0
    nvram-wakeup: rtc_mon_0_is_c0 = 0
    nvram-wakeup: reset_date = 1
    nvram-wakeup: reset_mon = 0
    nvram-wakeup: nr_stat = 1
    nvram-wakeup: nr_mon = 4
    nvram-wakeup: nr_date = 5
    nvram-wakeup: nr_hour = 5
    nvram-wakeup: nr_min = 6
    nvram-wakeup: nr_sec = 6
    nvram-wakeup: nr_rtc_date = 6
    nvram-wakeup: nr_rtc_mon = 5
    nvram-wakeup: nr_wdays = 7
    nvram-wakeup: bcd = 0
    nvram-wakeup: date_no_chk = 0
    nvram-wakeup: date_hack = 0
    nvram-wakeup: Opening /dev/rtc in O_RDONLY mode...
    nvram-wakeup: Hardware clock: 2003-06-19 23:58:18
    nvram-wakeup: rtc.tm_isdst : 1
    nvram-wakeup: rtc.tm_gmtoff: 7200
    nvram-wakeup: diff : -1
    nvram-wakeup: RTC is running in localtime!
    nvram-wakeup: Test (this should be the current time of the hardware clock): Thu Jun 19 23:58:17 2003
    nvram-wakeup: Opening /dev/nvram in O_RDONLY mode...
    nvram-wakeup: The size of /dev/nvram is 114 bytes.
    nvram-wakeup: value of the addr_stat byte is: 0x07.
    nvram-wakeup: rtc_date (0x7F) is beyond the end of nvram




    Ist das das "positive Ergebnis", von dem in Hubertus Anleitung die Rede ist, mit dem man dann weiterarbeiten kann?
    Besonders die letzte Zeile der Ausgabe macht mich etwas unsicher, aber kann ja auch sein, dass die ganz normal ist und so lauten muss.


    Gruß und gute N8,
    schelli

    Scenic D6 Umbau; Asus-P3B-F; Celeron 633Mhz; 256MB; 360GB; DVD+-RW; DD5.1; GLCD 240x128; 1x DVB-S Rev. 1.6

  • ich habe auch ein p3b-f
    du mußt noch ein kernelmodul umpatchen (readme nvram-wakeup) und neu kompilieren (make modules) und installieren, die schritte gehören zum thema - kenel neu kompilieren


    habe ich alles schon durch und keinen erfolg mit gehabt, die zeit wird bei mir ins nv-ram geschrieben aber der rechner schaltet sich nicht ein obwohl wenn man im bios schaut alles ok ist
    wenn ich von hand eine zeit im bios eintrage und ausschlate dann geht es
    (die im readme beschriebenen tests von wegen aktivierung und deaktivierung, need_reboot switch, jhabe ich auch getestet - ohne erfolg)


    solltest du erfolg habe lass es mich wissen
    (bios rev. usw.)


  • habe die Aenderung in CVS eingetragen.


    Zitat

    nvram-wakeup: rtc_date (0x7F) is beyond the end of nvram


    wie IG88 schreibt, musst du den Treiber fuer nvram patchen -- siehe auch man nvram-wakeup.conf.

  • Zitat

    Original von IG88
    habe ich alles schon durch und keinen erfolg mit gehabt, die zeit wird bei mir ins nv-ram geschrieben aber der rechner schaltet sich nicht ein obwohl wenn man im bios schaut alles ok ist
    wenn ich von hand eine zeit im bios eintrage und ausschlate dann geht es



    wenn du die Wakeup Zeit von nvram-wakeup setzen laesst, reboot machst und waehrend der
    BIOS-Meldungen den PC per Knopfdruck ausschaltest, wacht er dann auf?
    Wenn ja, kann dir geholfen werden.


    Manche PC's wollen einfach nicht aufwachen, wenn sie mit ACPI routinen ausgeschaltet werden.
    Manche PC's wollen einfach nicht aufwachen, wenn sie mit APM routinen ausgeschaltet werden.
    (auch wenn man die Wakeup Werte im BIOS Setup eintraegt, also ganz ohne nvram-wakeup)


    Probier doch mal das neue PwerOff image aus dem CVS ( http://cvs.sourceforge.net/cgi…t/bzImage.2.4.20.poweroff )
    Dann kannst du mit den boot parametern apm=off bzw. acpi=off das eine oder das
    andere abschalten.


    Wenn er immer noch nicht aufwacht, schau dir mal http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/nvram-wakeup/nvram-wakeup/reboot/dioden-poweroff.txt?rev=1.2&content-type=text/vnd.viewcvs-markup an

  • Hallo miteinander,


    Zitat


    IG88 schrieb:


    ich habe auch ein p3b-f
    du mußt noch ein kernelmodul umpatchen (readme nvram-wakeup) und neu kompilieren (make modules) und installieren, die schritte gehören zum thema - kenel neu kompilieren


    Zitat


    Bistr-o-Math schrieb


    wie IG88 schreibt, musst du den Treiber fuer nvram patchen -- siehe auch man nvram-wakeup.conf.


    Hab mir jetzt alle erwähnten Sachen und noch einiges mehr durchgelesen, aber irgendwie hab ich immernoch keinen Plan, was ich jetzt machen müsste, damit das irgendwie funktioniert. Ich werd das denk ich mal bleiben lassen, glaub nicht, dass das so gesund ist, wenn man als Linux-Neuling sich gleich ans Kernel-Neu-Kompilieren macht, zumal ich keine Ahnung hab, wie das geht, bzw. was ich damit noch so alles kaputt machen kann ;-)



    Hmm, wenns denn eh keinen Erfolg hat, dann brauch ich mich ja nicht verrückt zu machen, wenn ich das jetzt vorerst aufgebe ... vielleicht spendier ich meinem VDR irgendwann ein anderes Board, falls es mich in Zukunft zu stark aufregt ...


    Gruß,
    schelli

    Scenic D6 Umbau; Asus-P3B-F; Celeron 633Mhz; 256MB; 360GB; DVD+-RW; DD5.1; GLCD 240x128; 1x DVB-S Rev. 1.6

  • Zitat

    Original von schelli


    Hab mir jetzt alle erwähnten Sachen und noch einiges mehr durchgelesen, aber irgendwie hab ich immernoch keinen Plan, was ich jetzt machen müsste, damit das irgendwie funktioniert.


    einfach die Datei <kernel-src>/drivers/char/nvram.c editieren und aus

    Code
    1. #define NVRAM_BYTES 128-RTC_FIRST_BYTE

    muss das werden:

    Code
    1. #define NVRAM_BYTES 128


    danach

    Code
    1. make modules modules_install
    2. rmmod nvram
    3. modprobe nvram


    mehr zum neukompillieren des Kernels unter http://home.t-online.de/home/hubertus.sandmann/
    (dort "Linux" - "Allgemein" - "Kernel")


    Zitat


    Ich werd das denk ich mal bleiben lassen, glaub nicht, dass das so gesund ist, wenn man als Linux-Neuling sich gleich ans Kernel-Neu-Kompilieren macht, zumal ich keine Ahnung hab, wie das geht, bzw. was ich damit noch so alles kaputt machen kann ;-)


    Das ist natuerlich deine Entscheidung...


    Zitat


    Hmm, wenns denn eh keinen Erfolg hat, ...


    IG88 muss mal meine Hinweise ausprobieren. Vielleicht geht es ja doch...


    IG88 : schon Zeit gehabt?

  • Hallo Bistr-o-Math, hallo alle,


    hab mir die Seite von Hubertus zum Thema Kernel mal überflogen. Wenns mit dem verändern wirklich so einfach ist wie dus beschrieben hast, dann werd ich dass schon irgendwie hinkriegen :-)
    Allerdings habe ich etwas Probleme, den genauen Unterschied zwischen den Änderungen der beiden Zeilen in der nvram.c zu erkennen ...
    Könntest du dir bitte die beiden Zeilen von dir nochmal anschaun und mir sagen was ich in die nvram.c eintragen muss?


    Gruß,
    Mario

    Scenic D6 Umbau; Asus-P3B-F; Celeron 633Mhz; 256MB; 360GB; DVD+-RW; DD5.1; GLCD 240x128; 1x DVB-S Rev. 1.6

  • so habs jetzt mal ausprobiert ...


    hab


    Code
    1. make modules modules_install


    im richtigen verzeichniss eingegeben.
    danach hat der pc jetzt fast zwei stunden vor sich hingewerkelt um dann mit einer recht komischen error-meldung aufzuhören. hab die meldung leider nicht mehr da und im moment auch keine lust, nochmal zwei stunden zu warten, bis er die meldung wieder ausspuckt.


    der nvram-wakeup befehl bringt immernoch die gleiche meldung wie im ursprungsposting, also scheint der nvram.c teil noch nicht ge-maked worden zu sein, bevor der error aufgetreten ist.


    :(:(:(


    blöd! ...


    gruss,
    schelli

    Scenic D6 Umbau; Asus-P3B-F; Celeron 633Mhz; 256MB; 360GB; DVD+-RW; DD5.1; GLCD 240x128; 1x DVB-S Rev. 1.6

  • ei, da schaut man mal ein paar tage nicht hin und schon ist es passiert ....
    wertvolle tips diem man nicht verpassen sollte


    werde es heute abend testen und bescheid geben



    schelli


    ok, ich habe geschummelt, ich habe nur die module übersetzt und das eine (nvram) von hand "installiert" (umkopiert)
    wenn du eine "normale" SUSE 8.1 hats kann ich dir die quelle und das fertige modul auch schicken (obs unter anderen bedingungen auch geht kann ich nicht sagen, bin auch kein großer linux experte, imho sollte es gehen wenn du den selben kernel (2.4.19) hast

  • Zitat

    schelli


    ok, ich habe geschummelt, ich habe nur die module übersetzt und das eine (nvram) von hand "installiert" (umkopiert)
    wenn du eine "normale" SUSE 8.1 hats kann ich dir die quelle und das fertige modul auch schicken (obs unter anderen bedingungen auch geht kann ich nicht sagen, bin auch kein großer linux experte, imho sollte es gehen wenn du den selben kernel (2.4.19) hast


    Hab auch die Susi 8.1. Kernel ist bei mir 2.4.19-4GB. Ist dass der gleiche?
    Falls ja wär ich dir dankbar, falls du mir die Sachen schicken könntest (und wenn möglich noch ne kurze Beschreibung, was ich dann damit machen muss ... ... tjaja, neues OS, auf einmal is alles anders :rolleyes:


    wär cool, wenn ich das mit dem automatischen aufwachen doch noch irgendwie hinkriegen würde :]


    gruß
    schelli

    Scenic D6 Umbau; Asus-P3B-F; Celeron 633Mhz; 256MB; 360GB; DVD+-RW; DD5.1; GLCD 240x128; 1x DVB-S Rev. 1.6

  • Zitat

    Original von schelli


    Hab auch die Susi 8.1. Kernel ist bei mir 2.4.19-4GB. Ist dass der gleiche?
    Falls ja wär ich dir dankbar, falls du mir die Sachen schicken könntest ...


    Ja, ich denke, es ist das einfachste, wenn dir jemand ein fertig kompilliertes Modul schickt.


    Sollte es damit nicht funktionieren, mach doch bitte erst einen

    Code
    1. make modules


    und wenn der fehlerfrei durch ist, einen

    Code
    1. make modules_install


    so kann man den Fehler wenigstens eingraenzen.

  • Zitat

    Original von IG88
    Bistr-o-Math


    wenn man den rechner nach dem apm shutdown nochmal einschaltet und mit powerbutton auschaltet wird er wach


    dann sollte es auf jeden Fall zumindest mit der Dioden-Loesung gehen.


    Zitat

    werde mir mal das readme bezüglich dieses apm/acpi off kernels mal reinziehen


    da braucht man eigentlich nichts reinzuziehen: Wenn du grub benutzt, musst du entsprechende
    Sachen fuer Grub machen. Ich kenne grub selber nicht, daher hier die Schritte fuer Lilo:

    • das image nach /boot/ geschoben.
    • in lilo.conf ganz unten:
      Code
      1. image = /boot/bzImage-2.4.20-PowerOff
      2. label = PowerOff


    • einmal lilo laufen lassen


    Nun machst du alles wie du es oben beschrieben hast:

    Zitat

    wenn man den rechner nach dem apm shutdown nochmal einschaltet und mit powerbutton auschaltet wird er wach

    nur

    • Statt den Rechner mit dem Powerbutton auszuschalten, waehlst du im Lilo-Boot-Menu "PowerOff" aus
    • Wenn er nicht aufwacht, waehlst du das naechste mal "PowerOff" und schreibst in die Zeile fuer Parameter: "acpi=off"
    • Wenn er immer noch nicht aufwacht, waehlst du das naechste mal "PowerOff" und schreibst in die Zeile fuer Parameter: "apm=off"
    • Sollte er immer noch nicht aufwachen, bleibt wohl nur die Dioden-Loesung. Da musst du erst lesen...
  • hi


    habs jetz getestet, es geht wenn ich mit acpi=off den reboot kernel starte,
    habe im mb config von nvram-wakeup für das tusl2 reboot auf always gesetzt


    nur leider fehlt mir noch der teil der in die shutdowndatei kommt wo ich dem grub sage beim nächsten boot bitte den eintrag PowerOff benutzen
    (bei lilo ist das lilo -R PowerOff)

  • Zitat

    Original von IG88


    nur leider fehlt mir noch der teil der in die shutdowndatei kommt wo ich dem grub sage beim nächsten boot bitte den eintrag PowerOff benutzen
    (bei lilo ist das lilo -R PowerOff)


    Wie gesagt, ich kenne mich mit grub nicht aus.


    1. Da steht was darueber ganz unten in der README: http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/nvram-wakeup/nvram-wakeup/README?rev=1.32&content-type=text/vnd.viewcvs-markup


    2. Es gab hier im Forum schon einige threads, die sich mit grub beschaeftigen. Da solltest du fuendig werden.


  • hi,


    danke für die beiden dateien! funktioniert wunderbar!!!


    gruß,
    schelli

    Scenic D6 Umbau; Asus-P3B-F; Celeron 633Mhz; 256MB; 360GB; DVD+-RW; DD5.1; GLCD 240x128; 1x DVB-S Rev. 1.6


  • Hab bei mir jetzt auch ein wenig damit experimentiert. Reboot ist nicht nötig, wenn man den normalen Kernel mit der zusätzlichen option "acpi=off" bootet (einfach in /boot/grub/menu.lst mitreinschreiben) ... danach fährt er bei mir beim shutdown mit nvram-wakeup + poweroff wunderbar wieder hoch ...


    danke für eure hilfe, jetzt muss der vdr nichtmehr stundenlang laufen, falls noch eine aufnahme ansteht! :)


    :welle:welle


    viele grüße,
    schelli

    Scenic D6 Umbau; Asus-P3B-F; Celeron 633Mhz; 256MB; 360GB; DVD+-RW; DD5.1; GLCD 240x128; 1x DVB-S Rev. 1.6