DVD-Wiedergabe auf PVR350only-System?

  • Ich habe ein PVR350-only-System mit LinVDR 0.7 und MT Patch 20050414


    Gibt es eine Möglichkeit auf der PVR350 DVD's abzuspielen?
    - Beim pvr350-plugin steht, dass es das dvd-plugin nicht unterstützt
    - mplayer geht bei mir auch nicht (Wenn ich mplayer starte bekomme ich kein Bild und der mplayer steht nach ein par Sekunden:



    - Habe ich noch was übersehen? (BTW VDR-Fernsehen, Aufnehmen und Wiedergeben geht)
    - Gibt es eine Möglichkeit DVD's auf der PVR350 abzuspielen?
    Für jeden Hinweis dankbar.

    Neu(ab 10/2012): DigitalDevices Cine S2 V6, Asrock Board B75M, Intel CPU G530, 2GB, SATA-HDD Samsung 500GB, GT520 (Palit), SATA-DVD, CoolerMaster-Cavalier4, IR-Einschalter, yavdr 0.5 stable
    "Alt-System": Nexus-S (Rev 2.3), PVR-350 (Rev K257,Tuner 38 -derzeit nicht eingebaut), Samsung SP1614N(160GB),D-Link DWL-G520+WLAN, altes Pentium II-Board,CoolerMaster-Cavalier4,IR-Einschalter, ctvdr 6

  • Also da ich ebenfalls ein leidgeplagter PVR350 only Nutzer bin geb ich mal meinen Senf dazu ab. Ich verwende zwar nicht LinVDR sondern c't/e-tobi aber im Prinzip gilt hier das gleiche.
    Zunächst zum DVD Plugin, ich habe es hier am 'Laufen' aber nicht zu meiner Zufriedenheit. Das Hauptproblem hierbei sind die Menüs die entweder gar nicht oder nur teilweise angezeigt werden. Mit der Stabilität stehts auch nicht zum besten, an einem Testnachmittag hatte das Plugin bewirkt, das nur noch ein grünes Bild zu sehen war es war zwar kein Neustart notwendig sondern ein Reset mittels ivtvctl hat die Ausgabe wieder hingebogen. Und während der DVD Wiedergabe kam es alle paar sekunden zu Aussetzern und teilweise sogar zu grünen Bildfetzen die über den Schirm gewandert sind. -> Möglicherweise nimmt sich ja der Entwickler diesem Problem an.


    Um Videos via Mplayer über den PVR350-TV-Out zu schieben ist ein Patch und ein neukompilieren von Mplayer nötig. Leider weis ich nicht ob MT einen solchen bereits im LinVDR-Patch mit reingepackt hat. Falls ja dann kommt es noch darauf an welchen. Soweit ich meine Tests in Erinnerung habe gibt es 3 Patches wobei die beiden älteren ca. Sommer 2004 prinzipiell funktioniert haben aber nur mit bestimmten Auflösungen der Filme (ich glaube wo keine Neu-Skalierung nötig war also (720)768x576. Dabei war im Mplayer als -vo Option einmal mpegpes und einmal ivtv verwendet worden. Eventuell musst du also das mplayer.sh Config-Skript vom mpegpes auf ivtv umstellen? Aber nun zum wichtigeren es gibt seit anfang April einen neuen Patch für den ivtv-Videoausgabetreiber der auch diverse Filtereinstellungen zulässt. Und damit funktioniert das mplayer.sh Skript wieder einwandfrei mit Skalierung und allem was dazu gehört.
    Am besten du testest das mplayer.sh skript ohne den VDR laufen zu lassen so lassen sich Probleme leichter eingrenzen und lösen.


    Nun zum Schluß eine positive Nachricht, es ist auch mit Mplayer möglich DVDs abzuspielen allerdings ohne Menüs. Ein Sache noch zum Schluss der Ausgabetreiber funktioniert nur für das Bild den Ton musst du über die Soundkarte ausgeben, also '-ao oss'.


    mfg Tommyknocker

  • Hallo,


    ich hole diesen Artikel mal nach vorne....
    Ich nutze Gentoo, insofern passt es nicht genau hierhin, aber der Inhalt ist genau mein Problem.
    Hat sich da mittlerweile was geändert???


    Zwar läuft bei mir ein PVR-only System jetzt toll im TV-Bereich, aber.......


    Installation des DVB-Plugins und CDDA-Plugins war erfolgreich, die Plugins werden geladen.
    Es kommt aber kein Ton.


    Über die Soundkarte kommt nie Ton, kann man die Audioausgabe irgendwie auf die Soundkarte umbiegen???


    Auf der Konsole kann ich direkt Audio-CD's starten, Ton 1A.


    Gruß

  • mit ivtv 0.4 und dem neuen X Treiber gehr xv eigentlich problemlos. Ich bin gerade selber dabei mein System vom PVR350 Plugin auf das Xine Plugin umzustellen, damit ich endlich wieder DVDs anschauen kann.


    MfG


    Willi

    Server:

    Pentium D * 3 TB HDD * Ubuntu 6.06* VDR 1.4.7,2xSkystar2 in XEN DomU

    Clients:

    Compaq Deskpro EN umgebautes easyvdr via pxe boot

    2 SMT 7020s umgebautes Zenslack

  • Habe auch ein PVR350-only system (debian based). DVD Bild funktioniert, leider kein Ton. VCD laufen übrigends. Wer weiß denn mal, wo hier das Problem liegt.


    computerkammer : Welche ivtv Version?


    tuxinger : berichte mal, wenn es läuft, obwohl mir die alternative nicht wirklich gefällt - aber immerhin.


    E.

    VDR: Zotac D2550 ITX Wifi Supreme, GT610 onboard, 4GB DDR3, 1TB HD, PVRUSB2, DD DuoFlex C/T, yaVDR 0.5
    Alt-VDR: VIA EPIA Board, 512MB DDR, PVR350, c't VDR, ausser Betrieb

  • Kernel 2.6.14, ivtv 0.4 oder CVS.


    Aber statt der PVR-only ist jetzt eine Nexus CA dazugekommen.


    Gesteckt, Kernel gebaut und alles, aber auch wirklich alles was vorher nicht ging geht sofort!!!


    Mein Fazit ist:


    Will man nur den VDR für die Glotze nutzen, ist das eine feine Sachen mit der PVR.
    Ansonsten besser ine DVB-Karte zustecken, auch wenn es finanziell bitter ist.

  • So bin fertig und habe endlkich ein PVR System bei dem alles (außer gngb2vdr) funktioniert wie ich es mir vorstelle. :D (fertig wird´s wohl nie)


    Ich habe den Versuch das Xine Plugin mit der PVR zu nutzen wieder aufgegeben, da das OSD relativ zäh war. Die Lösung für DVD+AVI wiedergabe mit der PVR heißt externalplayer+xine und Mplayer unter X. das einzige Manko ist daß das starten von X und xine ein wenig dauert (ca 10s bis Bild da), dafür sind Bild und Ton endlich syncron und DD via SB Live auf analoges Boxenset funkt auch. ein weiterer Vorteil ist daß mit Xine die DVD Menüs korrekt funktionieren.


    Software ivtv 0.4 + Xfree 4.3 mit neuem X Treiber (der XV kann) unter Debian Sarge, vdr 1.3.34 + externalplayer (die letzte ich glaube 0.1.0 oder so) und ein script daß von externalplayer aufgerufen wird welches X und Xine startet und nach der Beendigung von Xine den X server killed.



    MfG


    Willi

    Server:

    Pentium D * 3 TB HDD * Ubuntu 6.06* VDR 1.4.7,2xSkystar2 in XEN DomU

    Clients:

    Compaq Deskpro EN umgebautes easyvdr via pxe boot

    2 SMT 7020s umgebautes Zenslack

  • Ich hatte das schon befürchtet, daß die Performance via xine-plugin zu wünschen übrig läßt - ich habe nur ein EPIA M6000 board. Deshalb hatte ich auch schon die Idee über externalplayer xine zu starten, war nur noch nicht dazu gekommen. Deshalb schön zu hören, daß es funktioniert - ich werd´s wohl auch so machen.


    Könntest du möglicherweise dein Start-Script irgendwo bereitstellen, dann muß ich nicht ganz von vorn anfangen. Danke!


    Es bleibt die Frage, warum beim DVD-Plugin mit PVR350 der Ton nicht da ist. Habe schon mehrfach im Forum danach gesucht, aber immer nur heißt es "geht wohl nicht".


    Gibt´s denn niemanden, der mehr darüber weiß?


    E.

    VDR: Zotac D2550 ITX Wifi Supreme, GT610 onboard, 4GB DDR3, 1TB HD, PVRUSB2, DD DuoFlex C/T, yaVDR 0.5
    Alt-VDR: VIA EPIA Board, 512MB DDR, PVR350, c't VDR, ausser Betrieb

  • das script ist sagen wir mal unelegant aber es funktioniert tadellos bei mir


    Shell-Script
    1. #!/bin/bash
    2. export DISPLAY=:0
    3. /usr/bin/X11/X&
    4. sleep 4
    5. /usr/bin/xine -V xv -f -s DVD -p
    6. kill -9 `pidof X`

    Server:

    Pentium D * 3 TB HDD * Ubuntu 6.06* VDR 1.4.7,2xSkystar2 in XEN DomU

    Clients:

    Compaq Deskpro EN umgebautes easyvdr via pxe boot

    2 SMT 7020s umgebautes Zenslack

  • Quote

    Original von Elvar
    Es bleibt die Frage, warum beim DVD-Plugin mit PVR350 der Ton nicht da ist. Habe schon mehrfach im Forum danach gesucht, aber immer nur heißt es "geht wohl nicht".


    Gibt´s denn niemanden, der mehr darüber weiß?


    läuft eine DVD denn ansonsten (ohne Ton) inzwischen sauber?


    ursprünglich hieß es vom Autor:


    Quote

    DVD plugin doesn't work (something to do with the SPUdecoder) and attempts to play a DVD will crash vdr.


    wenn`s nicht mehr crasht, sondern nur stumm ist, könnte vielleicht ein ähnlicher Trick wie bei der dxr3 helfen. Da gibt es einen Patch von LordZodiac für dxr3-plugin und vdr. Der Quellcode sieht beim pvr350-plugin an den betreffenden Stellen teilweise ähnlich aus. Da müsste aber jemand ran, der was davon versteht...

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EACS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Celeron G540, passive GT1030, Cine CT V6, KNC-One DVB-C, Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Mein zuverlässiges Arbeitspferd.

  • Ich habe eine(!) DVD mit dem DVD-Plugin für einige Minuten abgespielt und auch etwas vor- und zurückgespult. Video war meines Erachtens einwandfrei, kein Ruckeln (auf meinem EPIA M6000 = ca. 600 MHz), aber keinerlei Ton. Das Menü-Handling funktionierte nicht 100%tig, war aber bedienbar. Es gab aber keinerlei Absturz. Mit Ton wäre ich damit zufrieden ;).


    Die Patches habe ich mir mal geholt. Mal sehen, was sich da machen läßt - so wahnsinnig kompliziert sind die ja nicht (nicht, daß ich verstehen würde, was da passiert, aber vielleicht kann man rein formal was machen).


    Habe jetzt auch xine probiert, funkioniert, allerdings mit abgeschnittenen Rändern und es ruckelt furchtbar (ca 30% Frameverlust). Benutzt der ivtvdev_drv vielleicht nicht den Hardware-Decoder der PVR350? Außerdem habe ich da auch keinen Ton über die PVR, sondern wohl nur auf der Soundkarte - das kann xine wohl nicht anders (oder)?


    E.

    VDR: Zotac D2550 ITX Wifi Supreme, GT610 onboard, 4GB DDR3, 1TB HD, PVRUSB2, DD DuoFlex C/T, yaVDR 0.5
    Alt-VDR: VIA EPIA Board, 512MB DDR, PVR350, c't VDR, ausser Betrieb

  • Ich vermute mal, daß die selbst erstellten DVD´s mit "normalem" Ton erzeugt sind, also kein AC3. Das versteht die PVR350 offenbar. Kann es sein, daß Kauf-DVD´s eventuell nur AC3 Audio-Streams besitzen oder diese vorzugsweise verwendet werden? Ich habe mir das PVR350-Plugin angesehen, es schiebt im Prinzip schlicht alle Streams, Video und Audio, einfach in die Karte (auf /dev/video16, hardcoded!). Wahrscheinlich versteht die Karte keine AC3 Audio-Streams. Es gibt somit zwei Möglichkeiten:


    1. Falls die DVD eine "normale" (was immer das ist, PCM?) Audiospur besitzt, erzwinge diese (wie macht man das?). Das müßte die PVR verstehen.


    2. Der Audiostream muß on-the-fly so transcodiert werden, daß die PVR damit zurecht kommt.


    Der erwähnte dxr3-Patch nützt uns hier nicht viel, weil das PVR350-Plugin mit dem Typ des Audiostreams nicht anfangen kann.


    Übrigends schickt der vdr nur AC3 Audiostreams an das Output-Device, wenn der Parameter UseDolbyDigital auf 1 steht, sonst unterschlägt er sie schlicht (jedenfalls lese ich den Code so...).


    Es wäre interessant zu wissen, ob jemand über eine DVB Karte einen Kanal mit AC3 Ton auf der PVR350 wiedergeben kann (und etwas hört :) ).


    Noch als Hinweis: eine VCD mit dem VCD-Plugin kann ich problemlos wiedergeben.


    Kommentare?


    E.

    VDR: Zotac D2550 ITX Wifi Supreme, GT610 onboard, 4GB DDR3, 1TB HD, PVRUSB2, DD DuoFlex C/T, yaVDR 0.5
    Alt-VDR: VIA EPIA Board, 512MB DDR, PVR350, c't VDR, ausser Betrieb

  • stellt mal in Einstellungen- DVB die Dolby-Digitalfunktion ab

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EACS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Celeron G540, passive GT1030, Cine CT V6, KNC-One DVB-C, Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Mein zuverlässiges Arbeitspferd.

  • Elvar


    Welcher ivtv bzw i ivtv_drv Version benutzt du?


    habe ca 20-30% CPU Last auf meinem Athlon XP 1800 256MR Ram (wenn ich drüber nachdenke könnte das knapp werden auf einem Epia mit 600Mhz)


    Code
    1. 3635 root 15 0 28252 23m 10m S 11.6 9.7 0:17.44 XFree86
    2. 3657 root 15 0 110m 37m 14m S 11.3 15.3 0:18.26 xine
    3. 1348 root 5 -10 0 0 0 S 9.7 0.0 0:06.68 ivtv-enc-vbi
    4. 3667 root 15 0 110m 37m 14m S 1.0 15.3 0:01.51 xine
    5. 3658 root 15 0 110m 37m 14m S 0.7 15.3 0:01.38 xine
    6. 3618 root 15 0 51388 29m 6824 S 0.3 12.1 0:01.04 vdr


    meine XF86Config



    und keine abgeschnittenen Ränder


    MfG


    Willi

    Server:

    Pentium D * 3 TB HDD * Ubuntu 6.06* VDR 1.4.7,2xSkystar2 in XEN DomU

    Clients:

    Compaq Deskpro EN umgebautes easyvdr via pxe boot

    2 SMT 7020s umgebautes Zenslack

    The post was edited 2 times, last by tuxinger ().

  • Quote

    Original von Elvar
    Es wäre interessant zu wissen, ob jemand über eine DVB Karte einen Kanal mit AC3 Ton auf der PVR350 wiedergeben kann (und etwas hört :) ).


    das funzt ohne Probleme (Pro7 von DVB-T-Karte)

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EACS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Celeron G540, passive GT1030, Cine CT V6, KNC-One DVB-C, Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Mein zuverlässiges Arbeitspferd.

  • tuxinger


    ivtv 0.4.0, ivtvdev_drv 0.10.6, xine von debian (sarge). Die XF86config ist nahezu identisch. Wird der Hardware Decoder nun verwendet oder nicht? Ich dachte, die XV-Extension wäre dazu da (da kenne ich mich aber nicht so aus).


    Dr. Seltsam


    Die Einstellungen zu DolbyDigital in DVB haben nahezu keine Wirkung (bei "nein" gibt's manchmal kurzzeitiges Rauschen. Im wesentlichen aber hört man nichts).


    AC3 über Pro7: vielleicht wird´s irgendwo konvertiert...


    Ich habe mir mal während des Betriebes die Streamids ausgeben lassen, die das pvr350-plugin bekommt. E0 für den Videostream natürlich, bei Live-TV (analog über die PVR350) und bei VDR-Wiedergabe dazwischen C0 für standard Audio. Bei der DVD sieht man da BD, was auf AC3 hinweist. Das pvr350-plugin ändert die ID zwar in C0 (warum?), aber die Karte versteht´s halt nicht (auch nicht, wenn die ID nicht geändert wird). Selbstgebrannte DVD´s mit Standard-Ton und Kauf-CD ohne AC3 (gibt´s das?) funktionieren deshalb.


    Irgendwo muß also konvertiert werden. An der Quelle (DVD-plugin), im VDR selbst oder bei der Ausgabe (pvr350-plugin).


    Tja. Und nun?


    E.

    VDR: Zotac D2550 ITX Wifi Supreme, GT610 onboard, 4GB DDR3, 1TB HD, PVRUSB2, DD DuoFlex C/T, yaVDR 0.5
    Alt-VDR: VIA EPIA Board, 512MB DDR, PVR350, c't VDR, ausser Betrieb

    The post was edited 1 time, last by Elvar ().

  • hallo zusammen,
    ich habe gestern das externalplayer plugin installiert. Ein erster Test, mit dem o.g. Script hat meinen Monitor aufflackern lassen. Ich werde zuhause das von externalplayer aufgerufene script nochmal überarbeiten.


    Zwei Fragen


    1. Der export Display=:0 Befehl scheint meinen über die Grafikkarte angschlossenen Monitor anzusprechen, wie bekomme ich raus welches Display ich exportieren muss um den TV anzusprechen?


    2. Bekomme ich auch Sound mit dem Plugin und meiner pvr350, über den tvout der karte? oder muss ich die Soundkarte dafür anzapfen : I


    mfg


    --
    pvr350 only - ctVDR/Linvdr

    Server: Seagate Dockstar - Debian Squeeze

    Client: Apple TV 2 / Samsung LExxC650

    OldOne: Debian Etch - Matrox G450 & SkyStar2

  • Hallo


    Elvar Hab mir mal den code vom Treiber kurz angesehen. Sieht nicht so aus als würde der Decoder verwendet. ist nur ein schnelles Interface für den Framebuffer. Ist meiner Meihnung auch sinnvoll da die Firmware warscheinlich nur mpeg1/2 versteht. Vielleicht baut ja jemand ein Plugin für xine damit der decoder für mpeg1/2 direkt verwendet wird.


    uzer
    1) wird wohl DISPLAY=:1 sein
    2) Soundkarte


    MfG


    Willi

    Server:

    Pentium D * 3 TB HDD * Ubuntu 6.06* VDR 1.4.7,2xSkystar2 in XEN DomU

    Clients:

    Compaq Deskpro EN umgebautes easyvdr via pxe boot

    2 SMT 7020s umgebautes Zenslack

    The post was edited 4 times, last by tuxinger ().