[solved] Scovery xS 800 S26361-D1170

  • Hi,


    ich hab hier ne Fujitsu Scovery xS 800 stehen, VDR läuft schon, nur Timer setzen klappt garnicht (also nvram-wakeup oder /proc/acpi/alarm).
    nvram-wakeup kennt das Board nicht, "guess" generiert zwar eine config-datei, die aber schon wegen Syntaxfehlern nicht funktioniert ("rtc_hour" - unknown variable).


    Wie schaffe ich es, dass dieses Board sich zur rechten Zeit einschaltet ?



    In Zeile 11 und Zeile 14 gibts dann "nvram-wakeup: conf: 11: Syntax error: unknown variable name"


    --
    Zuck

  • guess-error.log



    schonmal danke.


    --
    zuck

  • es wird nicht gehen. Die checksumme ist in 0x6F+0x70. Zwischen den letzten beiden Dateien hat sich nur ein Bit geaendert, aber die Checksumme springt gleich wie verrueckt.



    Allerdings gibt es positive Berichte ueber das ACPI-Wakeup fuer diese Boards.


    Eine andere Moeglichkeit ist das set_timer Skript (liegt dem nvram-wakeup bei).
    Lies die Dokumentation am Anfang des Skriptes

  • Hi Bistro,


    ok, nvram kann ich also abschreiben, dummerweise hab ichs nicht geschafft, acpi so zu aktivieren, dass unter /proc/acpi der "alarm" eintrag auftaucht.
    Ich hab Kernel 2.6.10-rc3, ACPI aktiviert, BIOS auf ACPI gestellt, /proc/acpi gibts, aber der "alarm" oder "sleep" wird nicht angezeigt.



  • ansonsten, wie gesagt, probier mal set_timer aus. Hat den Vorteil, dass es (wie nvram-wakeup) ein Monats-Timer ist (d.h. wenn es so in deinem BIOS-Setup einstellbar ist), wohingegen der ACPI-Wakeup nur ein Ein-Tages-Timer ist.


    D.h. wenn du einen Film in 10 Tagen aufnehmen willst, wacht der mit set_timer erst in 10 Tagen auf. Mit acpi-wakeup jeden Tag um gleiche Uhrzeit, bis es soweit ist.


    PS.: Manche halten das natuerlich fuer ein Feature...

  • Danke für die Anstrengungen erstmal, aber die ACPI-Lösung wäre schon besser. Mir ist immer etwas unbehaglich, wenn ich die Uhrzeit bewusst "falsch" stellen muss. Jetzt brauch ich nur noch einen ACPI-Profi, der mir sagt, dass ACPI mit diesem Board nicht geht :))
    I.ü. kann ich im BIOS ohnehin nur die Aufwach-Uhrzeit einstellen, keinen Tag.


    --
    Zuck

  • hast Du mal versucht , etwas nach /proc/acpi/alarm zu schreiben ?
    (echo "2005-04-26 15.50:00" > /proc/acpi/alarm).


    Wenn das ohne Fehlermeldung geht, müsste es auch aufwachen...


    Gruß, Klaus

    gepanschtes LinVDR MT Edition - 23.01.2005 (Basis war linvdr 0.7)
    das Ganze auf FSC D1219 , PIII 933

  • Quote

    Original von Bistr-o-Math
    er hat kein /proc/acpi/alarm.


    war ja nur so'ne Idee..... ?(

    gepanschtes LinVDR MT Edition - 23.01.2005 (Basis war linvdr 0.7)
    das Ganze auf FSC D1219 , PIII 933

  • Quote

    Original von Bistr-o-Math
    er hat kein /proc/acpi/alarm.


    zuck


    welche distri benutzt du
    Ich bin mir nicht sicher aber irgendwer muss doch die proc einträge erstellen.
    Vielleicht fehlt was von der distri ?


    gruss Peter

    Mein anderer VDR ist (auch) ein EPIA
    1)VIA M10000-Nehemiah, 160+120G Samsung; NEC 1300A; YY A106; LCD20x4 ...
    2) ctvdr+e-tobi ; C3M266+1,2GHz-Nehmiah; 160G Samsung + 4x500G Seagate SATA; NEC3500; TT-Case; DVB-S 1.3+4MB + Nova ; gLCD 240x128 ...
    . . .TB rulez. . .

  • Hi Peter,


    ich hab hier ne abgespeckte ct'vdr 2.05, aber ausser dem basissystem alles handgestrickt.
    Die /proc Einträge werden über das Proc-FS automatisch entsprechend der erkannten Hardware erstellt (eigentlich ist das nur ein emuliertes FS).


    Daran kanns also eigentlich nicht liegen. Ich tippe mal auf BIOS-Einstellungen, Kernel-Parameter, Kernel-Modules ... aber wo anfangen zu suchen ...


    --
    Zuck

  • Quote

    Original von zuck
    Kernel-Parameter, Kernel-Modules ... aber wo anfangen zu suchen ...


    --
    Zuck


    eines von dene haett' ich auch getippt, aber wie gesagt, dachte ich, dass alarm ohne extra-Module drine sein sollte.


    Zum anfangen: ACPI an (ist ja schon) und alle untermodule aktivieren bzw. laden (wenns Module sind)


    und ma schau'n.

  • Hallo,


    ich hab mittlerweile das Problem gelöst. nvram-wakeup geht definitiv nicht, es bleibt die ACPI-Aufweck-Variante.
    Damit das funktioniert sollte das aktuellste BIOS installiert werden (D1171), das gibts auf der Fujitsu-Siemens Seite zum Download.
    Dann sollte im BIOS der Timer abgeschaltet werden und Power-On Control auf ACPI.
    Der Linux Kernel (getestet mit 2.6.10) muss offenbar mit ACPI UND(!) APM kompiliert werden, vorher hatte ich kein /proc/acpi/alarm und kein /proc/acpi/sleep. Bei Bedarf kann ich gerne die ".config" meines Kernels mal posten.
    Zum Wakeup:

    Code
    1. echo "2005-04-26 15:30:00" > /proc/acpi/alarm # mglw. Fehlermeldung
    2. echo "2005-04-26 15:30:00" > /proc/acpi/alarm # ok
    3. echo 5 > /proc/acpi/sleep


    scheint erstmal zu funktionieren. Zur Sicherheit hab ich in der "/etc/init.d/halt" am Ende den Wakeup nochmal wiederholt:


    Code
    1. ...
    2. ALM=$(cat /proc/acpi/alarm)
    3. echo $ALM > /proc/acpi/alarm
    4. echo $ALM > /proc/acpi/alarm
    5. echo 5 > /proc/acpi/sleep
    6. echo 5 > /proc/acpi/sleep
    7. halt -d -f -i -p $hddown
    8. ...


    Und damit kann ich einfach die Aufwachzeit nach /proc/acpi/alarm schreiben, und der Rechner wacht zuverlässig auf.


    Besten Dank nochmal an alle, die sich bemüht haben, mir zu helfen, aber letztendlich siegt der Mensch über seinen Computer :))


    --
    Zuck