[Announce] epg4vdr 0.5

  • moin,

    Quote

    Original von Emanuel
    Geht wieder. :versteck


    Besten Dank.
    Vielleicht aber sollte sich der Updatecheck in der conf deaktivieren lassen,
    damit man, falls man 'clearepg true' gesetzt hat,
    wieder zu ner gefuellten epg,data kommt.
    mfg


    /momentan scheint ja tvmovie nicht erreichbar zu sein, bekomme 'bad hostname)

  • wollte das ganze heute auch mal probieren da liwest wieder mal probleme mit dem epg von orf, ard & co hat.
    ich hab meine channels.conf in das epg4vdr verzeichniss kopiert und hinter orf 1 & 2, ard, zdf und 3sat die einträge gemacht.
    dann hab ich die sender in der tv.conf noch aktiviert, bzw. alle anderen auskommentiert.
    Soweit funkt auch alles, die daten werden heruntergeladen, das epg wird gefüttert. epg4vdr läuft ohne fehler durch.
    mit logread -f hab ich die meldungen vom vdr mitgelesen. der schreibt das mehrere svdrp verbindungen akzeptiert werden.
    Leider sehe ich aber im vdr keine epg daten. weis jemand rat?
    mfg
    killerholic

  • wie schaut der log von epg4vdr aus?


    sowas wie:


    Feeding atv.plus......................................................
    ........................................................................
    .................



    und dann ne fehlermeldung vielleicht?

    Software: e-tobi (1.4.7-2ctvdr3), etch (2.6.18-5-486)
    Hardware: ASUS Pundit AB-P2600, Celeron 2.4GHz, Ram 256MB, Hauppauge DVB-c rev2.1, TT DVB-c Budget rev1.0, 460GB, URC- 8203 @ Zapway IR
    Surround: Denon AVR-1801 & Magnat Prisma 5100a Boxen
    Patches/Addons: nvram, noad, vdrconvert
    Plugins: mplayer, mp3, dvd, dvdselect, text2skin, nordlichtsEPG, vdradmin-am, epgsearch, femon
    EPG: epg4vdr
    _____________________
    UPC Telekabel Austria

    The post was edited 1 time, last by NeoTrace ().

  • besteht die möglichkeit, dass ich das ganze auch für meine niederländischen kanäle nutzen kann ? passenden bin nebst xml file habe ich bereits..


    infinite

    kuifje
    asus m2n-vm | Athlon 5600 | Nvidia 9300GE | TT S2-3200
    yaVDR 0.4 | 1.7.21
    haddock
    asus p4pe | 2ghz | 3x DVB-S Budget | 2x500gb
    debian lenny 2.6.29.3 | e-tobi 1.7.0 | streamdev cvs | live


    <30.12.07 <igel>sid fuer den gewissen kick>
    <01.04.08 <igel>ich kann eh nix ausser debian pakete installiern>
    <15.12.09 igel hasst linux>
    <23.02.10 <igel> easyvdr is nur easy wenn es easy is>

  • die channels.conf anzupassen ist ja auch kein wirkliches problem; einfach die vdr channels.conf nehmen und dahinter den channel namen, der zur tv.conf passt..
    nur bei der tv.conf, woher holt man da die zahlen der sender?


    infinite

    kuifje
    asus m2n-vm | Athlon 5600 | Nvidia 9300GE | TT S2-3200
    yaVDR 0.4 | 1.7.21
    haddock
    asus p4pe | 2ghz | 3x DVB-S Budget | 2x500gb
    debian lenny 2.6.29.3 | e-tobi 1.7.0 | streamdev cvs | live


    <30.12.07 <igel>sid fuer den gewissen kick>
    <01.04.08 <igel>ich kann eh nix ausser debian pakete installiern>
    <15.12.09 igel hasst linux>
    <23.02.10 <igel> easyvdr is nur easy wenn es easy is>

  • Aus der include.xml (oder so) die du von Epgdata.com Downloaden kannst.


    Welche Zahl du verwenden musst erschliesst sich aus dem Vergleich von z.B. ARD oder nen anderen Sender.


  • Sorry für die späte Antwort, hab schon ganz auf den Thread vergessen.


    Hier mal ein Log:



    und noch hier noch die Ausgabe von logread:



    Fehlermeldung sehe ich keine :] EPG seh ich aber auch keines ;(

  • Hab jetzt mal versucht EPG Daten händisch einzuspielen. Das funkt ohne Probleme, mein Test wird sofort im VDR EPG angezeigt.



    Gibt es eine Möglichkeit wie ich die Daten die epg4vdr an den VDR schickt sehen kann?
    Ich sehe ja nur die Log Meldungen vom vorigem Post. Und ich kann mir die xml Datei mit den EPG Daten ansehen. Vieleicht gibt es beim übersetzen der xml in das EPG Format vom VDR ein Problem?
    Der Log sagt ja nur das die Daten geschickt werden, und der zweite Log sagt nur das eine Verbindung akzeptiert wurde, ob etwas brauchbares geschickt wurde steht nirgendwo. Oder hab ich etwas übersehen?


    mfg
    KiLLERHOLiC

  • Schön langsam mach ich fortschritte.


    Hab jetzt mal aus der channels.example den ZDF in meine channels.conf kopiert.
    Wenn ich dann epg4vdr starte wird wieder alles normal eingetragen (die Logmeldungen sind alle ok).
    Wenn ich dann aber mit VDR-Admin die Programmübersicht von ZDF ansehe sind alle EPG Daten da!


    Hier mal ein ausschnitt meiner channels.conf:

    Code
    1. ORF1:522000:M64:C:6900:160:161=deu;163=deu:165:B00:13001:0:1118:0
    2. ORF2:522000:M64:C:6900:500:501=deu;503=deu:505:B00:13006:0:1118:0
    3. Das Erste:442000:M64:C:6900:101:102=deu,103=2ch;106=dd:104:B00:28106:0:1101:0
    4. ZDF:538000:M64:C:6900:110:120=deu,121=2ch;125=dd:130:B00:28006:0:1079:0
    5. ZDFtest:11954:H:S19.2E:27500:110:120:130:0:28006:1:1079:0


    Die letzte Zeile ist für meinen Test.
    Die channels.conf für epg4vdr schaut genau so aus:

    Code
    1. ORF1:522000:M64:C:6900:160:161=deu;163=deu:165:B00:13001:0:1118:0
    2. ORF2:522000:M64:C:6900:500:501=deu;503=deu:505:B00:13006:0:1118:0
    3. Das Erste:442000:M64:C:6900:101:102=deu,103=2ch;106=dd:104:B00:28106:0:1101:0
    4. ZDF:538000:M64:C:6900:110:120=deu,121=2ch;125=dd:130:B00:28006:0:1079:0:zdf.de
    5. ZDFtest:11954:H:S19.2E:27500:110:120:130:0:28006:1:1079:0:zdf.de


    Wenn ich epg4vdr starte läuft alles wie gewohnt durch. Dann kille ich vdradmind.pl und starte es neu. Wenn ich dann in die Programmübersicht gehe steht der "normale" ZDF nicht drinnen, der ZDFtest steht sammt den EPG Daten drinnen.
    Verschluckt sich epg4vdr an meiner Sender ID? Wie kann ich das beheben?
    Fragen über Fragen....

  • So hab mich noch weiter gespielt und eine Lösung für das Ursprungsproblem gefunden.
    Mein Problem war das ich bei manchen Sendern kein EPG hatte. Deshalb wollte ich mit Hilfe von epg4vdr das Problem lösen. Durch meine Tests an der channels.conf bin ich aber darauf gekommen das w_scan die NID auf 0 gestellt hat. Jetzt hab ich die NID händisch auf 1 gestellt, VDR wieder gestartet und schon war das EPG da. Hab es bei allen Sendern gemacht die kein EPG hatten und jetzt funkt es!!!!!
    epg4vdr funkt bei mir nicht, ist jetzt aber auch nicht mehr so schlimm. Das Problem von epg4vdr dürfte aber irgendwo in der Sendererkennung liegen.


    So, und jetzt gibts ein kühles Blondes :prost1


    mfg
    KiLLERHOLiC

  • hoi,
    bekomme leider immer wieder folgende Meldung beim Aktualisieren per start.sh,
    ist immer mal wieder kein epg fuer einen Tag verfuegbar !?


    Woran scheitert das jetzt ?
    Die von Epgdata.com meinten,das von ihrer Seite aus kein Fehler vorliegen wuerde,
    hatte sie mal deswegen angemailt.
    mfg

  • moin,
    hier funktioiert epg2vdr nicht mehr,
    da www.wontarra.net anscheinend down ist. :(
    Das epgfile hat er natuerlich vorher geloescht.
    Der Updatecheck ist ja wichtig, bei den vielen Updates.
    Da sollte mal erst ueberprueft werden, ob die site online ist,
    bevor das file geloescht wird.
    mfg
    /lasse jetzt das epg von epgdata auch per tvm updaten
    Danke.