[Gelöst] PVR350 Keine Anzeige TV

  • CT-VDR 3.06 PVR350 only
    Leider bekomme ich trotz intensiver forschung hier im Forum, überhaupt keine Anzeige am TV hin (Bild bleibt dunktel).


    Die Installation ist soweit ich das erstmal einschätzen kann ohne Probleme durchgelaufen.


    Ich habe dann die Änderungen beschrieben im Beitrag:
    http://www.vdr-portal.de/board/thread.php?threadid=25469 für
    /etc/modutils/ivtv... (letzten beide Einträge Kommentar gelöscht)
    /etc/modules (ivtv) eingefügt
    /etc/lilo.conf (video=vc:64-64) vorgenommen. Hier ist allerdings mir folgendes aufgefallen. Nach dem stoppen des vdr und eingabe von modprobe ivtv erhielt ich keine Ausgabe.


    Weiterhin ist mein Fernsehbild nach einem neustart ohne irgend eine Anzeige.


    In /var/log/messages taucht auch der Eintrag auf "no DVB device found"


    Habe dann noch den Beitrag http://www.vdr-portal.de/board/thread.php?threadid=27401&sid=&hilight=PVR350 gefunden. Hier wird das Thema mit dem falsch ausgewählten Tuner angesprochen in Verbindung mit ivtv Version. Hier ist wenn ich das richtig verstanden habe allerdings schon eine TV-Ausgabe vorhanden. Würde in soweit passen da ich wohl auch ein PVR350 habe mit einem ganz neuen Tuner. Allerdings das neueinbinden des ivtv hat nicht funktioniert (fehlendes Linux wissen). Habe dann neuinstalliert


    Bin absoluter Linux und VDR Neuling. Mein momentanes wissen bezieht sich auf 2 Wochen lesen hier im Forum.


    Vielleicht hat noch jemand einen Tipp (Falls irgendwelche Ausgaben zur Fehlereingrenzung notwendig sind, bitte die Kommandos mitteilen)

    CTVDR5 mit PVR350 und Hauppauge Fernbedienung nciht mehr in Betrieb.


    Neuaufbau eines VDR mit TT S2-6400 Phenom X2 550 Black Edition


    FreeNAS als Storage


    3 XBMC Installationen als Streamingclient

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Zippo ()

  • Hi!


    Einen VDR nur mit einer PVR350 ist wohl sehr schwierig momentan.
    Ich habe ebenfalls eine neuere PVR350 (Rev.991), benutze diese allerdings lediglich als Eingabegerät und eine DVB-c Karte als Ausgabegerät.
    Mit ivtv-0.1.9 ist funktioniert diese Revision nicht.
    Ich versuche Dir trotzdem mal zu helfen.


    Zunächst brauchst du eine neuere Version von ivtv und die kernel-headers.
    Also erstmal ein:
    apt-get install kernel-headers-2.4.27-ctvdr-1


    Dann lade Dir den ivtv Treiber 0.2.0 von
    http://205.209.168.201/~ckennedy/ivtv/
    herunter.


    Du deinstallierst den alten ivtv-Treiber.


    Entpacke den ivtv-Treiber und wechsle in das Verzeichniss driver und führe ein
    make
    make install
    aus.
    Ich glaube ich hatte allerdings Probleme mit den Pfadangaben im Makefile im Verzeichniss driver. (ist schon ein paar Monate her, dass ich das gemacht habe)
    Das selbe im Verzeichniss utils.


    Wahrscheinlich musst du noch weitere Entwickler-Pakete aus dem Sarge-Pool installieren, damit du kompilieren kannst.


    Lege dann eine Datei ivtv im Verzeichniss /etc/modutils an und schreibe folgendes rein:
    options ivtv ivtv_debug=0 ivtv_std=2 tda9887=0 mpg_buffers=90
    add below ivtv msp3400 saa7115 saa7127 tda9887
    options msp3400 once=1 simple=1 debug=0 standard=03


    Anschließend ein:
    update-modules und
    modprobe ivtv


    Schaue in /var/log/syslog ob er deinen Tuner erkannt hat.
    Wenn das funktioniert hat musst du noch in /etc/modules
    ivtv
    eintragen, damit der Treiber beim booten geladen wird.


    Ich hoffe, das ist ein wenig hilfreich ;-)


    Grüsse
    Tobi

    VDR 1.7.15 - Debian Squeeze/Kernel 2.6.32
    Rebach-Gehäuse, Intel Atom330, Extension HD, Technisat Cablestar2

  • Hallo Tobi,
    ich vermute auch anhand der gelesenen Beiträge das ich erstmal den ivtv updaten muss.
    Leider ist genau hier mein Problem da ich von Linux sehr wenig weiss.


    Der von die beschriebene Ablauf ist für mich leider nicht ganz nachvollziehbar. (Bin halt Linux laie, lerne aber gerne dazu)


    Befehl apt-get... kein Problem


    Muss ich im Verzeichnisbaum irgendwo stehen oder mach ich das in der root /


    Treiber herunterladen ?? Denke Du meinst wget http://205.209.168.201/~ckennedy/ivtv/ivtv-0.2.0-rc3d.tgz


    Deinstallieren des alten Treibers?? Keine Ahnung wie ich das mache. Bitte noch einen Hinweis


    Treiber entpacken?? Denke Du meinst tar -xzf ivtv-0.2.0-rc3d.tgz


    Das mit dem make würde ich dann probieren wenn ich die ersten schritte erledigt habe.


    Nochmals Danke, verzeihe die simplen Fragen aber komme sonst leider nicht weiter.

    CTVDR5 mit PVR350 und Hauppauge Fernbedienung nciht mehr in Betrieb.


    Neuaufbau eines VDR mit TT S2-6400 Phenom X2 550 Black Edition


    FreeNAS als Storage


    3 XBMC Installationen als Streamingclient

  • Zitat

    Muss ich im Verzeichnisbaum irgendwo stehen o...


    Nö, aber besser ist es, wenn du dir die Kernelsourcen / header nach
    > /usr/src
    holst und dann in dem Verzeichnis einen symbolischen Link auf deine Sourcen machst namens linux


    Danach noch die modulesversion aus den HeaderVerzeichnis in das KernelVerzeichnis kopieren : Siehst du dann schon, wo die Fehlermeldung kommt .....


    und die VDR bzw -devel sourcen nach
    > /usr/local/src/vdr
    bzw.
    > /usr/local/src/vdrdevel



    Zitat


    Ja


    Zitat

    Deinstallieren des alten Treibers


    > apt-get remove <Name vom Paket>


    Zitat

    Treiber entpacken?? Denke Du meinst tar -xzf ivtv-0.2.0-rc3d.tgz


    Endweder so oder kurz mittels
    apt-get install mc
    den MidnightCommander holen, mit mc aufrufen und damit enpacken ( kann aber sein, dass der mc da Probleme macht und die Datei in Ascci anzeigen will

    Hardware : Hewlett500 130mm Geh.,DVB-C,PVR350,Nova-T,MVP,248*128 GLCD,DVD NEC 3540,Intel 2,4Ghz mit Pipe101&SK2,Asus P4P800VM,512RAM,Powermate,STB-Erw.,mod. Hardware Wakeup von Steini,2*MVP

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Wesie ()

  • Hi Zippo!


    Ok, du hast ja geschrieben, dass Linux für dich neu ist.
    Und ich verstehe auch, dass es ein wenig Zeit braucht um Debian zu verstehen,
    aber jeder hat mal angefangen ;-)


    Also zuerst einmal ein Link zu ein wenig Dokumentation:
    http://www.de.debian.org/doc/


    Schaue vieleicht in die beiden Anleitungen:
    Debian Reference
    APT HOWTO


    apt-get ist ein Tool um Pakete zu installieren.
    Dies funktioniert sowohl von einem lokalen Datenträger, sowie auch aus dem
    Internet.
    Das musst du aufjedenfall erst mal verstehen, um weiter zu machen.


    Versuche erst mal die kernel-headers zu installieren.



    Gruß
    Tobi

    VDR 1.7.15 - Debian Squeeze/Kernel 2.6.32
    Rebach-Gehäuse, Intel Atom330, Extension HD, Technisat Cablestar2

  • Nach wie vor kein Bild auf dem TV, komme irgendwie nicht weiter.


    Gegenüber vielen anderen hier bekomme ich überhaupt keine Anzeige auf dem TV. Beim starten des PC ist ein rot/grün flackerndes Bild zusehen, wird dann der ivtv geladen ist der TV dunkel.


    In /var/log/messages finde ich den Eintrag "no DVB device found".


    Denke nachwievor das richtige wäre den ivtv auf die V02.0rc3d upzudaten.


    Das funktioniert halt momentan nicht da default ct-vdr3.06 keine Werkzeuge zum kompilieren vorhanden sind. Habe mittlerweile fast alles nachgeladen bekomme allerdings mit apt-get install den gcc und den g++ nicht. Details http://www.vdr-portal.de/board/thread.php?sid=&postid=252816#post252816 (Sackgasse)


    Ist für die Anzeige auf dem TV bei PVR350 only der ivtv zuständig oder wirkt da noch ein anderer mit.


    Was kann die Ursache für die Meldung no DVB device found sein.


    In einigen Beitägen tauchen immer wieder Statements auf zu dem verwendeten Tuner (alt = 5, neu = 38) kann man die irgendwie abfragen.


    Die installierten Version z.B. ivtv kann ich bestimmt auch irgendwie abfragen, wer kann mir sagen wie.


    Hoffe so den Fehler zumindest ein bischen besser einzugrenzen. WIchtig wäre vorallem eine Aussge ivtv updaten macht sinn oder bringt gar nichts.

    CTVDR5 mit PVR350 und Hauppauge Fernbedienung nciht mehr in Betrieb.


    Neuaufbau eines VDR mit TT S2-6400 Phenom X2 550 Black Edition


    FreeNAS als Storage


    3 XBMC Installationen als Streamingclient

  • Hi


    Ich bin auch ein neuling und bin teilweise weiter aber auch noch nicht fertig.


    Zuerst einmal ich bin so vorgegangen :
    ersteinmal in /etc/apt die sources.list geändert
    sources.list umbenannt in sources.list.old dann sources.list.online in sources.list umbenennen
    jetzt bekommst du die packete ausm netz und nicht von cd.
    dann ein apt-get install gcc-3.3 (compiler installieren)
    gcc-3.3 in /usr/bin in gcc umgenannt.


    nu haste erstmal einen compiler.


    als nächstes habe ich mir nen neueu kernel gezogen 2.6.10 allerdings direkt von kernel.org für alles andere war ich zu dämlich.Entpackt nach /usr/src/linux


    danach ein apt-get install ncurses-dev
    make menuconfig
    configuration nach http://www.vdr-portal.de/board/thread.php?threadid=17298&sid=
    make && make_install
    System-map nach /boot bzImage nach /boot
    lilo anpassen => neustart so jetzt haste schonmal den 2.6.10 kernel am laufen (hoffe ich)
    und dann bin ich erstmal nach der anleitung von
    http://www.vdr-portal.de/board/thread.php?threadid=18913
    vorgeganngen .
    Jetzt bin ich soweit das ich mit modprob ivtv die treiber laden kann
    und auch mir mit dd if=irgent_ein_mepg2_file of=/dev/video16 bs=64
    ein mepg2 file auf dem fehrseher ansehen kann aber wenn ich vdr -P pvr350 angebe bekomme ich die fehlermeldung
    can't open device IVTV_IOC_GET_FB: Ungültiger Dateidesriptor
    Now primary
    Speicherzugrffsfehler
    kannst ja erstmal soweit probieren
    gruß thelema

  • 2 Sachen die ich vergessen habe
    nach dem umbennen der source.list noch apt-get update
    und nach dem übersetzen der modules noch depmod
    sonst findet der kernel die module nicht


    fehlermeldung ist auch nicht korrekt
    war vor dem laden der ivtv treiber


    richtig ist:
    IVTV_ICO_GET_FB: Das Argument ist ungültig
    Now Primary
    Speichgerzugriffsfehler

  • Hi!


    Ein neuer Kernel ist nicht notwendig, da lediglich der ivtv Treiber kompiliert werden muss. Um den kompilieren zu können braucht man entweder die kernel-headers oder den kernel-source.
    Also ich fahre mit dem 2.4.27 Kernel vom ctvdr wirklich gut und sehe keine Notwendigkeit, den 2.6er Kernel verwenden zu müssen.


    Schaut ihr denn auch in die Logdatei /var/log/syslog?
    > cat /var/log/syslog | more
    Wenn es Probleme beim laden der Treiber oder beim Start vom vdr gibt steht das dort drin.


    Bei der Revision 991, der PVR350 (steht auf dem Karton), braucht man einen neueren ivtv-Treiber.
    Schaut erst mal ob ihr ivtv zum laufen bekommt, bevor ihr an den vdr geht.
    Mit einem
    cat /dev/video0 > test.mpg
    könnt ihr schauen ob ihr überhaupt etwas empfangt und mit einem
    cat test.mpg > /dev/video16 (ich hoffe das war video16, bin mir jetzt nicht sicher) könnt ihr das auf dem TV wieder ausgeben.
    Wenn ihr ein Bild oder das typische Fernsehrieseln sieht, funktioniert der ivtv-Treiber.



    Gruß
    Tobi

    VDR 1.7.15 - Debian Squeeze/Kernel 2.6.32
    Rebach-Gehäuse, Intel Atom330, Extension HD, Technisat Cablestar2

  • Bin wesentlich weiter gekommen. Habe den ivtv upgedatet auf die 02.0-rc3d.
    Beim hochfahren des systems erscheint das in vielen Beiträgen beschriebene grüne Bild. Wechselt dann in eine schwer zu beschreibene Anzeige lauter bunter Punkte.


    Im syslog habe ich folgendes gefunden:
    VDR kernel: ivtv: Initialized WinTV PVR 350, card #0
    denke ich schaut schonmal nicht schlecht aus


    Weiter unten finde ich dann allerdings folgendes
    VDR vdr[1248]: ERROR: unknown config parameter: analogtv.avSyncHack = 0
    und ein paar zeilen tiefer
    VDR vdr[1248]: no DVB device found


    Hast du noch eine Idee


    Danke

    CTVDR5 mit PVR350 und Hauppauge Fernbedienung nciht mehr in Betrieb.


    Neuaufbau eines VDR mit TT S2-6400 Phenom X2 550 Black Edition


    FreeNAS als Storage


    3 XBMC Installationen als Streamingclient

  • Hi Zippo!


    Bekommst du ein Bild vom OnScreen Menü des vdr?


    Auf der ctvdr-cdrom ist ein Video enthalten.
    Stoppe mal den vdr (/etc/init.d/vdr stop) und versuche mal
    ein cat 001.vdr > /dev/video16


    Wenn das auf dem Fernseher erscheint, sieht es schon mal ganz gut aus.



    Gruß
    Tobi

    VDR 1.7.15 - Debian Squeeze/Kernel 2.6.32
    Rebach-Gehäuse, Intel Atom330, Extension HD, Technisat Cablestar2

  • Hallo Tobi
    denke das ich noch nicht ganz soweit bin.


    1. cat /dev/video0 > test.mpg erstellt eine Datei die auch grösser wird.
    2. cat test.mpg > /dev/video16 verändert sich die Anzeige TV nicht, habe die Test.mpg nach Windows gezogen, es wird graues rauschen angezeigt
    3. Stoppe mal den vdr (/etc/init.d/vdr stop), die Anzeige des TV verändert sich leider nicht.
    4. Auf der CT-CDROM, habe mir die CD online runtergezogen, weiss nicht ob da das video auch drauf ist. Finde es zumindest nicht.
    5. cat 001.vdr > /dev/video16, bekomme die Ausgabe 001.vdr: Datei nicht gefunden

    CTVDR5 mit PVR350 und Hauppauge Fernbedienung nciht mehr in Betrieb.


    Neuaufbau eines VDR mit TT S2-6400 Phenom X2 550 Black Edition


    FreeNAS als Storage


    3 XBMC Installationen als Streamingclient

  • Hallo Tobi,
    noch ein paar erkenntnisse:


    Habe eine Musik-CD verwendet mit einem mpg darauf.
    Bekomme erstaunlicherweise den Ton (ist auch schon was) aber das Bild verändert sich nicht.

    CTVDR5 mit PVR350 und Hauppauge Fernbedienung nciht mehr in Betrieb.


    Neuaufbau eines VDR mit TT S2-6400 Phenom X2 550 Black Edition


    FreeNAS als Storage


    3 XBMC Installationen als Streamingclient

  • Hi Zippo!


    Versuche es mal mit dem Video auf der ctvdr-CD. Ich weiß jetzt nicht Auswendig in welchem Verzeichniss es liegt. Wenn ich die in die PVR schreibe, funktioniert das.


    Ein graues rauschen sieht doch schon mal gut aus.
    Ein Fernsehbild bekommst du natürlich nur, wenn der Tuner auf eine Frequenz gesetzt wird, auf der ein Fernsehsender liegt, aber das ist dann eine Einstellungssache, die man in der channels.conf später einstellt.


    Wenn der TV-Ausgang und der Tuner jetzt geht, sollte man vieleicht mal versuchen ob man mit dem vdr ein onscreen Menü sehen kann.



    Gruß
    Tobi

    VDR 1.7.15 - Debian Squeeze/Kernel 2.6.32
    Rebach-Gehäuse, Intel Atom330, Extension HD, Technisat Cablestar2

  • Hi Tobi,
    schätze habe noch ein grösseres problem. Habe jetzt halt zwar eine Ausgabe auf dem TV obere zwei drittel schwarz-weiss gestreift untere drittel farbig gestreift. Egal ob VDR gestartet oder nicht.


    Im Syslog habe ich immer noch den Eintrag "no DVB device found".
    Schätze das ist halt noch mein Problem. Habe mein log mal mit dem aus dem Beitrag http://www.vdr-portal.de/board/thread.php?threadid=27401&sid=&hilight=PVR350 Wesie 26.02.2004 verglichen und festgestellt das er die Meldung erhält "End init ivtv" die bei mir fehlt.


    Habe noch nicht raus wie ich die logs nach windows bekomme mit zeilenumbrüchen sonst hätte ich das schonmal angehangen.

    CTVDR5 mit PVR350 und Hauppauge Fernbedienung nciht mehr in Betrieb.


    Neuaufbau eines VDR mit TT S2-6400 Phenom X2 550 Black Edition


    FreeNAS als Storage


    3 XBMC Installationen als Streamingclient

  • Hi Zippo!


    Verliere jetzt ein bißchen den Überblick.


    Hast du einen neuen ivtv-Treiber kompiliert und installiert (0.2.x)? (sehr wichtig, wenn die PVR eine neue Revision ist)


    Hast du die Datei /etc/modutils/ivtv angelegt wie oben beschrieben und dann 'update-modules' ausgeführt?


    Hat ivtv den Tuner erkannt und gibt sonst keine Fehler aus (steht im syslog)?


    Hast du versucht das Video auf der ctvdr-CDROM auf der PVR abzuspielen (Wichtig ist, das du den vdr vorher gestoppt hast mit /etc/init.d/vdr stop)?


    Wenn das alles nicht gemacht ist, macht es keinen Sinn den vdr zu versuchen zum Laufen zu bekommen!


    Gruß
    Tobi

    VDR 1.7.15 - Debian Squeeze/Kernel 2.6.32
    Rebach-Gehäuse, Intel Atom330, Extension HD, Technisat Cablestar2

  • Hallo Tobi, hier deine Fragen der reihe nach


    1. ivtv Treiber ist die 0.2.0-rc3d
    2. in /etc/modutils habe ich die Einträge in der Datei ivtv.2.4.27-ctvdr-1 gemacht. Danach update-modules. Die Änderungen sind in der modules.conf automatisch übernommen worden.
    3. ivtv hat den Tuner meiner Meinung nach erkannt, gibt auch keine Fehler aus. Allerdings die letzten Einträge sind:
    ivtv-osd: mode is 720x576x32 linelenght=2880
    Console: switching consoles 64-64 to frame buffer device
    ivtv-osd: fb0: iTVC15 TV out frame buffer device


    dachte da fehlt noch was.
    Bei VDR vdr[942]: no DVB device found


    4. Habe das Video auf meiner CD nicht gefunden. Hatte eine CD mit einem mpg file darauf. Wenn ich dieses ausgebe erhalte ich ton allerdings kein anderes TV-Bild

    CTVDR5 mit PVR350 und Hauppauge Fernbedienung nciht mehr in Betrieb.


    Neuaufbau eines VDR mit TT S2-6400 Phenom X2 550 Black Edition


    FreeNAS als Storage


    3 XBMC Installationen als Streamingclient

  • WEnn die PVR als Ausgabe benutzt weden soll:
    in /etc/modulutils die letzten 2 "#" löschen , damit sollte die Ausgabe auch scharf geschalten werden.
    Weiter zum VDR :
    Du brauchst auf alle Fälle das Plugin-pvr350only oder ähnlich.


    Das setzt aber vorraus, das der ivtv Treiber die Karte erkennt und das du auch etwas darüber rausschieben kannst.
    BTW.: Der Fernseher steht schon auf dem richtigen AV Eingang und die Richtige Eingangsart ? RGB Geht nicht mit dem normalen Ausgang => composite

    Hardware : Hewlett500 130mm Geh.,DVB-C,PVR350,Nova-T,MVP,248*128 GLCD,DVD NEC 3540,Intel 2,4Ghz mit Pipe101&SK2,Asus P4P800VM,512RAM,Powermate,STB-Erw.,mod. Hardware Wakeup von Steini,2*MVP

  • Die Meldung vom ivtv sieht vielversprechend aus.


    Test mal den vdr mit der Option -P pvr350 zu starten.


    Die Meldung no DVB Device ist normal; die pvr ist eben kein DVB device.

  • Habe den Fernseher auf korrekten AV Y/C bzw SVideo. Habe auf beide mit Windows die Kanäle.
    Die beiden # in /etc/modutils sind auch gelöscht.
    Das PlugIn PVR350 habe ich bei der Installation mitgeladen.
    Der ivtv Treiber hat die Karte geladen. Bekomme allerdings mit cat film.mpg > /dev/video16 nur ton kein bild.

    CTVDR5 mit PVR350 und Hauppauge Fernbedienung nciht mehr in Betrieb.


    Neuaufbau eines VDR mit TT S2-6400 Phenom X2 550 Black Edition


    FreeNAS als Storage


    3 XBMC Installationen als Streamingclient