vdr-plugin-analogtv 0.9.36

  • Hallo,


    da ich das im Betreff genannte Plugin immer noch nicht zum laufen bekommen habe, wollte ich nochmal nachfragen, ob das bei irgendwem zur zufriedenheit funktioniert?
    Beim Start des Plugins, kommt's bei mir immer zu einem Speicherzugriffsfehler, wenn ich vdr von der Kommandozeile starte, ansonsten restartet der vdr dauernd.
    Mein System ist ein ctvdr3 mit Tobis sarge/experimental repository auf einem Kernel 2.6.10 und ivtv- 0.3.2a.


    Ciao


    massi

  • Speicherzugriffsfehler kommt? Sollte gar nicht passieren.


    Mach mal ein


    make plugins-clean
    make plugins

  • Dann wurde das Paket möglicherweise mit einem andren Compiler gebaut oder mit andren libs verlinkt.

  • Dann poste bitte mal die Ausgabe beim Compilieren und die logs beim Starten des VDR.

  • Hallo,


    das gibt's in der /var/log/messages wenn der vdr per /etc/init.d/vdr start gestartet wird:


    und das wenn man den vdr von der Kommandozeile startet:


    Beim kompilieren läuft alles sauber durch ohne irgendwelche Fehlermeldungen.



    Ciao


    massi

  • Oh, ist ja lustig. Nix weiter? Dann bleibt ja nix weiter als systematisch nach allem zu suchen worauf analogtv zugreift: libs, audio-devices wie z.B. /dev/dsp, /dev/mixer, videodevices, die Einstellungen in der setup.conf dazu.

  • Hallo,


    Zitat

    Oh, ist ja lustig.


    Naja, geht so. ;)


    Zitat

    Nix weiter?


    Nee, leider nicht, das ist ja das Blöde.


    Zitat

    Dann bleibt ja nix weiter als systematisch nach allem zu suchen worauf analogtv zugreift: libs, audio-devices wie z.B. /dev/dsp, /dev/mixer, videodevices, die Einstellungen in der setup.conf dazu.


    Da das analogtv-plugin 0.9.33 ja einwandfrei funktioniert, dürften die Audio-/Videodevices wohl auszuschliessen sein. Die setup.conf habe ich auch schonmal gelöscht, das Resultat ist das Gleiche. Bleiben die Libs, nur welche werden vom analogtv-plugin benötigt?


    Ciao


    massi

  • Hallo,


    für alle die es noch interessieren sollte, das Speicherzugriffsproblem mit dem analogtv Plugin konnte ich lösen. Es liegt an dem im Makefile entkommentierten NEED_OWN_SIP=1
    Zitat aus dem README.de des Plugins:


    Zitat

    Wer den VDR _ohne_ DVB-Karte betreibt, d.h. das analogTV-Plugin als
    primary device verwendet, kommt durch _aktivieren_ der Zeile


    # NEED_OWN_SIP = 1


    im "Makefile" in den Genuß des EPG.


    Da ich meine PVR zusammen mit einer DVB-C Karte betreibe hätte das auskommentiert sein müssen, bei den früheren analogtv Versionen war das auch so.


    Ciao


    massi