IBM PC 300 PL --> ACPI / NVRAM Problem

  • Hallo Leute,


    ich hätte da mal ne blöde Frage: Benutzt vielleicht einer von Euch einen IBM PC 300 PL - 350 Mhz als VDR?? Wenn ja, wie habt Ihr das mit ACPI eingestellt, damit es funktioniert??? Bekomme es einfach nicht gebacken.
    Noch besser wäre natürlich wenn mir auch einer sagen könnte was man tun muss um NVRAM auf diesem Rechner zu laufen zu bekommen.


    Wäre echt für jeden Tipp dankbar.


    Gruß. COWBOY


    PS: Ich weiss es gibt hierzu schon tausende Beiträge, doch hat mich meine Recherchen bis jetzt nicht wirklich weiter gebracht :(

  • Hi cowboy,


    kannst du im Bios des Rechners manuell eine Aufwachzeit eingeben und activieren? wenn ja kommst du drüber an die nötigen ACPI-Einstellungen.
    wenn nein hast du wohl verloren (evtl noch Biosupdate?)


    Anschliesend hilft dir guess-helper zu einer funktionierenden config
    Gruss Ulf

    Samsung UE43RU7479U, Antec Fusion Black, Prime A320m-k, Athlon 200GE, Geforce GT 1030, [ DVB-C oder] DVB-T2

    Edited once, last by ULF ().

  • Hi Ulf,


    ja ich kann sogar ein Datum vorwählen. Wenn ich das mache startet der PC auch termingerecht (einmal). Wenn ich jedoch einen Timer im VDR programmiere übergibt er diesen Wert nicht ins BIOS. Ich dachte ACPI aktivieren im BIOS und im VDR und schon läufts?!?!?!


    Du sprichst von guesshelper --> Das bezieht sich doch auf NVRAM oder???


    Cowboy

  • Hab was vergessen. Was meinst du ich komme darüber an die ACPI Einstellungen???? Alles was ich einstellen kann ist ACPI on/off und dann den Tag (Datum) und Uhrzeit. Sollte es da weitere Einstellungen geben????


    Cowboy

  • [Edit]Unsinn gelöscht scheint ja um Linvdr zu gehen[/edit]


    guesshelper gehört natürlich zu nvram-wakeup und hilf dir eine funktionierede Konfigurationsdatei zu erzeugen.


    Dazu must du nvram-wakeup natürlich installieren. wie das geht ist abhängig von deiner Distribution.
    einfach mal :suche im Portal oder ins www.vdr-wiki.de schauen

    Gruss Ulf

    Samsung UE43RU7479U, Antec Fusion Black, Prime A320m-k, Athlon 200GE, Geforce GT 1030, [ DVB-C oder] DVB-T2

    Edited 2 times, last by ULF ().

  • Hi,


    habe auch einen IBM PC 300 PL, aber 450MHz. Dürfte ziehmlich das gleiche Ding sein.


    Standard nvram funktioniert nicht.
    Es funktioniert die Methode2, beschrieben in der README.nvram.


    Wie bin ich darauf gestoßen:
    Zuerst versuchte ich die Methode
    Sytematisches Kopieren des CMOS


    Ergebnis der nvram-wakeup.conf:
    ################################################
    ## Mainboard autodetection information:
    ##
    ## - Mainboard vendor: "IBM"
    ## - Mainboard type: "6862V10"
    ## - Mainboard revision: "(null)"
    ## - BIOS vendor: "IBM"
    ## - BIOS version: "NVKT44AGR"
    ## - BIOS release: "04/23/99"


    rtc_min = 0x75
    rtc_hour = 0x77
    addr_stat = 0x7F # but differs somewhere else
    rtc_date = 0x7F
    reset_date = ON


    Danach ge"google"t und die Seite von Hubertus Sandmann gefunden:
    http://home.t-online.de/home/h…s.sandmann/vdr_wakeup.htm


    Dort wird follgendes beschrieben:
    2.3.1 RTC
    In selteneren Fällen ist es mittels guess nicht möglich, die Bytes für addr_sec, addr_min und addr_hour, sondern liefert ein Ergebnis wie im folgenden Beispiel.
    ...
    rtc_sec = 0x73
    rtc_min = 0x75
    rtc_hour = 0x77
    ...


    H I N W E I S: Als ich dies damals (schon lange her) machte, funktionierte guess noch nicht. Vielleicht geht's mit der neuen Version. Probier's mal.



    Mit dem Tool rtc kann das RTC-Alarm-Register ausgelesen und überprüft werden, ob die ausgegebene Zeit mit der eingestellten Wakeup-Zeit übereinstimmt.
    ./rtc


    In diesem Fall wäre dann die obige Ausgabe in der /etc/nvram-wakeup.conf zu ersetzen durch die Zeile:
    ...
    rtc_time = ON
    ...


    Das traf auf meine erstellte nvram-wakeup.conf zu.
    Also habe ich die Methode2 probiert


    1.) In der rc.config die Wakeup Methode auf timer gestellt
    # nvram wakeup method (timer | rtc)
    NVRAM_WAKEUP="timer"
    und
    VDR_CMD="vdr -s /usr/sbin/shutdown"
    angepasst.
    2.) in der nvram-wakeup.conf steht nur der Wert
    rtc_time = ON
    (sonst nichts)
    3.) BIOS: Datum auf letzten Tag und Uhrzeit auf 23:59 stellen


    und Jubel, es hat funktioniert.
    Jetzt habe ich einen SSSSuper kompletten Videorecorder.



    Methode2:
    Alternativ kann auch die wakeup-Metode auf timer gestellt werden. In diesem Fall muss die Wakeuptime im Bios von Hand (soweit moeglich) auf 23:59:59 Uhr und den 31.12.2000 gestellt und aktiviert werden. Bei dieser Metode wird beim Runterfahren die Uhrzeit verstellt. Der PC muss nach dem Einschalten also auf jeden Fall die MLD booten, damit die Uhrzeit wieder korregiert wird.



    Example:
    VDR_CMD="vdr -s /usr/sbin/shutdown"

  • Hallo an alle!


    Ich bin neu hier im forum und als ich euern thread hier lass, habe ich mich angemeldet, denn ich steh bei meinem IBM 300PL 500MHz auch vor einem nvram problem.


    Ich verwende linvdr 0.7 und habe das *.deb packet von nvram-wakeup darauf installiert - version 0.97
    Habe mit guess-helper mein BIOS ausgelesen und dann die nvram-wakeup.conf mit: nvram-wakeup -N -s 'date -d "2005-01-18 18:00:00" +%s' -A -C /etc/nvram-wakeup.conf ausprobiert.


    da bei mir auch in der nvram-waleup.conf
    rtc_min = ...
    rtc_hour = ...
    vorkommt, habe ich diese beiden zeilen durch rtc_timer=ON ersetzt.


    Im BIOS wurde ebenfalls als Tag 18 und als Zeit 18:00h eingestellt.


    Als output bekam ich dann: (Anmerkung: Die Speicheradressen stimmen nicht ganz, muesste mal das original stdout posten falls es jemand braucht)


    Wakeup : Enable (0x41)
    rtcDay : 18 (0x08 )
    rtcHour: 18
    rtcMinute: 00
    rtcSecond: 00


    Enabling (0x41) WakeUp-on-RTC in nvram
    New rtcDay: 18 (0x08 )
    New rtcHour: 18
    New rtcMinute: 00
    New rtcSecond: 00



    Worauf ich jetzt hinaus moechte ist folgendes:
    wenn ich jetzt den rechner neu boote und in BIOS mir die wakeup zeit anschaue, dann ändert er bis auf den Tag nichts an den aufweckzeiten. ich vermute deshalb, da er bei tag eine adresse (0x08 ) erkennt und bei den stunden und minute keine speicheradresse findet.
    was kann man da tun, das er auch die stunde und minuten richtig erkennt?


    Nebenbei: Um zu ueberpruefen, ob er tasaechlich den tag im BIOS ueberschreibt, habe ich einfach 31 als Tag und 23:59h eingetragen.
    nachdem ich dann die -N option bei nvram-wakeup weggelassen hab, stand im BIOS 18 als tag, aber 23:59 blieb unveraendert.


    Kann mir jemand bei diesem Problem weiterhelfen? Wenn ihr irgendeine log files braucht, oder die nvram-wakeup.conf, sagt bescheid!


    @peter_weber69: wo befindet sich rc.config? bei linvdr 0.7 gibt es diese nicht - oder bin ich blind?


    Thomas

    debian squeeze mit vdr 2.1.6 [Asus E35M1-M mit TT 6400 und TT Budget S2 3200]

    Edited 2 times, last by HALLO01 ().

  • Hi Thomas,


    rc.config: Verwende www.miniDVBlinuix.org
    bei linvdr ? Es wird aber wahrscheinlich irgendwo eine config geben wo Du NVRAM_WAKEUP="timer" einstellen kanst.


    lg
    Peter

  • Moin zusammen,
    ich habe einen 300GL mit 266 Mhz, dürfte sich aber nicht viel unterscheiden.
    APCI läuft mit LinVDR 0.7 out-of-the-box.
    Die 3 a's *g*
    aufwachen, aufnehmen, abschalten funktioniert problemlos.
    Keine NVRAM Geschichten.
    Im Bios habe ich nur APCI eingeschaltet, mehr nicht.
    Kannst ja mal probeweise LinVDR installieren, um zu sehen, wie der Rechner sich mit ACPI verträgt.
    NVRAM ist imho nicht nötig.

    Software: LinVDR 0.7, Kernel 2.6.17, Cody 1.4
    Hardware: IBM 300GL, PII 266MHz, 256MB, 80GB Maxtor, DVB-S 1.6, DVB-T Budget(leider), AVBoard

  • Hallo Hallo01
    und :welcome
    bei Linvdr findest du Hinweise zu dem IBM z.B: hier:
    http://linvdr.org/wiki/index.p…agename=LinVDR-Mainboards


    Sinnvoll währe glaube ich auch einen neuen Thread zu deinem Problem zu eröffnen. Bleibt dann doch übersichtlicher.

    Die Anleitung von Hubertus Sandmann bezieht sich zwar auf SuSE kann dir aber dennoch einen Überblick verschaffen.


    Nvram bring normalerweise auch ein gutes Readme mit (hoffentlich auch beim Linvdr)


    Sonst ist www.linvdr.org oder
    das www.vdr-wiki.de oder die Portal FaQ dazu sehr lesenswert.


    und Nvram ist bei Linvdr glaube ich nicht die erste Wahl siehe Linvdr Doku


    Gruss Ulf

    Samsung UE43RU7479U, Antec Fusion Black, Prime A320m-k, Athlon 200GE, Geforce GT 1030, [ DVB-C oder] DVB-T2

    Edited once, last by ULF ().

  • Hi Peter!


    Danke fuer deine schnelle antwort!


    Haett da noch ne frage an dich: hast du im BIOS ACPI enabled?
    wenn du dann nen timer programmierst und den rechner neu bootest und im BIOS dann bei der aufwachzeit nachschaust - aendern sich dann bei dir der tag bzw die stunden und minuten auf die des timers?


    weiters, musst du deinen rechner rebooten, oder reicht es wenn du ihn nur mit poweroff bzw mit der fernbedienung auschaltest?


    lg,
    Thomas

    debian squeeze mit vdr 2.1.6 [Asus E35M1-M mit TT 6400 und TT Budget S2 3200]

  • Hi,


    Lord Helmchen, das versteh ich jetzt nicht ganz.


    Einfach linvdr installieren und das aufwachen funktioniert ohne weitere Software Einstellungen?


    lg
    peter

  • HALLO01,


    ACPI ist enabled, BIOS-Zeit ändert sich.
    Zuerst aber alles auf Tag 31 und Zeit 23:59 stellen.


    Das Ganze hatte bei mir nur einen Haken. Bei der Sommer/Winterzeit Umstellung fing alles zu "spinnen" an. Habe nvram dann eingestellt.


    Darum wäre vielleicht die linvdr Geschichte wenn's funktioniert vielleicht doch interessanter.


    @edit, L I N V D R FAQ:
    ..........=======............
    Q: Automatische einschalten des Rechners mit ACPI funktioniert nicht, umstellen auf settime Methode von Mirko Dölle


    Im Script /usr/bin/poweroff.pl den Parameter $Methode auf 1 für settime ändern.


    $METHOD = 1; # 0 = ACPI-Wakeup, 1 = settime


    Anschließend im BIOS unter Powermanagent die RTC (Real Time Clock) (Aufweckzeit des Rechners) auf den 1 im Monat um 00:00:00 einstelllen.


    Nähre Informationen auch im Artikel Weckdienste im Linux-Magazin von Mirko Dölle http://www.linux-magazin.de/Ar…004/08/wakeup/wakeup.html



    lg
    Peter

  • Hallo Peter!


    Danke fuer deinen Tipp, werd ihn heut mal am abend ausprobieren und morgen berichten!


    Hab dies zwar schon mal versucht, aber nicht die Aufweckzeit im BIOS auf den ersten und 00:00 gestellt.
    vielleicht klappts......

    debian squeeze mit vdr 2.1.6 [Asus E35M1-M mit TT 6400 und TT Budget S2 3200]

  • Hi,
    ob der 1. 0.00 Uhr oder der 31. 23:59 Uhr eingestellt werden ist im Prinzip vollkommen egal, wäre ja auch nur 1 Minute Differenz.
    Beim 1. des Monats um 0.00 Uhr würde er nur jeden Monat, sofern kein Timer gesetzt ist, unnötigerweise starten.
    Beim 31. um 23.59 Uhr würde er es nur 7x pro Jahr tun :D


    Gunnar

    vdr 2.x / Gentoo Linux / Wavefrontier T-90
    >> no gates no bills just satisfaction <<

  • @peter_weber69
    Ja, funktionierte out-of-the-box.
    Musste nichts weiter einstellen.


    HALLO01
    Gute Frage, nächste Frage.
    Bin zur Zeit auf Arbeit.
    Ich schaue mal heute Abend ins Bios.

    Software: LinVDR 0.7, Kernel 2.6.17, Cody 1.4
    Hardware: IBM 300GL, PII 266MHz, 256MB, 80GB Maxtor, DVB-S 1.6, DVB-T Budget(leider), AVBoard

  • Lord Helmchen : danke fuers nachschaun. meine BIOS version lautet: NVKT49RUS


    haet da noch ne frage: Im BIOS hast du nur ACPI aktiviert. Hast du auch eine Aufwachzeit eingestellt, oder ist dies bei dir deaktiviert? Was ist mit APM? Enabled oder disabled


    Gruesse,
    Thomas

    debian squeeze mit vdr 2.1.6 [Asus E35M1-M mit TT 6400 und TT Budget S2 3200]

  • Ich habe keine Aufwachzeit eingestellt.
    Wozu auch?
    Dafür reicht einmal "cat" *g*
    APM bin ich mir nicht sicher, ich schaue mal.

    Software: LinVDR 0.7, Kernel 2.6.17, Cody 1.4
    Hardware: IBM 300GL, PII 266MHz, 256MB, 80GB Maxtor, DVB-S 1.6, DVB-T Budget(leider), AVBoard

  • So, habe mal ins Bios geschaut.
    APM ist aktiviert, wobei ich das nicht explizit eingestellt habe.
    Hier dann die Produktdaten (hab mal alles reingeschrieben, weil ich nicht weiss was relevant ist):


    Maschinentyp/Modell: 6561190
    Flash-EEPROM-Revisionsstand: NZKT42ASG
    Überarbeitungsversion des Boot-Blocks: NZ24A
    Systemplatinenkennung: 9523C12ZW0G
    Systemseriennummer: 0000000
    System-UUID: b2cb47b323552012afb341be423c2922
    BIOS-Datum: 06/16/00

    Software: LinVDR 0.7, Kernel 2.6.17, Cody 1.4
    Hardware: IBM 300GL, PII 266MHz, 256MB, 80GB Maxtor, DVB-S 1.6, DVB-T Budget(leider), AVBoard

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!