Fernbedienung geht plötzlich nicht mehr

  • Ja, ja ich weiss - einfach so geht gar nichts kaputt. Man(n) hat immer irgend etas gemacht, bevor irgendwas nicht mehr geht (in diesem Fall die Fernbedienung).
    Aber diesmal trifft mich keine Schuld, denn ich war grade in Vietnam als mich meine Freundin völlig aufgelöst anrief und mir erzählte das die Fernbedienung nicht mehr geht. So beschrieb sie den Ablauf:


    [list=1]
    [*]Eine Aufnahme geschaut
    [*]Die grade gesehene Aufnahme wurde gelöscht. VDR reagiert "irgendwie langsamer".
    [*]Neue Timer programmiert, überflüssige gelöscht. VDR reagiert "noch langsamer" auf die FB
    [*]VDR reagiert gar nicht mehr auf die FB
    [/list=1]
    - Neustart des VDR wurde danach mehrfach durchgeführt.
    - Das Kabel des Infrarotempfängers an der Nexus 2.1 wurde auf korrekten Sitz überprüft
    - Die Fernbedienung geht noch, die hab ich nach meiner Heimkehr gleich getestet.
    - Das Logfile hab ich mir auch angeschaut - nichts auffälliges...


    Wie kann ich jetzt die FB testen um einen Hardwaredefekt auszuschließen?
    Was kann ich sonst noch tun?

    VDR:
    CPU: PIII 800 | Motherboard: Gigabyte GA-6OXM7 | HDA: Samsung SP2514N 250GB | HDB: Samsung SV1604N 160GB | DVD: LG GSA-4040B| DVB-S: TT 2.3 FF | VDR: Mahlzeit-ISO vdr1.4.0 #2


    TV/AV:
    Toschiba: 42Z3030D | Sony: Playstation 3 (Firmware: 2.1)

  • Blöde Frage, aber hast Du mal neue Batterien in die FB getan und damit nochmal probiert?
    Hatte den Fall schon öfters, dass die FB mal gut und mal nich so gut ging wenn die Batterien am Ende waren.


    Gruß
    Christian

    Hardware: A7V133, Athlon 1,2@900, 128 MB RAM, 160 GB Samsung HDD, FF TT 1.5 DVB-S
    Software:C't VDR, nvram-wakeup, vdrconvert, vdradmin
    Geplant: Budget DVB-S, Gehäuse mal schön machen :D

  • Quote

    Wie kann ich jetzt die FB testen um einen Hardwaredefekt auszuschließen?


    Wenn du eine Digitalkamera hast (oder eine Videokamera), kannst du die FB vor dem Objektiv halten und die Tasten drücken. Auf dem Display kannst du dann erkennen, wie die IR-LED flackert (wenn die FB funktioniert).

    Hardware:Athlon XP 2000@1250 Mhz, Asrock K7VT2, 512 MB RAM, 1x60 GB + 1x250 GB Maxtor HDD, FF Nexus-s 2.1, TT Budget
    Software:C't VDR5, nvram-wakeup

  • Die Fernbedienung läuft einwandfrei an meinem Verstärker. Ich geh mal davon aus das da kein Problem liegt.


    Bleibt das Kabel des IR empfängers oder etwas auf der DVB Karte oder ein Softwareproblem.


    Was kann ich tun? Das der VDR langsamer reagiert kommt ja schon mal vor, hab ja auch ein schwachbrüstiges Teil (siehe Signatur) aber etwas komisch ist es schon, da meine Freundin den VDR ja nur benutzt hat...


    Bin jetzt etwas ratlos...

    VDR:
    CPU: PIII 800 | Motherboard: Gigabyte GA-6OXM7 | HDA: Samsung SP2514N 250GB | HDB: Samsung SV1604N 160GB | DVD: LG GSA-4040B| DVB-S: TT 2.3 FF | VDR: Mahlzeit-ISO vdr1.4.0 #2


    TV/AV:
    Toschiba: 42Z3030D | Sony: Playstation 3 (Firmware: 2.1)

  • Hi!


    Wie wäre es mit back2theroots?


    Alles was nach lirc aussieht killen, anschliessend mit mode2 einfach mal schauen, ob überhaupt Daten ankommen.


    Anschliessend irw ausprobieren, ob Tasten erkannt werden.


    Dann weisst Du ob es an der Hardware liegt, am Lirc oder am VDR.


    Tschau
    Tueftler17

  • tueftler17 : thanx für die idee - hab aber das "Problem", nicht LIRC zu benuzten sondern das Remote-Plugin, da ich den Hauppauge IR-Empfänger benutze...


    hab beim Pluginentwickler schon mal geschaut. Es gibt da zum testen ein kleines proggie namens eventtest oder so (kann grad nicht nachschauen). Anscheinend ist das aber nicht in der C't Version mit dabei, oder?


    Ich dachte mir, daß man irgendwo eine Konsole aufmachen kann und die IR Signale ankommen sieht (naiv gesprochen). Oder soll man die FB komplett neu anlernen?


    Achje, das ist bestimmt nur ein kleines Problem - ich bin aber nicht Linux-Profi genug um es ohne eure Hilfe zu lösen...

    VDR:
    CPU: PIII 800 | Motherboard: Gigabyte GA-6OXM7 | HDA: Samsung SP2514N 250GB | HDB: Samsung SV1604N 160GB | DVD: LG GSA-4040B| DVB-S: TT 2.3 FF | VDR: Mahlzeit-ISO vdr1.4.0 #2


    TV/AV:
    Toschiba: 42Z3030D | Sony: Playstation 3 (Firmware: 2.1)

  • Auf die Gefahr hin das ich hier nur noch mit mir selbst rede... mir kann keiner helfen? Also was ich jetzt nochmal probiert habe:


    [list=1]
    [*]remote.conf aus etc/vdr gelöscht (ist nach einem neustart wieder da) - wie kann ich die FB neu anlernen? falls der VDR dann nicht reagiert liegt wohl ein Hardwareproblem vor, oder?
    [*]Log nochmal durchgeschaut - werde es mal unten drannhängen
    [*]Per VDR Admin läuft alles problemlos
    [/list=1]
    Bin echt ratlos... muss ich jetzt die karte in meinen Windows pc einbauen um die Infrarot-Funktionalität zu testen, oder gibt's da nicht sonst noch möglichkeiten?


    Im der faq zum remote-plugin steht noch was von "evtest" - das scheint aber beim c't VDR nicht dabei zu sein - oder ich bin zu blöd das Ding zu finden.


    Hier nochmal das LOG bis zur neustart-orgie:

    VDR:
    CPU: PIII 800 | Motherboard: Gigabyte GA-6OXM7 | HDA: Samsung SP2514N 250GB | HDB: Samsung SV1604N 160GB | DVD: LG GSA-4040B| DVB-S: TT 2.3 FF | VDR: Mahlzeit-ISO vdr1.4.0 #2


    TV/AV:
    Toschiba: 42Z3030D | Sony: Playstation 3 (Firmware: 2.1)

  • Möp!

    VDR:
    CPU: PIII 800 | Motherboard: Gigabyte GA-6OXM7 | HDA: Samsung SP2514N 250GB | HDB: Samsung SV1604N 160GB | DVD: LG GSA-4040B| DVB-S: TT 2.3 FF | VDR: Mahlzeit-ISO vdr1.4.0 #2


    TV/AV:
    Toschiba: 42Z3030D | Sony: Playstation 3 (Firmware: 2.1)

  • Möp zurück ;)


    Eine konkrete Idee habe ich leider nicht, aber ein paar Hinweise:


    - zum Neulernen der FB muss die Datei /var/lib/vdr/remote.remote-event.conf gelöscht werden, während der VDR _nicht_ läuft.


    - ich habe bei einem Nexus-Testsystem "Wackler" am Klinkenstecker des Empfängers - in der Regel hilft das Drehen des Steckers in der Buchse.


    - das spätere Anschließen einer USB-Tastatur oder -Maus verschiebt die Linux-Gerätenummer, weil die beim Booten schneller rankommen als das Plugin (/dev/input/event1 statt /dev/input/event0).


    - das Programm evtest wird standardmäßig mitinstalliert; es ist im Paket dvb-utils.


    Peter

  • psct : Vielen Dank für die Hilfe! An Wackler hab ich auch schon gedacht. Der ziemlich kleine Klinkenstecker an der Nexus ist wahrlich nicht optimal, besonders weil er auch nicht mittig angebracht ist und dadurch der Stecker ein bisschen am nächsten Slotblech schabt... Das war es leider nicht.


    Hab die Karte auch schon ausgebaut und mir alles (optisch) angeschaut - ist zwar fast sinnlos aber es sieht alles gut aus.


    Danke für den Tipp den VDR erstmal abzuschießen und dann remote-event.conf zu löschen - hab schon an mir gezweifelt - aber wer macht das nicht ab und zu wenn man mit dem VDR zu tun hat ;)


    USB hab ich an meinem alten Teil (ASUS P2B - das beste Slot1 Board der Welt ;) ) glaub ich gar nicht :)


    Also, mal sehen ob die FB neu angelernt werden kann, evtest läuft und hoffentlich kein Hardwareproblem vorliegt...

    VDR:
    CPU: PIII 800 | Motherboard: Gigabyte GA-6OXM7 | HDA: Samsung SP2514N 250GB | HDB: Samsung SV1604N 160GB | DVD: LG GSA-4040B| DVB-S: TT 2.3 FF | VDR: Mahlzeit-ISO vdr1.4.0 #2


    TV/AV:
    Toschiba: 42Z3030D | Sony: Playstation 3 (Firmware: 2.1)

  • hatte auch das Problem daß meine FB an der Nexus 2.1 nicht mehr funktionierte (die Klinkenbuchse ist Schrott). Ich habe den Empfänger direkt an die Nexus gelötet -> hatte nie wieder ein Problem



    MfG

    Server:

    Pentium D * 3 TB HDD * Ubuntu 6.06* VDR 1.4.7,2xSkystar2 in XEN DomU

    Clients:

    Compaq Deskpro EN umgebautes easyvdr via pxe boot

    2 SMT 7020s umgebautes Zenslack

  • tja
    ich hatte gestern mal meinen updatetag
    alles auf neuste vdrdevel
    lief eigentlich recht gut
    jede menge vdr neustart soweit kein problem
    heute ist meine remote (nexus) tod


    ok nix gravierendes
    vdrdevel stop
    rm /var/lib/vdrdevel/remote*conf
    start und neu anlernen
    trotzdem komisch da ich gestern keine probleme hatte

    VDR core Debian Nexus&SkyStar2
    Lenovo T61 Cooker streamdev & softdevice
    IAX² C4 3GHz 4G 600GR Mandriva Cooker HFC² DIVA¹
    c't vdr: recent Kernel : recent

    The post was edited 1 time, last by mac_7 ().

  • Hi InZone,
    ich würde in diesem Fall versuchen systematisch vorzugehen. Wenn du testen möchtest ob die Karte überhaupt Signale bekommt und weitergibt würde ich folgendes machen. Zunächst die Firmware mit

    Code
    1. insmod dvb-ttpci.o av7110_ir_debug=1

    laden. Das kannst du im Skript einfügen das die DVB Treiber läd. Nach dem Laden der Treiber dann

    Code
    1. tail -f /var/log/messages

    eingeben. Jetzt sollte bei jedem Tastendruck der FB (rc5-Code!!) eine Meldung im log erscheinen. Wenn das so ist sollte die Hardware ok sein.
    Gruß
    steini

    1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
    mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
    2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

    The post was edited 1 time, last by steini ().

  • tuxinger : interessante Lösung. Aber das kommt dann als letzte Möglichkeit in betracht.


    Kann man eigentlich am Stecker des IR Empfängers etwas mit einem "Strommessgerät" messen?


    steini super idee - werde ich gleich testen


    mac_7 : Bitte mal genau beschreiben was passier ist und was Du schon getestet hast.


    Thanx an alle für die Hilfe!

    VDR:
    CPU: PIII 800 | Motherboard: Gigabyte GA-6OXM7 | HDA: Samsung SP2514N 250GB | HDB: Samsung SV1604N 160GB | DVD: LG GSA-4040B| DVB-S: TT 2.3 FF | VDR: Mahlzeit-ISO vdr1.4.0 #2


    TV/AV:
    Toschiba: 42Z3030D | Sony: Playstation 3 (Firmware: 2.1)

  • Quote

    Original von InZone
    Kann man eigentlich am Stecker des IR Empfängers etwas mit einem "Strommessgerät" messen?


    nicht wirklich


    okay, gelogen:


    vcc mit 5 volt gesiebter gleichspannung versorgen, masse an masse und ein oszi an signal/masse


    solltest dann auf dem oszi die impulse sehn


    die belegung des nexus steckers steht hier irgendwo im forum


    (ich hatte irgendwann mal das ganze gefrickel satt gehabt, den stecker angeschnitten und ein empfänger für lirc gebaut)

    p5n7a-vm - debian lenny - vdr 1.7.9 - plugins: live, text2skin, epgsearch, xineliboutput cvs, streamdev-server - 2x tt s2-3200 - xine-vdpau 284 + df v9 patches - output vdr-sxfe
    p5n7a-vm - debian lenny - vdr 1.7.9 - plugins: text2skin, xineliboutput cvs, streamdev-client - xine-vdpau 284 + df v9 patches - output vdr-sxfe

  • Hallo,


    nur mal ne kleine Frage:
    Welches script lädt den beim ctvdr 3.06 dir treiber, wo ich das:

    Code
    1. insmod dvb-ttpci.o av7110_ir_debug=1

    einbinden muss?


    MFG
    der-brumm-baer

    MfG
    Der Brumm-Baer
    --------------------------------------------
    srv-vdr: HW: Dell T20 (Xeon) - SW: Openmediavault Erasmus, Frodo-VDR als Docker Container, EPGD als Docker Container


    med-og: HW: - SW: Libreelec
    med-sz: HW: SilverStone Milo ML03, BeQuiet SFX-300W, Asrock H61M-ITX, Intel G530, Asus G210 Silent, Asrock Smart Remote, 8GB USB-Stick - SW: Libereelec
    med-eg: HW: SilverStone Milo ML03, BeQuiet SFX-300W, Asrock H61M-ITX, Intel G530, Asus G210 Silent, Asrock Smart Remote, 8GB USB-Stick - SW: MLD 5.1