Fehler bei VDRConvert Installation

  • Hallo zusammen.


    Ich habe heute versucht mit Hilfe von apt-get vdrconvert zu installieren.


    Ich bekomme aber leider folgende Fehlermeldung:



    Mein System ist LinVDR 0.6 mit Kernel 2.6.8.1 und apt-get 0.5.4


    Weiß jemand Rat?


    Danke
    Tarandor

  • Quote

    Original von tarandor
    dpkg not recorded as installed, cannot check for epoch support !


    Die Frage wegen dieses Problems habe ich auch schon mal gestellt - keiner wußte Rat .
    Offensichtlich wird dpkg nicht sauber installiert oder irgendeine "Zutat" ist nicht konform .
    LinVDR biegt reichlich Funktionen auf busybox um - vielleicht liegt da die Ursache .


    Da du die Pakete aber ja bereits in /var/cache/apt liegen hast , kannste die Benötigten via dpkg-deb ( dem Original von LinVDR ) installieren .


    Allerdings ist es sinnvoll , diese Pakete in ein temporäres Verzeichnis zu entpacken , da gleichnamige Files oder Links nicht überschrieben werden und die Installation somit unvollständig ist .
    Vom temporären Verzeichnis kannste dann Stück für Stück die Dateien an den vorgesehenen Ort kopieren , am besten via mc .


    HJS

  • Danke.
    Muss ich das für alle restilichen Pakete machen, oder reicht es für das libc6.... ??


    Mal probieren.


    hab jetzt mit
    "dpkg-deb -x libc6_2.2.5-11.5_i386.deb /tmp/libc6" das Archive entpackt.
    Anschließend hab ich die unterverzeichnisse in die Originalverzeichnisse (/etc, /bin, /sbin, /usr...) verschoben.
    Aber das will leider immer noch nicht funktionieren.


    Hab ich noch was vergessen ?

  • Damit haste genau das Paket installiert , was sowieso vorhanden ist ;D


    Das apt-get install vdr-addon-vdrconvert hat dir gut 26 MB an .deb ausm Netz gesogen . ALLE in ein temporäres Verzeichnis auspacken .
    Dann kannste vergleichen , was schon da ist und was nicht .
    Ohne gozer , nebst den dazugehörigen libs kommste nich ma über die Erstellung des Menüs hinaus .


    Du hast die Wahl , alle Pakete einzeln zu installieren oder mit ner kleinen Batch :


    1. Ins Verzeichnis der .deb wechseln
    2. ls >vdrc-ins
    3. vdrc-ins mit Editor aufrufen
    4. Sämtliche <CR> durch <SPACE> ersetzen
    5. Dann :

    Code
    1. #./bin/bash
    2. for package in <das Ergebnis aus 4.>
    3. do
    4. dpkg-deb -x $package /vdrc-tmp
    5. done
    6. exit 0


    Das Ganze ausführbar machen und ausführen .


    Anschließend haste in /vdrc-tmp die Struktur , die eigentlich unter / sein sollte .


    Jetzt kannste vergleichen , was schon da ist und was nicht .
    apt libc6 vdr-1.2.6 gcc cpp und diverse andere Packages brauchste nich .


    HJS

  • Quote

    Original von hjs
    4. Sämtliche <CR> durch <SPACE> ersetzen
    5. Dann :

    Code
    1. #./bin/bash
    2. for package in <das Ergebnis aus 4.>
    3. do
    4. dpkg-deb -x $package /vdrc-tmp
    5. done
    6. exit 0


    Du meinst die Zeilenumbrüche durch richtige Spaces ersetzen!? Nicht <SPACE> reinschreiben?
    Und was muss dann bei "<das Ergebnis aus 4.>" eingetragen werden? Die Anzahl der Spaces funzt schonmal nicht!?


    Ist noch früh, steh ein bisschen auf dem Schlauch. :)

  • Quote

    Original von tarandor
    Du meinst die Zeilenumbrüche durch richtige Spaces ersetzen!? Nicht <SPACE> reinschreiben?


    Menno - hast du <CR> so geschrieben gefunden ? Nöö ? Wieso willste dann Steuerzeichen ( formuliert mit <> ) durch "SPACE" ersetzen ??? :gaga


    Ich will doch hoffen , daß es an der frühen?! Stunde liegt ... :mua


    Quote


    Und was muss dann bei "<das Ergebnis aus 4.>" eingetragen werden? Die Anzahl der Spaces funzt schonmal nicht!?


    Hey - du hast da Leerzeichen eingetragen ?
    Hihi - also die FOR-DO Schleife sollte jedem , der mal in irgendeiner Programmiersprache auch nur ansatzweise "reingerochen" hat , was sagen .
    Leerzeichen als aus zu führendes Argument is da nich so dolle .... :P


    Quote


    Ist noch früh, steh ein bisschen auf dem Schlauch. :)


    Siehe oben ...:D


    <das Ergebnis aus 4.> is natürlich die lange Liste der .deb , die du mit ls > vdrc-ins erstellt hast . Da hauste die ersten beiden Zeilen raus ( . und .. )
    <***> gehst ans Ende der Zeile , delete ( das <CR> an der Stelle ) <SPACE> ( ja , die Leertaste ) retour zu <***> bis alle Namen der .deb in einer Reihe stehen , mit Leerzeichen getrennt .


    Für den Spaß kannst auch n Script schreiben , aber so oft wird mans ja nich brauchen .
    So - nachdem du nu ne riesig lange Zeile da hast , haste auch <das Ergebnis aus 4.> OK ?


    Und damit du verstehst , was passiert , lies mal hier .
    Kleine Anleitung zum Batchen ;D


    HJS

  • So, hab jetzt alle Files an ihren Platz kopiert, aber datt funzt immer noch nicht.


    Scheinbar fehlt noch der Mencoder und "tosvcd" !?
    Hier die Check.txt die erstellt wird.


    Mencoder kann ich übrigens wegen obigem Problem auch nicht über apt-get installieren! :(


    Der VDRConvert "Dienst" lässt sich auch nicht starten. :(
    Mit logread kommt allerdings auch keine Fehlermeldung.
    Hat jemand noch eine Idee?


    Danke
    Tarandor

  • mencoder ist in einem der Pakete , die du mit apt-get install vdr-addon-vdrconvert geholt hast . Auf debian.org kannste in den Paketen suchen , was enthalten ist , dann weißte , welches du nicht installiert hast .
    tosvcd brauchste nur , wenn du SVCDs erstellen willst - wer will das schon , wenn er ne DVD erstellen kann .


    Das vdrconvert Start Script mußte etwas anpassen , da du ja nicht ctvdr hast .
    Die Abfrage und das Bauen der reccmds.conf und der command.conf aus den Templates würd ich aus-# - dann n Miniscript in die /etc/init.d mit nix Anderem als :

    Code
    1. ./vdr-addon-vdrconvert start


    Außerdem mußte natürlich deine reccmds.conf und deine command.conf anpassen , wie willste denn sonst n Film zufügen ? Da schraubste halt die Templates rein , wo du sie haben willst .


    Die logs von vdrconvert stehen natürlich nicht im logread , das ist LinVDR eigen . Die Logs findeste , wo se hingehören ( bei debian ) in /var/logs


    HJS

  • Die reccmds.conf und commands.conf hatte ich schon angepasst. Ist ja klar.


    Wenn ich ./vdr-addon-vdrconvert start in der Shell so ausführe bekomme ich folgende Fehlermeldung:



    Meinst du, es reicht alleine das mencoder-Paket zu installieren?


    Edit:
    Das MP3-Plugin will auch nicht mehr. :(

    Quote

    Sep 16 02:41:19 linvdr user.err vdr[3321]: ERROR: /usr/lib/libvorbisfile.so.3: undefined symbol: ogg_stream_reset_serialno


    Ob ich's vielleicht einfach mal mit der c't-VDR Version probieren sollte? *lol*

  • Quote

    Original von tarandor
    linvdr:/etc/init.d# ./vdr-addon-vdrconvert start
    Starting vdrconvertstart-stop-daemon: unrecognized option `--quiet'
    BusyBox v1.00-pre8 (2004.03.02-16:27+0000) multi-call binary


    Oups - ich vergaß - der busybox start-stop-daemon kennt die Option quiet nicht . Du mußt den Original start-stop-daemon nehmen ( welches Pakage verrät dir wieder die debian.org )


    Quote


    Meinst du, es reicht alleine das mencoder-Paket zu installieren?


    Für DVD ja .



    Is nich so lächerlich , wie du meinst . Hab das Projekt vdrconvert für LinVDR auch ersma auf Eis gelegt . Hab auch ctvdr2 auf dem Develop VDR laufen - genau wegen vdrconvert ;D


    Bis entweder vdrconvert unter LinVDR löppt , das Plugin für LinVDR da is oder mein Develop endlich steht .


    HJS


    PS : Steht in der log vielleicht was von libs , die ihm noch fehlen ? Vielleicht erledigt sich dein Symbol Prob oben dann von selbst ;)

  • Yeah! VDRConvert läuft jetzt endlich!


    Nachdem ich die start-stop-deamon aus dem Original dpkg_1.9.21_i386.deb kopiert habe, geht es!
    Mencoder ist jetzt auch drin, nur MP3 läuft glaub ich noch net.
    Aber das ist net sooo schlimm. Die spiele ich sowieso meist mit meinem Win-PC ab.


    Besten dank HJS!


    Gruß
    Tarandor

  • Edit:
    Zu früh gefreut. :(

  • Blöde busybox!



    Aber der Rest funktioniert! (DVD, MP3, MPEG)
    Und ich glaub das reicht. :)

  • Quote

    Original von tarandor
    Blöde busybox!


    Nanana ! Dafür macht se LinVDR schlank .


    Quote


    Aber der Rest funktioniert! (DVD, MP3, MPEG)
    Und ich glaub das reicht. :)


    Falls nicht , grep und ls aus den Paketen holen , kennst ja den Weg ;)


    HJS

  • Schade, daran lag es doch nicht. :(



    Scheinbar gibt es noch ein Problem mit dem Mencoder.
    Welcher ist eigentlich der richtige?? mencoder-k6 oder mencoder-586?
    Wahrscheinlich fehlt noch irgendein Paket dazu. ;(

  • Na haste den K6 oder nen Penti im System ? Dann weißte auch , welchen mencoder du brauchst . Wichtig ist vor Allem : Immer NUR aus der stable - nienich zur testing wechseln , dann brauchste ne andere libc und das haut LinVDR den Boden unter den Füßen weg .


    HJS