ständig Restarts während Aufnahme

  • Hallo,


    mein VDR-Systen lief seit Monaten ohne Probleme, doch seit zwei Tagen habe ich laufend Restarts (~ alle 30 Sekunden), wenn ich eine Aufnahme starte. Ich hatte dieses Problem schon mal, nachdem ich eine 2. TT-Karte (Budget Nova) eingebaut habe, aber dann war auf einmal alles ok.


    In /var/log/messages steht ausser der Tatsache, dass ein Restart aufgetreten ist nichts drin, aber die Meldungen in /var/log/debug deuten auf Probleme mit dem EPG hin (siehe angehängten log). Leider hat das löschen von /video/epg.data nichts geholfen.


    Hat jemand eine Idee?


    Gruss,


    Christof


    P.S.: Mit nur einer Karte (TT 1.6) funktioniert alles ohne Probleme.


    Jul 25 18:49:00 vdr vdr[3445]: Title: 'Die ZDF-reportage Palast der Tiere' Subtitle: 'Von Hundeglück und Katzenjammer'
    Jul 25 18:49:00 vdr vdr[3445]: creating directory /video/@Die_ZDF-reportage_Palast_der_Tiere_Von_Hundeglück_und_Katzenjammer/2004-07-25.18.49.50.50.rec
    Jul 25 18:49:00 vdr vdr[3445]: recording to '/video/@Die_ZDF-reportage_Palast_der_Tiere_Von_Hundeglück_und_Katzenjammer/2004-07-25.18.49.50.50.rec/001.vdr'
    Jul 25 18:49:00 vdr vdr[11407]: recording thread started (pid=11407)
    Jul 25 18:49:00 vdr vdr[11408]: receiver thread started on device 2 (pid=11408)
    Jul 25 18:49:31 vdr vdr[11407]: recording thread ended (pid=11407)
    Jul 25 18:49:31 vdr vdr[11408]: receiver thread ended on device 2 (pid=11408)
    Jul 25 18:49:31 vdr vdr[3445]: buffer stats: 0 (0%) used
    Jul 25 18:49:31 vdr vdr[3455]: KBD remote control thread ended (pid=3455)
    Jul 25 18:49:31 vdr vdr[3445]: =====================
    Jul 25 18:49:31 vdr vdr[3445]: EPG bugfix statistics
    Jul 25 18:49:31 vdr vdr[3445]: =====================
    Jul 25 18:49:31 vdr vdr[3445]: IF SOMEBODY WHO IS IN CHARGE OF THE EPG DATA FOR ONE OF THE LISTED
    Jul 25 18:49:31 vdr vdr[3445]: CHANNELS READS THIS: PLEASE TAKE A LOOK AT THE FUNCTION cEventInfo::FixEpgBugs()
    Jul 25 18:49:31 vdr vdr[3445]: IN VDR/eit.c TO LEARN WHAT'S WRONG WITH YOUR DATA, AND FIX IT!
    Jul 25 18:49:31 vdr vdr[3445]: =====================
    Jul 25 18:49:31 vdr vdr[3445]: Fix^IHits^IChannels
    Jul 25 18:49:31 vdr vdr[3445]: 0^I78^IZDF, Phoenix, MDR S-ANHALT, 3sat, RBB Berlin, MDR THÜRINGEN, MDR SACHSEN, WDR FERNSEHEN
    Jul 25 18:49:31 vdr vdr[3445]: 2^I23^IPhoenix, MDR S-ANHALT, 3sat, RBB Berlin, MDR THÜRINGEN, MDR SACHSEN, WDR FERNSEHEN
    Jul 25 18:49:31 vdr vdr[3445]: 3^I746^IBEUR TV, SAT.1, N24, ProSieben, KABEL1
    Jul 25 18:49:31 vdr vdr[3445]: 4^I7^IMDR THÜRINGEN, MDR SACHSEN, MDR S-ANHALT, DW-TV
    Jul 25 18:49:31 vdr vdr[3445]: 5^I49^Ihessen fernsehen, KABEL1, ProSieben
    Jul 25 18:49:31 vdr vdr[3445]: 6^I335^I3sat, BR-alpha, EinsFestival, MDR THÜRINGEN, RBB Berlin, MDR S-ANHALT, MDR SACHSEN, ARD-Online-Kanal, Bayerisches FS, NDR FS NDS, NDR FS HH, NDR FS SH, SR Fernsehen Suedwest, SÜDWEST BW, Das Erste, Phoenix, JUNIOR, N24, DISNEY CHANNEL, ONTV Regional, PREMIERE SPORT 1, FOX KIDS, PREMIERE NOSTALGIE, PREMIERE SPORT 2, PREMIERE Austria, PREMIERE START, 13 TH STREET, SCI FI, ProSieben
    Jul 25 18:49:31 vdr vdr[3445]: =====================
    Jul 25 18:49:31 vdr vdr[3448]: EIT processing thread ended (pid=3448) - master
    Jul 25 18:49:31 vdr vdr[3449]: tuner thread ended on device 1 (pid=3449)
    Jul 25 18:49:31 vdr vdr[3451]: EIT processing thread ended (pid=3451)
    Jul 25 18:49:31 vdr vdr[3452]: tuner thread ended on device 2 (pid=3452)
    Jul 25 18:49:31 vdr vdr[3453]: TVTV Timer Thread ended (pid=3453)
    Jul 25 18:49:31 vdr vdr[3445]: max. latency time 1 seconds
    Jul 25 18:49:42 vdr vdr[13616]: probing /dev/dvb/adapter0/frontend0
    Jul 25 18:49:42 vdr vdr[13616]: video device offset is 0
    Jul 25 18:49:42 vdr vdr[13619]: EIT processing thread started (pid=13619) - master
    Jul 25 18:49:42 vdr vdr[13625]: tuner thread started on device 1 (pid=13625)
    Jul 25 18:49:42 vdr vdr[13616]: probing /dev/dvb/adapter1/frontend0
    Jul 25 18:49:42 vdr vdr[13632]: EIT processing thread started (pid=13632)
    Jul 25 18:49:42 vdr vdr[13638]: tuner thread started on device 2 (pid=13638)
    Jul 25 18:49:42 vdr vdr[13616]: probing /dev/dvb/adapter2/frontend0
    Jul 25 18:49:42 vdr vdr[13643]: TVTV Timer Thread started (pid=13643)
    Jul 25 18:49:42 vdr vdr[13643]: TVTV Timer Make Update
    Jul 25 18:49:42 vdr vdr[13650]: LIRC remote control thread started (pid=13650)
    Jul 25 18:49:42 vdr vdr[13659]: KBD remote control thread started (pid=13659)
    Jul 25 18:49:42 vdr vdr[13616]: remote control LIRC - keys known
    Jul 25 18:49:42 vdr vdr[13616]: remote control KBD - keys known
    Jul 25 18:49:42 vdr vdr[13616]: setting watchdog timer to 60 seconds
    Jul 25 18:49:42 vdr vdr[13616]: waiting for EPG info...
    Jul 25 18:49:42 vdr vdr[13643]: TVTV Receive 4558 Bytes
    Jul 25 18:49:42 vdr vdr[13643]: TVTV Timer File processed
    Jul 25 18:49:43 vdr vdr[13616]: got EPG info after 1 seconds
    Jul 25 18:49:43 vdr vdr[13616]: Title: 'Die ZDF-reportage Palast der Tiere' Subtitle: 'Von Hundeglück und Katzenjammer'
    Jul 25 18:49:43 vdr vdr[13616]: recording to '/video/@Die_ZDF-reportage_Palast_der_Tiere_Von_Hundeglück_und_Katzenjammer/2004-07-25.18.49.50.50.rec/002.vdr'
    Jul 25 18:49:43 vdr vdr[13873]: recording thread started (pid=13873)
    Jul 25 18:49:43 vdr vdr[13874]: receiver thread started on device 2 (pid=13874)
    Jul 25 18:49:43 vdr vdr[13616]: max. latency time 1 seconds
    Jul 25 18:50:04 vdr vdr[13873]: recording thread ended (pid=13873)
    Jul 25 18:50:04 vdr vdr[13874]: receiver thread ended on device 2 (pid=13874)
    Jul 25 18:50:04 vdr vdr[13616]: buffer stats: 0 (0%) used
    Jul 25 18:50:04 vdr vdr[13616]: max. latency time 3 seconds

  • Hallo,


    kommt mir sehr bekannt vor. Bei mir (Asus P4P8x, Intel 865 Chipset, 2.4er Kernel) tritt das auf, wenn ich ACPI aktiviere und sich die DVBs einen Interrupt mit wem auch immer teilt.


    Viele Grüße,
    Holger

    VDR 1-3: Zotac ZBox HD-ID42, yavdr-0.5
    VDR 4: AMD5900/Asus M3N-78, yavdr-0.5
    DVB-Empfang: Netceiver
    Storage: via NFS von separatem Fileserver

    [size=10]

  • Hallo,



    bei mir trat so etwas nachvollziehbar immer dann auf, wenn die zweite Karte kein Signal hatte bzw. nicht ans Sat-Kabel angeschlossen war. Überprüfe das mal.


    Gruss Günter

    VDR: Coolermaster 620, Athlon 2.6 GHz, 160GB-Samsung-SV1604N, 512MB, TT-1.6, VDR 1.2.6, Slackware 9.0, div Plugins


  • dem schließe ich mich an , da habe ich auch schon mal ne woche das problem gesucht. bis ich das signal an die 2. karte angelegt hatte

  • Hallo,


    danke erstmal für die Tips. Bei meinem Hermes 651p habe ich leider keine Möglichkeit im BIOS gefunden, den Karten exclusive Interrupts zuzuweisen. Aber ich glaube sowieso eher, dass es am Signal liegt: Das Problem tritt nur bei den Sendern auf, die gerade etwas schlechter empfangen werden, und bei schlechtem Wetter tritt es bei mehr Programmen auf.


    Trotzdem bleiben noch Fragen:


    Mit femon messe ich typisch ein STR von 64% und SNR von über 80%. Nur bei RTL ist SNR z.Z. nur ~74%; und ich habe im Moment nur Restarts, wenn ich diesen Sender aufnehme. Was sind denn bei DVB-S normale Werte für STR und SNR?


    Ich sehen mit femon immer nur die Signalstärke von der primären (TT 1.6) Karte. Wie kann ich femon dazu überreden, die 2. (TT Budget) anzuzeigen?


    Gruss,


    Christof